Loading ...
Sorry, an error occurred while loading the content.

Messages List

14826

Re: The Klotski Problem from last year's MOOC.

My code copied okay--I think--but it didn't paste that well! :-( Oh well. If anyone can provide some feedback, that's great. IF not.... no worries.
Douglas Lewit
10:57 PM
#14826
 
14825

The Klotski Problem from last year's MOOC.

Hi everyone, Was anyone in the group a member of that OCaml MOOC last year that was hosted by OCaml Pro and Universite Paris Diderot? Anyhow, do you recall
Douglas Lewit
7:31 PM
#14825
 
14824

Re: My utop disappeared!

If you run just "opam config env" you will see that it generates a bunch of shell variable redefinitions that "eval" then applies to your shell -- it is not
Gabriel Scherer
May 31
#14824
 
14823

Re: My utop disappeared!

It works (the output of eval $(opam config env) is empty though) ! Thank you very much.
doylejonathan58
May 31
#14823
 
14822

Re: My utop disappeared!

$(opam config var bin)/utop should work no matter what your PATH setting is. (Have you tried running "eval $(opam config env)"? My command in my first email
Gabriel Scherer
May 31
#14822
 
14821

Re: My utop disappeared!

I really meant "opam update utop". If I try "opam upgrade utop", the terminal answers (correctly I think) "Already up-to-date". I also tried opam remove utop
doylejonathan58
May 31
#14821
 
14820

Re: My utop disappeared!

I reported the confusion you had with `opam update` upstream: https://github.com/ocaml/opam/issues/2951 Also, note that there is now a webforum to ask
Gabriel Scherer
May 31
#14820
 
14819

Re: My utop disappeared!

You probably meant "opam upgrade utop". A "pinned" package is one that you did not install from a package repository, but from a development version on your
Gabriel Scherer
May 31
#14819
 
14818

Re: My utop disappeared!

I also just tried `opam update utop` and got the following answer : Cannot update the package utop because it is not pinned What does "pinned" mean here ?
doylejonathan58
May 31
#14818
 
14817

Re: My utop disappeared!

It could also be a PATH issue related to not running opam $(eval config env) to put opam's settings in your environment. (Although normally `opam init` offers
Gabriel Scherer
May 31
#14817
 
14816

Re: My utop disappeared!

Good morning, I had a similar problem a while back on a different Mac computer with two user accounts. I did a "brew update" and also a "brew upgrade". It
Douglas Lewit
May 31
#14816
 
14815

My utop disappeared!

After I restarted my computer, utop has now somewhat disappeared : $ utop -bash: utop: command not found Yet utop is still there according to opam : $opam list
doylejonathan58
May 31
#14815
 
14814

Re: Pure Functional programming in OCaml ????

It compiles fine for me. I'm using version 4.02.2. Which version are you using? I'll email you the code in a private message. --D. Sleator
darooha
May 22
#14814
 
14813

Re: Pure Functional programming in OCaml ????

Hi Danny, That's what I had originally, but it would not compile. I ***think*** (not 100% sure of this) the reason is that you can't have let-expressions in
Douglas Lewit
May 22
#14813
 
14812

Re: Pure Functional programming in OCaml ????

It's easy to write fully functional programs in ocaml. Just don't use the non-functional stuff like ref variables and arrays. But the task you've set out for
darooha
May 21
#14812
 
View First Topic Go to View Last Topic