Loading ...
Sorry, an error occurred while loading the content.

14062unable to install async_graphics with opam

Expand Messages
  • Jean Saint-Remy
    Jun 7, 2014
    • 0 Attachment
      Hi,

      I am not sure why 'opam install async_graphics' fails. The error message says

      /usr/bin/ocamlfind ocamldep -package async -package graphics -modules async_graphics.mli > async_graphics.mli.depends
      + /usr/bin/ocamlfind ocamldep -package async -package graphics -modules async_graphics.mli > async_graphics.mli.depends
      ocamlfind: Package `async' not found
      Command exited with code 2.

      but

      opam install async returns

      [NOTE] Package async is already installed (current version is 108.08.00).

      Is there a --force option or some other unmet dependency that I should be trying? The ocaml version I am using is 3.12.1 (which opam allows you to have many different ones). Maybe ocamlfind needs to be told where to find the async library?

      Thanks in advance,

      jean

    • Show all 3 messages in this topic