Loading ...
Sorry, an error occurred while loading the content.

Re: reload library on .clb save

Expand Messages
  • tallguy354u1
    ... The Restore Default Library fixed the problem ... You have to right click in the clip-book to see it and it has to be active, meaning that you sorted the
    Message 1 of 6 , Mar 20 1:13 PM
    • 0 Attachment
      --- In ntb-scripts@yahoogroups.com, "Sheri" <silvermoonwoman@...> wrote:
      >
      > On 3/20/2010 12:19 PM, Robb wrote:
      >
      > > I have built libraries that use Perl script to manipulate text
      > > selections within NTP. These libraries are stored in .clb files
      > > (ex: mylib.clb) that can themselves be opened and edited.
      > > Previous to NTP 6.2 once a .clb file was edited and saved the act
      > > of saving would refresh the library ... so for instance if I
      > > added a new clip in the file the new clip would appear upon
      > > saving the .clb. It no longer does this ... and the library won't
      > > seem to reload or refresh at all.
      >
      > Usually I edit my clips using clip-edit. But I can instead right click the the library name in the clip panel and Open the clb library as a document. I can type new instructions onto an existing clip and do a file save (Ctrl+S). Then I can run the clip from the already loaded library and the new instructions are part of the clip that is executed. I can also do a File-Open, browse to my Application Data area, NoteTab Pro, Libraries folder, and open (as a document) the clb file that is currently loaded in the clipbook and do the same thing. I still have no idea what you are doing differently.
      >
      > If you happen to be running your clips from the clipbar, there is a documented limitation that perl scripts that are stored in clip libraries are not clipbar-safe. However, that limitation is nothing new. What previous NoteTab version were you using?
      >
      > Regards,
      > Sheri
      >

      The "Restore Default Library" fixed the problem ... You have to right click in the clip-book to see it and it has to be active, meaning that you sorted the library or did something to alter its state. It may have been the "Sorted" option that started all this ... its on the same palette via right click. Thanks
    Your message has been successfully submitted and would be delivered to recipients shortly.