Loading ...
Sorry, an error occurred while loading the content.

[wine] How I "broke" Wine using the Graphics tab of winecfg

Expand Messages
  • lm_hamilton
    The other day I was experimenting with winecfg and broke wine. I ended up not being able to run any program via wine, and none of the wine programs bundles
    Message 1 of 1 , Sep 21, 2007
    • 0 Attachment
      The other day I was experimenting with winecfg and "broke" wine.

      I ended up not being able to run any program via wine, and none of the
      wine programs bundles with wine.

      I did not figure out how to undo it. I ended up renaming my .wine
      directory and running winecfg to create a fresh one. I then copied my
      programs to the new .wine directory.

      This is running Slackware 12 with wine-0.9.44, current wine is 0.9.45,
      as of September 14, 2007.

      To get the version of wine, run " wine --version" at a command prompt.

      Some settings changes in winecfg make a big difference on the plus
      side, here is my negative side:

      I ran winecfg and went to the Graphics tab. I checked emulate a
      virtual desktop. Some things seemed smoother, and it reminded me of
      running Windows98 in Qemu, but when I minimized NoteTab, I could not
      maximize it. When I exited Wine, I could not get wine to launch any
      program and winecfg did not work. I had to create a
      new .wine and copy programs from the old one.

      If anyone has a solution to this that does not involve renaming the
      .wine directory and making a new one, please let us know. Does editing
      the registry files in a text editor help, etc.

      Is this an issue that is fixed/resolved in wine-0.9.45? Do other Linux
      or Unix variants have this issue? NOTE: Be sure to make a copy of your
      .wine directory if you try to duplicate this to save yourself a lot of
      frustration.

      Larry Hamiton
    Your message has been successfully submitted and would be delivered to recipients shortly.