Loading ...
Sorry, an error occurred while loading the content.

Funny codes after pasting emails into NoteTab

Expand Messages
  • MarkH
    Hi all, I ve converted to Linux Mint 5, and installed Notetab 5.7b/fv (Full version) with Wine 1. It works fine for what I want to do - except copying text
    Message 1 of 10 , Dec 22, 2008
    • 0 Attachment
      Hi all,

      I've converted to Linux Mint 5, and installed Notetab 5.7b/fv (Full
      version) with Wine 1.

      It works fine for what I want to do - except copying text from emails.
      I'm still using Thunderbird 2.0.0.18.

      Any ideas as to why I get these funny codes appearing instead of
      punctuation?

      Never had this problem in Windows.

      I'm sure I had the same with Ubuntu Hardy Heron.

      See example below.

      Many thanks, and Happy Christmas,
      MarkH


      COPIED HERE DIRECT FROM WEBSITE
      Stourton observed snootily: ‘There were two bits of radio history being
      made there – and one of them I’m sure you will recognise was Charlotte
      Green.’

      Another example of Today’s ‘lighter’ tone came when a new programme was
      described as a ‘brand new spanking show’. Evan Davis quipped: ‘I think
      he means brand spanking new show. How disappointing.’

      And when Strictly contestant John Sergeant snubbed a request to appear,
      John Humphrys said: ‘He didn’t return my calls. You expect Prime
      Ministers to do that.’


      COPIED FROM AN EMAIL (eg Yahoo Groups) VIA NOTETAB TO THIS EMAIL
      Stourton observed snootily: \u2018There were two bits of radio history being
      made there \u2013 and one of them I\u2019m sure you will recognise was
      Charlotte
      Green.\u2019

      Another example of Today\u2019s \u2018lighter\u2019 tone came when a new
      programme was
      described as a \u2018brand new spanking show\u2019. Evan Davis quipped:
      \u2018I think
      he means brand spanking new show. How disappointing.\u2019

      And when Strictly contestant John Sergeant snubbed a request to appear,
      John Humphrys said: \u2018He didn\u2019t return my calls. You expect Prime
      Ministers to do that.\u2019

      http://www.dailymail.co.uk/news/article-1094508/BBC-treated-worse-
      Jonathan-Ross-says-Posh-Ed-Today-sacking.html#
    • sisterscape
      I get those all the time and have to search and replace to get rid of them. I can t remember whether they are MS specific encoding or whether UTF is the
      Message 2 of 10 , Dec 22, 2008
      • 0 Attachment
        I get those all the time and have to search and replace to get rid of them. I can't remember whether they are MS specific encoding or whether UTF is the culprit. Very annoying but NoteTab doesn't know how to translate them. Wish I had better news.

        I think there was a thread about this not long back that had a clip to fix such things.

        --- On Mon, 12/22/08, MarkH <pm9000@...> wrote:

        > From: MarkH <pm9000@...>
        > Subject: [ntb-linux] Funny codes after pasting emails into NoteTab
        > To: ntb-linux@yahoogroups.com
        > Date: Monday, December 22, 2008, 2:09 PM
        > Hi all,
        >
        > I've converted to Linux Mint 5, and installed Notetab
        > 5.7b/fv (Full
        > version) with Wine 1.
        >
        > It works fine for what I want to do - except copying text
        > from emails.
        > I'm still using Thunderbird 2.0.0.18.
        >
        > Any ideas as to why I get these funny codes appearing
        > instead of
        > punctuation?
        >
        > Never had this problem in Windows.
        >
        > I'm sure I had the same with Ubuntu Hardy Heron.
        >
        > See example below.
        >
        > Many thanks, and Happy Christmas,
        > MarkH
        >
        >
        > COPIED HERE DIRECT FROM WEBSITE
        > Stourton observed snootily: ‘There were two bits of radio
        > history being
        > made there – and one of them I’m sure you will
        > recognise was Charlotte
        > Green.’
        >
        > Another example of Today’s ‘lighter’ tone came when a
        > new programme was
        > described as a ‘brand new spanking show’. Evan Davis
        > quipped: ‘I think
        > he means brand spanking new show. How disappointing.’
        >
        > And when Strictly contestant John Sergeant snubbed a
        > request to appear,
        > John Humphrys said: ‘He didn’t return my calls. You
        > expect Prime
        > Ministers to do that.’
        >
        >
        > COPIED FROM AN EMAIL (eg Yahoo Groups) VIA NOTETAB TO THIS
        > EMAIL
        > Stourton observed snootily: \u2018There were two bits
        > of radio history being
        > made there \u2013 and one of them I\u2019m sure you
        > will recognise was
        > Charlotte
        > Green.\u2019
        >
        > Another example of Today\u2019s
        > \u2018lighter\u2019 tone came when a new
        > programme was
        > described as a \u2018brand new spanking show\u2019.
        > Evan Davis quipped:
        > \u2018I think
        > he means brand spanking new show. How
        > disappointing.\u2019
        >
        > And when Strictly contestant John Sergeant snubbed a
        > request to appear,
        > John Humphrys said: \u2018He didn\u2019t return my
        > calls. You expect Prime
        > Ministers to do that.\u2019
        >
        > http://www.dailymail.co.uk/news/article-1094508/BBC-treated-worse-
        > Jonathan-Ross-says-Posh-Ed-Today-sacking.html#
        >
        >
        > ------------------------------------
        >
        > Yahoo! Groups Links
        >
        >
        >
      • Lee Underwood
        Yeah, I just wrote a small clip to take care of it. Just one of those small prices to pay for the freedom of Linux. Lee
        Message 3 of 10 , Dec 22, 2008
        • 0 Attachment
          Yeah, I just wrote a small clip to take care of it. Just one of those small prices to pay for the freedom of Linux.

          Lee



          ===========================================
          On Mon, 22 Dec 2008 20:09:57 +0000 MarkH <pm9000@...> wrote:

          | Hi all,
          |
          | I've converted to Linux Mint 5, and installed Notetab 5.7b/fv (Full
          | version) with Wine 1.
          |
          | It works fine for what I want to do - except copying text from emails.
          | I'm still using Thunderbird 2.0.0.18.
          |
          | Any ideas as to why I get these funny codes appearing instead of
          | punctuation?
          |
          | Never had this problem in Windows.
          |
          | I'm sure I had the same with Ubuntu Hardy Heron.
          |
          | See example below.
          |
          | Many thanks, and Happy Christmas,
          | MarkH
          |
          |
        • lm_hamilton
          These are Unicode characters. You can put the /u and number in Google and find out what character it is. For example, u2018 is the LEFT SINGLE QUOTATION
          Message 4 of 10 , Dec 23, 2008
          • 0 Attachment
            These are Unicode characters. You can put the /u and number in Google
            and find out what character it is.

            For example, "\u2018" is the "'LEFT SINGLE QUOTATION MARK' (U+2018)".

            NoteTab does not convert Unicode to ASCII. You can build a clip to do
            it if you want. Lee indicated that he has a clip to remove these codes.

            If you were to build a clip, I would first build one to capture the
            various /u+number strings and compare to the list you already have, to
            know if you need to add it. Then you could run this list through
            Google and get their meanings and build a script to replace all
            "\u2018" with "'".

            I believe some on the clips list may have addressed this issue.

            A future version of NoteTab will be able to handle Unicode.

            If you do not want to deal with Unicode, you can change your Linux
            installation's character set from UTF-8 to the English Character Set,
            ISO 8859-1.

            I have never run into this. I use text only email, which I think
            avoids the problem, and the text I copy off the web has, to date, not
            been Unicode. Then again, I also use ISO 8859-1.

            Larry Hamilton

            --- In ntb-linux@yahoogroups.com, MarkH <pm9000@...> wrote:
            >
            > Hi all,
            >
            > I've converted to Linux Mint 5, and installed Notetab 5.7b/fv (Full
            > version) with Wine 1.
            >
            > It works fine for what I want to do - except copying text from emails.
            > I'm still using Thunderbird 2.0.0.18.
            >
            > Any ideas as to why I get these funny codes appearing instead of
            > punctuation?
            >
            > Never had this problem in Windows.
            >
            > I'm sure I had the same with Ubuntu Hardy Heron.
            >
            > See example below.
            >
            > Many thanks, and Happy Christmas,
            > MarkH
          • Lee Underwood
            ... I ve never heard of this. How do you do it? Lee
            Message 5 of 10 , Dec 23, 2008
            • 0 Attachment
              | If you do not want to deal with Unicode, you can change your Linux
              | installation's character set from UTF-8 to the English Character Set,
              | ISO 8859-1.
              |


              I've never heard of this. How do you do it?

              Lee
            • Larry Hamilton
              ... I mis-stated. LOCALE is the proper term. By default, Linux uses the ISO 9959-1. However, individual applications, such as your web browser or email client
              Message 6 of 10 , Dec 23, 2008
              • 0 Attachment
                --- On Tue, 12/23/08, Lee Underwood <leeu@...> wrote:

                > From: Lee Underwood <leeu@...>
                > Subject: Re: [ntb-linux] Re: Funny codes after pasting emails into NoteTab
                > To: ntb-linux@yahoogroups.com
                > Date: Tuesday, December 23, 2008, 12:52 PM
                > | If you do not want to deal with Unicode, you can change
                > your Linux
                > | installation's character set from UTF-8 to the
                > English Character Set,
                > | ISO 8859-1.
                > |
                >
                >
                > I've never heard of this. How do you do it?
                >
                > Lee

                I mis-stated. LOCALE is the proper term.

                By default, Linux uses the ISO 9959-1.

                However, individual applications, such as your web browser or email client may be configured to use another locale. If your default locale is ISO 9959-1, then you may want to check the locale of the other applications you use. Maybe it is an Ubuntu thing, I have not run into this with Slaskware.

                I found this link for Ubuntu users (Long line, wrapped):

                <http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_add_locales_to_Ubuntu_the_command_line_way>

                You can use the following command to check your current locale (Ubuntu):

                cat /etc/default/locale

                Other distributions will have different ways to control this. For this, and configuring the locale of a specific application, Google is your friend. ;-)

                The only applications I use where the codepage (DOS/Windows terminology)/locale matters is genealogy applications. This is usually not an issue when I am working with Windows, except with one genealogy program, the CLI program, LifeLines. LifeLines is available at SourceForge. For LifeLines, it takes a little extra tweaking to get Unicode or other languages working (both Windows & *Nix). Something I have not yet succeeded in changing, so I could test my feeble attempt at an updated Spanish PO file. I like LifeLines as I can run the same database using either the Windows or *Nix program (Only when similar processors, i.e. 32 bit.), and it works great from a USB thumb drive.

                HTH,

                Larry
              • MarkH
                Dear All, Thanks for responses. I delayed asking for weeks, thinking it would be such an elementary thing, that NoteTab would surely handle it. For emails I
                Message 7 of 10 , Dec 23, 2008
                • 0 Attachment
                  Dear All,

                  Thanks for responses. I delayed asking for weeks, thinking it would be
                  such an elementary thing, that NoteTab would surely handle it.

                  For emails I prefer text only too. I didn't realize I wasn't text only.

                  Nevertheless, I'm completely sold on Linux. If and when NoteTab handles
                  Unicode, it will be a major step forward. Meantime I think I could
                  use a clip.

                  Kind regards, and happy Christmas,
                  MarkH

                  > Messages in this topic (5)
                  > ________________________________________________________________________
                  > 1d. Re: Funny codes after pasting emails into NoteTab
                  > Posted by: "lm_hamilton" lm_hamilton@... lm_hamilton
                  > Date: Tue Dec 23, 2008 9:15 am ((PST))
                  >
                  > These are Unicode characters. You can put the /u and number in Google
                  > and find out what character it is.
                  >
                  > For example, "\u2018" is the "'LEFT SINGLE QUOTATION MARK' (U+2018)".
                  >
                  > NoteTab does not convert Unicode to ASCII. You can build a clip to do
                  > it if you want. Lee indicated that he has a clip to remove these codes.
                  >
                  > If you were to build a clip, I would first build one to capture the
                  > various /u+number strings and compare to the list you already have, to
                  > know if you need to add it. Then you could run this list through
                  > Google and get their meanings and build a script to replace all
                  > "\u2018" with "'".
                  >
                  > I believe some on the clips list may have addressed this issue.
                  >
                  > A future version of NoteTab will be able to handle Unicode.
                  >
                  > If you do not want to deal with Unicode, you can change your Linux
                  > installation's character set from UTF-8 to the English Character Set,
                  > ISO 8859-1.
                  >
                  > I have never run into this. I use text only email, which I think
                  > avoids the problem, and the text I copy off the web has, to date, not
                  > been Unicode. Then again, I also use ISO 8859-1.
                  >
                  > Larry Hamilton
                  >
                • tr6vb6z02@sneakemail.com
                  ... A VERY simple and limited version that I use: ^!Replace u201d WASI ^!Replace u201c WASI ^!Replace u2026 ... WASI ^!Replace
                  Message 8 of 10 , Dec 23, 2008
                  • 0 Attachment
                    >NoteTab does not convert Unicode to ASCII. You can build a clip to do
                    >it if you want. Lee indicated that he has a clip to remove these codes.

                    A VERY simple and limited version that I use:

                    ^!Replace "\u201d" >> """ WASI
                    ^!Replace "\u201c" >> """ WASI
                    ^!Replace "\u2026" >> "..." WASI
                    ^!Replace "\u2019" >> "'" WASI
                    ^!Replace "\u2014" >> "--" WASI
                    ^!Replace "\u2013" >> "-" WASI
                    ^!Replace "\u2018" >> "'" WASI

                    You can, of course, expand it indefinitely.

                    Donald
                  • Lee Underwood
                    ... Yes, that what I use. I tried changing the locale but the problem still exists in NoteTabPro. Oh well, running the clip is not big deal.
                    Message 9 of 10 , Dec 24, 2008
                    • 0 Attachment
                      On Tue, 23 Dec 2008 20:47:45 -0600 tr6vb6z02@... wrote:

                      | A VERY simple and limited version that I use:
                      |
                      | ^!Replace "\u201d" >> """ WASI
                      | ^!Replace "\u201c" >> """ WASI
                      | ^!Replace "\u2026" >> "..." WASI
                      | ^!Replace "\u2019" >> "'" WASI
                      | ^!Replace "\u2014" >> "--" WASI
                      | ^!Replace "\u2013" >> "-" WASI
                      | ^!Replace "\u2018" >> "'" WASI
                      |


                      Yes, that what I use.

                      I tried changing the locale but the problem still exists in NoteTabPro. Oh well, running the clip is not big deal.
                    • lm_hamilton
                      ... NoteTabPro. Oh well, running the clip is not big deal. NoteTab cannot handle Unicode. Until it can, the clip is the only way to handle Unicode in NoteTab.
                      Message 10 of 10 , Dec 24, 2008
                      • 0 Attachment
                        --- In ntb-linux@yahoogroups.com, Lee Underwood <leeu@...> wrote:
                        > I tried changing the locale but the problem still exists in
                        NoteTabPro. Oh well, running the clip is not big deal.

                        NoteTab cannot handle Unicode. Until it can, the clip is the only way
                        to handle Unicode in NoteTab.

                        Changing the Locale should disable Unicode in other programs from
                        which text is copied to NoteTab.

                        Larry Hamilton
                      Your message has been successfully submitted and would be delivered to recipients shortly.