Loading ...
Sorry, an error occurred while loading the content.
 

Re: [NH] .html version displaying different than .php version in IE 8

Expand Messages
  • loro
    ... Did you remove that page or is the URL wrong? Lotta
    Message 1 of 8 , Oct 26, 2009
      Mike wrote:
      >Page with non PHP top menu and php bottom menu and footer:
      >http://epicroadtrips.us/2009/sept/ca/d1/index.html
      >When viewed in IE 8 the two columns are jammed together.

      Did you remove that page or is the URL wrong?

      Lotta
    • Mike Breiding - Morgantown WV
      ... Ooops... It is back. Thanks, -Mike
      Message 2 of 8 , Oct 26, 2009
        loro wrote:
        > Mike wrote:
        >> Page with non PHP top menu and php bottom menu and footer:
        >> http://epicroadtrips.us/2009/sept/ca/d1/index.html
        >> When viewed in IE 8 the two columns are jammed together.
        >
        > Did you remove that page or is the URL wrong?
        >

        Ooops...
        It is back.

        Thanks,
        -Mike

        >
        >
        >
        >
        > ------------------------------------
        >
        > Fookes Software: http://www.fookes.com/
        > NoteTab website: http://www.notetab.com/
        > NoteTab Discussion Lists: http://www.notetab.com/groups.php
        >
        > ***
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
      • loro
        ... Well, I don t know, but the documents are not the same. To start with, the HTML one validated (Congratulations! ;-) ) while the PHP one is a mess.
        Message 3 of 8 , Oct 26, 2009
          Mike Breiding - Morgantown WV wrote:
          >Ooops...
          >It is back.

          Well, I don't know, but the documents are not the same. To start
          with, the HTML one validated (Congratulations! ;-) ) while the PHP
          one is a mess.

          <http://www.htmlhelp.com/cgi-bin/validate.cgi?url=http%3A//epicroadtrips.us/2009/sept/ca/d1/index.php&warnings=yes&input=yes>

          <http://www.htmlhelp.com/cgi-bin/validate.cgi?url=http%3A//epicroadtrips.us/2009/sept/ca/d1/index.html&warnings=yes&input=yes>


          To start with, there is a PHP error in the source of the PHP page
          Gosh, I've never seen THAT before.

          <div id="wrapper"><!--
          Warning: include(header.php): failed to open stream: No such file or
          directory in
          /hsphere/local/home/mbreidin/epicroadtrips.us/2009/sept/ca/d1/index.php
          on line 13

          Warning: include(): Failed opening 'header.php' for inclusion
          (include_path='.:/hsphere/shared/apache/libexec/php5ext/php/') in
          /hsphere/local/home/mbreidin/epicroadtrips.us/2009/sept/ca/d1/index.php
          on line 13
          -->

          So that header.php is never included. On the other hand its content
          doesn't seem to be used in the HTML version either.

          Look at the PHP page (in a browser). In the menu you have

          Week 2
          Week 3Week 2
          Week 3

          That can't be design. I think it comes from that you have commented
          out a bunch of LIs, but the comment is screwed up because the closing
          tag for LI right before it lacks the closing ">". It's at line 203 or
          thereabout.


          I don't know if the fact that the menu is broader on the PHP page
          (because of the above) causes the difference you ask about, but it's
          place to start anyway. There are other oddities too.

          Lotta
        • Mike Breiding - Morgantown WV
          ... I have never seen this error show up. The header.php was a commented line so I don t know why it would generate an error. However, I removed the comment.
          Message 4 of 8 , Oct 26, 2009
            loro wrote:
            > Mike Breiding - Morgantown WV wrote:
            >> Ooops...
            >> It is back.
            >
            > Well, I don't know, but the documents are not the same. To start
            > with, the HTML one validated (Congratulations! ;-) ) while the PHP
            > one is a mess.
            >
            > <http://www.htmlhelp.com/cgi-bin/validate.cgi?url=http%3A//epicroadtrips.us/2009/sept/ca/d1/index.php&warnings=yes&input=yes>
            >
            > <http://www.htmlhelp.com/cgi-bin/validate.cgi?url=http%3A//epicroadtrips.us/2009/sept/ca/d1/index.html&warnings=yes&input=yes>
            >
            >
            > To start with, there is a PHP error in the source of the PHP page
            > Gosh, I've never seen THAT before.
            >
            > <div id="wrapper"><!--
            > Warning: include(header.php): failed to open stream: No such file or
            > directory in
            > /hsphere/local/home/mbreidin/epicroadtrips.us/2009/sept/ca/d1/index.php
            > on line 13
            >
            > Warning: include(): Failed opening 'header.php' for inclusion
            > (include_path='.:/hsphere/shared/apache/libexec/php5ext/php/') in
            > /hsphere/local/home/mbreidin/epicroadtrips.us/2009/sept/ca/d1/index.php
            > on line 13
            > -->

            I have never seen this error show up.
            The 'header.php' was a commented line so I don't know why it would
            generate an error.
            However, I removed the comment.

            >
            > So that header.php is never included. On the other hand its content
            > doesn't seem to be used in the HTML version either.
            >
            > Look at the PHP page (in a browser). In the menu you have
            >
            > Week 2
            > Week 3Week 2
            > Week 3
            >
            > That can't be design. I think it comes from that you have commented
            > out a bunch of LIs, but the comment is screwed up because the closing
            > tag for LI right before it lacks the closing ">". It's at line 203 or
            > thereabout.

            I *think* I got the php menu comments cleaned up.
            But, the <br> is still in there as I cannot see another way to get a
            line break in menu.

            The "Error: ID currentpage already defined" always generates errors.
            I have tried changing over to classes to avoid this, but I never seem to
            get anywhere.

            Here are the php menus in case that might help.
            http://epicroadtrips.us/2009/sept/ca/d1/php-menus.txt

            Where to go from here?

            Thanks,
            -Mike

            >
            > I don't know if the fact that the menu is broader on the PHP page
            > (because of the above) causes the difference you ask about, but it's
            > place to start anyway. There are other oddities too.
            >
            > Lotta
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.