Loading ...
Sorry, an error occurred while loading the content.

Re: [NH] Frames

Expand Messages
  • Dave
    Hi just went to this site it is fine http://www.rainbowends.org/cadre.htm two frames just the way it should be?? THANKYOU DAVE M ... From: bensbach
    Message 1 of 20 , Jan 19, 2008
    • 0 Attachment
      Hi
      just went to this site it is fine
      http://www.rainbowends.org/cadre.htm two frames just the way it should be??
      THANKYOU DAVE M

      ----- Original Message -----
      From: "bensbach" <ericbj-mmvii@...>
      To: <ntb-html@yahoogroups.com>
      Sent: Saturday, January 19, 2008 1:52 AM
      Subject: [NH] Frames


      >
      > Some days ago I did a little re-vamping and put some
      > additional documents on my website, on a server in the
      > UK. The changes cannot be seen here in Thailand. Going
      > on past experience it will take about a week for the
      > changes to become visible. Have been told that websites
      > are cached on servers around the world and these are only
      > "refreshed" every so often. (?) Anyway, I cannot yet see
      > what bugs the site may have, or even if it is there at
      > all.
      > Frustrating !
      >
      > The site, www.rainbow ends.org uses two vertical frames:
      > a narrow left-hand one to list content and to the right
      > of that the document being viewed.
      >
      > I gather that frames are rather disparaged these days,
      > but the alternative until something better is widely
      > adopted would seem to be tables.
      >
      > The problem with tables is:
      >
      > 1) I do not have time to go manually updating large
      > numbers of files every time the Contents changes
      > (optimistically, I hope to do this more often in future,
      > the site having been almost unchanged in seven years)
      >
      > 2) I do not have any programming skills to automate the
      > task.
      >
      > 3) The content of a table is fixed, while the content of
      > a frame can be changed with a mouse click
      >
      > At the foot of each document there is a link which now
      > goes to a Categories Page which links to several Contents
      > Pages. Each of the latter lists files that can be clicked
      > on and brought up in the Main Frame.
      >
      > Previously there was just a single Contents Page, listing
      > all documents (i.e. no Categories). But this made for a
      > long and rather indigestible list of documents, which
      > would have become longer still with additions.
      >
      > In the good old days, a person clicking on "Contents" at
      > the bottom of a page would see all the documents
      > available. If they came through the Front Page of the
      > site, they would see this in the Main Frame, and if they
      > came though a search-engine they would see it without any
      > frames. Doubtless there was a better way of doing this,
      > but at least there were no frames-within-frames.
      >
      > Now however, using modern browsers -- IE7 and Opera (not
      > having tried with the others) -- this no longer works
      > properly if one is not viewing the files from within
      > frames. Maybe TARGET="xxx" confuses the browser when
      > there is no TARGET="xxx".
      >
      > What happens is that the linked file is opened, but the
      > focus remains on the existing file.
      >
      > With Opera, a new tab appears, but most people would not
      > realise this and so would not click on it.
      >
      > With IE7, a new window opens, but this is often hidden
      > behind the existing window.
      >
      > One answer might be to take people to the Frameset page.
      > But is there is some way of preventing those already
      > viewing within frames from picking up another set of
      > frames ?
      >
      > Would this make the site less accessible to the search-
      > engines ?
      >
      > Despite the frames, which it has always had, five years
      > ago 65% of hits were via the search-engines -- although
      > it had never been promoted to them.
      >
      > Now however, perhaps as result of the site's content
      > remaining unchanged for so long, not only has the number
      > of visitors fallen off considerably, but the proportion
      > coming through the search engines has fallen to 35% of
      > the total.
      >
      > Your advice and comments would be much appreciated.
      >
      > Eric Johnston
      >
      > p.s. Of the search criteria, the one that has brought by
      > far the most visitors to my site is the word "torture".
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      >
      > NoteTab site: http://www.notetab.com/
      > Fookes Software site: http://www.fookes.com/
      > Yahoo! Groups Links
      >
      >
      >
      >
    • Axel Berger
      ... In that case it can t be a proxy cache problem. Are you sure it is not your server at fault here? ... I don t -- so it definitely is your server that does
      Message 2 of 20 , Jan 20, 2008
      • 0 Attachment
        bensbach wrote:
        > When I give the URL of a new
        > file, I get a "404: not found" response.

        In that case it can't be a proxy cache problem. Are you sure it is not
        your server at fault here?

        > If you are not seeing on the Front Page the
        > photos of Burma's three top ruling generals,
        > you are not seeing the updated site,

        I don't -- so it definitely is your server that does not update.
        Is it possible that you don't FTP directly into your webspace but send
        updates somewhere that someone has to insert manually and that they take
        their time?

        Axel
      • bensbach
        ... The site always had two frames. The question is this: Does index.html show you three portait photos of Burmese generals ? And do the frames it brings up
        Message 3 of 20 , Jan 20, 2008
        • 0 Attachment
          > Hi
          > just went to this site it is fine
          > http://www.rainbowends.org/cadre.htm two frames
          > just the way it should be??
          > THANKYOU DAVE M

          The site always had two frames. The question
          is this:

          Does index.html show you three portait photos
          of Burmese generals ?

          And do the frames it brings up show you, in the
          righthand one, a text in English?

          If not, you are seeing my 7-year old site.

          > > If you are not seeing on the Front Page the
          > > photos of Burma's three top ruling generals,
          > > you are not seeing the updated site,
          >
          > I don't -- so it definitely is your server that
          > does not update.
          > Is it possible that you don't FTP directly into
          > your webspace but send updates somewhere that
          > someone has to insert manually and that they
          > take their time?
          >
          > Axel

          Thanks.

          I'll get on to the company that is hosting my
          site, www.skymarket.co.uk

          When I first tried to update my site Sunday a
          week ago, I was unable to do so: the FTP server
          didn't recognise my login details. I checked
          them and they were correct. It turned out the
          company had lost my login!

          After they gave me a new ID and password
          everything went smoothly, at least as far as
          concerns the uploading to the FTP server.

          The log file showed everything was OK.

          Moreover in the past week, since then, I have
          added new files and modified others by
          synchronising with the server. And the
          synchronising process has indicated that all
          the other files were on the server.

          Maybe someone at the hosting company must
          manually transfer the files from the FTP server
          to the HTTP server? That is something I am
          totally ignorant about.

          I do remember that years ago when I uploaded
          the odd file from France the changes were
          visible within hours, but from Thailand it took
          about a week for the changes to become visible.

          But if no-one is seeing the new site, there
          must be something drastically wrong.

          Thanks again.

          Eric Johnston
        • Axel Berger
          ... This is not as it should be. When I upload I can see the changes right away and so can the W3C validator. If it were not so, how could I ever debug? In
          Message 4 of 20 , Jan 20, 2008
          • 0 Attachment
            bensbach wrote:
            > I do remember that years ago when I uploaded
            > the odd file from France the changes were
            > visible within hours, but from Thailand it took
            > about a week for the changes to become visible.

            This is not as it should be. When I upload I can see the changes right
            away and so can the W3C validator. If it were not so, how could I ever
            debug? In very rare cases my own browser cache jumps in and hides
            changes, but that only happens with stylesheets or scripts, never with
            the site itself.

            Axel
          • bensbach
            I have been in contact with my website hosting company s technical support, but up to now the mystery of where my uploaded files can be remains unresolved, as
            Message 5 of 20 , Jan 21, 2008
            • 0 Attachment
              I have been in contact with my website hosting
              company's technical support, but up to now the
              mystery of where my uploaded files can be
              remains unresolved, as the hosting company,
              skymarket.co.uk cannot find them on its
              servers. But my FTP client can see them.

              I give below the exchange of messages.

              Anyone any suggestions?

              ME:
              After the small problem with logging in to the
              FTP server was resolved I successfully uploaded
              my new files, on Tuesday 15th January. The log
              file showed this was accomplished successfully.
              Since then I have uploaded new and modified
              files by synchronisation with the FTP server.
              The synchronisation process has shown that the
              previously uploaded files are present on the
              server.
              However I am not seeing the new site in my
              browsers.
              [...]

              HOST:
              Which domain are you having issues with?

              ME:
              www.rainbowends.org
              This is my only domain.

              HOST:
              I have looked at that hosting and it was last
              updated in 2003.
              Can you confirm the FTP information you are
              using. Host, user and pass please.

              ME:
              I have been using as my "FTP Neighbourhood":
              www.rainbowends.org and my user i/d and
              password are as given to me by you, as below.

              HOST:
              I have logged into FTP using that information
              and I see the same files as before, the ones
              that haven't been updated since 2003.
              The problem appears to be in your uploading
              process somewhere, as your new files are not
              being uploaded.

              ME:
              My new files must be on your server somewhere,
              surely?
              Please see below.
              I have connected using this time a different
              FTP client, SmartFTP instead of that included
              with HotMetal Pro v.6.
              It sees all the new files and folders. When I
              cut the Internet connection it sees them no
              longer so it cannot be seeing something on my
              computer. It must be on the web at
              212.84.161.99. Is that right?
              ________________________________
              [22:40:54] SmartFTP v2.5.1008.27
              [22:40:55] Resolving host name "www.rainbowends.org"
              [22:40:57] Connecting to 212.84.161.99 Port: 21
              [22:40:57] Connected to www.rainbowends.org.
              [22:41:03] 220 ProFTPD 1.2.10 Server (Cougar FTP
              Service) [212.84.161.99]
              [22:41:03] USER rainbowe
              [22:41:05] 331 Password required for rainbowe.
              [22:41:05] PASS (hidden)
              [22:41:06] 230 User rainbowe logged in.
              [22:41:06] SYST
              [22:41:07] 215 UNIX Type: L8
              [22:41:07] Detected Server Type: UNIX
              [22:41:07] FEAT
              [22:41:08] 211-Features:
              [22:41:08] MDTM
              [22:41:10] REST STREAM
              [22:41:10] SIZE
              [22:41:10] 211 End
              [22:41:10] PWD
              [22:41:12] 257 "/" is current directory.
              [22:41:12] CWD www.rainbowends.org
              [22:41:14] 250 CWD command successful
              [22:41:14] PWD
              [22:41:17] 257 "/www.rainbowends.org" is current directory.
              [22:41:17] TYPE A
              [22:41:19] 200 Type set to A
              [22:41:19] PASV
              [22:41:20] 227 Entering Passive Mode (212,84,161,99,226,215).
              [22:41:20] Opening data connection to 212.84.161.99 Port: 58071
              [22:41:20] LIST -aL
              [22:41:22] 150 Opening ASCII mode data connection for file list
              [22:41:22] 1379 bytes transferred. (1,69 Ko/s) (796 ms)
              [22:41:23] 226 Transfer complete.
              [22:41:53] NOOP
              [22:41:57] 200 NOOP command successful
              [22:42:27] NOOP
              [22:42:29] 200 NOOP command successful
              [22:42:59] NOOP
              [22:43:01] 200 NOOP command successful
              [22:43:32] NOOP
              [22:43:35] 200 NOOP command successful
              [22:43:40] CWD /www.rainbowends.org/mmviii
              [22:43:43] 250 CWD command successful
              [22:43:43] PWD
              [22:43:46] 257 "/www.rainbowends.org/mmviii" is current directory.
              [22:43:46] PASV
              [22:43:48] 227 Entering Passive Mode (212,84,161,99,227,88).
              [22:43:48] Opening data connection to 212.84.161.99 Port: 58200
              [22:43:48] LIST -aL
              [22:43:55] 150 Opening ASCII mode data connection for file list
              [22:43:55] 1350 bytes transferred. (394 octets/s) (00:00:03)
              [22:43:58] 226 Transfer complete.
              [22:44:28] NOOP
              [22:44:32] 200 NOOP command successful
              [22:44:46] Une connexion établie a été abandonnée par un logiciel de
              votre ordinateur hôte.
              [22:44:46] Server closed connection




              --- In ntb-html@yahoogroups.com, Axel Berger <Axel-Berger@...> wrote:
              >
              > bensbach wrote:
              > > I do remember that years ago when I uploaded
              > > the odd file from France the changes were
              > > visible within hours, but from Thailand it took
              > > about a week for the changes to become visible.
              >
              > This is not as it should be. When I upload I can see the changes
              right
              > away and so can the W3C validator. If it were not so, how could I
              ever
              > debug? In very rare cases my own browser cache jumps in and hides
              > changes, but that only happens with stylesheets or scripts, never
              with
              > the site itself.
              >
              > Axel
              >
            • bensbach
              The website hosters have found MY mistake. I had uploaded not only the files intended for the website but also the folder they are contained in. The name of
              Message 6 of 20 , Jan 21, 2008
              • 0 Attachment
                The website hosters have found MY mistake.
                I had uploaded not only the files intended
                for the website but also the folder they
                are contained in. The name of that folder
                is www.rainbowends.org so the mistake was
                not obvious at first site.

                My apologies for troubling you all.

                Eric Johnston


                --- In ntb-html@yahoogroups.com, "bensbach" <ericbj-mmvii@...> wrote:
                >
                > I have been in contact with my website hosting
                > company's technical support, but up to now the
                > mystery of where my uploaded files can be
                > remains unresolved, as the hosting company,
                > skymarket.co.uk cannot find them on its
                > servers. But my FTP client can see them.
                >
                > I give below the exchange of messages.
                >
                > Anyone any suggestions?
              • Axel Berger
                ... Using FTP: Can you see the old files, those that are displayed through HTTP, in the self-same directory. If so you uploadd to the right place. Is your
                Message 7 of 20 , Jan 21, 2008
                • 0 Attachment
                  bensbach wrote:
                  > Anyone any suggestions?

                  Using FTP: Can you see the old files, those that are displayed through
                  HTTP, in the self-same directory. If so you uploadd to the right place.

                  Is your capitalization correct for all the new file names? And have you
                  made sure that none of them contains any accented French letters that
                  are not part of standard US 7-bit ASCII?

                  Axel
                • Axel Berger
                  ... No problem, glad it s solved. N.B: I recommend the Totalcommander for FTP (among very many other things). It makes things like that very easy to spot. Axel
                  Message 8 of 20 , Jan 21, 2008
                  • 0 Attachment
                    bensbach wrote:
                    > My apologies for troubling you all.

                    No problem, glad it's solved.
                    N.B: I recommend the Totalcommander for FTP (among very many other
                    things). It makes things like that very easy to spot.

                    Axel
                  Your message has been successfully submitted and would be delivered to recipients shortly.