Loading ...
Sorry, an error occurred while loading the content.

style and layout presentation using notetab -moving to new folder-

Expand Messages
  • xmarti3
    HI, I am glad to find this group! I have a problem.. I ve built website pages using NoteTab Light and saved everything in one folder that has to do with the
    Message 1 of 9 , Apr 11, 2007
    • 0 Attachment
      HI, I am glad to find this group!
      I have a problem..
      I've built website pages using NoteTab Light and saved everything in
      one folder that has to do with the website. I am ready to upload the
      pages to a server but I am unsure it is going to work because if I put
      the web pages in a different folder (any different location) it seems
      the layout and presentation pages are not the same and seem to no
      longer support the other pages. The entire look of the presentation
      and layout sheets change. ????? So.. I guess something is lost when
      I move the pages? I did go in and check the feature to filter binary
      files.. and I tested it once, it did not seem to matter. Can you help
      me with this? All I need is for the page to stay the same if it is
      moved out of the original folder. I can move the folder out where it
      displays incorrectly, but then when I move the file back into the
      original folder it is ok again. I don't understand this.

      I am using NoteTab Light. I guess this will always be an issue until
      I get it figured out, but for now I am most interested in a successful
      upload to the webserver. If I upgrade to the Standard edition of
      NoteTab, will this help overcome the problem as it apparently has a
      clipboard feature that will upload files to the web server?

      Thanks for any help.
      Laura
    • Don - HtmlFixIt.com
      ... Hi Laura, Welcome to the notetab family. The problem you are experiencing has NOTHING to do with your version of notetab. I would encourage you to order
      Message 2 of 9 , Apr 11, 2007
      • 0 Attachment
        xmarti3 wrote:
        > HI, I am glad to find this group!
        > I have a problem..
        > I've built website pages using NoteTab Light and saved everything in
        > one folder that has to do with the website. I am ready to upload the
        > pages to a server but I am unsure it is going to work because if I put
        > the web pages in a different folder (any different location) it seems
        > the layout and presentation pages are not the same and seem to no
        > longer support the other pages. The entire look of the presentation
        > and layout sheets change. ????? So.. I guess something is lost when
        > I move the pages? I did go in and check the feature to filter binary
        > files.. and I tested it once, it did not seem to matter. Can you help
        > me with this? All I need is for the page to stay the same if it is
        > moved out of the original folder. I can move the folder out where it
        > displays incorrectly, but then when I move the file back into the
        > original folder it is ok again. I don't understand this.
        >
        > I am using NoteTab Light. I guess this will always be an issue until
        > I get it figured out, but for now I am most interested in a successful
        > upload to the webserver. If I upgrade to the Standard edition of
        > NoteTab, will this help overcome the problem as it apparently has a
        > clipboard feature that will upload files to the web server?
        >
        > Thanks for any help.
        > Laura


        Hi Laura,

        Welcome to the notetab family. The problem you are experiencing has
        NOTHING to do with your version of notetab. I would encourage you to
        order standard or pro just to be supportive of a great program, but
        there is no obligation to do so -- but multiple undo's make it worth having!

        Your most likely cause is probably hard linking -- find your href tags
        that will look like this:
        <a
        href="file:///C|/Documents%20and%20Settings/user/My%20Documents/folder/filename.html">link
        to file</a>

        and or your image tags that might look like this:

        <img
        src="file:///C|/Documents%20and%20Settings/user/My%20Documents/folder/filename.html"
        width="130" height="98" border="0" alt="image" />

        If that is what they look like, then they won't work if you move them
        because the links are to a particular location on your machine. Most
        people prefer relative linking so those would become this:
        <a href="filename.html">link to file</a>

        and or your image tags that might look like this:

        <img src="filename.html" width="130" height="98" border="0" alt="image" />

        After deleting the unnecessary location information:
        file:///C|/Documents%20and%20Settings/user/My%20Documents/folder/

        If you post just a little bit out of the body of your page that will
        help us to see. Be judicious in posting it as we don't need to see the
        whole page ... as it will be long perhaps for an email.

        Hard linking occurs if you don't save the html file before inserting the
        links to images, css files, other pages, etc. If you save your html
        file you are working on first, then notetab will by default use relative
        instead of absolute links.

        This link may explain it:
        http://www.extropia.com/tutorials/web_design/relative_absolute_links.html
        I would strongly urge you however to avoid using capitals, spaces and
        any other character besides a-z, 0-9 and the underscore _ character for
        folder, path or file names.

        Good luck and let us know how it goes.

        Don
      • xmarti3
        I forgot to change the links to the folder names, that s probably the problem, lol. I ll try that. All I need is for the page to stay the same if it is
        Message 3 of 9 , Apr 11, 2007
        • 0 Attachment
          I forgot to change the links to the folder names, that's probably the
          problem, lol. I'll try that.


          All I need is for the page to stay the same if it is
          > moved out of the original folder. I can move the folder out where it
          > displays incorrectly, but then when I move the file back into the
          > original folder it is ok again. I don't understand this.
          >
          > I am using NoteTab Light. I guess this will always be an issue until
          > I get it figured out, but for now I am most interested in a successful
          > upload to the webserver. If I upgrade to the Standard edition of
          > NoteTab, will this help overcome the problem as it apparently has a
          > clipboard feature that will upload files to the web server?
          >
          > Thanks for any help.
          > Laura
          >
        • loro
          Hi Laura, ... Folder, file... I have a feeling you move only a HTML page and not other files that may be involved. Images, CSS, JavaScript, whatever you may
          Message 4 of 9 , Apr 11, 2007
          • 0 Attachment
            Hi Laura,

            >I have a problem..
            >I've built website pages using NoteTab Light and saved everything in
            >one folder that has to do with the website. I am ready to upload the
            >pages to a server but I am unsure it is going to work because if I put
            >the web pages in a different folder (any different location) it seems
            >the layout and presentation pages are not the same and seem to no
            >longer support the other pages. The entire look of the presentation
            >and layout sheets change. ????? So.. I guess something is lost when
            >I move the pages? I did go in and check the feature to filter binary
            >files.. and I tested it once, it did not seem to matter. Can you help
            >me with this? All I need is for the page to stay the same if it is
            >moved out of the original folder. I can move the folder out where it
            >displays incorrectly, but then when I move the file back into the
            >original folder it is ok again. I don't understand this.

            Folder, file... I have a feeling you move only a HTML page and not other
            files that may be involved. Images, CSS, JavaScript, whatever you may have
            used. Also, if you have used relative URLs, in image tags for example, the
            files must keep the same relationship to each other on the server. If you
            have all HTML in one folder and all images in a subfolder called "images"
            inside the first folder, that's how it has to be on the server too.

            Sorry if this is a too simplistic answer to your question, but I hope it
            helps. :-)
            Lotta
          • xmarti3
            in answer to my post and reply..maybe the idea to change the folder name was just for thinkin too hard. .. if i try to change the folder name, it is read-only,
            Message 5 of 9 , Apr 11, 2007
            • 0 Attachment
              in answer to my post and reply..maybe the idea to change the folder
              name was just for thinkin too hard. ..
              if i try to change the folder name, it is read-only, anyway, here is
              what it looks like for the link to on all the pages which work well in
              the original folder, doesn't look like a folder is accessed (I used a
              css template from www.ssi-developer.net -btw- I didn't create the
              original layout and folders.
              :
              <link rel="stylesheet" type="text/css"
              href="3c-lcrc-static-layout.css" />
              <link rel="stylesheet" type="text/css"
              href="3c-lcrc-static-presentation.css" />



              and that is the name of the files too.. i got a little confused
              thinking at first maybe the problem was the folder because the
              original folder has the same name as 3c-lcrc-static. I just put a lot
              of stuff in the original folder so I thought if I moved just the stuff
              needed for the website to a different folder I'd be able to see it all
              much easier for the ftp upload (another thing I have never used
              before!) even so, I have no idea yet if maybe i can just upload from
              the original folder and it will all work out well, but this thing is
              bothering me anyway.


              --- In ntb-html@yahoogroups.com, "xmarti3" <lalmarti@...> wrote:
              >
              >
              > I forgot to change the links to the folder names, that's probably the
              > problem, lol. I'll try that.
              >
              >
              > All I need is for the page to stay the same if it is
              > > moved out of the original folder. I can move the folder out where it
              > > displays incorrectly, but then when I move the file back into the
              > > original folder it is ok again. I don't understand this.
              > >
              > > I am using NoteTab Light. I guess this will always be an issue until
              > > I get it figured out, but for now I am most interested in a successful
              > > upload to the webserver. If I upgrade to the Standard edition of
              > > NoteTab, will this help overcome the problem as it apparently has a
              > > clipboard feature that will upload files to the web server?
              > >
              > > Thanks for any help.
              > > Laura
              > >
              >
            • xmarti3
              ... ... href= file:///C|/Documents%20and%20Settings/user/My%20Documents/folder/filename.html link ...
              Message 6 of 9 , Apr 11, 2007
              • 0 Attachment
                --- In ntb-html@yahoogroups.com, "Don - HtmlFixIt.com" <don@...> wrote:
                <SNIP>
                > Your most likely cause is probably hard linking -- find your href tags
                > that will look like this:
                > <a
                >
                href="file:///C|/Documents%20and%20Settings/user/My%20Documents/folder/filename.html">link

                > to file</a>
                >
                > and or your image tags that might look like this:
                >
                > <img
                >
                src="file:///C|/Documents%20and%20Settings/user/My%20Documents/folder/filename.html"

                > width="130" height="98" border="0" alt="image" />
                >
                > If that is what they look like, then they won't work if you move them
                > because the links are to a particular location on your machine. Most
                > people prefer relative linking so those would become this:
                > <a href="filename.html">link to file</a>
                >
                > and or your image tags that might look like this:
                >
                > <img src="filename.html" width="130" height="98" border="0"
                alt="image" />
                >
                > After deleting the unnecessary location information:
                > file:///C|/Documents%20and%20Settings/user/My%20Documents/folder/
                >
                > If you post just a little bit out of the body of your page that will
                > help us to see. Be judicious in posting it as we don't need to see the
                > whole page ... as it will be long perhaps for an email.
                >
                > Hard linking occurs if you don't save the html file before inserting
                the
                > links to images, css files, other pages, etc. If you save your html
                > file you are working on first, then notetab will by default use
                relative
                > instead of absolute links.

                I did use relative links, and I did save them as .html first thing as
                well. And also after I moved ALL the needed web files into a new
                folder what happens is.. all the text shows and links do take me to
                the proper pages, they DO work. Images are there, it's just that
                everything is placed wrong, like linear to the side or cast out into
                the middle where it does not belong. Presentation styles are no longer
                used either. So it is layout and presentation that is a mess, not
                being read. Not only is it not being read, but if I open the those
                files, it is all suddenly in paragraph form instead of the nice neat
                easy to read placement it has in the original, but maybe that is
                normal, unsure, I don't like it though,lol. I AM very new to this,
                it's taken me a long time to get this far in part for all the little
                mistakes and experimenting, this could be a very simple mistake on my
                part, but I cannot figure it out and I hate to upload to the website
                and find a mess there..


                > This link may explain it:
                >
                http://www.extropia.com/tutorials/web_design/relative_absolute_links.html
                > I would strongly urge you however to avoid using capitals, spaces and
                > any other character besides a-z, 0-9 and the underscore _ character for
                > folder, path or file names.
                >
                > Good luck and let us know how it goes.
                >
                > Don
                >
                It's all done in lowercase XHTML.
                Thanks for your help. If you still want me to copy/paste a little let
                me know.. but the links are working. Everything seems right .. ALMOST :)

                Laura
              • Don - HtmlFixIt.com
                do you have a link on the server where we can just look at it?
                Message 7 of 9 , Apr 11, 2007
                • 0 Attachment
                  do you have a link on the server where we can just look at it?
                • xmarti3
                  ... ... other ... may have ... example, the ... If you ... images ... hope it ... Thanks Lotta, and don t worry, nothing is too simplistic, I know
                  Message 8 of 9 , Apr 11, 2007
                  • 0 Attachment
                    --- In ntb-html@yahoogroups.com, loro <loro-spam01-@...> wrote:
                    <SNIP>
                    >
                    > Folder, file... I have a feeling you move only a HTML page and not
                    other
                    > files that may be involved. Images, CSS, JavaScript, whatever you
                    may have
                    > used. Also, if you have used relative URLs, in image tags for
                    example, the
                    > files must keep the same relationship to each other on the server.
                    If you
                    > have all HTML in one folder and all images in a subfolder called
                    "images"
                    > inside the first folder, that's how it has to be on the server too.
                    >
                    > Sorry if this is a too simplistic answer to your question, but I
                    hope it
                    > helps. :-)
                    > Lotta

                    Thanks Lotta, and don't worry, nothing is too simplistic, I know it's
                    a simple error somewhere, but feels like looking for a needle in a
                    haystack.
                    What I did was move everything (Can't 'think' of anything i missed!) I
                    needed to a new folder, only NoteTab files, and images, no java or any
                    other scripting . So far I have never even created an absolute
                    pathname, I kept everything real simple, which is good, cause nothing
                    has been THAT simple. Anyway, every little bit of info helps me
                    somewhere, sometime, I learn that too. Thanks, I'll take ANY idea.
                    Laura
                  • xmarti3
                    ... No, nothing is on the server yet. I may give that a go soon though, just to see what happens. Here s a snippet of the text in NoteTab .. all the links
                    Message 9 of 9 , Apr 11, 2007
                    • 0 Attachment
                      --- In ntb-html@yahoogroups.com, "Don - HtmlFixIt.com" <don@...> wrote:
                      >
                      > do you have a link on the server where we can just look at it?

                      No, nothing is on the server yet. I may give that a go soon though,
                      just to see what happens.
                      Here's a snippet of the text in NoteTab .. all the links work on the
                      entire website.
                      I hope this shows up in the orderly fashion I copy/pasted.

                      Laura

                      >
                      <link rel="stylesheet" type="text/css"
                      href="3c-lcrc-static-layout.css" />
                      <link rel="stylesheet" type="text/css"
                      href="3c-lcrc-static-presentation.css" />
                      <link rel="stylesheet" type="text/css"
                      href="print.css" media="print"/>

                      </head>


                      <body>
                      <!-- left column -->


                      <div id="lh-col">

                      <div id="navigation">
                      <ul>
                      <li><a href="index.html">Home</a></li>
                      <li><a href="services.html">Services</a></li>
                      <ul>
                      <li><a href="petsit.html">Pet Sitting</a></li>
                      <li><a href="dogwalking.html">Dog Walking</a></li>
                      <li><a href="pettaxi.html">Pet Taxi</a></li>
                      </ul>
                      <li><a href="terms.html">Terms</a></li>
                      <li><a href="FAQs.html">FAQs</a></li>
                      <li><a href="clients.html">Request Service</a></li>
                      <li><a href="resources.html">Resources</a></li>
                      <li><a href="contact.html">Contact Info</a></li>

                      </ul>

                      </div>
                      <div id="lh-col-link">

                      <img src="project10.jpg" border="0" alt="parakeets" class="leftimage" />

                      </div>

                      </div>

                      <!-- end of left column -->
                    Your message has been successfully submitted and would be delivered to recipients shortly.