Loading ...
Sorry, an error occurred while loading the content.

Re: [NH] Expression worked in 5 beta 1 broken in 5 beta 2

Expand Messages
  • Gary Oliver
    Hi, Thanks, Yes I did try lots of syntax for html comments but the only one that works in RegEx in clips is the way I have it in my example. I put this an
    Message 1 of 3 , Jul 21, 2006
    • 0 Attachment
      Hi, Thanks,
      Yes I did try lots of syntax for html comments but the only one that
      works in RegEx in clips is the way I have it in my example.
      I put this an other observations in a post on the CLIPS list called.
      "Notes On Regular Expressions In version 5 beta-G.O."

      Their is an RTF file in the files with more notes on the RegEx help.
      That syntax <\!-- does work in RegEx find dialogs though.

      Your customizable HTML editor save our but at work when we had to drop
      FrontPage to become NYS-ADA compliant. Thanks.

      --- In ntb-html@yahoogroups.com, Eric Fookes <egroups@...> wrote:
      >
      > Thanks for the info Gary. I'll see what I can do. I'm not sure that I
      > understand the beginning of your regex pattern though. Have you tried
      >
      > ^!Replace "<\!--
      >
      > instead of
      >
      > ^!Replace "[<][!]--
      >
      > --
      > Regards,
      >
      > Eric Fookes
      > http://www.fookes.com/
      >
      >
      > Gary Oliver wrote:
      > > ^!Replace "[<][!]-- EDITED-DATE\s*\B+\s*\B+\s*-->" >> "<!--
      > > EDITED-DATE ^%user% ^$GetDate(yyyy/mm/dd-HH:mm)$ -->" RWAIS
      > >
      > > First I get an error that says "regex error: nothing to repeat" then
      > > it says the line above is the problem
      > > It worked in beta 1.
      > > I think I remember there was something said about new meaningful error
      > > messages.
      > >
      > > I might as well metion another strange behavior in both betas.
      > > The clicp wizard field that produces a file open dialog apears to be
      > > waiting for an event and then it jumps to the forground. Unfortunately
      > > when the open file dialog has to also use a login box to get where it
      > > is going (Such as webpage or a server location) then as soon as the
      > > login occurs (clicking OK to login box) the clip wizard box jumps
      > > infront of the open file dialog. Slightly confusing for the people I
      > > will be programing for.
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.