Loading ...
Sorry, an error occurred while loading the content.

Re: [NH] non SGML errors . . . lot's of them

Expand Messages
  • loro
    ... Which are the characters? Anyway, THIS document is served without any character encoding from the server and has ISO-8859-1 in a Meta tag. The other one is
    Message 1 of 20 , Jun 3, 2005
    • 0 Attachment
      sisterscape wrote:
      >I just did a fresh download of WordPress and the characters are there
      >just after I unzip the file. I noticed them before in Notepad but
      >they were hidden in NoteTab.
      >
      >But here's the kicker . . . I just checked out a test installation I
      >did on another server. It validates perfectly with the evil
      >characters.
      >http://validator.w3.org/check?uri=http%3A%2F%2Fwww.eartherdesigns.com%2Fj
      >ournal%2F So this makes me think it's a server configuration. Does
      >that sound logical?

      Which are the characters?

      Anyway, THIS document is served without any character encoding from the
      server and has ISO-8859-1 in a Meta tag. The other one is served as UTF-8.
      I don't know, but if you wrote it in Notetab and used characters outside
      US-ASCII and then tried to pass it off as UTF-8 that could maybe be the
      reason. The ASCII characters are the same in UTF-8, but not other ANSI
      characters, like åäö. That's about right, I think. This stuff always
      confuses me. :-o

      Lotta
    • sisterscape
      ... Thanks for the follow up. I have attached an images of one of the php files so you can see the funny 0s at the line breaks. The server admin said it was
      Message 2 of 20 , Jun 3, 2005
      • 0 Attachment
        --- loro <loro-spam01-@...> wrote:

        > sisterscape wrote:
        > >I just did a fresh download of WordPress and the characters are
        > there
        > >just after I unzip the file. I noticed them before in Notepad but
        > >they were hidden in NoteTab.
        > >
        > >But here's the kicker . . . I just checked out a test installation I
        > >did on another server. It validates perfectly with the evil
        > >characters.
        >
        >http://validator.w3.org/check?uri=http%3A%2F%2Fwww.eartherdesigns.com%2Fj
        > >ournal%2F So this makes me think it's a server configuration. Does
        > >that sound logical?
        >
        > Which are the characters?
        >
        > Anyway, THIS document is served without any character encoding from
        > the
        > server and has ISO-8859-1 in a Meta tag. The other one is served as
        > UTF-8.
        > I don't know, but if you wrote it in Notetab and used characters
        > outside
        > US-ASCII and then tried to pass it off as UTF-8 that could maybe be
        > the
        > reason. The ASCII characters are the same in UTF-8, but not other
        > ANSI
        > characters, like åäö. That's about right, I think. This stuff always
        > confuses me. :-o
        >
        > Lotta
        >

        Thanks for the follow up. I have attached an images of one of the php
        files so you can see the funny 0s at the line breaks. The server admin
        said it was \x00 but he wasn't clear on it either.

        I did not actually write the WordPress code and most of the SGML errors
        - a whooping total of 33,513 for the entire script - came from files I
        never even opened. So the errors were transmitted without any
        interference from NoteTab.

        Yes, the encoding is charset=UTF-8, probably because of the RSS feeds
        etc.- it's all a mystery to me. The question is why can one server deal
        with it but not another?

        sisterscape

        __________________________________________________
        Do You Yahoo!?
        Tired of spam? Yahoo! Mail has the best spam protection around
        http://mail.yahoo.com

        [Non-text portions of this message have been removed]
      • sisterscape
        So what happened to the attachment? Not allowed on this list? Anyway, I posted it here http://www.waterstonewildlife.org/images/SGML.jpg so you can see the
        Message 3 of 20 , Jun 3, 2005
        • 0 Attachment
          So what happened to the attachment? Not allowed on this list? Anyway,
          I posted it here http://www.waterstonewildlife.org/images/SGML.jpg so
          you can see the critters.

          --- sisterscape <sisterscape@...> wrote:

          > --- loro <loro-spam01-@...> wrote:
          >
          > > sisterscape wrote:
          > > >I just did a fresh download of WordPress and the characters are
          > > there
          > > >just after I unzip the file. I noticed them before in Notepad
          > but
          > > >they were hidden in NoteTab.
          > > >
          > > >But here's the kicker . . . I just checked out a test installation
          > I
          > > >did on another server. It validates perfectly with the evil
          > > >characters.
          > >
          >
          >http://validator.w3.org/check?uri=http%3A%2F%2Fwww.eartherdesigns.com%2Fj
          > > >ournal%2F So this makes me think it's a server configuration.
          > Does
          > > >that sound logical?
          > >
          > > Which are the characters?
          > >
          > > Anyway, THIS document is served without any character encoding from
          > > the
          > > server and has ISO-8859-1 in a Meta tag. The other one is served as
          > > UTF-8.
          > > I don't know, but if you wrote it in Notetab and used characters
          > > outside
          > > US-ASCII and then tried to pass it off as UTF-8 that could maybe be
          > > the
          > > reason. The ASCII characters are the same in UTF-8, but not other
          > > ANSI
          > > characters, like åäö. That's about right, I think. This stuff
          > always
          > > confuses me. :-o
          > >
          > > Lotta
          > >
          >
          > Thanks for the follow up. I have attached an images of one of the
          > php
          > files so you can see the funny 0s at the line breaks. The server
          > admin
          > said it was \x00 but he wasn't clear on it either.
          >
          > I did not actually write the WordPress code and most of the SGML
          > errors
          > - a whooping total of 33,513 for the entire script - came from files
          > I
          > never even opened. So the errors were transmitted without any
          > interference from NoteTab.
          >
          > Yes, the encoding is charset=UTF-8, probably because of the RSS feeds
          > etc.- it's all a mystery to me. The question is why can one server
          > deal
          > with it but not another?
          >
          > sisterscape
          >
          > __________________________________________________
          > Do You Yahoo!?
          > Tired of spam? Yahoo! Mail has the best spam protection around
          > http://mail.yahoo.com
          >
          > [Non-text portions of this message have been removed]
          >
          >


          __________________________________________________
          Do You Yahoo!?
          Tired of spam? Yahoo! Mail has the best spam protection around
          http://mail.yahoo.com
        • sisterscape
          ... I have learned that the problem characters are UNIX line breaks (i.e. carriage returns) - why didn t I know that. For some reason, the ftp isn t converting
          Message 4 of 20 , Jun 4, 2005
          • 0 Attachment
            --- sisterscape <sisterscape@...> wrote:

            > So what happened to the attachment? Not allowed on this list?
            > Anyway,
            > I posted it here http://www.waterstonewildlife.org/images/SGML.jpg so
            > you can see the critters.
            >
            > --- sisterscape <sisterscape@...> wrote:
            >

            I have learned that the problem characters are UNIX line breaks (i.e.
            carriage returns) - why didn't I know that. For some reason, the ftp
            isn't converting them to a Mac compatible format. Using WS_FTP LE and
            yes, I uploaded in ASCII. I've not had this problem with other scripts
            before.




            __________________________________
            Discover Yahoo!
            Have fun online with music videos, cool games, IM and more. Check it out!
            http://discover.yahoo.com/online.html
          • loro
            ... Odd. I always use Unix style line breaks, LF only, and that doesn t cause any problems. Or is this some kind of special line breaks? I hate confusing
            Message 5 of 20 , Jun 4, 2005
            • 0 Attachment
              sisterscape wrote:
              >I have learned that the problem characters are UNIX line breaks (i.e.
              >carriage returns) - why didn't I know that. For some reason, the ftp
              >isn't converting them to a Mac compatible format.

              Odd. I always use Unix style line breaks, LF only, and that doesn't cause
              any problems. Or is this some kind of "special" line breaks? I hate
              confusing mysteries! ;-)

              Lotta
            • Jody
              Hi sisterscape, ... Sorry, no attachments allowed. ... You probably knew it; just couldn t recall from memory. ;) Once I read it was the line endings I figured
              Message 6 of 20 , Jun 4, 2005
              • 0 Attachment
                Hi sisterscape,

                >> So what happened to the attachment? Not allowed on this list?
                >> I posted it here http://www.waterstonewildlife.org/images/SGML.jpg
                >> so you can see the critters.

                Sorry, no attachments allowed.

                >I have learned that the problem characters are UNIX line breaks
                >(i.e. carriage returns) - why didn't I know that. For some
                >reason, the ftp isn't converting them to a Mac compatible format.
                >Using WS_FTP LE and yes, I uploaded in ASCII. I've not had this
                >problem with other scripts before.

                You probably knew it; just couldn't recall from memory. ;) Once I
                read it was the line endings I figured it had to do wit that, but
                was out, busy, etc... and could not get back to you. Glad it took
                awhile and you found it, because you will remember it easier next
                time around. I think some of the following features will explain
                why you did not detect the characters in NoteTab and may be useful
                to you in the future. FYI...

                If you open the file in NoteTab and place your mouse pointer
                somewhere in the edit window the Status bar will tell you what
                format it is. NoteTab can save to different formats via Save
                Format in Options | Documents | Format | Saves as (global) and
                right click on file tabs for the individual file.

                Menu commands...

                Modify | Lines | Adjust Line Breaks
                Use this command on documents (for example UNIX or Mac files)
                that do not display lines with standard carriage return + line
                feed characters.

                File | Export...
                Saves the text selection or the active document in a different
                format: ASCII/ANSI, DOS, UNIX, EBCDIC, or Mac. Using this command
                on an Outline document will produce a normal text file from it.
                By default, headings are underlined. This setting can be turned
                off through the "Underline Headings" field in the Options dialog
                box on the Outline tab.

                Clip commands and functions...

                StrAsciiToAnsi
                ^$StrAsciiToAnsi("Str")$
                Returns Str with all extended ASCII characters converted to ANSI.

                StrFixLines
                ^$StrFixLines("Str")$ (added in v4.51)
                Corrects carriage returns in text criteria (Unix and Mac-
                formatted text is converted to Dos/Windows format).

                SaveAscii
                ^!SaveAscii FileName (added in v4.6)
                Similar to the ^!Save command (and accepts the same parameters) but
                saves the document using the DOS extended ASCII character set instead
                of Windows ANSI.

                Export
                ^!Export "FileName" [ASCII|ANSI][MAC|UNIX][SELECTION|ALL][HARDBREAKS]
                ^!Export "FileName" [EBCDIC][SELECTION|ALL][LRECL=nnn] (added in v4.6)
                Exports current document under specified file name. Optional
                settings are used to define output format. Use a comma or colon
                to separate multiple settings and use double quotes around the
                file name if it contain spaces. When creating EBCDIC files, you
                can optionally define a record length (for fixed-width lines) by
                using the LRECL parameter followed by an equal sign and the width
                value.


                Happy HTML'n!
                Jody

                http://www.notetab.net
                http://www.clean-funnies.com
                http://groups.yahoo.com/group/ntb-html
              • loro
                sisterscape and Jody, The document now contains a mix of Windows CR/LF and Unix LF. http://snipurl.com/fd0f That shouldn t be a problem, I think. And it isn t.
                Message 7 of 20 , Jun 4, 2005
                • 0 Attachment
                  sisterscape and Jody,

                  The document now contains a mix of Windows CR/LF and Unix LF.
                  http://snipurl.com/fd0f
                  That shouldn't be a problem, I think. And it isn't.
                  http://snipurl.com/fd0i

                  ????????
                  Lotta
                • Jody
                  Hi loro & sisterscape, ... If it is, see my previous message with the different settings for saving formats. It should correct the mixed line ending issue. You
                  Message 8 of 20 , Jun 4, 2005
                  • 0 Attachment
                    Hi loro & sisterscape,

                    >The document now contains a mix of Windows CR/LF and Unix LF.
                    >http://snipurl.com/fd0f
                    >That shouldn't be a problem, I think. And it isn't.
                    >http://snipurl.com/fd0i

                    If it is, see my previous message with the different settings for
                    saving formats. It should correct the mixed line ending issue.
                    You might use the fix line ending features, then save as the
                    format you want. Note, some FTP clients, servers, programs, etc.
                    are what corrupts the line endings.


                    Happy HTML'n!
                    Jody

                    http://www.notetab.net
                    http://www.clean-funnies.com
                    http://groups.yahoo.com/group/ntb-html
                  • sisterscape
                    Thanks to both Jody and Lotta for your expertise and generosity in sharing. I ve learned a lot in the process. The info below is very useful as are the links
                    Message 9 of 20 , Jun 4, 2005
                    • 0 Attachment
                      Thanks to both Jody and Lotta for your expertise and generosity in
                      sharing. I've learned a lot in the process.

                      The info below is very useful as are the links to
                      http://www.rexswain.com/ You (and NoteTab) are the best!

                      Sister

                      --- Jody <kjv-av1611@...> wrote:

                      > Hi sisterscape,
                      >
                      > If you open the file in NoteTab and place your mouse pointer
                      > somewhere in the edit window the Status bar will tell you what
                      > format it is. NoteTab can save to different formats via Save
                      > Format in Options | Documents | Format | Saves as (global) and
                      > right click on file tabs for the individual file.
                      >
                      > Menu commands...
                      >
                      > Modify | Lines | Adjust Line Breaks
                      > Use this command on documents (for example UNIX or Mac files)
                      > that do not display lines with standard carriage return + line
                      > feed characters.
                      >
                      > File | Export...
                      > Saves the text selection or the active document in a different
                      > format: ASCII/ANSI, DOS, UNIX, EBCDIC, or Mac. Using this command
                      > on an Outline document will produce a normal text file from it.
                      > By default, headings are underlined. This setting can be turned
                      > off through the "Underline Headings" field in the Options dialog
                      > box on the Outline tab.
                      >
                      > Clip commands and functions...
                      >
                      > StrAsciiToAnsi
                      > ^$StrAsciiToAnsi("Str")$
                      > Returns Str with all extended ASCII characters converted to ANSI.
                      >
                      > StrFixLines
                      > ^$StrFixLines("Str")$ (added in v4.51)
                      > Corrects carriage returns in text criteria (Unix and Mac-
                      > formatted text is converted to Dos/Windows format).
                      >
                      > SaveAscii
                      > ^!SaveAscii FileName (added in v4.6)
                      > Similar to the ^!Save command (and accepts the same parameters) but
                      > saves the document using the DOS extended ASCII character set instead
                      > of Windows ANSI.
                      >
                      > Export
                      > ^!Export "FileName" [ASCII|ANSI][MAC|UNIX][SELECTION|ALL][HARDBREAKS]
                      > ^!Export "FileName" [EBCDIC][SELECTION|ALL][LRECL=nnn] (added in
                      > v4.6)
                      > Exports current document under specified file name. Optional
                      > settings are used to define output format. Use a comma or colon
                      > to separate multiple settings and use double quotes around the
                      > file name if it contain spaces. When creating EBCDIC files, you
                      > can optionally define a record length (for fixed-width lines) by
                      > using the LRECL parameter followed by an equal sign and the width
                      > value.
                      >
                      >
                      > Happy HTML'n!
                      > Jody
                      >
                      > http://www.notetab.net
                      > http://www.clean-funnies.com
                      > http://groups.yahoo.com/group/ntb-html
                      >
                      >


                      __________________________________________________
                      Do You Yahoo!?
                      Tired of spam? Yahoo! Mail has the best spam protection around
                      http://mail.yahoo.com
                    • sisterscape
                      Until this ordeal, I d never given a second thought to line endings and OS compaibility. So much to learn . . . At least the site is validating now so I can
                      Message 10 of 20 , Jun 4, 2005
                      • 0 Attachment
                        Until this ordeal, I'd never given a second thought to line endings and
                        OS compaibility. So much to learn . . . At least the site is
                        validating now so I can start thinking about putting the rest of it
                        together. Cheers. Sister

                        --- Jody <kjv-av1611@...> wrote:

                        > Hi loro & sisterscape,
                        >
                        > >The document now contains a mix of Windows CR/LF and Unix LF.
                        > >http://snipurl.com/fd0f
                        > >That shouldn't be a problem, I think. And it isn't.
                        > >http://snipurl.com/fd0i
                        >
                        > If it is, see my previous message with the different settings for
                        > saving formats. It should correct the mixed line ending issue.
                        > You might use the fix line ending features, then save as the
                        > format you want. Note, some FTP clients, servers, programs, etc.
                        > are what corrupts the line endings.
                        >
                        >
                        > Happy HTML'n!
                        > Jody
                        >
                        > http://www.notetab.net
                        > http://www.clean-funnies.com
                        > http://groups.yahoo.com/group/ntb-html
                        >
                        >


                        __________________________________________________
                        Do You Yahoo!?
                        Tired of spam? Yahoo! Mail has the best spam protection around
                        http://mail.yahoo.com
                      • sisterscape
                        Just for reference here s a follow-up. . . The Mac server admin did a little research and tweaking and upgraded his ftp server in the process. But the files
                        Message 11 of 20 , Jun 11, 2005
                        • 0 Attachment
                          Just for reference here's a follow-up. . .

                          The Mac server admin did a little research and tweaking and upgraded
                          his ftp server in the process. But the files were still doing weird -
                          but different - things. He posted on a Mac list, as was told that if I
                          upload in binary, the line breaks should remain intact. That so goes
                          against instinct but it seems to work. The UNIX line breaks are
                          undisturbed ftping either way and the validator isn't choking anymore.
                          Go figure . . .

                          sisterscape



                          __________________________________
                          Discover Yahoo!
                          Use Yahoo! to plan a weekend, have fun online and more. Check it out!
                          http://discover.yahoo.com/
                        Your message has been successfully submitted and would be delivered to recipients shortly.