Loading ...
Sorry, an error occurred while loading the content.

Re: [NH] non SGML errors . . . lot's of them

Expand Messages
  • loro
    ... Non SGML characters. Open the page in NoteTab and let it do its replacement of non text characters . Make sure Filter Binary Codes is on. Then use Find
    Message 1 of 20 , Jun 2, 2005
    • 0 Attachment
      sisterscape wrote:
      >I'm working on a site here http://www.waterstonewildlife.org/journal/
      > When I try to validate I'm getting a slew of non-SGML errors. :mad

      Non SGML characters. Open the page in NoteTab and let it do its replacement
      of "non text characters". Make sure "Filter Binary Codes" is on. Then use
      Find & Replace to get rid of all 151 of them. They aren't part of the
      content anyway. What program put them in?

      Lotta
    • sisterscape
      Thanks Lotta. Filter Binary Codes is on but I can t figure out how to do the character replacement. Can this be done in NT light? ...
      Message 2 of 20 , Jun 2, 2005
      • 0 Attachment
        Thanks Lotta. "Filter Binary Codes" is on but I can't figure out how
        to do the character replacement. Can this be done in NT light?

        --- loro <loro-spam01-@...> wrote:

        > sisterscape wrote:
        > >I'm working on a site here
        > http://www.waterstonewildlife.org/journal/
        > > When I try to validate I'm getting a slew of non-SGML errors.
        > :mad
        >
        > Non SGML characters. Open the page in NoteTab and let it do its
        > replacement
        > of "non text characters". Make sure "Filter Binary Codes" is on. Then
        > use
        > Find & Replace to get rid of all 151 of them. They aren't part of the
        >
        > content anyway. What program put them in?
        >
        > Lotta
        >
        >
        >




        __________________________________
        Discover Yahoo!
        Have fun online with music videos, cool games, IM and more. Check it out!
        http://discover.yahoo.com/online.html
      • loro
        ... I used the Edit button in IE to get it into NoteTab. I don t think one gets the binary warning otherwise. No idea why that is, but I recall I ve noticed it
        Message 3 of 20 , Jun 2, 2005
        • 0 Attachment
          sisterscape wrote:
          >Thanks Lotta. "Filter Binary Codes" is on but I can't figure out how
          >to do the character replacement. Can this be done in NT light?

          I used the Edit button in IE to get it into NoteTab. I don't think one gets
          the binary warning otherwise. No idea why that is, but I recall I've
          noticed it before. Anyway, did you fix it or did it fix itself? The evil
          characters are gone now.

          Lotta
        • sisterscape
          Yes, the evil characters are gone but it was not my doing. My friend, the server admin, did a search and replace. But that does not answer the question of how
          Message 4 of 20 , Jun 3, 2005
          • 0 Attachment
            Yes, the evil characters are gone but it was not my doing. My friend,
            the server admin, did a search and replace.

            But that does not answer the question of how they got there in the
            first place or how I can correct the error. Sorry to say, your
            suggestion 'I used the Edit button in IE to get it into NoteTab.' makes
            absolutely no sense to me. Apologies for being so dense . . . but
            could you explain a bit more? I really need to get a handle on this.

            Thanks,

            sisterscape

            --- loro <loro-spam01-@...> wrote:
            >
            > I used the Edit button in IE to get it into NoteTab. I don't think
            > one gets
            > the binary warning otherwise. No idea why that is, but I recall I've
            > noticed it before. Anyway, did you fix it or did it fix itself? The
            > evil
            > characters are gone now.
            >
            > Lotta
            >
            >
            >


            __________________________________________________
            Do You Yahoo!?
            Tired of spam? Yahoo! Mail has the best spam protection around
            http://mail.yahoo.com
          • loro
            sisterscape wrote ... No, it s I that am dense. I was tired and didn t explain properly. I have added NoteTab at Tools | Internet Options | Programs | HTML
            Message 5 of 20 , Jun 3, 2005
            • 0 Attachment
              sisterscape wrote
              > Sorry to say, your
              >suggestion 'I used the Edit button in IE to get it into NoteTab.' makes
              >absolutely no sense to me. Apologies for being so dense . . . but
              >could you explain a bit more? I really need to get a handle on this.

              No, it's I that am dense. I was tired and didn't explain properly. I have
              added NoteTab at Tools | Internet Options | Programs | HTML Editor. That
              is, it comes up when I use Edit, not View Source. When I first posted I
              didn't think about that I had used the Edit button to get your code. For
              some reason the file sometimes comes up as partly binary when I do and I
              have no idea why that is so. If I download the same file with some other
              method I don't get the binary warning.

              So I don't know. Maybe you could select the "illegal" space and just do a
              Find and Replace. Can't check since the oddities are gone now. Did you
              copy-paste from Word or some other Office program or did WordPress put them in?

              Lotta
            • Jody
              Hi loro & sisterscape, Just a short comment - long version below. If NoteTab sees binary characters it will mark the opened file as read-only. In this case, it
              Message 6 of 20 , Jun 3, 2005
              • 0 Attachment
                Hi loro & sisterscape,

                Just a short comment - long version below. If NoteTab sees binary
                characters it will mark the opened file as read-only. In this
                case, it would probably be safe to click on Document and uncheck
                Read-only if it is checked. Then do your replacements.

                >> suggestion 'I used the Edit button in IE to get it into
                >> NoteTab.' makes absolutely no sense to me. Apologies for being
                >> so dense . . . but could you explain a bit more? I really need
                >> to get a handle on this.
                >
                >No, it's I that am dense. I was tired and didn't explain
                >properly. I have added NoteTab at Tools | Internet Options |
                >Programs | HTML Editor. That is, it comes up when I use Edit, not
                >View Source. When I first posted I didn't think about that I had
                >used the Edit button to get your code. For some reason the file
                >sometimes comes up as partly binary when I do and I have no idea
                >why that is so. If I download the same file with some other
                >method I don't get the binary warning.
                >
                >So I don't know. Maybe you could select the "illegal" space and
                >just do a Find and Replace. Can't check since the oddities are
                >gone now. Did you copy-paste from Word or some other Office
                >program or did WordPress put them in?

                Please understand what Help says (below) before making changes to
                binary documents such as *.doc, and *.exe, etc. I suggest you
                read this in full as well.

                Some servers and programs add a binary character at the end of the
                files. This is usually the case when you know they are text based
                files such as.txt and .htm. NoteTab detects the character and
                warns you that it may be a binary file like .doc, .jpg. NoteTab
                replaces the null character (binary value of no importance
                usually) with a replacement character. That assumes you have your
                binary features checked under the Files tab in Options. You can
                see the character in Options | File | Binary Replace Character.
                When NoteTab replaces it it also marks the file as read-only in
                NoteTab.

                You have a couple of options to take. One is if you know for sure
                the file is a text based file, take it out of read-only from the
                Document menu at the bottom and then Ctrl+End to get to the bottom
                of the document. This assumes that is where the binary/null
                character is and where they are normally inserted at. The NoteTab
                default replacement character is the center dot/center period. If
                you see it at the bottom, delete it and then save the file. If you
                upload to the server and then download again, and the same thing
                happens you can use the second option.

                The second option is to uncheck all the binary warnings in Options
                | Files. You can get there from the View menu. There are three
                binary options to be concerned with. Actually, you can leave the
                warnings there if you don't mind the error message every time you
                open one of these files. If you turn off all three, then just
                remember that you did so and do not try to edit true binary files
                like .doc (MS Word) files - you will surely corrupt them.

                The following is from Help (under the File tab in Options).

                Filter Binary Codes:
                By default, if you try to load a file that contains null
                characters (a character with a decimal value of 0), NoteTab will
                treat the first occurring null as the end of the file. This
                option lets you override this behavior by allowing NoteTab to
                substitute null characters with another character – defined in
                the "Substitute Binary Character" field. When set, you can load
                the full content of any type of file (including binaries).

                Important: saving files which have had characters substituted
                will not restore the control character! This option slows the
                loading of large files, so do not set it if you use only true
                text files.

                Warn Partial Loading:
                Warns if a file has only been partially loaded due to the
                presence of null characters. This option has no effect if "Filter
                Binary Codes" is set.

                Warn Binaries Substituted:
                Displays a warning message if binary characters have been
                substituted in the loaded document.

                Happy HTML'n!
                Jody

                http://www.notetab.net
                http://www.clean-funnies.com
                http://groups.yahoo.com/group/ntb-html
              • sisterscape
                I just did a fresh download of WordPress and the characters are there just after I unzip the file. I noticed them before in Notepad but they were hidden in
                Message 7 of 20 , Jun 3, 2005
                • 0 Attachment
                  I just did a fresh download of WordPress and the characters are there
                  just after I unzip the file. I noticed them before in Notepad but
                  they were hidden in NoteTab.

                  But here's the kicker . . . I just checked out a test installation I
                  did on another server. It validates perfectly with the evil
                  characters.
                  http://validator.w3.org/check?uri=http%3A%2F%2Fwww.eartherdesigns.com%2Fj
                  ournal%2F So this makes me think it's a server configuration. Does
                  that sound logical?

                  Thanks for all your input.

                  --- loro <loro-spam01-@...> wrote:

                  > sisterscape wrote
                  > > Sorry to say, your
                  > >suggestion 'I used the Edit button in IE to get it into NoteTab.'
                  > makes
                  > >absolutely no sense to me. Apologies for being so dense . . . but
                  > >could you explain a bit more? I really need to get a handle on
                  > this.
                  >
                  > No, it's I that am dense. I was tired and didn't explain properly. I
                  > have
                  > added NoteTab at Tools | Internet Options | Programs | HTML Editor.
                  > That
                  > is, it comes up when I use Edit, not View Source. When I first posted
                  > I
                  > didn't think about that I had used the Edit button to get your code.
                  > For
                  > some reason the file sometimes comes up as partly binary when I do
                  > and I
                  > have no idea why that is so. If I download the same file with some
                  > other
                  > method I don't get the binary warning.
                  >
                  > So I don't know. Maybe you could select the "illegal" space and just
                  > do a
                  > Find and Replace. Can't check since the oddities are gone now. Did
                  > you
                  > copy-paste from Word or some other Office program or did WordPress
                  > put them in?
                  >
                  > Lotta
                  >
                  >
                  >
                  >
                  >


                  __________________________________________________
                  Do You Yahoo!?
                  Tired of spam? Yahoo! Mail has the best spam protection around
                  http://mail.yahoo.com
                • sisterscape
                  Thanks for the suggestion Jody. The problem is that NoteTab isn t seeing them! I have been wroking with the files as usual and wasn t aware anything was amiss
                  Message 8 of 20 , Jun 3, 2005
                  • 0 Attachment
                    Thanks for the suggestion Jody. The problem is that NoteTab isn't
                    seeing them! I have been wroking with the files as usual and wasn't
                    aware anything was amiss until I tried validation.

                    Bit as I responded earlier. An install on another server - same
                    template, same files validated without a problem. That makes me think
                    it's a server configuration issue - Mac vs PC RedHat.

                    Any suggestions on that front?

                    sisterscape

                    --- Jody <kjv-av1611@...> wrote:

                    > Hi loro & sisterscape,
                    >
                    > Just a short comment - long version below. If NoteTab sees binary
                    > characters it will mark the opened file as read-only. In this
                    > case, it would probably be safe to click on Document and uncheck
                    > Read-only if it is checked. Then do your replacements.
                    >
                    > >> suggestion 'I used the Edit button in IE to get it into
                    > >> NoteTab.' makes absolutely no sense to me. Apologies for being
                    > >> so dense . . . but could you explain a bit more? I really need
                    > >> to get a handle on this.
                    > >
                    > >No, it's I that am dense. I was tired and didn't explain
                    > >properly. I have added NoteTab at Tools | Internet Options |
                    > >Programs | HTML Editor. That is, it comes up when I use Edit, not
                    > >View Source. When I first posted I didn't think about that I had
                    > >used the Edit button to get your code. For some reason the file
                    > >sometimes comes up as partly binary when I do and I have no idea
                    > >why that is so. If I download the same file with some other
                    > >method I don't get the binary warning.
                    > >
                    > >So I don't know. Maybe you could select the "illegal" space and
                    > >just do a Find and Replace. Can't check since the oddities are
                    > >gone now. Did you copy-paste from Word or some other Office
                    > >program or did WordPress put them in?
                    >
                    > Please understand what Help says (below) before making changes to
                    > binary documents such as *.doc, and *.exe, etc. I suggest you
                    > read this in full as well.
                    >
                    > Some servers and programs add a binary character at the end of the
                    > files. This is usually the case when you know they are text based
                    > files such as.txt and .htm. NoteTab detects the character and
                    > warns you that it may be a binary file like .doc, .jpg. NoteTab
                    > replaces the null character (binary value of no importance
                    > usually) with a replacement character. That assumes you have your
                    > binary features checked under the Files tab in Options. You can
                    > see the character in Options | File | Binary Replace Character.
                    > When NoteTab replaces it it also marks the file as read-only in
                    > NoteTab.
                    >
                    > You have a couple of options to take. One is if you know for sure
                    > the file is a text based file, take it out of read-only from the
                    > Document menu at the bottom and then Ctrl+End to get to the bottom
                    > of the document. This assumes that is where the binary/null
                    > character is and where they are normally inserted at. The NoteTab
                    > default replacement character is the center dot/center period. If
                    > you see it at the bottom, delete it and then save the file. If you
                    > upload to the server and then download again, and the same thing
                    > happens you can use the second option.
                    >
                    > The second option is to uncheck all the binary warnings in Options
                    > | Files. You can get there from the View menu. There are three
                    > binary options to be concerned with. Actually, you can leave the
                    > warnings there if you don't mind the error message every time you
                    > open one of these files. If you turn off all three, then just
                    > remember that you did so and do not try to edit true binary files
                    > like .doc (MS Word) files - you will surely corrupt them.
                    >
                    > The following is from Help (under the File tab in Options).
                    >
                    > Filter Binary Codes:
                    > By default, if you try to load a file that contains null
                    > characters (a character with a decimal value of 0), NoteTab will
                    > treat the first occurring null as the end of the file. This
                    > option lets you override this behavior by allowing NoteTab to
                    > substitute null characters with another character – defined in
                    > the "Substitute Binary Character" field. When set, you can load
                    > the full content of any type of file (including binaries).
                    >
                    > Important: saving files which have had characters substituted
                    > will not restore the control character! This option slows the
                    > loading of large files, so do not set it if you use only true
                    > text files.
                    >
                    > Warn Partial Loading:
                    > Warns if a file has only been partially loaded due to the
                    > presence of null characters. This option has no effect if "Filter
                    > Binary Codes" is set.
                    >
                    > Warn Binaries Substituted:
                    > Displays a warning message if binary characters have been
                    > substituted in the loaded document.
                    >
                    > Happy HTML'n!
                    > Jody
                    >
                    > http://www.notetab.net
                    > http://www.clean-funnies.com
                    > http://groups.yahoo.com/group/ntb-html
                    >
                    >


                    __________________________________________________
                    Do You Yahoo!?
                    Tired of spam? Yahoo! Mail has the best spam protection around
                    http://mail.yahoo.com
                  • loro
                    ... Which are the characters? Anyway, THIS document is served without any character encoding from the server and has ISO-8859-1 in a Meta tag. The other one is
                    Message 9 of 20 , Jun 3, 2005
                    • 0 Attachment
                      sisterscape wrote:
                      >I just did a fresh download of WordPress and the characters are there
                      >just after I unzip the file. I noticed them before in Notepad but
                      >they were hidden in NoteTab.
                      >
                      >But here's the kicker . . . I just checked out a test installation I
                      >did on another server. It validates perfectly with the evil
                      >characters.
                      >http://validator.w3.org/check?uri=http%3A%2F%2Fwww.eartherdesigns.com%2Fj
                      >ournal%2F So this makes me think it's a server configuration. Does
                      >that sound logical?

                      Which are the characters?

                      Anyway, THIS document is served without any character encoding from the
                      server and has ISO-8859-1 in a Meta tag. The other one is served as UTF-8.
                      I don't know, but if you wrote it in Notetab and used characters outside
                      US-ASCII and then tried to pass it off as UTF-8 that could maybe be the
                      reason. The ASCII characters are the same in UTF-8, but not other ANSI
                      characters, like åäö. That's about right, I think. This stuff always
                      confuses me. :-o

                      Lotta
                    • sisterscape
                      ... Thanks for the follow up. I have attached an images of one of the php files so you can see the funny 0s at the line breaks. The server admin said it was
                      Message 10 of 20 , Jun 3, 2005
                      • 0 Attachment
                        --- loro <loro-spam01-@...> wrote:

                        > sisterscape wrote:
                        > >I just did a fresh download of WordPress and the characters are
                        > there
                        > >just after I unzip the file. I noticed them before in Notepad but
                        > >they were hidden in NoteTab.
                        > >
                        > >But here's the kicker . . . I just checked out a test installation I
                        > >did on another server. It validates perfectly with the evil
                        > >characters.
                        >
                        >http://validator.w3.org/check?uri=http%3A%2F%2Fwww.eartherdesigns.com%2Fj
                        > >ournal%2F So this makes me think it's a server configuration. Does
                        > >that sound logical?
                        >
                        > Which are the characters?
                        >
                        > Anyway, THIS document is served without any character encoding from
                        > the
                        > server and has ISO-8859-1 in a Meta tag. The other one is served as
                        > UTF-8.
                        > I don't know, but if you wrote it in Notetab and used characters
                        > outside
                        > US-ASCII and then tried to pass it off as UTF-8 that could maybe be
                        > the
                        > reason. The ASCII characters are the same in UTF-8, but not other
                        > ANSI
                        > characters, like åäö. That's about right, I think. This stuff always
                        > confuses me. :-o
                        >
                        > Lotta
                        >

                        Thanks for the follow up. I have attached an images of one of the php
                        files so you can see the funny 0s at the line breaks. The server admin
                        said it was \x00 but he wasn't clear on it either.

                        I did not actually write the WordPress code and most of the SGML errors
                        - a whooping total of 33,513 for the entire script - came from files I
                        never even opened. So the errors were transmitted without any
                        interference from NoteTab.

                        Yes, the encoding is charset=UTF-8, probably because of the RSS feeds
                        etc.- it's all a mystery to me. The question is why can one server deal
                        with it but not another?

                        sisterscape

                        __________________________________________________
                        Do You Yahoo!?
                        Tired of spam? Yahoo! Mail has the best spam protection around
                        http://mail.yahoo.com

                        [Non-text portions of this message have been removed]
                      • sisterscape
                        So what happened to the attachment? Not allowed on this list? Anyway, I posted it here http://www.waterstonewildlife.org/images/SGML.jpg so you can see the
                        Message 11 of 20 , Jun 3, 2005
                        • 0 Attachment
                          So what happened to the attachment? Not allowed on this list? Anyway,
                          I posted it here http://www.waterstonewildlife.org/images/SGML.jpg so
                          you can see the critters.

                          --- sisterscape <sisterscape@...> wrote:

                          > --- loro <loro-spam01-@...> wrote:
                          >
                          > > sisterscape wrote:
                          > > >I just did a fresh download of WordPress and the characters are
                          > > there
                          > > >just after I unzip the file. I noticed them before in Notepad
                          > but
                          > > >they were hidden in NoteTab.
                          > > >
                          > > >But here's the kicker . . . I just checked out a test installation
                          > I
                          > > >did on another server. It validates perfectly with the evil
                          > > >characters.
                          > >
                          >
                          >http://validator.w3.org/check?uri=http%3A%2F%2Fwww.eartherdesigns.com%2Fj
                          > > >ournal%2F So this makes me think it's a server configuration.
                          > Does
                          > > >that sound logical?
                          > >
                          > > Which are the characters?
                          > >
                          > > Anyway, THIS document is served without any character encoding from
                          > > the
                          > > server and has ISO-8859-1 in a Meta tag. The other one is served as
                          > > UTF-8.
                          > > I don't know, but if you wrote it in Notetab and used characters
                          > > outside
                          > > US-ASCII and then tried to pass it off as UTF-8 that could maybe be
                          > > the
                          > > reason. The ASCII characters are the same in UTF-8, but not other
                          > > ANSI
                          > > characters, like åäö. That's about right, I think. This stuff
                          > always
                          > > confuses me. :-o
                          > >
                          > > Lotta
                          > >
                          >
                          > Thanks for the follow up. I have attached an images of one of the
                          > php
                          > files so you can see the funny 0s at the line breaks. The server
                          > admin
                          > said it was \x00 but he wasn't clear on it either.
                          >
                          > I did not actually write the WordPress code and most of the SGML
                          > errors
                          > - a whooping total of 33,513 for the entire script - came from files
                          > I
                          > never even opened. So the errors were transmitted without any
                          > interference from NoteTab.
                          >
                          > Yes, the encoding is charset=UTF-8, probably because of the RSS feeds
                          > etc.- it's all a mystery to me. The question is why can one server
                          > deal
                          > with it but not another?
                          >
                          > sisterscape
                          >
                          > __________________________________________________
                          > Do You Yahoo!?
                          > Tired of spam? Yahoo! Mail has the best spam protection around
                          > http://mail.yahoo.com
                          >
                          > [Non-text portions of this message have been removed]
                          >
                          >


                          __________________________________________________
                          Do You Yahoo!?
                          Tired of spam? Yahoo! Mail has the best spam protection around
                          http://mail.yahoo.com
                        • sisterscape
                          ... I have learned that the problem characters are UNIX line breaks (i.e. carriage returns) - why didn t I know that. For some reason, the ftp isn t converting
                          Message 12 of 20 , Jun 4, 2005
                          • 0 Attachment
                            --- sisterscape <sisterscape@...> wrote:

                            > So what happened to the attachment? Not allowed on this list?
                            > Anyway,
                            > I posted it here http://www.waterstonewildlife.org/images/SGML.jpg so
                            > you can see the critters.
                            >
                            > --- sisterscape <sisterscape@...> wrote:
                            >

                            I have learned that the problem characters are UNIX line breaks (i.e.
                            carriage returns) - why didn't I know that. For some reason, the ftp
                            isn't converting them to a Mac compatible format. Using WS_FTP LE and
                            yes, I uploaded in ASCII. I've not had this problem with other scripts
                            before.




                            __________________________________
                            Discover Yahoo!
                            Have fun online with music videos, cool games, IM and more. Check it out!
                            http://discover.yahoo.com/online.html
                          • loro
                            ... Odd. I always use Unix style line breaks, LF only, and that doesn t cause any problems. Or is this some kind of special line breaks? I hate confusing
                            Message 13 of 20 , Jun 4, 2005
                            • 0 Attachment
                              sisterscape wrote:
                              >I have learned that the problem characters are UNIX line breaks (i.e.
                              >carriage returns) - why didn't I know that. For some reason, the ftp
                              >isn't converting them to a Mac compatible format.

                              Odd. I always use Unix style line breaks, LF only, and that doesn't cause
                              any problems. Or is this some kind of "special" line breaks? I hate
                              confusing mysteries! ;-)

                              Lotta
                            • Jody
                              Hi sisterscape, ... Sorry, no attachments allowed. ... You probably knew it; just couldn t recall from memory. ;) Once I read it was the line endings I figured
                              Message 14 of 20 , Jun 4, 2005
                              • 0 Attachment
                                Hi sisterscape,

                                >> So what happened to the attachment? Not allowed on this list?
                                >> I posted it here http://www.waterstonewildlife.org/images/SGML.jpg
                                >> so you can see the critters.

                                Sorry, no attachments allowed.

                                >I have learned that the problem characters are UNIX line breaks
                                >(i.e. carriage returns) - why didn't I know that. For some
                                >reason, the ftp isn't converting them to a Mac compatible format.
                                >Using WS_FTP LE and yes, I uploaded in ASCII. I've not had this
                                >problem with other scripts before.

                                You probably knew it; just couldn't recall from memory. ;) Once I
                                read it was the line endings I figured it had to do wit that, but
                                was out, busy, etc... and could not get back to you. Glad it took
                                awhile and you found it, because you will remember it easier next
                                time around. I think some of the following features will explain
                                why you did not detect the characters in NoteTab and may be useful
                                to you in the future. FYI...

                                If you open the file in NoteTab and place your mouse pointer
                                somewhere in the edit window the Status bar will tell you what
                                format it is. NoteTab can save to different formats via Save
                                Format in Options | Documents | Format | Saves as (global) and
                                right click on file tabs for the individual file.

                                Menu commands...

                                Modify | Lines | Adjust Line Breaks
                                Use this command on documents (for example UNIX or Mac files)
                                that do not display lines with standard carriage return + line
                                feed characters.

                                File | Export...
                                Saves the text selection or the active document in a different
                                format: ASCII/ANSI, DOS, UNIX, EBCDIC, or Mac. Using this command
                                on an Outline document will produce a normal text file from it.
                                By default, headings are underlined. This setting can be turned
                                off through the "Underline Headings" field in the Options dialog
                                box on the Outline tab.

                                Clip commands and functions...

                                StrAsciiToAnsi
                                ^$StrAsciiToAnsi("Str")$
                                Returns Str with all extended ASCII characters converted to ANSI.

                                StrFixLines
                                ^$StrFixLines("Str")$ (added in v4.51)
                                Corrects carriage returns in text criteria (Unix and Mac-
                                formatted text is converted to Dos/Windows format).

                                SaveAscii
                                ^!SaveAscii FileName (added in v4.6)
                                Similar to the ^!Save command (and accepts the same parameters) but
                                saves the document using the DOS extended ASCII character set instead
                                of Windows ANSI.

                                Export
                                ^!Export "FileName" [ASCII|ANSI][MAC|UNIX][SELECTION|ALL][HARDBREAKS]
                                ^!Export "FileName" [EBCDIC][SELECTION|ALL][LRECL=nnn] (added in v4.6)
                                Exports current document under specified file name. Optional
                                settings are used to define output format. Use a comma or colon
                                to separate multiple settings and use double quotes around the
                                file name if it contain spaces. When creating EBCDIC files, you
                                can optionally define a record length (for fixed-width lines) by
                                using the LRECL parameter followed by an equal sign and the width
                                value.


                                Happy HTML'n!
                                Jody

                                http://www.notetab.net
                                http://www.clean-funnies.com
                                http://groups.yahoo.com/group/ntb-html
                              • loro
                                sisterscape and Jody, The document now contains a mix of Windows CR/LF and Unix LF. http://snipurl.com/fd0f That shouldn t be a problem, I think. And it isn t.
                                Message 15 of 20 , Jun 4, 2005
                                • 0 Attachment
                                  sisterscape and Jody,

                                  The document now contains a mix of Windows CR/LF and Unix LF.
                                  http://snipurl.com/fd0f
                                  That shouldn't be a problem, I think. And it isn't.
                                  http://snipurl.com/fd0i

                                  ????????
                                  Lotta
                                • Jody
                                  Hi loro & sisterscape, ... If it is, see my previous message with the different settings for saving formats. It should correct the mixed line ending issue. You
                                  Message 16 of 20 , Jun 4, 2005
                                  • 0 Attachment
                                    Hi loro & sisterscape,

                                    >The document now contains a mix of Windows CR/LF and Unix LF.
                                    >http://snipurl.com/fd0f
                                    >That shouldn't be a problem, I think. And it isn't.
                                    >http://snipurl.com/fd0i

                                    If it is, see my previous message with the different settings for
                                    saving formats. It should correct the mixed line ending issue.
                                    You might use the fix line ending features, then save as the
                                    format you want. Note, some FTP clients, servers, programs, etc.
                                    are what corrupts the line endings.


                                    Happy HTML'n!
                                    Jody

                                    http://www.notetab.net
                                    http://www.clean-funnies.com
                                    http://groups.yahoo.com/group/ntb-html
                                  • sisterscape
                                    Thanks to both Jody and Lotta for your expertise and generosity in sharing. I ve learned a lot in the process. The info below is very useful as are the links
                                    Message 17 of 20 , Jun 4, 2005
                                    • 0 Attachment
                                      Thanks to both Jody and Lotta for your expertise and generosity in
                                      sharing. I've learned a lot in the process.

                                      The info below is very useful as are the links to
                                      http://www.rexswain.com/ You (and NoteTab) are the best!

                                      Sister

                                      --- Jody <kjv-av1611@...> wrote:

                                      > Hi sisterscape,
                                      >
                                      > If you open the file in NoteTab and place your mouse pointer
                                      > somewhere in the edit window the Status bar will tell you what
                                      > format it is. NoteTab can save to different formats via Save
                                      > Format in Options | Documents | Format | Saves as (global) and
                                      > right click on file tabs for the individual file.
                                      >
                                      > Menu commands...
                                      >
                                      > Modify | Lines | Adjust Line Breaks
                                      > Use this command on documents (for example UNIX or Mac files)
                                      > that do not display lines with standard carriage return + line
                                      > feed characters.
                                      >
                                      > File | Export...
                                      > Saves the text selection or the active document in a different
                                      > format: ASCII/ANSI, DOS, UNIX, EBCDIC, or Mac. Using this command
                                      > on an Outline document will produce a normal text file from it.
                                      > By default, headings are underlined. This setting can be turned
                                      > off through the "Underline Headings" field in the Options dialog
                                      > box on the Outline tab.
                                      >
                                      > Clip commands and functions...
                                      >
                                      > StrAsciiToAnsi
                                      > ^$StrAsciiToAnsi("Str")$
                                      > Returns Str with all extended ASCII characters converted to ANSI.
                                      >
                                      > StrFixLines
                                      > ^$StrFixLines("Str")$ (added in v4.51)
                                      > Corrects carriage returns in text criteria (Unix and Mac-
                                      > formatted text is converted to Dos/Windows format).
                                      >
                                      > SaveAscii
                                      > ^!SaveAscii FileName (added in v4.6)
                                      > Similar to the ^!Save command (and accepts the same parameters) but
                                      > saves the document using the DOS extended ASCII character set instead
                                      > of Windows ANSI.
                                      >
                                      > Export
                                      > ^!Export "FileName" [ASCII|ANSI][MAC|UNIX][SELECTION|ALL][HARDBREAKS]
                                      > ^!Export "FileName" [EBCDIC][SELECTION|ALL][LRECL=nnn] (added in
                                      > v4.6)
                                      > Exports current document under specified file name. Optional
                                      > settings are used to define output format. Use a comma or colon
                                      > to separate multiple settings and use double quotes around the
                                      > file name if it contain spaces. When creating EBCDIC files, you
                                      > can optionally define a record length (for fixed-width lines) by
                                      > using the LRECL parameter followed by an equal sign and the width
                                      > value.
                                      >
                                      >
                                      > Happy HTML'n!
                                      > Jody
                                      >
                                      > http://www.notetab.net
                                      > http://www.clean-funnies.com
                                      > http://groups.yahoo.com/group/ntb-html
                                      >
                                      >


                                      __________________________________________________
                                      Do You Yahoo!?
                                      Tired of spam? Yahoo! Mail has the best spam protection around
                                      http://mail.yahoo.com
                                    • sisterscape
                                      Until this ordeal, I d never given a second thought to line endings and OS compaibility. So much to learn . . . At least the site is validating now so I can
                                      Message 18 of 20 , Jun 4, 2005
                                      • 0 Attachment
                                        Until this ordeal, I'd never given a second thought to line endings and
                                        OS compaibility. So much to learn . . . At least the site is
                                        validating now so I can start thinking about putting the rest of it
                                        together. Cheers. Sister

                                        --- Jody <kjv-av1611@...> wrote:

                                        > Hi loro & sisterscape,
                                        >
                                        > >The document now contains a mix of Windows CR/LF and Unix LF.
                                        > >http://snipurl.com/fd0f
                                        > >That shouldn't be a problem, I think. And it isn't.
                                        > >http://snipurl.com/fd0i
                                        >
                                        > If it is, see my previous message with the different settings for
                                        > saving formats. It should correct the mixed line ending issue.
                                        > You might use the fix line ending features, then save as the
                                        > format you want. Note, some FTP clients, servers, programs, etc.
                                        > are what corrupts the line endings.
                                        >
                                        >
                                        > Happy HTML'n!
                                        > Jody
                                        >
                                        > http://www.notetab.net
                                        > http://www.clean-funnies.com
                                        > http://groups.yahoo.com/group/ntb-html
                                        >
                                        >


                                        __________________________________________________
                                        Do You Yahoo!?
                                        Tired of spam? Yahoo! Mail has the best spam protection around
                                        http://mail.yahoo.com
                                      • sisterscape
                                        Just for reference here s a follow-up. . . The Mac server admin did a little research and tweaking and upgraded his ftp server in the process. But the files
                                        Message 19 of 20 , Jun 11, 2005
                                        • 0 Attachment
                                          Just for reference here's a follow-up. . .

                                          The Mac server admin did a little research and tweaking and upgraded
                                          his ftp server in the process. But the files were still doing weird -
                                          but different - things. He posted on a Mac list, as was told that if I
                                          upload in binary, the line breaks should remain intact. That so goes
                                          against instinct but it seems to work. The UNIX line breaks are
                                          undisturbed ftping either way and the validator isn't choking anymore.
                                          Go figure . . .

                                          sisterscape



                                          __________________________________
                                          Discover Yahoo!
                                          Use Yahoo! to plan a weekend, have fun online and more. Check it out!
                                          http://discover.yahoo.com/
                                        Your message has been successfully submitted and would be delivered to recipients shortly.