Loading ...
Sorry, an error occurred while loading the content.
 

re: [NH] Audio Play isn't Reliable

Expand Messages
  • LEE CRESSWELL
    Ray, IE supports the element. Navigator does not. Navigator instead requires the element and a plug-in audio player. For background sound on
    Message 1 of 6 , Feb 21, 2004
      Ray,
      IE supports the<bgsound> element. Navigator does not.
      Navigator instead requires the <embed> element and a
      plug-in audio player. For background sound on both
      browsers, two different techniques are required. If
      you incorporate the script below the program will run
      OK on either, and it will stay with the original page.
      Regards,
      Lee.

      <script language="Javascript" type="text/javascript">

      <!-- Original: Kipp W. Shinabarger (kipps@...)
      -->

      <!-- Begin
      var MSIE=navigator.userAgent.indexOf("MSIE");
      var NETS=navigator.userAgent.indexOf("Netscape");
      var OPER=navigator.userAgent.indexOf("Opera");

      if((MSIE>-1) || (OPER>-1)) {
      document.write("<bgsound=sound.mid loop=infinite>");
      } else {
      document.write("<embed=sound.mid autostart=true ");
      document.write("hidden=true volume=100 loop=true>");
      }
      // End -->
      </script>
    • Dave
      Hi Ray I have tried what is below and it works for me , when I said try ADPCM 4 BIT I thought you would convert from the original wav , The one I have tried
      Message 2 of 6 , Feb 21, 2004
        Hi Ray
        I have tried what is below and it works for me , when I said try ADPCM 4 BIT
        I thought you would convert from the original wav , The one I have tried was
        a 50meg -CD QUALITY WAV it converted to about 5meg , if you dropped the
        quality down the end result will be smaller ,I then tried the bit below

        <EMBED SRC="F:\The Overture.wav" AUTOSTART="true" HIDDEN="false" >
        it streamed across home network .
        THANKYOU DAVE
        ----- Original Message -----
        From: "R Shapp" <ras45@...>
        To: <ntb-html@yahoogroups.com>
        Sent: Friday, February 20, 2004 4:56 PM
        Subject: [NH] Audio Play isn't Reliable


        > Hi Group,
        >
        > The audio file associated with a page on my website doesn't play reliably.
        > See:
        >
        > http://www.asterism.org/humor/humover.htm
        >
        > Ignoring Netscape users for now, I used the <bgsound> tag, and the "Oh
        > Fee-Yukus and the Top Ten" page works fine. Oh Suzannah plays
        continuously
        > in the background. The next page is problematic, however.
        >
        > If I use the <bgsound> tag in "The Galaxy Song" page, I hear a very
        > garbled noise. It's as if only a very small percentage of the sound file
        is
        > actually being sampled. To avoid that, I used a hyperlink as follows:
        >
        > <a href="galaxy.mp3" target="_top">Click for sound</a>
        >
        > This allows the Galaxy song to play properly, but the link opens a
        separate
        > page. I tried other values for target such as "_blank", "_parent", and
        > "_self", but the link still opens a new page.
        >
        > I suspect the galaxy song may require some kind of format conversion to
        play
        > as a background sound. I would like to avoid that, if possible.
        >
        > If I am forced to use the hyperlink, what must I do to prevent the new
        page
        > from launching?
        >
        > An even more general question: Is there a way to provide audio for most
        > modern brands of browser?
        >
        > Thanks for the help.
        >
        > Ray Shapp
        >
        >
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.