Loading ...
Sorry, an error occurred while loading the content.

Re: [Clip] Re: Variables - values don't stick

Expand Messages
  • Jody
    Hi M. Sean, ... I believe you still have a problem. ^!Insert or ^!InsertText is not needed. There was a time when at least ^! had to be in the Clip for
    Message 1 of 19 , Feb 28, 2003
    • 0 Attachment
      Hi M. Sean,

      >BINGO! That was it!

      I believe you still have a problem. ^!Insert or ^!InsertText is not
      needed. There was a time when at least "^!" had to be in the Clip
      for certain other code to work. I think it was wizards: ^?[Test].
      It appears Eric may have fixed it so that "^!" is not needed at all
      anymore or I forget the certain code that would not work. Your
      original Clip was tested and worked in XP for at least two of us
      that tried. I'm glad it works for you, but it is added code that
      you have to put in that is not needed. I have many a Clips that do
      what you had. In fact, when the Clip Code was much smaller, only a
      few dozen commands maybe, it was common practice to use pure text.
      Variables containing text do indeed get processed w/o using ^!Insert
      or ^!InsertText. I'd be curious to know what it does know if you
      take ^!InsertText out.

      >All of the clips had simple text, with inserted variables, without
      >the ^!InsertText command. (The documentation does not make it clear
      >that this should be used.) It appears that the clip language under
      >Windows 2000 is more forgiving on this point than under Win XP.
      >
      >Thanks to all for your help and advice.
      >
      >
      >--- In ntb-clips@yahoogroups.com, "John Zeman <john041650@y...>"
      ><john041650@y...> wrote:
      >> If your command line in the "Play" clip is literally as you post it
      >here, then is there is no command to execute in it.. So NoteTab is
      >probably interpreting the entire line as text, only. Have you tried
      >changing your clip from this:
      >>
      >> H="Play"
      >> The string is ^%var1%
      >>
      >> to:
      >>
      >> H="Play"
      >> ^!InsertText The string is ^%var1%


      Happy Clip'n!
      Jody

      http://www.notetab.net

      Subscribe, UnSubscribe, Options
      mailto:Ntb-Clips-Subscribe@yahoogroups.com
      mailto:Ntb-Clips-UnSubscribe@yahoogroups.com
      http://groups.yahoo.com/group/ntb-clips
    • John Zeman <john041650@yahoo.com>
      Actually Jody, as recently as a few months ago, I occasionally experienced that same problem M. Sean had.. Sometimes back then I was inserting text without
      Message 2 of 19 , Mar 1, 2003
      • 0 Attachment
        Actually Jody, as recently as a few months ago, I occasionally experienced that same problem M. Sean had.. Sometimes back then I was inserting text without the ^!InsertText command and occasionally, not always, (op system Win2k) the variable name would be inserted instead of the variable contents. I started making a habit of always using ^!InsertText before the text and/or variable and haven't had the problem since.. By the way, I stay current on the NoteTab Pro versions, so it was probably 4.90 or 4.91 I was using then..

        John




        --- In ntb-clips@yahoogroups.com, Jody <av1611@e...> wrote:
        > Hi M. Sean,
        >
        > >BINGO! That was it!
        >
        > I believe you still have a problem. ^!Insert or ^!InsertText is not
        > needed. There was a time when at least "^!" had to be in the Clip
        > for certain other code to work. I think it was wizards: ^?[Test].
        > It appears Eric may have fixed it so that "^!" is not needed at all
        > anymore or I forget the certain code that would not work. Your
        > original Clip was tested and worked in XP for at least two of us
        > that tried. I'm glad it works for you, but it is added code that
        > you have to put in that is not needed. I have many a Clips that do
        > what you had. In fact, when the Clip Code was much smaller, only a
        > few dozen commands maybe, it was common practice to use pure text.
        > Variables containing text do indeed get processed w/o using ^!Insert
        > or ^!InsertText. I'd be curious to know what it does know if you
        > take ^!InsertText out.
        >
        > >All of the clips had simple text, with inserted variables, without
        > >the ^!InsertText command. (The documentation does not make it clear
        > >that this should be used.) It appears that the clip language under
        > >Windows 2000 is more forgiving on this point than under Win XP.
        > >
        > >Thanks to all for your help and advice.
        > >
        > >
        > >--- In ntb-clips@yahoogroups.com, "John Zeman <john041650@y...>"
        > ><john041650@y...> wrote:
        > >> If your command line in the "Play" clip is literally as you post it
        > >here, then is there is no command to execute in it.. So NoteTab is
        > >probably interpreting the entire line as text, only. Have you tried
        > >changing your clip from this:
        > >>
        > >> H="Play"
        > >> The string is ^%var1%
        > >>
        > >> to:
        > >>
        > >> H="Play"
        > >> ^!InsertText The string is ^%var1%
        >
        >
        > Happy Clip'n!
        > Jody
        >
        > http://www.notetab.net
        >
        > Subscribe, UnSubscribe, Options
        > mailto:Ntb-Clips-Subscribe@yahoogroups.com
        > mailto:Ntb-Clips-UnSubscribe@yahoogroups.com
        > http://groups.yahoo.com/group/ntb-clips
      • M. Sean Fosmire <msf@theup.com>
        Whether or not this should happen, the fact is that it does. Without the !^InsertText command, the results are eccentric and unpredictable. With it, it works
        Message 3 of 19 , Mar 1, 2003
        • 0 Attachment
          Whether or not this should happen, the fact is that it does. Without
          the !^InsertText command, the results are eccentric and
          unpredictable. With it, it works every time and on each system.

          Among the other problems, without the command, the predefined
          internal variables don't work. Try this one:

          --------------------------------------------------
          = V5 MultiLine NoSorting TabWidth=30

          H="one"
          ^%nl% First line ^%nl% Second line

          H="two"
          ^!InsertText ^%nl% First line ^%nl% Second line
          --------------------------------------------------

          The results on my Win2000 system this morning:

          "one" produces:

          ^%nl% First line ^%nl% Second line

          "two" produces the intended result:

          First line
          Second line

          The Clip library has a bullet in front of "one" and an ! in front
          of "two", indicating that it interprets "one" as text and "two" as a
          programmed clip.

          >
          > I believe you still have a problem. ^!Insert or ^!InsertText is not
          > needed. There was a time when at least "^!" had to be in the Clip
          > for certain other code to work. I think it was wizards: ^?[Test].
          > It appears Eric may have fixed it so that "^!" is not needed at all
          > anymore or I forget the certain code that would not work. Your
          > original Clip was tested and worked in XP for at least two of us
          > that tried. I'm glad it works for you, but it is added code that
          > you have to put in that is not needed. I have many a Clips that do
          > what you had. In fact, when the Clip Code was much smaller, only a
          > few dozen commands maybe, it was common practice to use pure text.
          > Variables containing text do indeed get processed w/o using ^!Insert
          > or ^!InsertText. I'd be curious to know what it does know if you
          > take ^!InsertText out.
          >
        • Sheri
          ... Now I understand the problem, because this came up before and Eric responded to it. If you don t have any clip commands at all in your clip the Clip
          Message 4 of 19 , Mar 1, 2003
          • 0 Attachment
            At 03:06 PM 3/1/03 +0000, you wrote:
            >Whether or not this should happen, the fact is that it does. Without
            >the !^InsertText command, the results are eccentric and
            >unpredictable. With it, it works every time and on each system.
            >
            >Among the other problems, without the command, the predefined
            >internal variables don't work. Try this one:
            >
            >--------------------------------------------------
            >= V5 MultiLine NoSorting TabWidth=30
            >
            >H="one"
            >^%nl% First line ^%nl% Second line
            >
            >H="two"
            >^!InsertText ^%nl% First line ^%nl% Second line
            >--------------------------------------------------

            Now I understand the problem, because this came up before and Eric responded to it.

            If you don't have any clip commands at all in your "clip" the Clip Interpreter is apt to be bypassed. Try removing the ^!InsertText, but include some other clip command above it, such as ^!Info Hello.

            Regards,
            Sheri
          • Jody
            Hi John, I ve never had the problem on Win95,98,XP. I use ^!InsertText most the time, but I like to try to not use it so that the text is black and it stands
            Message 5 of 19 , Mar 1, 2003
            • 0 Attachment
              Hi John,

              I've never had the problem on Win95,98,XP. I use ^!InsertText
              most the time, but I like to try to not use it so that the text
              is black and it stands out easy. I can readily see that text
              will be inserted. I don't know why a couple of you have
              experienced problems with it.

              >Actually Jody, as recently as a few months ago, I occasionally
              >experienced that same problem M. Sean had.. Sometimes back then
              >I was inserting text without the ^!InsertText command and
              >occasionally, not always, (op system Win2k) the variable name
              >would be inserted instead of the variable contents. I started
              >making a habit of always using ^!InsertText before the text
              >and/or variable and haven't had the problem since.. By the way,
              >I stay current on the NoteTab Pro versions, so it was probably
              >4.90 or 4.91 I was using then..
              >
              >John
              >--- In ntb-clips@yahoogroups.com, Jody <av1611@e...> wrote:
              >> Hi M. Sean,
              >>
              >> >BINGO! That was it!
              >>
              >> I believe you still have a problem. ^!Insert or ^!InsertText is not
              >> needed. There was a time when at least "^!" had to be in the Clip
              >> for certain other code to work. I think it was wizards: ^?[Test].
              >> It appears Eric may have fixed it so that "^!" is not needed at all
              >> anymore or I forget the certain code that would not work. Your
              >> original Clip was tested and worked in XP for at least two of us
              >> that tried. I'm glad it works for you, but it is added code that
              >> you have to put in that is not needed. I have many a Clips that do
              >> what you had. In fact, when the Clip Code was much smaller, only a
              >> few dozen commands maybe, it was common practice to use pure text.
              >> Variables containing text do indeed get processed w/o using ^!Insert
              >> or ^!InsertText. I'd be curious to know what it does know if you
              >> take ^!InsertText out.


              Happy Clip'n!
              Jody

              http://www.notetab.net

              Subscribe, UnSubscribe, Options
              mailto:Ntb-Clips-Subscribe@yahoogroups.com
              mailto:Ntb-Clips-UnSubscribe@yahoogroups.com
              http://groups.yahoo.com/group/ntb-clips
            • Jody
              Hi M. Sean, ... That fact still remains that it should work without it and there are times with me for personal preference that I do not want to use ^!Insert.
              Message 6 of 19 , Mar 1, 2003
              • 0 Attachment
                Hi M. Sean,

                >Whether or not this should happen, the fact is that it does. Without
                >the !^InsertText command, the results are eccentric and
                >unpredictable. With it, it works every time and on each system.

                That fact still remains that it should work without it and there
                are times with me for personal preference that I do not want to
                use ^!Insert. Sometimes I just don't feel like typing it in. :)
                Straight text with or without variables has not failed for me
                ever since they both came out. Since it does not fail for
                others, perhaps it is a setting in NoteTab conflicting or some
                specific on your machine conflicting.

                You might try a new ini file temporarily just for grins. If you
                want to create a new INI file, close NoteTab and rename
                NotePro.ini found in its main folder (NoteTab.ini for Std/Light).
                Start up NoteTab and it will use its default settings actually
                creating the INI file when you shut it down.

                >Among the other problems, without the command, the predefined
                >internal variables don't work. Try this one:

                They execute both predefined variables for me as I mentioned the
                other day. I can only suggest if you do not want to spend the
                time to try to figure out why it does not work on your machine,
                then just use ^!InsertText all the time and be done with it. I'd
                have to play with it for awhile if it were me. :) I can suggest
                that you do the INI file first, then a new install, and lastly
                try it with other programs closed.

                It is odd that you are getting a bullet. Is that what you have
                set in Options | General | Bullet Character? If so, I'd
                definitely try the new ini file.

                >--------------------------------------------------
                >= V5 MultiLine NoSorting TabWidth=30
                >
                >H="one"
                >^%nl% First line ^%nl% Second line
                >
                >H="two"
                >^!InsertText ^%nl% First line ^%nl% Second line
                >--------------------------------------------------
                >
                >The results on my Win2000 system this morning:
                >
                >"one" produces:
                >
                >^%nl% First line ^%nl% Second line
                >
                >"two" produces the intended result:
                >
                >First line
                >Second line
                >
                >The Clip library has a bullet in front of "one" and an ! in front
                >of "two", indicating that it interprets "one" as text and "two"
                >as a programmed clip.


                Happy Clip'n!
                Jody

                http://www.notetab.net

                Subscribe, UnSubscribe, Options
                mailto:Ntb-Clips-Subscribe@yahoogroups.com
                mailto:Ntb-Clips-UnSubscribe@yahoogroups.com
                http://groups.yahoo.com/group/ntb-clips
              • Jody
                Hi Sheri, ... That is why I mentioned having to have at least ^! in the Clip. I have Clips around from the past that on line one all it has is: ^! If you
                Message 7 of 19 , Mar 1, 2003
                • 0 Attachment
                  Hi Sheri,

                  >>--------------------------------------------------
                  >>= V5 MultiLine NoSorting TabWidth=30
                  >>
                  >>H="one"
                  >>^%nl% First line ^%nl% Second line
                  >>
                  >>H="two"
                  >>^!InsertText ^%nl% First line ^%nl% Second line
                  >>--------------------------------------------------
                  >
                  >Now I understand the problem, because this came up before and
                  >Eric responded to it.
                  >
                  >If you don't have any clip commands at all in your "clip" the
                  >Clip Interpreter is apt to be bypassed. Try removing the
                  >^!InsertText, but include some other clip command above it, such
                  >as ^!Info Hello.

                  That is why I mentioned having to have at least "^!" in the Clip.
                  I have Clips around from the past that on line one all it has is: ^!

                  If you have a ^!Set though, it takes care of the "^!". NoteTab
                  does not need to see a complete command; just ^!. As far as
                  using the original Clips that was sent in if you first ^!Set,
                  then use the second Clip *without* exiting the Library, then the
                  initial ^!Set takes care of it. If you go outside the Library
                  and switch back in it will loose it of course unless "p_" is
                  used. Still, the initial ^!Set should take care of it for the
                  whole Library regardless of where the variable is used (in this
                  case).

                  Happy Clip'n!
                  Jody

                  http://www.notetab.net

                  Subscribe, UnSubscribe, Options
                  mailto:Ntb-Clips-Subscribe@yahoogroups.com
                  mailto:Ntb-Clips-UnSubscribe@yahoogroups.com
                  http://groups.yahoo.com/group/ntb-clips
                • M. Sean Fosmire <msf@theup.com>
                  See bullet.jpg in the Files section for a screenshot.
                  Message 8 of 19 , Mar 2, 2003
                  • 0 Attachment
                    See "bullet.jpg" in the Files section for a screenshot.

                    >
                    > It is odd that you are getting a bullet. Is that what you have
                    > set in Options | General | Bullet Character? If so, I'd
                    > definitely try the new ini file.
                    >
                  • Jody
                    Hi M. Sean, OK, I misunderstood. Those are the Clip icons that you have turned on via Options | Clipbook. The bullet means it is text only and the
                    Message 9 of 19 , Mar 2, 2003
                    • 0 Attachment
                      Hi M. Sean,

                      OK, I misunderstood. Those are the Clip icons that you have
                      turned on via Options | Clipbook. The bullet means it is text
                      only and the exclamation mark means there is a command in it
                      (actually, at least "^!" without the quotes). If you add ^! to
                      line one or anywhere else in a text only Clip you will see the
                      bullet change to an exclamation mark.

                      I haven't turned the Clip icons on in years so I forget about
                      them. It seems to me they don't serve any purpose for my needs
                      so I don't want to take up any resources no matter how small that
                      might be when not needed. I think one of the main reasons I
                      turned them off originally was so that there was more space for
                      the Clip name therefore I could keep my Clipbook about 1-2
                      columns smaller. :)

                      http://groups.yahoo.com/group/ntb-clips/files/
                      http://groups.yahoo.com/group/ntb-clips/files/bullet.jpg

                      >See "bullet.jpg" in the Files section for a screenshot.
                      >
                      >>
                      >> It is odd that you are getting a bullet. Is that what you have
                      >> set in Options | General | Bullet Character? If so, I'd
                      >> definitely try the new ini file.


                      Happy Clip'n!
                      Jody

                      http://www.notetab.net

                      Subscribe, UnSubscribe, Options
                      mailto:Ntb-Clips-Subscribe@yahoogroups.com
                      mailto:Ntb-Clips-UnSubscribe@yahoogroups.com
                      http://groups.yahoo.com/group/ntb-clips
                    • M. Sean Fosmire <msf@theup.com>
                      I like the idea of the naked ^!
                      Message 10 of 19 , Mar 2, 2003
                      • 0 Attachment
                        I like the idea of the naked ^!

                        >
                        > OK, I misunderstood. Those are the Clip icons that you have
                        > turned on via Options | Clipbook. The bullet means it is text
                        > only and the exclamation mark means there is a command in it
                        > (actually, at least "^!" without the quotes). If you add ^! to
                        > line one or anywhere else in a text only Clip you will see the
                        > bullet change to an exclamation mark.
                      Your message has been successfully submitted and would be delivered to recipients shortly.