Loading ...
Sorry, an error occurred while loading the content.

Searching Backwards

Expand Messages
  • Robert Barrows
    Is there a bug in searching backwards? I m using Note Tab Pro 4.86 (Full Release). Whenever I perform a Find operation using the B option, it seems to perform
    Message 1 of 2 , May 1, 2002
    • 0 Attachment
      Is there a bug in searching backwards?
      I'm using Note Tab Pro 4.86 (Full Release).
      Whenever I perform a Find operation using the B option, it seems to perform questionable results.
      For instance-
      ^!Find "\<\/h[1-3]\>" CIBRS
      Refuses to search backwards.

      I'm just trying to identify headings on an HTML page using the following clip:
      ^!Jump Select_End
      ^!MoveCursor +5
      ^!Find "\<\/h[1-3]\>" CIRS
      ^!Jump Select_Start
      ^!Set %HEndPos%=^$GetRow$:^$GetCol$
      ^!Find "<" BS
      ^!Jump Select_End
      ^!SelectTo ^%HEndPos%

      This works fine on the first try except although the second Select_End is not jumping the cursor to the position directly after the < character but is instead selecting /a>. I'm not sure what's causing this. I've tried using Select_Start instead but that gets me the entire </a> tag.

      Why can't I use regular expressions in a backwards search?
      Why does Select_End act oddly directly after a backwards search?
      Is there someway to reset the search settings after performing a backwards search?

      Thanks for any help.

      -Rob.



      [Non-text portions of this message have been removed]
    • Robert Barrows
      Ok, one problem fixed, I was searching for the wrong character. I wanted not
      Message 2 of 2 , May 1, 2002
      • 0 Attachment
        Ok, one problem fixed, I was searching for the wrong character. I wanted > not <.
        Sorry about that.
        The clip works now, but I still haven't figured out why I can't use regular expressions in a backwards search.

        Thanks.

        -Rob.

        -----Original Message-----
        From: Robert Barrows
        Sent: Wednesday, May 01, 2002 12:31 PM
        To: ntb-clips@yahoogroups.com
        Subject: Searching Backwards


        Is there a bug in searching backwards?
        I'm using Note Tab Pro 4.86 (Full Release).
        Whenever I perform a Find operation using the B option, it seems to perform questionable results.
        For instance-
        ^!Find "\<\/h[1-3]\>" CIBRS
        Refuses to search backwards.

        I'm just trying to identify headings on an HTML page using the following clip:
        ^!Jump Select_End
        ^!MoveCursor +5
        ^!Find "\<\/h[1-3]\>" CIRS
        ^!Jump Select_Start
        ^!Set %HEndPos%=^$GetRow$:^$GetCol$
        ^!Find "<" BS
        ^!Jump Select_End
        ^!SelectTo ^%HEndPos%

        This works fine on the first try except although the second Select_End is not jumping the cursor to the position directly after the < character but is instead selecting /a>. I'm not sure what's causing this. I've tried using Select_Start instead but that gets me the entire </a> tag.

        Why can't I use regular expressions in a backwards search?
        Why does Select_End act oddly directly after a backwards search?
        Is there someway to reset the search settings after performing a backwards search?

        Thanks for any help.

        -Rob.



        [Non-text portions of this message have been removed]
      Your message has been successfully submitted and would be delivered to recipients shortly.