Loading ...
Sorry, an error occurred while loading the content.

Re: [Clip] Strange(?) behaviour with paragraphs

Expand Messages
  • Jody
    Hi Martyn, The ^C token you are seeing is used for a carriage return in NoteTab Std/Light. The CR might be added by another program. It may also be possible
    Message 1 of 2 , Mar 1, 2002
    • 0 Attachment
      Hi Martyn,

      The ^C token you are seeing is used for a carriage return in
      NoteTab Std/Light. The CR might be added by another program. It
      may also be possible that you are saving the file in a format
      that uses them. (I do not know what the different formats use.)
      Right click over the file tab and choose Save Format changing it
      to DOS/Windows. Look in Options also and change it under the
      Document tab. I do not know if those settings effect the ^!Save
      and/or ^!Save As commands or not. If nothing changes, try using
      the ^!Replace command in your Clip or ^$StrReplace

      ^!Set %Text%=^$StrReplace("^c";"^p";"^%Text%";0;0)$

      Returns a new string with all occurrences of SubStr replaced with
      ReplaceStr according to the settings of the CaseSensitive and
      WholeWord parameters. Tab and line-break tokens are automatically
      converted to their real characters since version 4.6.

      Example: ^$StrReplace("o";"?";"NoteTab Pro";True;False)$
      Result: N?teTab Pr?"

      Tokens used in NoteTab:

      ^T = Tab ($09)
      ^B = Page break ($0C)
      ^P = Paragraph (carriage-return/line-feed pair)
      ^C = Carriage-return ($0D) (Std/Light)
      ^L = Line-feed ($0A) (Std/Light)

      >I hope someone will be able to explain to me what is happening
      >and what to do to avoid it happening.
      >
      >I have written a clip that converts xhtml to the Palm Markup for
      >the Palm Reader. It is all done in a clip without opening the
      >file.
      >
      >When I view the .txt file in NTP, all the paragraph marks show as
      >they should. However, when I dump the text held in the variable
      >%text% there are square black blocks scattered throughout the
      >text apparently at random. If I select one of these black blocks
      >and open the Replace dialogue it comes up as ^C. So these ^C
      >characters are being introduced from somewhere, and they are
      >causing problems for the layout in the Palm Reader file. I
      >believe these characters are both the ascii characters 10 and 13,
      >but I am not sure how I know that!
      >
      >I can open the file and do a Replace to get rid of them but can't
      >think of a way to do this without opening the file. Ideally I
      >would prefer it if these characters are not introduced into the
      >file at all.


      Happy Clip'n!
      Jody

      http://www.notetab.net

      Subscribe, UnSubscribe, Options
      mailto:Ntb-Clips-Subscribe@yahoogroups.com
      mailto:Ntb-Clips-UnSubscribe@yahoogroups.com
      http://groups.yahoo.com/group/ntb-clips
    • Martyn Folkes
      Thanks, Jody. I had read the bit in the help file ( Tab and line-break tokens are automatically converted to their real characters since version 4.6. ) but it
      Message 2 of 2 , Mar 3, 2002
      • 0 Attachment
        Thanks, Jody. I had read the bit in the help file ("Tab and line-break
        tokens are automatically converted to their real characters since version
        4.6.") but it hadn't clicked with me what it actually meant.

        Martyn

        > -----Original Message-----
        > From: Jody [mailto:av1611@...]
        > Sent: 01 March 2002 22:36
        > To: ntb-clips@yahoogroups.com
        > Subject: Re: [Clip] Strange(?) behaviour with paragraphs
        >
        >
        > Hi Martyn,
        >
        > The ^C token you are seeing is used for a carriage return in
        > NoteTab Std/Light. The CR might be added by another program. It
        > may also be possible that you are saving the file in a format
        > that uses them. (I do not know what the different formats use.)
        > Right click over the file tab and choose Save Format changing it
        > to DOS/Windows. Look in Options also and change it under the
        > Document tab. I do not know if those settings effect the ^!Save
        > and/or ^!Save As commands or not. If nothing changes, try using
        > the ^!Replace command in your Clip or ^$StrReplace
        >
        > ^!Set %Text%=^$StrReplace("^c";"^p";"^%Text%";0;0)$
        >
        > Returns a new string with all occurrences of SubStr replaced with
        > ReplaceStr according to the settings of the CaseSensitive and
        > WholeWord parameters. Tab and line-break tokens are automatically
        > converted to their real characters since version 4.6.
        >
        > Example: ^$StrReplace("o";"?";"NoteTab Pro";True;False)$
        > Result: N?teTab Pr?"
        >
        > Tokens used in NoteTab:
        >
        > ^T = Tab ($09)
        > ^B = Page break ($0C)
        > ^P = Paragraph (carriage-return/line-feed pair)
        > ^C = Carriage-return ($0D) (Std/Light)
        > ^L = Line-feed ($0A) (Std/Light)
        >
        > >I hope someone will be able to explain to me what is happening
        > >and what to do to avoid it happening.
        > >
        > >I have written a clip that converts xhtml to the Palm Markup for
        > >the Palm Reader. It is all done in a clip without opening the
        > >file.
        > >
        > >When I view the .txt file in NTP, all the paragraph marks show as
        > >they should. However, when I dump the text held in the variable
        > >%text% there are square black blocks scattered throughout the
        > >text apparently at random. If I select one of these black blocks
        > >and open the Replace dialogue it comes up as ^C. So these ^C
        > >characters are being introduced from somewhere, and they are
        > >causing problems for the layout in the Palm Reader file. I
        > >believe these characters are both the ascii characters 10 and 13,
        > >but I am not sure how I know that!
        > >
        > >I can open the file and do a Replace to get rid of them but can't
        > >think of a way to do this without opening the file. Ideally I
        > >would prefer it if these characters are not introduced into the
        > >file at all.
        >
        >
        > Happy Clip'n!
        > Jody
        >
        > http://www.notetab.net
        >
        > Subscribe, UnSubscribe, Options
        > mailto:Ntb-Clips-Subscribe@yahoogroups.com
        > mailto:Ntb-Clips-UnSubscribe@yahoogroups.com
        > http://groups.yahoo.com/group/ntb-clips
        >
        >
        >
        >
        >
        > Your use of Yahoo! Groups is subject to http://docs.yahoo.com/info/terms/
        >
        >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.