Loading ...
Sorry, an error occurred while loading the content.
 

Re: JUMP LINE_END not performing as expected

Expand Messages
  • rdeckard_@excite.ca
    I was the poster of the original mssg in the NoteTabs General ng. Will try your solution. However, as I noted in the other ng, the JUMP LINE_END seems to work
    Message 1 of 3 , Sep 4, 2001
      I was the poster of the original mssg in the NoteTabs General ng. Will try your solution. However, as I noted in the other ng, the JUMP LINE_END seems to work properly (jumps to the next hard return vice the screen line end) sometimes. Seems to depend on the last character of the line. In the case of my non-working line, it ends with a #. Would this make a difference?

      --- In ntb-clips@y..., h.paulissen@f... wrote:
      > --- In notetab@y..., rdeckard_@e... wrote:
      > > I've written a clip, however, it's not working consistently because
      > of the ^!JUMP LINE_END command. According to the help file,
      > >
      > > "LINE_START or LINE_END: places cursor at the beginning or end of
      > the current line. This feature treats a line as if word wrap is
      > turned off."
      > >
      > > This isn't true. If word wrap is turned on, it only moves it to the
      > end of the screen line, not to the next hard return as it should. The
      > result is that -- depending on how my window is sized -- the clip may
      > or may not work correctly.
      > >
      > > How do I fix?
      >
      > There were two answers without a fix, but you could use this one:
      > wrap your Jump-line with SetScreenUpdate-commands...
      >
      > ^!SetScreenUpdate Off
      > ^!Jump Line_end
      > ^!SetScreenUpdate On
      > ^!SetView :1
      >
      > I found that the last line actually is necessary to update the screen
      > to the correct position. I left RowTop out (cheap, I know) and to my
      > own surprise it worked...
      >
      > From Help:
      > ^!SetView RowTop:ColLeft (added in v4.8)
      > Moves the top line and leftmost column to the specified coordinates
      > in current document window.
      >
      > Hugo
    • Jody
      Hi rdeckard, I still cannot get it to fail with the line ending in the # character. What version of NoteTab are you in? Also, have you tried just the ^!Jump
      Message 2 of 3 , Sep 4, 2001
        Hi rdeckard,

        I still cannot get it to fail with the line ending in the #
        character. What version of NoteTab are you in? Also, have you
        tried just the ^!Jump Line_End by itself in case if it is in a
        Clip with other things that may be causing the behavior?

        >I was the poster of the original mssg in the NoteTabs General ng.
        >Will try your solution. However, as I noted in the other ng, the
        >JUMP LINE_END seems to work properly (jumps to the next hard
        >return vice the screen line end) sometimes. Seems to depend on
        >the last character of the line. In the case of my non-working
        >line, it ends with a #. Would this make a difference?


        Happy Clip'n!
        Jody

        http://www.notetab.net

        Subscribe, UnSubscribe, Options
        mailto:Ntb-Clips-Subscribe@yahoogroups.com
        mailto:Ntb-Clips-UnSubscribe@yahoogroups.com
        http://www.egroups.com/group/ntb-clips
      Your message has been successfully submitted and would be delivered to recipients shortly.