Loading ...
Sorry, an error occurred while loading the content.

[Clip] Re: Bug Report: NoteTab Pro v4.60a/np

Expand Messages
  • Raymond Fitzgerald
    Hi Larry, ... That reminds me of a fix in 4.60a Pro only that affected a few clips of mine. These are clips that set a starting point after a ^!Find using
    Message 1 of 1 , Jul 1, 1999
    • 0 Attachment
      Hi Larry,

      >I have a copy of the previous version of NoteTab Pro v4.60/np and in that
      >version, the last line of the range is returned by ^!Info ^GetRow$.
      >
      >This can cause and has caused clips written for one version to fail when
      >run on the other version.

      That reminds me of a fix in 4.60a Pro only that affected a few clips of
      mine. These are clips that set a starting point after a ^!Find using
      ^$GetCol$. I had written Eric, "$GetCol$ is now returning the value for the
      beginning of the selected text. With 4.6 and prior, it was returning the
      value for the end of the selection, where the cursor is."

      Eric responded, "A user had brought to my attention that the rich-edit
      control in NoteTab Standard/Light always returned the start of the
      selection. So to force NoteTab Pro to behave like Standard/Light, I cause
      the GetCol function to always return the start of the selection."

      To fix my clips at first I incremented the column # by the selection size.
      Worked great until I had a large selection that happened to span two rows!
      So now I jump to the selection end before using GetCol.

      Cheers,
      Ray

      ------------------------------------------------------------------------

      eGroups.com home: http://www.egroups.com/group/ntb-clips
      http://www.egroups.com - Simplifying group communications
    Your message has been successfully submitted and would be delivered to recipients shortly.