Loading ...
Sorry, an error occurred while loading the content.

FIND+REPLACE : Stop Automatically Checkmarking "Criteria","Whole Words" in a clip like !Replace "" >> """ AS

Expand Messages
  • Hans Witschi
    How to STOP Automatically Checkmarking Criteria , Whole Words in a clip like !Replace  AS Dear NTBrs In text versions of newpaper documents from
    Message 1 of 4 , Jan 4, 2001
    • 0 Attachment
      How to STOP Automatically Checkmarking "Criteria","Whole Words" in a
      clip like !Replace "" >> """ AS


      Dear NTBrs

      In text versions of newpaper documents from the Internet -- specially
      from Europe -- there are frequently this little black boxes = . They
      appear instead of an „ or " for example. I want replace this little
      black thing with a simple " (the remaining others with -, or with :) .
      A clip like !Replace "" AS >> """ assumes that this  is a whole word
      and automatically checkmarks "Whole Words" in Criteria. So it can't find
      any.
      If I do replace it without a clip and uncheck "Whole Words", it has no
      problems to find and replaces all occurences.

      How can I tell NoteTab to stop automatical checkmarking "Whole Words" in
      Criteria, when it sees a blackbox-character , when I'm running the clip
      below ?


      [ = black box]

      ;Quotationmark Beginning of Word
      ^!Replace "" >> """ AS
      ;Quotationmark End of Word
      ^!Replace "" >> """ AS

      ^!Replace "" >> "-" AS
      ^!Replace "" >> ":" AS



      Regards.

      Hans
    • Alan
      Hi Hans, ... options, I see you using A for all and S for silent Have you also tried, in addition to the above two, T option? T for does not search for whole
      Message 2 of 4 , Jan 4, 2001
      • 0 Attachment
        Hi Hans,

        >How can I tell NoteTab to stop automatical checkmarking "Whole Words" in
        >Criteria, when it sees a blackbox-character , when I'm running the clip

        options, I see you using A for all and S for silent

        Have you also tried, in addition to the above two, T option?

        T for "does not search for whole words"

        Regards. Alan.
      • Hans Witschi
        Alan, thank you very much for your advice. T solved my problem. Hans
        Message 3 of 4 , Jan 4, 2001
        • 0 Attachment
          Alan,

          thank you very much for your advice.
          "T" solved my problem.

          Hans
        • Jody
          Hi Hans, ... The Clip is doing what you told it to. :) Alan gave you the correct answer. FWIW, in my version of Pro which is the beta it works with or
          Message 4 of 4 , Jan 4, 2001
          • 0 Attachment
            Hi Hans,

            >A clip like ^!Replace "" AS >> """ assumes that this  is a
            >whole word and automatically checkmarks "Whole Words" in
            >Criteria.

            The Clip is doing what you told it to. :) Alan gave you the
            correct answer. FWIW, in my version of Pro which is the beta it
            works with or without the "T" Option. NoteTab makes some
            assumptions when using ^!Replace like whole document and case
            sensitive. You need to tell NoteTab not to do that if you do not
            want those used. Also, you might want to add the "W" option for
            the whole document. "A" only does all occurrences from the
            cursor position down. See Help under the Find tab and type in
            ^!Replace for explanation of all the Options.

            Happy Clip'n!
            Jody

            http://www.notetab.net

            Subscribe, UnSubscribe, Options
            mailto:Ntb-Clips-Subscribe@...
            mailto:Ntb-Clips-UnSubscribe@...
            http://www.egroups.com/group/ntb-clips
          Your message has been successfully submitted and would be delivered to recipients shortly.