Loading ...
Sorry, an error occurred while loading the content.

[Clip] Re: AutoReplace Libraries & Ini

Expand Messages
  • Larry Thomas
    Hi Jody, ... First there is the AutoReplace Mode on the menu -- Tools | Autoreplace Mode. Your clips turn this on and off every time just as they should.
    Message 1 of 14 , May 5, 1999
    • 0 Attachment
      Hi Jody,

      At 03:15 PM 5/5/1999 -0500, you wrote:
      >Hi Larry,
      >
      >Thanks for your reply! I saw that the two differed like you said
      >as I tried to explain in my post.
      >
      >Did you try the clips? Why does the On clips change the Menubar
      >setting, but AutoReplace IS NOT trurned on. Why does the Off clip
      >change the setting and AutoReplace IS turned off.

      First there is the AutoReplace Mode on the menu -- Tools | Autoreplace Mode.
      Your clips turn this on and off every time just as they should.

      Second there is the Autoreplace item that you can check when you
      right-click on the clipbook body. Your clip has no effect on this at all
      at any time as far as I can tell. You could write a clip for this item by
      using ^!Keyboard commands on the clipbook as you have in the past or your
      could write a clip that opens the current clipbook as a document and
      changes the header to what you want which would do the same thing. Which
      ever you do, it requires a different clip than the one you wrote for the
      main menu bar.

      Regards,

      Larry
      larryt@...

      ------------------------------------------------------------------------
      eGroup home: http://www.eGroups.com/group/ntb-clips
      http://www.eGroups.com - Simplifying group communications
    • Kay Roath
      Hi Jody & Larry - Interesting discussion. Do I have this right? If a Library is defined as AutoReplace (= V5 MultiLine AutoReplace TabWidth=30), it can be
      Message 2 of 14 , May 5, 1999
      • 0 Attachment
        Hi Jody & Larry -
        Interesting discussion. Do I have this right?

        If a Library is defined as AutoReplace
        (= V5 MultiLine AutoReplace TabWidth=30),
        it can be turned on/off with the AutoReplace Mode flag but
        if it's a regular Library, it's not affected by the flag.

        You couldn't reliably use ^!Keyboard to get to the clip
        right click option to set Auto-Replace because the
        doc/Library toggle key works differently depending on
        how the clip is executed :(

        I think you'd have to open the library as a document,
        change the header & use ^!ReloadLibrary.

        --- Grandma Kay ---



        ------------------------------------------------------------------------
        eGroup home: http://www.eGroups.com/group/ntb-clips
        http://www.eGroups.com - Simplifying group communications
      • Larry Thomas
        Hi Kay, ... It appears that the AutoReplace Mode flag turns on or off the feature for all librairies not just the one in focus. You are correct however in
        Message 3 of 14 , May 5, 1999
        • 0 Attachment
          Hi Kay,

          At 04:18 PM 5/5/1999 -0500, you wrote:
          >Hi Jody & Larry -
          >Interesting discussion. Do I have this right?
          >
          >If a Library is defined as AutoReplace
          >(= V5 MultiLine AutoReplace TabWidth=30),
          >it can be turned on/off with the AutoReplace Mode flag but
          >if it's a regular Library, it's not affected by the flag.
          >

          It appears that the AutoReplace Mode flag turns on or off the feature for
          all librairies not just the one in focus. You are correct however in that
          regular librairies are not affected by the flag.

          >You couldn't reliably use ^!Keyboard to get to the clip
          >right click option to set Auto-Replace because the
          >doc/Library toggle key works differently depending on
          >how the clip is executed :(
          >
          >I think you'd have to open the library as a document,
          >change the header & use ^!ReloadLibrary.

          That is my opinion as well. For me it is more practical to just use the
          right-click menu itself as it is designed. I think that Jody likes to
          write clips sometimes just to see if he can do it that way ;-)

          Regards,

          Larry
          larryt@...

          ------------------------------------------------------------------------
          eGroup home: http://www.eGroups.com/group/ntb-clips
          http://www.eGroups.com - Simplifying group communications
        • Jody
          Hi Larry and Kay, ... I must not be making myself clear, you are not testing my clips, or I do not understand the point you are trying to get across. I ll try
          Message 4 of 14 , May 5, 1999
          • 0 Attachment
            Hi Larry and Kay,

            > First there is the AutoReplace Mode on the menu -- Tools |
            > Autoreplace Mode. Your clips turn this on and off every time
            > just as they should.

            I must not be making myself clear, you are not testing my clips,
            or I do not understand the point you are trying to get across.
            I'll try again to make it as clear as I can.

            AutoReplace from the Menubar (which is global) works regardless
            of what type of Library it is (and does not effect the type of
            Library) and from what I can gather it is designed that way.

            From the beginning I understood the .ini setting has nothing to
            do with the Clipbook Content menu which effects the type of
            Library it is.

            > I think that Jody likes to write clips sometimes just to see if
            > he can do it that way ;-)

            Nope, the reason is below, but to spell it out: ^!Keyboard commands
            and Libraries are sloppy.

            > You could write a clip for this item by using ^!Keyboard
            > commands

            I understand this and trying to avoid that, but that is still not
            my issue which follows:

            Why does my "Turn Off" clip stop AutoReplace?
            Why does my "Turn On" clip *not* turn on AutoReplace?

            The on/off changes the Menubar setting as it is suppose to.
            The Off clip stops AutoReplace from working.
            The On clip does *not* turn in on.
            If I manually change the setting on the Menubar it turns
            on/off according to what it is set at.

            > I think you'd have to open the library as a document, change
            > the header & use ^!ReloadLibrary.

            That is not needed if one is doing the change from ^!Keyboard
            checking AutoReplace to change the Library type. NoteTab takes
            care of that. Open a .clb as a document and you can watch the
            changes and see that it indeed changes the actual on/off for the
            Library. Furthermore, that will also change the Menubar setting.
            However, in this case, the Menubar setting is not global but will
            turn off if the library is switched.

            Thanks!
            Jody

            Tell a friend about Clean-Funnies...
            To subscribe send a post to: mdaemon@...
            In body of message put: subscribe Clean-Funnies

            ------------------------------------------------------------------------
            eGroup home: http://www.eGroups.com/group/ntb-clips
            http://www.eGroups.com - Simplifying group communications
          • Kay Roath
            5/5/1999 5:03 PM Jody wrote ... Put ^!Keyboard Shift+F4 Shift+F10 in a clip and execute it by clicking or using In-Context & you should get the clip right
            Message 5 of 14 , May 5, 1999
            • 0 Attachment
              5/5/1999 5:03 PM Jody wrote
              > That is not needed if one is doing the change from
              > ^!Keyboard checking AutoReplace to change the Library
              > type. NoteTab takes care of that.

              Put ^!Keyboard Shift+F4 Shift+F10 in a clip and execute it
              by clicking or using In-Context & you should get the clip
              right click menu. Start the clip using Ctrl+SpaceBar & you
              should get the document menu :( I know one of the 3 brings
              up the wrong menu & I'm pretty sure it's Ctrl+SpaceBar :)

              If there's a LoadLibrary before the Keyboard all 3 work
              correctly.

              --- Grandma Kay ---
              Introduction to NoteTab Clip Programming
              http://notetab.kay.net



              ------------------------------------------------------------------------
              eGroup home: http://www.eGroups.com/group/ntb-clips
              http://www.eGroups.com - Simplifying group communications
            • Jody
              Hi Kay, ... H=Test4Kay ; Works fine for me by clicking for on/off. ^!Keyboard Shift+F4 Shift+F4 Shift+F10 R This still does not answer my questions. The
              Message 6 of 14 , May 5, 1999
              • 0 Attachment
                Hi Kay,

                > Put ^!Keyboard Shift+F4 Shift+F10 in a clip and execute it...
                > should get the document menu :(

                H=Test4Kay
                ; Works fine for me by clicking for on/off.
                ^!Keyboard Shift+F4 Shift+F4 Shift+F10 R

                This still does not answer my questions. <g>

                The menu problem is a timing issue. Under normal
                circumstances:

                Your machine:
                ^!Keyboard Shift+F4 Shift+F10

                My machine:
                ^!Keyboard Shift+F4 Shift+F4 Shift+F10

                Someday we will need to find a happy medium for us using
                something like below. I have no idea where the delay
                would need to go:

                My machine:
                ^!FocusDoc
                ^!Keyboard Shift+F4 &50 Shift+F4 Shift+F10

                Später,
                Jody Adair

                I can only please one person a day.
                Today is obviously not your day.
                Tomorrow does not look good either. :-)
                http://www.sureword.com/sojourner/

                ------------------------------------------------------------------------
                eGroup home: http://www.eGroups.com/group/ntb-clips
                http://www.eGroups.com - Simplifying group communications
              • Larry Thomas
                Hi Jody, ... I don t know if I have a good answer to this but I did some more checking. I had not tried to use the autoreplace items in your clips before. I
                Message 7 of 14 , May 5, 1999
                • 0 Attachment
                  Hi Jody,

                  At 05:03 PM 5/5/1999 -0500, you wrote:
                  >Hi Larry and Kay,
                  >
                  >I must not be making myself clear, you are not testing my clips,
                  >or I do not understand the point you are trying to get across.
                  >I'll try again to make it as clear as I can.
                  >
                  >AutoReplace from the Menubar (which is global) works regardless
                  >of what type of Library it is (and does not effect the type of
                  >Library) and from what I can gather it is designed that way.
                  >

                  I don't know if I have a good answer to this but I did some more checking.
                  I had not tried to use the autoreplace items in your clips before. I just
                  checked out the menu items to see if they were checked or not and I assumed
                  that if they were check, then they worked. Wrongo!

                  1. Turning on auto-replace mode from the menu affects all clipbooks not
                  just the ones with the autoreplace header. If you have a one word clip [no
                  spaces in it] in the Acronyms library for example, you can type the word
                  followed by a space and auto-replace will change it in your document.

                  2. The Autoreplace header seems to be used by NoteTab to automatically
                  turn on the auto-replace mode in the menu when ever you switch to a library
                  that contains it.

                  3. With Auto-replace mode on, your examples t and tt are replaced when
                  they are typed and followed by a space with test and test this 2. If I run
                  the "off" clip, the mode is switched off and they are not replaced. If I
                  then run the "on" clip, the mode appears to be on if you drop down the
                  Tools menu but in fact it is not working and does not work. If the header
                  is set to Autoreplace and I close and re-open the clipbook or switch to
                  another and back, it works again.

                  I would say that this is something built into the NoteTab code.

                  Regards,

                  Larry
                  larryt@...

                  ------------------------------------------------------------------------
                  eGroup home: http://www.eGroups.com/group/ntb-clips
                  http://www.eGroups.com - Simplifying group communications
                • Jody
                  Hi Larry and/or Anybody/Everybody, This is as clear as I can make it and easy to test. Why does the QuickOpenLinks work when turning on/off and not
                  Message 8 of 14 , May 5, 1999
                  • 0 Attachment
                    Hi Larry and/or Anybody/Everybody,

                    This is as clear as I can make it and easy to test.
                    Why does the QuickOpenLinks work when turning on/off
                    and not AutoReplace? The ini file is not changed in
                    both cases till shut down, or at least visibly to
                    us. Pay attention to the Menubar setting while doing
                    this and try the provided clips to test to see if it
                    turns on/off correctly.

                    H="AutoReplace On"
                    ^!SaveValue Options:AutoReplace=1
                    ^!ProgIniLoad NotePro

                    H="AutoReplace Off"
                    ^!SaveValue Options:AutoReplace=0
                    ^!ProgIniLoad NotePro

                    H="Reload NotePro.ini"
                    ^!Keyboard Alt+E L
                    ^!Jump Doc_End
                    ^!Find "AutoReplace=" SB
                    ^!Keyboard Alt+T

                    H="Restart NotePro"
                    ^!Keyboard Alt+F X
                    ^!^$GetAppPath$NotePro.exe

                    H="Check AutoReplace After Restart"
                    ^!Open ^$GetAppPath$NotePro.ini
                    ^!Jump Doc_End
                    ^!Find "AutoReplace=" SB
                    ^!Keyboard Alt+T

                    H="Proof 'N Puddin'"
                    ; Double click on some text
                    ^!SaveValue Options:QuickOpenLinks=^?[Quick Open Links=_0|1]
                    ^!ProgIniLoad NotePro
                    ^!Keyboard Alt+E L
                    ^!Jump Doc_End
                    ^!Find "QuickOpenLinks=" SB
                    ^!Keyboard Alt+T

                    H=i
                    It works fine here Dummie!


                    H=o
                    Oops, it does not act the way one would think!


                    H=j
                    Jody, you are having one of your days - it works just fine!


                    Später,
                    Jody Adair

                    I can only please one person a day.
                    Today is obviously not your day.
                    Tomorrow does not look good either. :-)
                    http://www.sureword.com/sojourner/

                    ------------------------------------------------------------------------
                    eGroup home: http://www.eGroups.com/group/ntb-clips
                    http://www.eGroups.com - Simplifying group communications
                  • Jody
                    Hi Larry, Eric, Kay, and All, As you might have noticed there is a big lag. Larry sent me this private as I did him another post still lagged so I m trying to
                    Message 9 of 14 , May 5, 1999
                    • 0 Attachment
                      Hi Larry, Eric, Kay, and All,

                      As you might have noticed there is a big lag. Larry sent me this
                      private as I did him another post still lagged so I'm trying to
                      beat the lag a bit here.

                      > 3. With Auto-replace mode on, your examples t and tt are
                      > replaced when they are typed and followed by a space with test
                      > and test this 2. If I run the "off" clip, the mode is switched
                      > off and they are not replaced. If I then run the "on" clip,
                      > the mode appears to be on if you drop down the Tools menu but
                      > in fact it is not working and does not work. If the header is
                      > set to Autoreplace and I close and re-open the clipbook or
                      > switch to another and back, it works again.
                      > I would say that this is something built into the NoteTab
                      code.

                      Thank you, I rest my case!-)

                      > I would say that this is something built into the NoteTab
                      > code.

                      Ok then, what? My questions still remain about the same:

                      Why does it turn off and not on?

                      Why do the other settings like my example with the
                      QuickLinks work both ways?

                      c ya,
                      Jody

                      The whole world doth err save you
                      and me and even thou doest err some!

                      http://www.sureword.com/sojourner
                      http://www.sureword.com/mm

                      ------------------------------------------------------------------------
                      eGroup home: http://www.eGroups.com/group/ntb-clips
                      http://www.eGroups.com - Simplifying group communications
                    • Kay Roath
                      05/05/1999 4:54 PM Jody wrote ... but gives DOCUMENT SHORTCUT menu if you use In-Context or Ctrl+SpaceBar instead of clicking to execute the clip. On my
                      Message 10 of 14 , May 6, 1999
                      • 0 Attachment
                        05/05/1999 4:54 PM Jody wrote

                        > H=Test4Kay
                        > ; Works fine for me by clicking for on/off.
                        > ^!Keyboard Shift+F4 Shift+F4 Shift+F10 R

                        but gives DOCUMENT SHORTCUT menu if you use In-Context or
                        Ctrl+SpaceBar instead of clicking to execute the clip. On
                        my system, this clip executes Sort Ascending on the
                        document menu if I use the keyboard & Auto-Replace if I
                        use the mouse. It's not a timing or system thing except
                        that R on my shortcut menu happens to be Sort Ascending.
                        It's a starting focus thing that changes with keyboard vs
                        mouse usage.

                        Actually, if you use the mouse, you don't need Shift+F4
                        because you're focused in the clip area when you click
                        there.

                        Disregarding everything to do with Auto-Replace, my point is
                        that you can't use the Shift+F4 toggle in a clip & be
                        sure of where you are. ^!FocusDoc doesn't fix it & AR_KEY
                        can't be used. There's just no reliable way of using a
                        clip/document toggle in a clip that's going to be
                        distributed to other people. If it's strictly for your own
                        use & you always use the mouse, you're safe :)



                        ------------------------------------------------------------------------
                        eGroup home: http://www.eGroups.com/group/ntb-clips
                        http://www.eGroups.com - Simplifying group communications
                      • Jody
                        Hi Kay, ... I don t use that so I wouldn t know. ... It am still not settled on that. When using the mouse on my system shift+f4 twice always works but fails
                        Message 11 of 14 , May 6, 1999
                        • 0 Attachment
                          Hi Kay,

                          >> H=Test4Kay
                          >> ; Works fine for me by clicking for on/off.
                          >> ^!Keyboard Shift+F4 Shift+F4 Shift+F10 R
                          >
                          > but gives DOCUMENT SHORTCUT menu if you use In-Context or
                          > Ctrl+SpaceBar instead of clicking to execute the clip.

                          I don't use that so I wouldn't know.

                          > It's not a timing or system thing except that R on my shortcut
                          > menu happens to be Sort Ascending. It's a starting focus thing
                          > that changes with keyboard vs mouse usage.

                          It am still not settled on that. When using the mouse on my
                          system shift+f4 twice always works but fails on faster machines.
                          Shift+f4 once fails on my machine but not on faster machines.

                          ^!Focusdoc
                          ...shift+f4 (once)
                          seems to work for me in all cases (using click).

                          > Actually, if you use the mouse, you don't need Shift+F4 because
                          > you're focused in the clip area when you click there.

                          See above.

                          > If it's strictly for your own use & you always use the mouse,
                          > you're safe :)

                          OK, I see your point now - thanks. There is still a difference
                          on machines when clicking in the Library though.

                          C ya,
                          Jody

                          http://www.sureword.com/sojourner
                          http://www.sureword.com/notetab

                          ------------------------------------------------------------------------
                          eGroup home: http://www.eGroups.com/group/ntb-clips
                          http://www.eGroups.com - Simplifying group communications
                        • RS
                          ... Kay was right when she said the above. 1) These work well as far as you use Ctrl+Space to trigger the Clip. They will fail using the mouse: ^!Keyboard
                          Message 12 of 14 , May 6, 1999
                          • 0 Attachment
                            Hi Jody, Kay, Eric, and All:


                            >There's just no reliable way of using a
                            >clip/document toggle in a clip that's going to be
                            >distributed to other people. If it's strictly for your own
                            >use & you always use the mouse, you're safe :)


                            Kay was right when she said the above.

                            1) These work well as far as you use Ctrl+Space to trigger the Clip. They
                            will fail using the mouse:

                            ^!Keyboard Ctrl+G Shift+F4 Shift+F10

                            ^!Keyboard Ctrl+F6 Ctrl+F6 Shift+F10

                            ^!Keyboard Ctrl+G Ctrl+F6 Ctrl+F6 Shift+F10


                            2) On the contrary, the one proposed by Jody works well with the mouse, but
                            not with Ctrl+Space:

                            ^!Keyboard Shift+F4 Shift+F4 Shift+F10


                            Conclusion:
                            Looks like Eric has something to fix here, if possible. Above all when you
                            take into account that the next one, which opens the Clipbook Combo Context
                            Menu, works BOTH with the mouse and with Ctrl+Space:

                            ^!Keyboard Ctrl+G Ctrl+F6 Shift+F10


                            Regards,


                            RS


                            ======================================================

                            Have you ever dreamed of...
                            a Professional Clip Editor for NoteTab?

                            Coming soon:

                            ClipWriter.

                            http://home.att.net/~ptools/main/index.htm




                            ======================================================







                            ======================================================

                            ------------------------------------------------------------------------
                            eGroup home: http://www.eGroups.com/group/ntb-clips
                            http://www.eGroups.com - Simplifying group communications
                          Your message has been successfully submitted and would be delivered to recipients shortly.