Loading ...
Sorry, an error occurred while loading the content.

Re: [Clip] Multiline wizard captions

Expand Messages
  • hsavage
    ... If in a clip wizard, how about, ^!SetWizardWidth xxx ··············································· ¤•
    Message 1 of 7 , May 13, 2013
    • 0 Attachment
      On 5/13/2013 1:51 PM, Axel Berger wrote:
      > hsavage wrote:
      >> Not exactly sure what you mean
      >
      > I'm not surprised, hard as it is to believe, I was not drunk, when I
      > typed that gibberish.
      >
      >> try the NoteTab variables - ^p crlf, or ^%nl% newline variable.
      >
      > Did that, doesn't work, neither of those.
      >
      > Axel

      If in a clip wizard, how about, ^!SetWizardWidth xxx

      ···············································
      ¤• JD#.133 - ¤• SL.1475/@16>24 - 13.05.13~15.19.06

      • Top Things A Wife Won't Say,
      • No, No, I'll Take The Car To Have The Oil Changed.

      € hrs € hsavage € pobox € com
    • Art Kocsis
      ... One does not have to be elderly to be forgetful or to appreciate reminders (nor is the above gibberish). I remember playing around with multi-line wizard
      Message 2 of 7 , May 13, 2013
      • 0 Attachment
        At 5/13/2013 10:54 AM, Axel wrote:
        >Being elderly and forgetful I rely on my captions to remind me, what my
        >wizard fields are for and what to place in them, Of course that may make
        >them longer than usual. I seem to half remember, that someone here maged
        >to insert a line braek into caption, but I forgot how.
        >Can you remind me?
        >Danke

        One does not have to be elderly to be forgetful or to appreciate reminders (nor is the above gibberish).

        I remember playing around with multi-line wizard captions many years ago. Unfortunately, I can't find my notes or test cases. However, I did (re-?) discover that adding a new line variable (^%nl%) will split a caption into two readable lines. Unfortunately it does not increase the line spacing so the text gets a bit crowded (and unreadable for three lines). The same technique splits the wizard label but does not work for the wizard title.

        Your later post says that ^%nl% didn't work for you. Strange. My test clips and links to images of my results follow. Interestingly - NTS v5.8/fv has a larger vertical spacing than NTS v6.2/fv.

        Inserting one ^%nl%:
        ^!SetWizardTitle "Embedding nl in SetWizardTitle ^%nl% Add line1"
        ^!SetWizardLabel "Embedding nl in SetWizardLabel ^%nl% Add line1"
        ^!Set %OpnPF%==^?{(T=A)Single line Wizard prompt text=Yes|}; %x%==^?{(T=A)Embedding nl(s) in Wizard items ^%nl% Add line1=Yes|};

        Inserting two ^%nl%s:
        ^!SetWizardTitle "Embedding nl in SetWizardTitle ^%nl% Add line1 ^%nl% Add line2"
        ^!SetWizardLabel "Embedding nl in SetWizardLabel ^%nl% Add line1 ^%nl% Add line2"
        ^!Set %OpnPF%==^?{(T=A)Single line Wizard prompt text=Yes|}; %x%==^?{(T=A)Embedding nl(s) in Wizard items ^%nl% Add line1 ^%nl% Add line2=Yes|};

        https://googledrive.com/host/0B4wYw6kqKkbiUWVvbXd0TWlQbkU/Multi-line_Wizard_Items-N513_(NTS58fv+1).gif
        https://googledrive.com/host/0B4wYw6kqKkbiUWVvbXd0TWlQbkU/Multi-line_Wizard_Items-N513_(NTS58fv+2).gif
        https://googledrive.com/host/0B4wYw6kqKkbiUWVvbXd0TWlQbkU/Multi-line_Wizard_Items-N513_(NTS62fv+1).gif
        https://googledrive.com/host/0B4wYw6kqKkbiUWVvbXd0TWlQbkU/Multi-line_Wizard_Items-N513_(NTS62fv+2).gif

        Namaste', Art

        My mind is like the subway. If I end up where I'm going,
        it's best if I don't try to understand the system.
        Jef Mallett, 04-21-13
      • Alec Burgess
        Art - all your googledrive links give 404 errors. Maybe a sharing (or lack thereof) problem? ... -- Regards ... Alec (buralex@gmail & WinLiveMess -
        Message 3 of 7 , May 13, 2013
        • 0 Attachment
          Art - all your googledrive links give 404 errors. Maybe a sharing (or
          lack thereof) problem?

          On 2013-05-13 21:39, Art Kocsis wrote:
          > Your later post says that ^%nl% didn't work for you. Strange. My test
          > clips and links to images of my results follow. Interestingly - NTS
          > v5.8/fv has a larger vertical spacing than NTS v6.2/fv.
          >
          > Inserting one ^%nl%:
          > ^!SetWizardTitle "Embedding nl in SetWizardTitle ^%nl% Add line1"
          > ^!SetWizardLabel "Embedding nl in SetWizardLabel ^%nl% Add line1"
          > ^!Set %OpnPF%==^?{(T=A)Single line Wizard prompt text=Yes|};
          > %x%==^?{(T=A)Embedding nl(s) in Wizard items ^%nl% Add line1=Yes|};
          >
          > Inserting two ^%nl%s:
          > ^!SetWizardTitle "Embedding nl in SetWizardTitle ^%nl% Add line1 ^%nl%
          > Add line2"
          > ^!SetWizardLabel "Embedding nl in SetWizardLabel ^%nl% Add line1 ^%nl%
          > Add line2"
          > ^!Set %OpnPF%==^?{(T=A)Single line Wizard prompt text=Yes|};
          > %x%==^?{(T=A)Embedding nl(s) in Wizard items ^%nl% Add line1 ^%nl% Add
          > line2=Yes|};
          >
          > https://googledrive.com/host/0B4wYw6kqKkbiUWVvbXd0TWlQbkU/Multi-line_Wizard_Items-N513_(NTS58fv+1).gif
          > https://googledrive.com/host/0B4wYw6kqKkbiUWVvbXd0TWlQbkU/Multi-line_Wizard_Items-N513_(NTS58fv+2).gif
          > https://googledrive.com/host/0B4wYw6kqKkbiUWVvbXd0TWlQbkU/Multi-line_Wizard_Items-N513_(NTS62fv+1).gif
          > https://googledrive.com/host/0B4wYw6kqKkbiUWVvbXd0TWlQbkU/Multi-line_Wizard_Items-N513_(NTS62fv+2).gif
          >
          > Namaste', Art
          --
          Regards ... Alec (buralex@gmail & WinLiveMess - alec.m.burgess@skype)
        • Axel Berger
          ... Now we ve proof my senility is well advanced, if I ever was that bright to to begin with. The wizard in question, an old one updated many times, had a ?[]
          Message 4 of 7 , May 14, 2013
          • 0 Attachment
            Art Kocsis wrote:
            > Your later post says that ^%nl% didn't work for you. Strange.
            > NTS v5.8/fv has a larger vertical spacing than NTS v6.2/fv.

            Now we've proof my senility is well advanced, if I ever was that bright
            to to begin with. The wizard in question, an old one updated many times,
            had a ?[] wizard instead of a ?{} one, in spite of that multi-field
            ^!Set coming right at the top. So of course nothing inside was
            evaluated. Fixed now, but didn't help. As you noted things get tight and
            while in 5.8 it looks fine, 7.1 totally hides the second line except for
            a few letter tops.

            So it's now ^!SetWizardWidth 110, thanks HSavage. According to help this
            command's scope is not limited, so after that all wizards would have
            been wider. I find now, that this is not the case, so everything's fine.

            Danke
            Axel
          Your message has been successfully submitted and would be delivered to recipients shortly.