Loading ...
Sorry, an error occurred while loading the content.

Bookmark getting lost

Expand Messages
  • flo.gehrke
    Is this a known bookmark issue (NTP only)? Take a list like... Anthony Bertha Carla Anthony Anthony Donald Now tests the following clip against that list:
    Message 1 of 2 , Mar 19, 2013
    • 0 Attachment
      Is this a known bookmark issue (NTP only)?

      Take a list like...

      Anthony
      Bertha
      Carla
      Anthony
      Anthony
      Donald

      Now tests the following clip against that list:

      ^!Jump Doc_Start
      ^!SetBookmark 1
      ^!Replace "^PAnthony" >> "" AS

      The clip will jump to line #1, enter a bookmark, and delete line #4 and #5.

      Though line #1 isn't affected by '^!Replace' (note the '^P' token in the search string) the bookmark in line #1 gets lost. Why this?

      Somehow this seems to be connected with the 'A' option in the replacement. Without 'A', only line #4 will be deleted, and the bookmark in line #1 will be still there.

      You can reproduce that issue also with 'Search | Replace' and a manually set bookmark.

      Flo

      P.S. Please note: I'm not looking for any alternative solution for that replacing. My question is concerning this specific bookmark issue only!
    • loro
      ... Strange. It doesn t need to be the same word as you want to replace either. All bookmarks disappear. I don t know if it s known, but I ve never heard of it
      Message 2 of 2 , Mar 19, 2013
      • 0 Attachment
        Flo write:
        >Is this a known bookmark issue (NTP only)?
        >
        >Take a list like...
        >
        >Anthony
        >Bertha
        >Carla
        >Anthony
        >Anthony
        >Donald
        >
        >Now tests the following clip against that list:
        >
        >^!Jump Doc_Start
        >^!SetBookmark 1
        >^!Replace "^PAnthony" >> "" AS
        >
        >The clip will jump to line #1, enter a bookmark, and delete line #4 and #5.
        >
        >Though line #1 isn't affected by '^!Replace' (note the '^P' token in
        >the search string) the bookmark in line #1 gets lost. Why this?
        >
        >Somehow this seems to be connected with the 'A' option in the
        >replacement. Without 'A', only line #4 will be deleted, and the
        >bookmark in line #1 will be still there.
        >
        >You can reproduce that issue also with 'Search | Replace' and a
        >manually set bookmark.

        Strange. It doesn't need to be the same word as you want to replace
        either. All bookmarks disappear. I don't know if it's known, but I've
        never heard of it and it has probably been around forever. 4.91 is the same.

        Lotta
      Your message has been successfully submitted and would be delivered to recipients shortly.