Loading ...
Sorry, an error occurred while loading the content.

Irregular NoteTab behavior on Win7 x64

Expand Messages
  • Piotr
    Hi, I have a simple clip that loops through a folder of files (opening and closing them without modification), find some information and appends it to a disk
    Message 1 of 4 , Jan 27, 2013
    • 0 Attachment
      Hi,

      I have a simple clip that loops through a folder of files (opening and
      closing them without modification), find some information and appends it to
      a disk file.

      Sometimes the iteration process completes successfully, sometimes it will
      stop for no obvious reason without an error, with a file open or with no
      file open.

      Could it be due to NoteTab running on Win 7 x64?

      I use NoteTab 7.1

      Regards,

      Piotr


      [Non-text portions of this message have been removed]
    • john041650
      ... Perhaps, but I m running NoteTab Pro 7.1 on a Windows 7 64 machine and I haven t noticed any problems like that. You might try inserting a slight delay
      Message 2 of 4 , Jan 28, 2013
      • 0 Attachment
        > Could it be due to NoteTab running on Win 7 x64?

        Perhaps, but I'm running NoteTab Pro 7.1 on a Windows 7 64 machine and I haven't noticed any problems like that.

        You might try inserting a slight delay between each opening/closing of files to see if that solves the problem.

        ^!Delay 5

        john



        --- In ntb-clips@yahoogroups.com, Piotr wrote:
        >
        > Hi,
        >
        > I have a simple clip that loops through a folder of files (opening and
        > closing them without modification), find some information and appends it to
        > a disk file.
        >
        > Sometimes the iteration process completes successfully, sometimes it will
        > stop for no obvious reason without an error, with a file open or with no
        > file open.
        >
        > Could it be due to NoteTab running on Win 7 x64?
        >
        > I use NoteTab 7.1
        >
        > Regards,
        >
        > Piotr
        >
        >
        > [Non-text portions of this message have been removed]
        >
      • Piotr
        You may be right John. The clip is running too fast and, speaking figuratively, falls over its own legs. Piotr ... [Non-text portions of this message have been
        Message 3 of 4 , Jan 30, 2013
        • 0 Attachment
          You may be right John. The clip is running too fast and, speaking
          figuratively, falls over its own legs.

          Piotr


          On Mon, Jan 28, 2013 at 9:27 PM, john041650 <john041650@...> wrote:

          > **
          >
          >
          > > Could it be due to NoteTab running on Win 7 x64?
          >
          > Perhaps, but I'm running NoteTab Pro 7.1 on a Windows 7 64 machine and I
          > haven't noticed any problems like that.
          >
          > You might try inserting a slight delay between each opening/closing of
          > files to see if that solves the problem.
          >
          > ^!Delay 5
          >
          > john
          >
          >
          > --- In ntb-clips@yahoogroups.com, Piotr wrote:
          > >
          > > Hi,
          > >
          > > I have a simple clip that loops through a folder of files (opening and
          > > closing them without modification), find some information and appends it
          > to
          > > a disk file.
          > >
          > > Sometimes the iteration process completes successfully, sometimes it will
          > > stop for no obvious reason without an error, with a file open or with no
          > > file open.
          > >
          > > Could it be due to NoteTab running on Win 7 x64?
          > >
          > > I use NoteTab 7.1
          > >
          > > Regards,
          > >
          > > Piotr
          > >
          > >
          > > [Non-text portions of this message have been removed]
          > >
          >
          >
          >


          [Non-text portions of this message have been removed]
        • Axel Berger
          ... If so, Eric is still having trouble adjusting to Win7. In the higher version Win98, that I use, NT is very good about sequences like ^!Save ^!Dos char w2t
          Message 4 of 4 , Jan 30, 2013
          • 0 Attachment
            Piotr wrote:
            > The clip is running too fast and, speaking figuratively,
            > falls over its own legs.

            If so, Eric is still having trouble adjusting to Win7. In the higher
            version Win98, that I use, NT is very good about sequences like

            ^!Save
            ^!Dos char w2t ^**
            ^!Wait
            ^!Menu Edit/Reload

            and does the required waiting on its own. This is all the more
            remarkable of NT as DOS itself does not do the waiting in batches and I
            have to cater for write cacheing with generously distributed "delay 1"
            myself.
            Where I do need lots of delay is in the workaround for the broken <F3>
            "find again", i.e.

            ^!SaveValue FindDialog:SearchList_1=^%Pattern%
            ^!ProgIniLoad
            ^!Menu Search/Find
            ^!Delay 8
            ^!Keyboard #^%Pattern%#

            I have looped through long lists of ^$GetFileFirst()$ ^$GetFileNext$
            without any delay anywhere, so it must be a Windows issue.
          Your message has been successfully submitted and would be delivered to recipients shortly.