Loading ...
Sorry, an error occurred while loading the content.

Re: [Clip] Re: Find dialog problems

Expand Messages
  • Eric Fookes
    Hi John, What s the code page for your Clip window? Note that this feature hasn t changed since NoteTab 6. So you d probably see the same behavior whether you
    Message 1 of 14 , Aug 3, 2012
    • 0 Attachment
      Hi John,

      What's the code page for your Clip window?

      Note that this feature hasn't changed since NoteTab 6. So you'd probably
      see the same behavior whether you use version 7 or 6.

      On 03/08/2012 14:37, John Shotsky wrote:
      > I should have done a little more testing, because it is now reproducible. I have a working document and I have the clip
      > editor active. When I have the Find dialog open, and my document is active, the dialog has a dropdown arrow and
      > remembered terms. When I click on the '[Clips]' tab, the down arrow vanishes, and that last term remains. As I click
      > back and forth between the document tab and the [clips] tab it repeats with each click. Again, this is new with version
      > 7, I've never seen it before.

      --
      Regards,

      Eric Fookes
      http://www.fookes.com/
    • John Shotsky
      It s code page 1252, for the document, but the problem occurs only when I m looking at the clip library. This isn t a document issue, it is a clip editor
      Message 2 of 14 , Aug 3, 2012
      • 0 Attachment
        It's code page 1252, for the document, but the problem occurs only when I'm looking at the clip library. This isn't a
        document issue, it is a clip editor problem, and it has never happened to me before. I've been using it since 4.95. When
        I look at the code page for the clip library, NoteTab says it is UTF-8. I do have conversion routines in the clip
        library, but the clip library itself isn't UTF-8. If I close NoteTab and open the clip library in EditPad Pro, it says
        the clip library code page is 1252. That is, NoteTab says it is UTF8, but EditPad Pro says it is 1252.

        Regards,
        John
        RecipeTools Web Site: <http://recipetools.gotdns.com/> http://recipetools.gotdns.com/

        From: ntb-clips@yahoogroups.com [mailto:ntb-clips@yahoogroups.com] On Behalf Of Eric Fookes
        Sent: Friday, August 03, 2012 07:54
        To: ntb-clips@yahoogroups.com
        Subject: Re: [Clip] Re: Find dialog problems


        Hi John,

        What's the code page for your Clip window?

        Note that this feature hasn't changed since NoteTab 6. So you'd probably
        see the same behavior whether you use version 7 or 6.

        On 03/08/2012 14:37, John Shotsky wrote:
        > I should have done a little more testing, because it is now reproducible. I have a working document and I have the
        clip
        > editor active. When I have the Find dialog open, and my document is active, the dialog has a dropdown arrow and
        > remembered terms. When I click on the '[Clips]' tab, the down arrow vanishes, and that last term remains. As I click
        > back and forth between the document tab and the [clips] tab it repeats with each click. Again, this is new with
        version
        > 7, I've never seen it before.

        --
        Regards,

        Eric Fookes
        http://www.fookes.com/



        [Non-text portions of this message have been removed]
      • Eric Fookes
        The feature did not exist prior to version 6, so you wouldn t have seen it in version 4.95. The reason why the drop-down menu in the search dialog disappears
        Message 3 of 14 , Aug 3, 2012
        • 0 Attachment
          The feature did not exist prior to version 6, so you wouldn't have seen
          it in version 4.95.

          The reason why the drop-down menu in the search dialog disappears when
          you activate the Clip editor is because it is marked to save extended
          ANSI characters in UTF-8 format (e.g. diacritic characters). Unless you
          tell it otherwise, NoteTab remembers to respect that format even after
          you remove all extended characters. So the fact that EditPad doesn't see
          any is irrelevant.

          Now I have no idea why your Clip editor is set to UTF-8. There are many
          possible reasons for that. Perhaps your Clip library had some UTF-8
          characters in it at one point?

          --
          Regards,

          Eric Fookes
          http://www.fookes.com/


          On 03/08/2012 17:07, John Shotsky wrote:
          > It's code page 1252, for the document, but the problem occurs only when I'm looking at the clip library. This isn't a
          > document issue, it is a clip editor problem, and it has never happened to me before. I've been using it since 4.95. When
          > I look at the code page for the clip library, NoteTab says it is UTF-8. I do have conversion routines in the clip
          > library, but the clip library itself isn't UTF-8. If I close NoteTab and open the clip library in EditPad Pro, it says
          > the clip library code page is 1252. That is, NoteTab says it is UTF8, but EditPad Pro says it is 1252.
          >
          > Regards,
          > John
          > RecipeTools Web Site: <http://recipetools.gotdns.com/> http://recipetools.gotdns.com/
        • John Shotsky
          I thought of that, but then I went through several shipped clip libararies, and they are all marked UTF-8. It doesn t appear to be anything IN my library, it
          Message 4 of 14 , Aug 3, 2012
          • 0 Attachment
            I thought of that, but then I went through several shipped clip libararies, and they are all marked UTF-8. It doesn't
            appear to be anything IN my library, it is just marking all libraries as UTF-8.

            Regards,
            John
            RecipeTools Web Site: <http://recipetools.gotdns.com/> http://recipetools.gotdns.com/

            From: ntb-clips@yahoogroups.com [mailto:ntb-clips@yahoogroups.com] On Behalf Of Eric Fookes
            Sent: Friday, August 03, 2012 08:31
            To: ntb-clips@yahoogroups.com
            Subject: Re: [Clip] Re: Find dialog problems


            The feature did not exist prior to version 6, so you wouldn't have seen
            it in version 4.95.

            The reason why the drop-down menu in the search dialog disappears when
            you activate the Clip editor is because it is marked to save extended
            ANSI characters in UTF-8 format (e.g. diacritic characters). Unless you
            tell it otherwise, NoteTab remembers to respect that format even after
            you remove all extended characters. So the fact that EditPad doesn't see
            any is irrelevant.

            Now I have no idea why your Clip editor is set to UTF-8. There are many
            possible reasons for that. Perhaps your Clip library had some UTF-8
            characters in it at one point?

            --
            Regards,

            Eric Fookes
            http://www.fookes.com/

            On 03/08/2012 17:07, John Shotsky wrote:
            > It's code page 1252, for the document, but the problem occurs only when I'm looking at the clip library. This isn't a
            > document issue, it is a clip editor problem, and it has never happened to me before. I've been using it since 4.95.
            When
            > I look at the code page for the clip library, NoteTab says it is UTF-8. I do have conversion routines in the clip
            > library, but the clip library itself isn't UTF-8. If I close NoteTab and open the clip library in EditPad Pro, it says
            > the clip library code page is 1252. That is, NoteTab says it is UTF8, but EditPad Pro says it is 1252.
            >
            > Regards,
            > John
            > RecipeTools Web Site: <http://recipetools.gotdns.com/> http://recipetools.gotdns.com/



            [Non-text portions of this message have been removed]
          • Axel Berger
            ... How can I see that setting? I know there are some UTF-8 in my clipbook in e.g. ^!Replace ¡ã ° WASTI (it corrects text pasted from journals PDFs)
            Message 5 of 14 , Aug 3, 2012
            • 0 Attachment
              Eric Fookes wrote:
              > the Clip editor is because it is marked to save extended
              > ANSI characters in UTF-8 format (e.g. diacritic characters).

              How can I see that setting? I know there are some UTF-8 in my clipbook
              in e.g.

              ^!Replace "¡ã" >> "°" WASTI

              (it corrects text pasted from journals' PDFs) but I never had John's
              problem, in my find. The status line only tells me "Format.
              DOS/Windows".

              BUG REPORT:
              In testing for this I just noticed again:
              Document --> Font --> Change Font --> Script
              does not really drop down but shows a selection with only two lines. Not
              nice at all having to step through that until you find the desired one.

              Axel
            • flo.gehrke
              ... I can t confirm that this issue is connected with the Clip Editor. I ve tested it with the files in the Samples folder. No matter, if the Clip Editor is
              Message 6 of 14 , Aug 3, 2012
              • 0 Attachment
                --- In ntb-clips@yahoogroups.com, Eric Fookes <egroups@...> wrote:
                >
                > Hi John,
                >
                > What's the code page for your Clip window?


                I can't confirm that this issue is connected with the Clip Editor.

                I've tested it with the files in the '\Samples' folder. No matter, if the Clip Editor is active or not -- in the Find and in the Replace dialog, the History vanishes every time I open a file that is not set to 'System Codepage (1252)' or 'Western European'.

                With cp_Polish.TXT (Codepage 'Central European'), for example, the History is lost again.

                Also, in my view, it's no NT 7.0 issue. I saw a vanishing History also in NT 6.2 (maybe even previous).

                Regards,
                Flo

                OS: Win XP SP3
              • John Shotsky
                I removed my own library from the Libraries folder, with NoteTab closed, and then started NoteTab and began looking at all the shipping libraries. The find
                Message 7 of 14 , Aug 3, 2012
                • 0 Attachment
                  I removed my own library from the Libraries folder, with NoteTab closed, and then started NoteTab and began looking at
                  all the shipping libraries. The find dialog has no dropdown for any of those libraries, as long as the clip editor is
                  the active document. Every one of them is set to UTF-8. If I then start a new document, even with the find dialog still
                  displayed, the dropdown arrow shows immediately, and the history is present.

                  When I look at those (stock) libraries with EditPad Pro, it says they are all code page 1252, which I believe to be
                  true. It also says my own library is CP 1252. I may reinstall to see if that corrects the issue.

                  Regards,
                  John
                  RecipeTools Web Site: <http://recipetools.gotdns.com/> http://recipetools.gotdns.com/

                  From: ntb-clips@yahoogroups.com [mailto:ntb-clips@yahoogroups.com] On Behalf Of flo.gehrke
                  Sent: Friday, August 03, 2012 10:17
                  To: ntb-clips@yahoogroups.com
                  Subject: [Clip] Re: Find dialog problems



                  --- In ntb-clips@yahoogroups.com <mailto:ntb-clips%40yahoogroups.com> , Eric Fookes <egroups@...> wrote:
                  >
                  > Hi John,
                  >
                  > What's the code page for your Clip window?

                  I can't confirm that this issue is connected with the Clip Editor.

                  I've tested it with the files in the '\Samples' folder. No matter, if the Clip Editor is active or not -- in the Find
                  and in the Replace dialog, the History vanishes every time I open a file that is not set to 'System Codepage (1252)' or
                  'Western European'.

                  With cp_Polish.TXT (Codepage 'Central European'), for example, the History is lost again.

                  Also, in my view, it's no NT 7.0 issue. I saw a vanishing History also in NT 6.2 (maybe even previous).

                  Regards,
                  Flo

                  OS: Win XP SP3



                  [Non-text portions of this message have been removed]
                • John Shotsky
                  The reinstall fixed this problem. I copied my library and the .ini file over to the new installation, and all is as it should be. I will report if it happens
                  Message 8 of 14 , Aug 3, 2012
                  • 0 Attachment
                    The reinstall fixed this problem. I copied my library and the .ini file over to the new installation, and all is as it
                    should be. I will report if it happens again.

                    Regards,
                    John
                    RecipeTools Web Site: http://recipetools.gotdns.com/


                    -----Original Message-----
                    From: ntb-clips@yahoogroups.com [mailto:ntb-clips@yahoogroups.com] On Behalf Of John Shotsky
                    Sent: Friday, August 03, 2012 10:43
                    To: ntb-clips@yahoogroups.com
                    Subject: RE: [Clip] Re: Find dialog problems

                    I removed my own library from the Libraries folder, with NoteTab closed, and then started NoteTab and began looking at
                    all the shipping libraries. The find dialog has no dropdown for any of those libraries, as long as the clip editor is
                    the active document. Every one of them is set to UTF-8. If I then start a new document, even with the find dialog still
                    displayed, the dropdown arrow shows immediately, and the history is present.

                    When I look at those (stock) libraries with EditPad Pro, it says they are all code page 1252, which I believe to be
                    true. It also says my own library is CP 1252. I may reinstall to see if that corrects the issue.

                    Regards,
                    John
                    RecipeTools Web Site: <http://recipetools.gotdns.com/> http://recipetools.gotdns.com/

                    From: ntb-clips@yahoogroups.com [mailto:ntb-clips@yahoogroups.com] On Behalf Of flo.gehrke
                    Sent: Friday, August 03, 2012 10:17
                    To: ntb-clips@yahoogroups.com
                    Subject: [Clip] Re: Find dialog problems



                    --- In ntb-clips@yahoogroups.com <mailto:ntb-clips%40yahoogroups.com> , Eric Fookes <egroups@...> wrote:
                    >
                    > Hi John,
                    >
                    > What's the code page for your Clip window?

                    I can't confirm that this issue is connected with the Clip Editor.

                    I've tested it with the files in the '\Samples' folder. No matter, if the Clip Editor is active or not -- in the Find
                    and in the Replace dialog, the History vanishes every time I open a file that is not set to 'System Codepage (1252)' or
                    'Western European'.

                    With cp_Polish.TXT (Codepage 'Central European'), for example, the History is lost again.

                    Also, in my view, it's no NT 7.0 issue. I saw a vanishing History also in NT 6.2 (maybe even previous).

                    Regards,
                    Flo

                    OS: Win XP SP3



                    [Non-text portions of this message have been removed]



                    ------------------------------------

                    Fookes Software: http://www.fookes.com/
                    NoteTab website: http://www.notetab.com/
                    NoteTab Discussion Lists: http://www.notetab.com/groups.php

                    ***
                    Yahoo! Groups Links
                  Your message has been successfully submitted and would be delivered to recipients shortly.