Loading ...
Sorry, an error occurred while loading the content.
 

Re: [Clip] Tab settings lost after sort

Expand Messages
  • Art Kocsis
    To answer your question you need to post your code. A possible workaround to try: force a reload of the NTB s ini file using ^!SetIniFile. If NTB is smart
    Message 1 of 12 , Feb 17, 2012
      To answer your question you need to post your code.

      A possible workaround to try: force a reload of the NTB's ini file using
      ^!SetIniFile.
      If NTB is smart enough to know that it is already loaded, set it to a dummy
      and then reset it back to the original:

      ^!Set %usrini%=^$GetIniFile$
      ^!SetIniFile <dummy_ini_file>.ini
      ^!SetIniFile ^%usrini%

      Art

      At 2/16/2012 07:04 PM, Joy wrote:
      >NT Light ver 6.2 Windows 7
      >I can't find any posts on a little problem I'm having in a clip in which
      >doing a sort from the menu causes the document to be redisplayed without
      >the tab settings applied.
      >
      >What's worse, if you go to doc properties where the (correct) settings
      >still show, the only way I can find to have the tab settings take effect
      >(again) is to make a change to the existing tab settings.
      >
      >Is this a bug and can everyone reproduce this?
    • jeff
      ... I have always had to use the toolbar and load document default tab settings (After changing them in settings). When I look at tabulated text I like to
      Message 2 of 12 , Feb 17, 2012
        On 2/17/2012 1:02 AM, Art Kocsis wrote:
        >
        > To answer your question you need to post your code.
        >
        > A possible workaround to try: force a reload of the NTB's ini file using
        > ^!SetIniFile.
        > If NTB is smart enough to know that it is already loaded, set it to a
        > dummy
        > and then reset it back to the original:
        >
        > ^!Set %usrini%=^$GetIniFile$
        > ^!SetIniFile <dummy_ini_file>.ini
        > ^!SetIniFile ^%usrini%
        >
        > Art
        >
        > At 2/16/2012 07:04 PM, Joy wrote:
        > >NT Light ver 6.2 Windows 7
        > >I can't find any posts on a little problem I'm having in a clip in which
        > >doing a sort from the menu causes the document to be redisplayed without
        > >the tab settings applied.
        > >
        > >What's worse, if you go to doc properties where the (correct) settings
        > >still show, the only way I can find to have the tab settings take effect
        > >(again) is to make a change to the existing tab settings.
        > >
        > >Is this a bug and can everyone reproduce this?
        >

        I have always had to use the toolbar and load document default tab
        settings (After changing them in settings). When I look at tabulated
        text I like to see the columns line up so I set tabs at 25 spaces.


        [Non-text portions of this message have been removed]
      • paulmaser
        After copying two lines into a variable, I would like to parse the variable by line into two variables. Is it possible to parse a variable using at the line
        Message 3 of 12 , Feb 18, 2012
          After copying two lines into a variable, I would like to parse the variable by line into two variables. Is it possible to parse a variable using at the line feed?
        • Axel Berger
          ... ^!Set %lines%= First line here^%NL%Second line there ^!SetListDelimiter ^P ^!SetArray %alines%= ^%lines% ^!Set %firstline%=^%alines1% ^!Set
          Message 4 of 12 , Feb 18, 2012
            paulmaser wrote:
            > After copying two lines into a variable, I would like to parse
            > the variable by line into two variables. Is it possible to parse
            > a variable using at the line feed?

            ---------------------------------------------------------------
            ^!Set %lines%="First line here^%NL%Second line there"
            ^!SetListDelimiter ^P
            ^!SetArray %alines%="^%lines%"
            ^!Set %firstline%=^%alines1%
            ^!Set %secondline%=^%alines2%
            ^!Continue ^%firstline% ^%secondline%
            ---------------------------------------------------------------


            You could do away with the array by looping
            ^$StrPos("SubStr";"Str";CaseSensitive)$
            ^$StrCopyLeft("Str";Amount)$ (added in v4.82)
            ^$StrDeleteLeft("Str";Amount)$ (added in v4.82)


            Axel

            --
            Dipl.-Ing. F. Axel Berger Tel: +49/ 2174/ 7439 07
            Johann-Häck-Str. 14 Fax: +49/ 2174/ 7439 68
            D-51519 Odenthal-Heide eMail: Axel-Berger@...
            Deutschland (Germany) http://berger-odenthal.de
          • Eb
            As usual, there is more than one way to solve a problem. When you copy the two lines into a variable, make that variable a EOL delimited array:
            Message 5 of 12 , Feb 18, 2012
              As usual, there is more than one way to solve a problem.

              When you copy the two lines into a variable, make that variable a EOL delimited array:

              ^!SetListDelimiter ^%nl%
              ^!SetArray %bothlines%=^$GetSelection$

              The array automatically has split the lines at the EOL (end of Line).
              So assign the individual array elements to the target variables,
              ---OR--- just use the array elements directly for whatever your goal is:

              ^!Set %lineone%=^%bothlines1%
              ^!Set %linetwo%=^%bothlines2%

              ---or---

              ^!(Process) ^%bothlines1%
              ^!(Process) ^%bothlines2%


              Either solution will also tackle more than two lines, as long as you keep track of which line is which.

              Read up on variables in Help with clip code, "Variables"

              Cheers

              Eb


              --- In ntb-clips@yahoogroups.com, "paulmaser" <paul@...> wrote:
              >
              > After copying two lines into a variable, I would like to parse the variable by line into two variables. Is it possible to parse a variable using at the line feed?
              >
            • paulmaser
              Axel and Eb; Thanks for the help. It has been awhile since I used arrays, but this is a great way to solve the problem. Also the use of ^$StrPos was
              Message 6 of 12 , Feb 18, 2012
                Axel and Eb;
                Thanks for the help.
                It has been awhile since I used arrays, but this is a great way to solve the problem. Also the use of "^$StrPos" was something I never knew, though I spent a some time in the clip help files before posting.
                Thanks again;
                Paul
              • joy8388608
                Sorry, but I am not seeing anything that applies to my question here. Is it in any way possible that you help me understand and explain it? Thanks, Joy
                Message 7 of 12 , Feb 20, 2012
                  Sorry, but I am not seeing anything that applies to my question here.
                  Is it in any way possible that you help me understand and explain it?
                  Thanks,
                  Joy

                  --- In ntb-clips@yahoogroups.com, Gerard Huijing <inboxgen@...> wrote:
                  >
                  > Is it in any way possible that the 'IMPORTANT' notice for NTB Std and
                  > Lite users
                  > menu View | Options | Documents -> Click on Help button in this tab
                  > is relevant to you problem?
                  >
                  > Cheers,
                  > Gerard
                  >
                  >
                  >
                  > On 17-2-2012 4:04, joy8388608 wrote:
                  > > NT Light ver 6.2 Windows 7
                  > >
                  > > I can't find any posts on a little problem I'm having in a clip in which
                  > > doing a sort from the menu causes the document to be redisplayed without
                  > > the tab settings applied.
                  > >
                  > > What's worse, if you go to doc properties where the (correct) settings
                  > > still show, the only way I can find to have the tab settings take effect
                  > > (again) is to make a change to the existing tab settings.
                  > >
                  > > Is this a bug and can everyone reproduce this?
                  > >
                  > > Joy
                  >
                  >
                  > --
                  > Gerard (E.G.P.) Huijing
                  > 2312 ZD Leiden
                  > Netherlands
                  > inboxgen@...
                  >
                • joy8388608
                  Sure. My clip code is ^!ToolBar Sort Ascending but the same thing happens manually from the toolbar. I tried your code but it did nothing. It doesn t seem
                  Message 8 of 12 , Feb 20, 2012
                    Sure. My clip code is
                    ^!ToolBar Sort Ascending

                    but the same thing happens manually from the toolbar.

                    I tried your code but it did nothing.

                    It doesn't seem right that just doing a sort would cause the newly sorted lines to suddenly display without regard for the currently set tabs.

                    Another note which is surprising but may or may not be called a bug is that changing the tab settings does not make the document 'unsaved'

                    Joy



                    --- In ntb-clips@yahoogroups.com, Art Kocsis <artkns@...> wrote:
                    >
                    > To answer your question you need to post your code.
                    >
                    > A possible workaround to try: force a reload of the NTB's ini file using
                    > ^!SetIniFile.
                    > If NTB is smart enough to know that it is already loaded, set it to a dummy
                    > and then reset it back to the original:
                    >
                    > ^!Set %usrini%=^$GetIniFile$
                    > ^!SetIniFile <dummy_ini_file>.ini
                    > ^!SetIniFile ^%usrini%
                    >
                    > Art
                    >
                    > At 2/16/2012 07:04 PM, Joy wrote:
                    > >NT Light ver 6.2 Windows 7
                    > >I can't find any posts on a little problem I'm having in a clip in which
                    > >doing a sort from the menu causes the document to be redisplayed without
                    > >the tab settings applied.
                    > >
                    > >What's worse, if you go to doc properties where the (correct) settings
                    > >still show, the only way I can find to have the tab settings take effect
                    > >(again) is to make a change to the existing tab settings.
                    > >
                    > >Is this a bug and can everyone reproduce this?
                    >
                  • jeff
                    ... The Tab spacing is a system setting for notetab, a Tab is a Tab Is a Tab. The setting is not a change to the document but a change to the display
                    Message 9 of 12 , Feb 20, 2012
                      On 2/20/2012 12:08 PM, joy8388608 wrote:
                      > Another note which is surprising but may or may not be called a bug is
                      > that changing the tab settings does not make the document 'unsaved'
                      >
                      > Joy
                      The Tab spacing is a system setting for notetab, a Tab is a Tab Is a
                      Tab. The setting is not a change to the document but a change to the
                      display properties ONLY

                      --

                      __

                      Jeffery G. Scism, IBSSG

                      Due to increased JUNK emails at a rate of over 300 per hour, I am filtering all suspected JUNK/Spam directly to DELETE.


                      http://ibssg.org/blacksheep/
                    • Gerard Huijing
                      ... The Help file on Document Properties gives two ´important´ (all caps) caveats for Std and Lite users regarding changing some of those properties and how
                      Message 10 of 12 , Feb 21, 2012
                        On 20-2-2012 20:57, joy8388608 wrote:
                        > Sorry, but I am not seeing anything that applies to my question here.
                        > Is it in any way possible that you help me understand and explain it?


                        The Help file on Document Properties gives two ´important´ (all caps)
                        caveats for Std and Lite users regarding changing some of those
                        properties and how these changes are updated.
                        In the Std and Light versions of NTB one has to do something extra, as
                        compared to NTB Pro.
                        I thought that this might have some bearing on how one processes a file
                        in a clip.

                        I apologise if I lead you up the garden path, but my question was just a
                        question.


                        Cheers,
                        Gerard









                        > Thanks,
                        > Joy
                        >
                        > --- In ntb-clips@yahoogroups.com <mailto:ntb-clips%40yahoogroups.com>,
                        > Gerard Huijing <inboxgen@...> wrote:
                        > >
                        > > Is it in any way possible that the 'IMPORTANT' notice for NTB Std and
                        > > Lite users
                        > > menu View | Options | Documents -> Click on Help button in this tab
                        > > is relevant to you problem?
                        > >
                        > > Cheers,
                        > > Gerard
                        > >
                        > >
                        > >
                        > > On 17-2-2012 4:04, joy8388608 wrote:
                        > > > NT Light ver 6.2 Windows 7
                        > > >
                        > > > I can't find any posts on a little problem I'm having in a clip in
                        > which
                        > > > doing a sort from the menu causes the document to be redisplayed
                        > without
                        > > > the tab settings applied.
                        > > >
                        > > > What's worse, if you go to doc properties where the (correct) settings
                        > > > still show, the only way I can find to have the tab settings take
                        > effect
                        > > > (again) is to make a change to the existing tab settings.
                        > > >
                        > > > Is this a bug and can everyone reproduce this?
                        > > >
                        > > > Joy
                        > >
                        > >
                        > > --
                        > > Gerard (E.G.P.) Huijing
                        > > 2312 ZD Leiden
                        > > Netherlands
                        > > inboxgen@...
                        > >
                        >
                        >

                        --
                        Gerard (E.G.P.) Huijing
                        2312 ZD Leiden
                        Netherlands
                        inboxgen@...
                      Your message has been successfully submitted and would be delivered to recipients shortly.