Loading ...
Sorry, an error occurred while loading the content.

Square brackets in clips

Expand Messages
  • barlennan
    Hello; Beginner here, please bear with me. I m trying to write a few clips as helpers for posting in an SMF forum, which uses html-like syntax but with square
    Message 1 of 6 , Aug 6, 2009
    • 0 Attachment
      Hello;

      Beginner here, please bear with me. I'm trying to write a few clips as helpers for posting in an SMF forum, which uses html-like syntax but with square brackets not angle brackets. I'm having problems.

      This works:

      (1)
      URL
      [url=^?[URL]]^?[Web page name][/url]

      Even pops up the dialogue to ask for the details. But these *don't* work:

      (2)
      ;Bold
      [b]^&[/b]

      (3)
      ;3-element list
      [list]
      [li][/li]
      [li][/li]
      [li][/li]
      [/list]

      Yet this does:

      (4)
      test
      <b>^&</b>

      and the only difference I see between (2) and (4) is the type of brackets. Do square brackets in a clip need to be escaped somehow? If they do, why does (1) work?

      --
      TIA,

      Robert Bull
    • loro
      ... They do for me... Peculiar. Lotta
      Message 2 of 6 , Aug 6, 2009
      • 0 Attachment
        barlennan wrote:
        >But these *don't* work:
        >
        >(2)
        >;Bold
        >[b]^&[/b]
        >
        >(3)
        >;3-element list
        >[list]
        >[li][/li]
        >[li][/li]
        >[li][/li]
        >[/list]

        They do for me... Peculiar.

        Lotta
      • barlennan
        ... Indeed :( I should have added, the ones that don t work pop up an information box showing the clip as plain text. Clicking on the box s [OK] button
        Message 3 of 6 , Aug 7, 2009
        • 0 Attachment
          --- In ntb-clips@yahoogroups.com, loro <tabbie@...> wrote:
          >
          > They do for me... Peculiar.

          Indeed :(

          I should have added, the ones that don't work pop up an information box showing the clip as plain text. Clicking on the box's [OK] button dismisses the box, and nothing else happens.

          I'm using NoteTab Pro 6.12/fv (Full version) on Windows XP [Version 5.1.2600].
        • loro
          ... Could you open the library as a document (right-click in combo box and choose Open as Document ) and copy a bit of it containing at least one non working
          Message 4 of 6 , Aug 7, 2009
          • 0 Attachment
            barlennan wrote:
            >I should have added, the ones that don't work pop up an information
            >box showing the clip as plain text. Clicking on the box's [OK]
            >button dismisses the box, and nothing else happens.

            Could you open the library as a document (right-click in combo box
            and choose "Open as Document") and copy a bit of it containing at
            least one non working clip, headings and all?

            Lotta
          • Stephen Riddle
            Be sure to save the clip after editing. Makes a big difference.
            Message 5 of 6 , Aug 7, 2009
            • 0 Attachment
              Be sure to save the clip after editing. Makes a big difference.
            • barlennan
              ... FOUND IT... I d been putting semicolons in the headers of most of the clips that didn t work, turning them into headers rather than active clips!
              Message 6 of 6 , Aug 10, 2009
              • 0 Attachment
                --- In ntb-clips@yahoogroups.com, loro <tabbie@...> wrote:
                > Could you open the library as a document (right-click in combo box
                > and choose "Open as Document") and copy a bit of it containing at
                > least one non working clip, headings and all?

                FOUND IT... I'd been putting semicolons in the headers of most of the clips that "didn't work," turning them into headers rather than active clips! Getting things the right way round improved things :)

                Thanks for your patience!

                --
                Robert Bull
              Your message has been successfully submitted and would be delivered to recipients shortly.