Loading ...
Sorry, an error occurred while loading the content.

Re: [Clip] keyboard in odd character?

Expand Messages
  • Art Kocsis
    Is this what you want? ^!SetClipboard • ^!Set %address2%= ^%the_data6% ^%the_data7% ^%the_data8%^%NL% ^!Keyboard #^%address%# CTRL+V #^%address2%# Art
    Message 1 of 10 , Jun 11, 2008
    • 0 Attachment
      Is this what you want?

      ^!SetClipboard •
      ^!Set %address2%="^%the_data6% ^%the_data7% ^%the_data8%^%NL%"
      ^!Keyboard #^%address%# CTRL+V #^%address2%#

      Art

      At 6/11/2008 07:24 AM, you wrote:
      >I need a dot in data I am entering.
      >
      >I am using this character >•< which should appear as a >dot< perhaps.
      >
      >I use these lines in my clip:
      >^!Set %address%="^%address%•^%the_data6% ^%the_data7% ^%the_data8%"
      >^!Keyboard #^%address%#
      >
      >The Dot disappears (you should see it between ^%address% and ^%the_data6%.
      >
      >I am having this keyboarded into a form on a web page.
      >
      >Thanks,
      >
      >Don
    • Don - HtmlFixIt.com
      ... Hi Art, That does achieve the desired result, but I am hoping for a direct entry method. While this solves this issue what if I had two such characters to
      Message 2 of 10 , Jun 11, 2008
      • 0 Attachment
        Art Kocsis wrote:
        > Is this what you want?
        >
        > ^!SetClipboard •
        > ^!Set %address2%="^%the_data6% ^%the_data7% ^%the_data8%^%NL%"
        > ^!Keyboard #^%address%# CTRL+V #^%address2%#
        >
        Hi Art,

        That does achieve the desired result, but I am hoping for a direct entry
        method. While this solves this issue what if I had two such characters
        to insert in the string?

        Don
      • Art Kocsis
        Either it is a bug or by design, NoteTab does not appear to support extended characters (above 80 hex or 128 decimal), in (at least), the ^!Set and ^!Keyboard
        Message 3 of 10 , Jun 11, 2008
        • 0 Attachment
          Either it is a bug or by design, NoteTab does not appear to support
          extended characters (above 80 hex or 128 decimal), in (at least),
          the ^!Set and ^!Keyboard commands. So just extend what I gave
          you before. Multiple ^!Keyboard output strings are concatenated
          until terminated. Play with this work around:

          ^!SetClipboard •
          ^!Keyboard #test8:# #string1# $20 CTRL+V $20 #string2#
          ^!SetClipboard ^$DecToChar(151)$
          ^!Keyboard $22 CTRL+V $22 #string3#
          ^!SetClipboard ^$DecToChar(167)$
          ^!Keyboard $20 CTRL+V $20 #string4#
          ^!SetClipboard ^$DecToChar(169)$
          ^!Keyboard $22 CTRL+V $22 #string5# #^%NL%# #^%NL%#

          Art

          At 6/11/2008 04:56 PM, you wrote:
          >Art Kocsis wrote:
          > > Is this what you want?
          > >
          > > ^!SetClipboard •
          > > ^!Set %address2%="^%the_data6% ^%the_data7% ^%the_data8%^%NL%"
          > > ^!Keyboard #^%address%# CTRL+V #^%address2%#
          > >
          >Hi Art,
          >
          >That does achieve the desired result, but I am hoping for a direct entry
          >method. While this solves this issue what if I had two such characters
          >to insert in the string?
          >
          >Don
        • Don - HtmlFixIt.com
          ... It seems that maybe notetab should support the extended characters. I wonder why not. Thanks Art for figuring that out. Help also should mention the
          Message 4 of 10 , Jun 12, 2008
          • 0 Attachment
            Art Kocsis wrote:
            > Either it is a bug or by design, NoteTab does not appear to support
            > extended characters (above 80 hex or 128 decimal), in (at least),
            > the ^!Set and ^!Keyboard commands. So just extend what I gave
            > you before. Multiple ^!Keyboard output strings are concatenated
            > until terminated. Play with this work around:
            >
            > ^!SetClipboard •
            > ^!Keyboard #test8:# #string1# $20 CTRL+V $20 #string2#
            > ^!SetClipboard ^$DecToChar(151)$
            > ^!Keyboard $22 CTRL+V $22 #string3#
            > ^!SetClipboard ^$DecToChar(167)$
            > ^!Keyboard $20 CTRL+V $20 #string4#
            > ^!SetClipboard ^$DecToChar(169)$
            > ^!Keyboard $22 CTRL+V $22 #string5# #^%NL%# #^%NL%#
            >
            > Art

            It seems that maybe notetab should support the extended characters. I
            wonder why not. Thanks Art for figuring that out. Help also should
            mention the limitation it seems to me. Maybe this can either be fixed
            or mentioned in the newest version 5.7 that will be released some day soon.
          • hsavage
            ... ^%the_data6%. ... Don, The sample clip below should solve your problem with a few changes to the way you setup your variables. ^!ClipBoardSave and
            Message 5 of 10 , Jun 12, 2008
            • 0 Attachment
              Don - HtmlFixIt.com wrote:
              > I need a dot in data I am entering.
              >
              > I am using this character >•< which should appear as a >dot< perhaps.
              >
              > I use these lines in my clip:
              > ^!Set %address%="^%address%•^%the_data6% ^%the_data7% ^%the_data8%"
              > ^!Keyboard #^%address%#
              >
              > The Dot disappears (you should see it between ^%address% and
              ^%the_data6%.
              >
              > I am having this keyboarded into a form on a web page.
              >
              > Thanks,
              >
              > Don

              Don,

              The sample clip below should solve your problem with a few changes to
              the way you setup your variables.

              ^!ClipBoardSave and ^!ClipBoardRestore +, work great, a sample clip is
              included to demonstrate the use of the commands.

              ^!ClipBoardSave (added in v4.6)
              Saves the Clipboard contents (any type of data) in NoteTab's internal
              memory. This command is to be used in conjunction with
              ^!ClipBoardRestore. It is particularly useful when you want to use the
              Clipboard for temporary storage without permanently removing what the
              user may have initially stored in it.

              ^!ClipBoardRestore [+] (added in v4.6)
              Restore the contents of clipboard saved through the ^!ClipBoardSave
              command. Use the optional "+" parameter if you want NoteTab to keep the
              saved Clipboard data in its internal memory (lets you restore it again
              at a later stage).

              ----------------------------
              h=bullet
              ; Save the bullet to clipboard in this manner at beginning of clip.
              ^!SetClipboard •
              ^!ClipBoardSave

              ^!SetClipboard XXXXX

              ^!Set %address%="40 Golf Course Road"; %the_data6%="THE DATA6";
              %the_data7%="THE DATA7"; %the_data8%="THE DATA8"

              ; For each subsequent use of bullet preface each ^!KeyBoard command with
              ^!ClipBoardRestore +
              ; only necessary if you've copied some else to the clipboard in the interim.
              ; the ^!SetClipboard command for XXXXX and YYYYY are there for demo
              purposes only.

              ^!ClipBoardRestore +
              ^!Keyboard #^%address%# $20 Ctrl+V $20 #^%the_data6%# $20 #^%the_data7%#
              $20 #^%the_data8%# ENTER

              ^!SetClipboard YYYYY

              ^!ClipBoardRestore +
              ^!Keyboard #WORD# $20 CTRL+V $20 #WORD# ENTER ENTER
              --------------------------


              ·············································
              ºvº SL_164 created_2008.06.12_20.20.07

              Newspaper HeadLine...
              • Some Pieces of Rock Hudson Sold at Auction
              € hrs € hsavage € pobox € com
            Your message has been successfully submitted and would be delivered to recipients shortly.