Loading ...
Sorry, an error occurred while loading the content.

[Clip] Replace Using ^$GetField(...)$

Expand Messages
  • Jody
    Hi All, I can force this Clip to work by selecting a number just for the example. Why won t the replace work? The numbers all look good in the info box with
    Message 1 of 1 , Oct 31, 1999
    • 0 Attachment
      Hi All,

      I can force this Clip to work by selecting a number just for the
      example. Why won't the replace work? The numbers all look good
      in the info box with the defaults I have set. There is some test
      text below it that had real tabs in it before I sent it. Place
      your cursor on any line you want to start at. Thanks! Nite...
      OH, Gopal - thanks for the link update. Uplaoded the change to
      my site with their home page and about 10 alt sites. <g> Also
      put two know libraries up. I'll explain them sometime. ;)

      So, is this a bug, or one of those NoteTab does the figuring
      first things?

      H=Reorder Numbers...
      ^!Set %n%=^$GetRow$; %StartInc%=^?[Start numbering at=5]; %StopInc%=^?[Stop at=7]; %Field%=^?[Do field number=2]
      ^!SetDelimiter ^?[Enter Delimiter: ^p ^t ";", Tab shown=^t]

      :Loop
      ^!Replace "^$GetField(^%n%;^%Field%)$" >> "^%StartInc%" S
      ^!Select -1
      ^!Info Replace "^$GetField(^%n%;^%Field%)$" with "^%StartInc%"
      ^!InsertText ^%StartInc%
      ^!If ^%StartInc% = ^%StopInc% End
      ^!Inc %n%
      ^!Inc %StartInc%
      ^!Goto Loop

      1 1
      2 2
      3 3
      4 4
      5 5
      6 6
      7 7

      Thanks!
      Jody

      Clean-Funnies: click and send...
      mailto:CF@...?subject=Subscribe
    Your message has been successfully submitted and would be delivered to recipients shortly.