Loading ...
Sorry, an error occurred while loading the content.

NTP4 clip no longer works in NTP5

Expand Messages
  • Jelks Cabaniss
    I have a clip called Quote Reformat to reformat email-quoted text. I used it all the time in version 4, but it no longer works in version 5. Here s the
    Message 1 of 16 , Aug 5, 2006
    • 0 Attachment
      I have a clip called "Quote Reformat" to reformat email-quoted text.
      I used it all the time in version 4, but it no longer works in version
      5. Here's the clip:

      ^!If ^$GetSelSize$ > 0 Skip
      ^!Select ALL
      ^!Keyboard CTRL+SHIFT+Q
      ^!Keyboard CTRL+SHIFT+M #0# TAB #60# TAB ENTER
      ^!Keyboard CTRL+Q

      What's happened the "Reformat Lines" dialog (line #4 above) is no
      longer "automated". Instead, it replaces the selection with a literal
      "0 TAB 60", and THEN gives me the "Reformat Lines" dialog. I even
      added a delay in that line like so:

      ^!Keyboard CTRL+SHIFT+M &1000 #0# TAB #60# TAB ENTER

      but to no avail.

      Any ideas?

      Thanks in advance.

      /Jelks
    • Sheri
      Hi Jelks, I m not sure what s going on with that but fortunately you can still accomplish your Quote Reformat task like this: ^!If ^$GetSelSize$ 0 Skip
      Message 2 of 16 , Aug 5, 2006
      • 0 Attachment
        Hi Jelks,

        I'm not sure what's going on with that but fortunately you can still
        accomplish your Quote Reformat task like this:

        ^!If ^$GetSelSize$ > 0 Skip
        ^!Select ALL
        ^!Menu Modify/E-mail/Unquote Text
        ^$StrFormat("^$GetSelection$";0;60;No)$
        ;end of clip

        Regards,
        Sheri

        --- In ntb-clips@yahoogroups.com, "Jelks Cabaniss"
        <jelkscabaniss@...> wrote:
        >
        I have a clip called "Quote Reformat" to reformat email-
        quoted text. I used it all the time in version 4, but it no
        longer works in version 5. Here's the clip:

        ^!If ^$GetSelSize$ > 0 Skip
        ^!Select ALL
        ^!Keyboard CTRL+SHIFT+Q
        ^!Keyboard CTRL+SHIFT+M #0# TAB #60# TAB ENTER
        ^!Keyboard CTRL+Q

        What's happened the "Reformat Lines" dialog (line #4 above)
        is no longer "automated". Instead, it replaces the
        selection with a literal "0 TAB 60", and THEN gives me the
        "Reformat Lines" dialog. I even added a delay in that line
        like so:

        ^!Keyboard CTRL+SHIFT+M &1000 #0# TAB #60# TAB ENTER

        but to no avail.

        Any ideas?

        Thanks in advance.

        /Jelks
      • Jelks Cabaniss
        Thank you, Sheri. First, let me just tell you I got my original code working. Well *almost* working -- I had to put that delay in I spoke of. But with that
        Message 3 of 16 , Aug 5, 2006
        • 0 Attachment
          Thank you, Sheri.

          First, let me just tell you I got my original code working. Well
          *almost* working -- I had to put that delay in I spoke of. But with
          that modification it does work. But here's the really weird part: it
          only runs if I double-click the clip from the clipbook pane. If I run
          it from the button it's been assigned to on the clipbar, it does as I
          earlier described! ??? How can that possibly be? Yes, I've
          double-checked to make sure the button points to that clip, but it
          fails on clicking the button and yet works when double-clicking the
          clip itself. Too strange.

          I did try your version, but it didn't quite work. For one, it needs
          to "requote" at the end of the clip (which is why mine has the
          ^!Keyboard CTRL+Q at the end). So I added that, but only the last
          line of the original selection ended up being quoted.

          Again, though, my old clip now works with an &50 delay added -- but it
          only works from the clipbook pane! :)

          /Jelks


          --- In ntb-clips@yahoogroups.com, "Sheri" <silvermoonwoman@...> wrote:
          >
          > Hi Jelks,
          >
          > I'm not sure what's going on with that but fortunately you can still
          > accomplish your Quote Reformat task like this:
          >
          > ^!If ^$GetSelSize$ > 0 Skip
          > ^!Select ALL
          > ^!Menu Modify/E-mail/Unquote Text
          > ^$StrFormat("^$GetSelection$";0;60;No)$
          > ;end of clip
          >
          > Regards,
          > Sheri
          >
          > --- In ntb-clips@yahoogroups.com, "Jelks Cabaniss"
          > <jelkscabaniss@> wrote:
          > >
          > I have a clip called "Quote Reformat" to reformat email-
          > quoted text. I used it all the time in version 4, but it no
          > longer works in version 5. Here's the clip:
          >
          > ^!If ^$GetSelSize$ > 0 Skip
          > ^!Select ALL
          > ^!Keyboard CTRL+SHIFT+Q
          > ^!Keyboard CTRL+SHIFT+M #0# TAB #60# TAB ENTER
          > ^!Keyboard CTRL+Q
          >
          > What's happened the "Reformat Lines" dialog (line #4 above)
          > is no longer "automated". Instead, it replaces the
          > selection with a literal "0 TAB 60", and THEN gives me the
          > "Reformat Lines" dialog. I even added a delay in that line
          > like so:
          >
          > ^!Keyboard CTRL+SHIFT+M &1000 #0# TAB #60# TAB ENTER
          >
          > but to no avail.
          >
          > Any ideas?
          >
          > Thanks in advance.
          >
          > /Jelks
          >
        • Jeff Scism
          Tried a ^!KEYBOARD CTRL+A CTRL+Q ? ~~ Jeffery Scism, USGenWeb Project Local Coordinator Rep NC/NE region
          Message 4 of 16 , Aug 6, 2006
          • 0 Attachment
            Tried a ^!KEYBOARD CTRL+A CTRL+Q ?

            ~~

            Jeffery Scism,
            USGenWeb Project Local Coordinator Rep
            NC/NE region




            Jelks Cabaniss wrote:

            >Thank you, Sheri.
            >
            >First, let me just tell you I got my original code working. Well
            >*almost* working -- I had to put that delay in I spoke of. But with
            >that modification it does work. But here's the really weird part: it
            >only runs if I double-click the clip from the clipbook pane. If I run
            >it from the button it's been assigned to on the clipbar, it does as I
            >earlier described! ??? How can that possibly be? Yes, I've
            >double-checked to make sure the button points to that clip, but it
            >fails on clicking the button and yet works when double-clicking the
            >clip itself. Too strange.
            >
            >I did try your version, but it didn't quite work. For one, it needs
            >to "requote" at the end of the clip (which is why mine has the
            >^!Keyboard CTRL+Q at the end). So I added that, but only the last
            >line of the original selection ended up being quoted.
            >
            >Again, though, my old clip now works with an &50 delay added -- but it
            >only works from the clipbook pane! :)
            >
            >/Jelks
            >
            >
            >--- In ntb-clips@yahoogroups.com, "Sheri" <silvermoonwoman@...> wrote:
            >
            >
            >>Hi Jelks,
            >>
            >>I'm not sure what's going on with that but fortunately you can still
            >>accomplish your Quote Reformat task like this:
            >>
            >>^!If ^$GetSelSize$ > 0 Skip
            >>^!Select ALL
            >>^!Menu Modify/E-mail/Unquote Text
            >>^$StrFormat("^$GetSelection$";0;60;No)$
            >>;end of clip
            >>
            >>Regards,
            >>Sheri
            >>
            >>--- In ntb-clips@yahoogroups.com, "Jelks Cabaniss"
            >><jelkscabaniss@> wrote:
            >>
            >>
            >>I have a clip called "Quote Reformat" to reformat email-
            >>quoted text. I used it all the time in version 4, but it no
            >>longer works in version 5. Here's the clip:
            >>
            >>^!If ^$GetSelSize$ > 0 Skip
            >>^!Select ALL
            >>^!Keyboard CTRL+SHIFT+Q
            >>^!Keyboard CTRL+SHIFT+M #0# TAB #60# TAB ENTER
            >>^!Keyboard CTRL+Q
            >>
            >>What's happened the "Reformat Lines" dialog (line #4 above)
            >>is no longer "automated". Instead, it replaces the
            >>selection with a literal "0 TAB 60", and THEN gives me the
            >>"Reformat Lines" dialog. I even added a delay in that line
            >>like so:
            >>
            >>^!Keyboard CTRL+SHIFT+M &1000 #0# TAB #60# TAB ENTER
            >>
            >>but to no avail.
            >>
            >>Any ideas?
            >>
            >>Thanks in advance.
            >>
            >>/Jelks
            >>
            >>
            >>
            >
            >
            >
            >
            >
            >
            >Fookes Software: http://www.fookes.us, http://www.fookes.com
            >Fookes Software Mailing Lists: http://www.fookes.us/maillist.htm
            >
            >Yahoo! Groups Links
            >
            >
            >
            >
            >
            >
            >
            >
            >
            >
          • Jelks Cabaniss
            ... No, because that would just quote everything, and that s not what my Quote reformat clip is intended for. Quote reformat first UNquotes the selection
            Message 5 of 16 , Aug 6, 2006
            • 0 Attachment
              Jeff Scism wrote:

              > Tried a ^!KEYBOARD CTRL+A CTRL+Q ?

              No, because that would just quote everything, and that's not what my
              "Quote reformat" clip is intended for. "Quote reformat" first
              UNquotes the selection (or the entire doc if there is none), *then*
              reformats it, *then* quotes it. In other words, it takes stuff like
              this found in the wild:

              > > Now
              > > > > > is the time
              > for all bad men to
              >> >>> use Notetab Pro and
              > > > remove these extraneous
              > > quotes that are
              >> > SO annoying.

              and turns it into this:

              > Now is the time for all bad men to use Notetab Pro and
              > remove these extraneous quotes that are SO annoying.

              Incidentally, the clip now works from the clipbar button too.
              Apparently, when you call a clip from the button, it uses a *cached*
              version of the clip, not the modified version. Exiting and restarting
              Notetab fixed that.

              /Jelks
            • hsavage
              ... ^!If ^$GetSelSize$ 0 Skip ^!Select ALL ^!Keyboard CTRL+SHIFT+Q ^!Keyboard CTRL+SHIFT+M &1 #0# TAB #60# TAB ENTER ^!Keyboard CTRL+Q The addition of,
              Message 6 of 16 , Aug 6, 2006
              • 0 Attachment
                Jelks Cabaniss wrote:
                > Thank you, Sheri.
                >
                > First, let me just tell you I got my original code working. Well
                > *almost* working -- I had to put that delay in I spoke of. But with
                > that modification it does work.

                ^!If ^$GetSelSize$ > 0 Skip
                ^!Select ALL
                ^!Keyboard CTRL+SHIFT+Q
                ^!Keyboard CTRL+SHIFT+M &1 #0# TAB #60# TAB ENTER
                ^!Keyboard CTRL+Q

                The addition of, apparently, any length delay causes the clip to work
                correctly. This would seem to indicate, either v5 isn't presenting the
                dialog boxes quickly enough or, the new input control runs commands a
                bit more quickly. I added a one millisecond delay to your clip and that
                works too. I have other clips that open dialogs and they all use time
                delays to synchronize things.

                > I did try your version, but it didn't quite work. For one, it needs
                > to "requote" at the end of the clip (which is why mine has the
                > ^!Keyboard CTRL+Q at the end). So I added that, but only the last
                > line of the original selection ended up being quoted.
                >
                > /Jelks

                ^!If ^$GetSelSize$ > 0 Skip
                ^!Select ALL
                ^!Menu Modify/E-mail/Unquote Text
                ;
                ; ^$StrFormat("^$GetSelection$";0;60;0)$
                ^!InsertSelect ^$StrFormat("^$GetSelection$";0;60;0)$
                ;
                ^!Keyboard CTRL+Q

                ^$StrFormat in the first clip formats the selected string in the edit
                window and deselects the highlighting, whatever is selected. Adding
                ^!InsertSelect to the beginning of that line causes the string to be
                formatted in memory, then inserted into the selected area leaving the
                text marked so it can be re-quoted.

                ºvº
                06.08.06_10.19
                "Communication Skills I; Tears - The Last Resort, Not the First."
                hrs ø hsavage@...
              • Jeff Scism
                How about a CTRL+J, to join the selection then requote it? ~~ Jeffery Scism, USGenWeb Project Local Coordinator Rep NC/NE region
                Message 7 of 16 , Aug 6, 2006
                • 0 Attachment
                  How about a CTRL+J, to join the selection then requote it?

                  ~~

                  Jeffery Scism,
                  USGenWeb Project Local Coordinator Rep
                  NC/NE region




                  Jelks Cabaniss wrote:

                  >Jeff Scism wrote:
                  >
                  >
                  >
                  >>Tried a ^!KEYBOARD CTRL+A CTRL+Q ?
                  >>
                  >>
                  >
                  >No, because that would just quote everything, and that's not what my
                  >"Quote reformat" clip is intended for. "Quote reformat" first
                  >UNquotes the selection (or the entire doc if there is none), *then*
                  >reformats it, *then* quotes it. In other words, it takes stuff like
                  >this found in the wild:
                  >
                  >
                  >
                  >>>Now
                  >>>
                  >>>
                  >>>>>>is the time
                  >>>>>>
                  >>>>>>
                  >>for all bad men to
                  >>
                  >>
                  >>>>>>use Notetab Pro and
                  >>>>>>
                  >>>>>>
                  >>>>remove these extraneous
                  >>>>
                  >>>>
                  >>>quotes that are
                  >>>
                  >>>
                  >>>>SO annoying.
                  >>>>
                  >>>>
                  >
                  >and turns it into this:
                  >
                  >
                  >
                  >>Now is the time for all bad men to use Notetab Pro and
                  >>remove these extraneous quotes that are SO annoying.
                  >>
                  >>
                  >
                  >Incidentally, the clip now works from the clipbar button too.
                  >Apparently, when you call a clip from the button, it uses a *cached*
                  >version of the clip, not the modified version. Exiting and restarting
                  >Notetab fixed that.
                  >
                  >/Jelks
                  >
                  >
                  >
                  >
                  >
                  >
                  >Fookes Software: http://www.fookes.us, http://www.fookes.com
                  >Fookes Software Mailing Lists: http://www.fookes.us/maillist.htm
                  >
                  >Yahoo! Groups Links
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                  >
                • Jelks Cabaniss
                  ... Interesting -- a one millisecond delay doesn t cut it on my 1 ghz machine! The fastest I could get it to work was with a 14 millisecond delay. At 13, it
                  Message 8 of 16 , Aug 6, 2006
                  • 0 Attachment
                    hsavage wrote:
                    > The addition of, apparently, any length delay causes the
                    > clip to work correctly. This would seem to indicate, either
                    > v5 isn't presenting the dialog boxes quickly enough or, the
                    > new input control runs commands a bit more quickly. I added
                    > a one millisecond delay to your clip and that works too.

                    Interesting -- a one millisecond delay doesn't cut it on my 1 ghz
                    machine! The fastest I could get it to work was with a 14 millisecond
                    delay. At 13, it bombs. Seems to be machine-dependent. Maybe I need
                    to henceforth make them all 25 (50? 100?) millisecond delays in case I
                    ever use them on a slower machine (or share these clips with others on
                    slower machines).

                    Looks like all our 4.9x clips should be verified, not just
                    RegExp-using ones.

                    /Jelks
                  • Jelks Cabaniss
                    ... That will work for short lines, but it would put a single at the beginning of long paragraphs. *Joining* means getting rid of hard line breaks. I
                    Message 9 of 16 , Aug 6, 2006
                    • 0 Attachment
                      Jeff Scism wrote:
                      > How about a CTRL+J, to join the selection then requote it?

                      That will work for short lines, but it would put a single '> ' at the
                      beginning of long paragraphs. *Joining* means getting rid of hard
                      line breaks. I *want* those hard breaks, so there will be a '> ' in
                      front of *each* line when I quote the selection. That's why I use a
                      CTRL+SHIFT+M instead of a CTRL+J.

                      Anyway, my clip now works with a delay inserted after the CTRL+SHIFT+M.

                      /Jelks
                    • Sheri
                      ... Yes, but I would avoid the ^!Keyboard command and use a Menu command there too, i.e., ^!Menu Modify/E-mail/Quote Text For one thing, the same keyboard
                      Message 10 of 16 , Aug 7, 2006
                      • 0 Attachment
                        --- In ntb-clips@yahoogroups.com, hsavage <hsavage@...> wrote:
                        > ^!If ^$GetSelSize$ > 0 Skip
                        > ^!Select ALL
                        > ^!Menu Modify/E-mail/Unquote Text
                        > ;
                        > ; ^$StrFormat("^$GetSelection$";0;60;0)$
                        > ^!InsertSelect ^$StrFormat("^$GetSelection$";0;60;0)$
                        > ;
                        > ^!Keyboard CTRL+Q
                        >

                        Yes, but I would avoid the ^!Keyboard command and use a Menu command
                        there too, i.e.,

                        ^!Menu Modify/E-mail/Quote Text

                        For one thing, the same keyboard shortcut is not necessarily
                        selected by all users. For another, in some configurations there is
                        the potential need for delays when using ^!Keyboard. So wherever
                        possible I try to avoid ^!Keyboard commands.

                        Regards,
                        Sheri
                      • Jelks Cabaniss
                        ... You convinced me. The clip, rewritten: ^!If ^$GetSelSize$ 0 Skip ^!Select ALL ^!Menu Modify/E-mail/Unquote Text ^!InsertSelect
                        Message 11 of 16 , Aug 7, 2006
                        • 0 Attachment
                          Sheri wrote:
                          > Yes, but I would avoid the ^!Keyboard command and use a Menu
                          > command there too ...
                          > For one thing, the same keyboard shortcut is not necessarily
                          > selected by all users. For another, in some configurations
                          > there is the potential need for delays when using
                          > ^!Keyboard. So wherever possible I try to avoid ^!Keyboard
                          > commands.

                          You convinced me. The clip, rewritten:

                          ^!If ^$GetSelSize$ > 0 Skip
                          ^!Select ALL
                          ^!Menu Modify/E-mail/Unquote Text
                          ^!InsertSelect ^$StrFormat("^$GetSelection$";0;60;0)$
                          ^!Menu Modify/E-mail/Quote Text

                          Thanks to you and hsavage for all the help!

                          (My goodness, I sure have a *lot* of clips using ^!Keyboard. *Cringe*. :)


                          /Jelks
                        • Don Daugherty
                          How do you all use the following clip -- copy something from email to Notetab, run the clip, then copy back into email?
                          Message 12 of 16 , Aug 9, 2006
                          • 0 Attachment
                            How do you all use the following clip -- copy something from email to
                            Notetab, run the clip, then copy back into email?
                            > ^!If ^$GetSelSize$ > 0 Skip
                            > ^!Select ALL
                            > ^!Menu Modify/E-mail/Unquote Text
                            > ^!InsertSelect ^$StrFormat("^$GetSelection$";0;60;0)$
                            > ^!Menu Modify/E-mail/Quote Text
                            >
                          • Jelks Cabaniss
                            ... Yes, that s the primary purpose. Most email software (Outlook, OE, web-based email) can end up mangling quoting pretty badly. That clip just cleans it
                            Message 13 of 16 , Aug 9, 2006
                            • 0 Attachment
                              Don Daugherty wrote:
                              > How do you all use the following clip -- copy something from email to
                              > Notetab, run the clip, then copy back into email?
                              > > ^!If ^$GetSelSize$ > 0 Skip
                              > > ^!Select ALL
                              > > ^!Menu Modify/E-mail/Unquote Text
                              > > ^!InsertSelect ^$StrFormat("^$GetSelection$";0;60;0)$
                              > > ^!Menu Modify/E-mail/Quote Text

                              Yes, that's the primary purpose. Most email software (Outlook, OE,
                              web-based email) can end up mangling quoting pretty badly. That clip
                              just "cleans it all up". Note that it reduces everything selected to
                              just one level of quotes, so if there are multiple levels, I then
                              select those blocks and press CTRL+Q to add another level of quotes as
                              many times as necessary.

                              Also -- and this is just a personal preference, YMMV -- I changed the
                              default NTP quote character '>' in the Options to have a space after
                              it, i.e. '> '.

                              /Jelks
                            • Ray Shapp
                              Hi Jelks, Sheri, and Harvey: Thanks for your three-way discussion about this clip. I m now using the final version posted by Jelks on 8/7/2006. My question:
                              Message 14 of 16 , Aug 13, 2006
                              • 0 Attachment
                                Hi Jelks, Sheri, and Harvey:

                                Thanks for your three-way discussion about this clip. I'm now using the final
                                version posted by Jelks on 8/7/2006.

                                My question: Where is the delay? I looked at both the commands (^$StrFormat
                                and ^$GetSelection$) in Help, but I don't see the introduction of any delay in
                                them.

                                Your clip is running fine on my 3GHz PC (very few other processing running
                                simultaneously).

                                Ray Shapp
                                WinXP Home SP2
                              • hsavage
                                ... the final ... (^$StrFormat ... delay in ... Ray, The delay was discussed in reference to an earlier clip when using ^!Keyboard commands, as below from a
                                Message 15 of 16 , Aug 13, 2006
                                • 0 Attachment
                                  Ray Shapp wrote:
                                  > Hi Jelks, Sheri, and Harvey:
                                  >
                                  > Thanks for your three-way discussion about this clip. I'm now using
                                  the final
                                  > version posted by Jelks on 8/7/2006.
                                  >
                                  > My question: Where is the delay? I looked at both the commands
                                  (^$StrFormat
                                  > and ^$GetSelection$) in Help, but I don't see the introduction of any
                                  delay in
                                  > them.
                                  >
                                  > Ray Shapp
                                  > WinXP Home SP2

                                  Ray,

                                  The 'delay' was discussed in reference to an earlier clip when using
                                  ^!Keyboard commands, as below from a previous email. In the 4th line
                                  down is an entry '&1', in keyboard commands the '&' precedes a number
                                  representing fractions of a second, in this case it's milliseconds, my
                                  entry, '&1' represents 1 millisecond, '&500' represents a half second.


                                  ^!If ^$GetSelSize$ > 0 Skip
                                  ^!Select ALL
                                  ^!Keyboard CTRL+SHIFT+Q
                                  ^!Keyboard CTRL+SHIFT+M &1 #0# TAB #60# TAB ENTER
                                  ^!Keyboard CTRL+Q


                                  You're probably already be aware of this but I thought, just in case
                                  I'll answer to explain.

                                  ºvº
                                  2006.08.13
                                  -Newspaper HeadLine...
                                  "Enraged Cow Injures Farmer with Ax"
                                  hrs ø hsavage@...
                                • Ray Shapp
                                  Hi Harvey, Great help, and a very funny tag line. I still giggle when I picture the ax-carrying farmer being injured. Then shifting gears, I see an ax-wielding
                                  Message 16 of 16 , Aug 14, 2006
                                  • 0 Attachment
                                    Hi Harvey,

                                    Great help, and a very funny tag line. I still giggle when I picture the
                                    ax-carrying farmer being injured. Then shifting gears, I see an ax-wielding
                                    cow.

                                    Regards,

                                    Ray Shapp
                                  Your message has been successfully submitted and would be delivered to recipients shortly.