Loading ...
Sorry, an error occurred while loading the content.

Re: SV: [Clip] A problem with SetDocIndex

Expand Messages
  • Jody
    Hi Sheri, (I ll let Eric know about this so that he can file this in his NoteTab - things to do/check folder.) ... That should be a bug then IMO. If you click
    Message 1 of 23 , Jan 6, 2004
    • 0 Attachment
      Hi Sheri,

      (I'll let Eric know about this so that he can file this in his
      NoteTab - things to do/check folder.)

      >I guess something I had done in clip-edit (i.e., while editing
      >the [Clips] document) was causing it not to use default
      >properties, so my changing the options default to Trim White
      >Spaces had no effect.

      That should be a bug then IMO. If you click on Document | Trim
      White Spaces (TWS) in Properties (not Options), it should set it for
      the whole clb file since NoteTab deals with the whole file.
      (Sometimes we overlook that thinking the Clip Editor is a
      separate entity.) (I don't write like this (saying things you
      probably know) making it sound like you do not know what you are
      doing, but for the benefit of others and a reminder for us all. :)

      My argument is if you open a regular document and set TWS in the
      document's Properties, it will/should be set overriding the
      Default (our personal Options | Documents) settings. Therefore,
      it should act the same with the Clipbook Library. I have not
      checked to set it with the clb opened as a document, and not just
      the Clip Editor. Perhaps that is where the glitch is.

      >Maybe that had happened to Mangus too. I've discovered that even
      >clicking Wordwrap on the toolbar disables default properties for
      >the current document.

      Yes, you will notice if you toggle the word wrap state and then
      go to Document | Properties that it should be toggled there as
      well. I've seen it like that. Never paid attention to see if it
      does it "hot" or if NoteTab has to be restarted for it to show
      though. Note that the Toolbar icons work hand in hand (tied
      together) with the dialog check boxes. If you check the Word Wrap
      box, then the Word Wrap icon will get depressed on the Toolbar
      for instance.

      >There is only one set of properties that applies to the [Clips]
      >document; it doesn't matter which library is active. New clippers
      >should be warned to set Trim White Spaces in Document|Properties
      >for [Clips] as well as in Options.

      I will have to investigate this further. I'm not agreeing or
      disagreeing although in theory, it should not work like that at
      least when compared to how other documents work with these
      features. I think that would be the better setting though.
      Although the Clipbook Library is its own think, NoteTab still
      treats it as a file/document, at least for the most part.
      Thinking about the Show Headers feature though - that works for
      all Libraries. You cannot set it to show for one Library, but not
      another. However, that is not a document property.

      >IMO it would be helpful if the post-install default for Trim
      >White Spaces was "on" instead of "off". Then unless the user
      >changed that particular default option prior to ever using clip-
      >edit he'd be all set. Just a thought for future versions :)

      I agree if... you know more scripting and programming languages
      than me, so maybe you know the answer. What if a programmer has
      real white spaces at the end of an existing 30k line file with
      460 lines ending in them. Ouch! We know he would have plenty of
      backups, but nevertheless... :) Perhaps Eric could have a one
      time warning whenever a document had a white space at the end of
      the line and it was about to get removing stating what the
      circumstances would be and the benefit of having it done.

      Thanks for your feedback! Off to town now...

      Happy Clip'n!
      Jody

      www.clean-funnies.com, http://www.fookes.us/maillist.htm

      Subscribe: mailto:ntb-Clips-Subscribe@yahoogroups.com
      UnSubscribe: mailto:ntb-Clips-UnSubscribe@yahoogroups.com
      Options: http://groups.yahoo.com/group/ntb-clips
    Your message has been successfully submitted and would be delivered to recipients shortly.