Loading ...
Sorry, an error occurred while loading the content.

Re: [Clip] A problem with SetDocIndex

Expand Messages
  • Jody
    Hi Magnus, It still works just fine for me in Pro 4.95 XP Pro. That is if you are talking about the SetDocIndex still (see my remarks about line 36). When and
    Message 1 of 23 , Jan 5, 2004
    • 0 Attachment
      Hi Magnus,

      It still works just fine for me in Pro 4.95 XP Pro. That is if
      you are talking about the SetDocIndex still (see my remarks about
      line 36). When and if you get it working I suggest you add the
      following two lines to the top of the Clip to speed it up:

      ^!SetHintInfo Working...
      ^!SetScreenUpdate Off
      ; Sometimes it helps to:
      ^!MinimizeApp
      ; and at the end of the script
      ^!ActivateApp

      >As Sheri suggested, a library containing clip and data file is now put on
      >the Yahoo file area. The file is called SetDocIndex.zip. The problem occurs
      >in the 36th line of the clip.

      My line 36 is either one of these depending on whether you have
      Show Headers on or not (right click over the Library).

      ^!Set %diffuse%=^$Calc(^%diffuse%;1)$
      ^!Keyboard RIGHT LEFT

      What does your ^!Keyboard do? Unselect? That might be where your
      glitch is coming from. Try ^!Jump Select_Start or ^!Jump Select_End.
      Or I think ^!Select 0 (zero) will do it, it's been awhile. <g>

      >Again, I use NoteTab Pro 4.95 and Windows 2000 (Norwegian version).
      >
      >Regards,
      >Magnus
      >
      > -----Opprinnelig melding-----
      > Fra: Sheri [mailto:silvermoonwoman@...]
      > Sendt: 23. desember 2003 15:17
      > Til: ntb-clips@yahoogroups.com
      > Emne: Re: [Clip] A problem with SetDocIndex
      >
      >
      > Which NoteTab variant and version are you using? And which OS and
      > language?


      Happy Clip'n!
      Jody

      www.clean-funnies.com, http://www.fookes.us/maillist.htm

      Subscribe: mailto:ntb-Clips-Subscribe@yahoogroups.com
      UnSubscribe: mailto:ntb-Clips-UnSubscribe@yahoogroups.com
      Options: http://groups.yahoo.com/group/ntb-clips
    • Magnus H. Sorby
      Hi Jody, My problem line is ^!SetDocIndex ^%newindex% (line 36 with no Word Wrap and no header). The ^Keyboard command is for unselecting. I ve replaced it
      Message 2 of 23 , Jan 5, 2004
      • 0 Attachment
        Hi Jody,

        My problem line is
        ^!SetDocIndex ^%newindex%
        (line 36 with no Word Wrap and no header).

        The ^Keyboard command is for unselecting. I've replaced it with ^Jump
        Select_End without any change of behaviour.

        Well then, I guess the problem is in my computer. I will work around the
        problem by replacing ^%newindex% with the proper number.

        I've tried all the posted suggestions but none of them helped. Thanks
        anyway!

        Magnus
        -----Opprinnelig melding-----
        Fra: Jody [mailto:kjv-av1611@...]
        Sendt: 5. januar 2004 11:29
        Til: ntb-clips@yahoogroups.com
        Emne: Re: [Clip] A problem with SetDocIndex


        Hi Magnus,

        It still works just fine for me in Pro 4.95 XP Pro. That is if
        you are talking about the SetDocIndex still (see my remarks about
        line 36). When and if you get it working I suggest you add the
        following two lines to the top of the Clip to speed it up:

        ^!SetHintInfo Working...
        ^!SetScreenUpdate Off
        ; Sometimes it helps to:
        ^!MinimizeApp
        ; and at the end of the script
        ^!ActivateApp

        >As Sheri suggested, a library containing clip and data file is now put on
        >the Yahoo file area. The file is called SetDocIndex.zip. The problem
        occurs
        >in the 36th line of the clip.

        My line 36 is either one of these depending on whether you have
        Show Headers on or not (right click over the Library).

        ^!Set %diffuse%=^$Calc(^%diffuse%;1)$
        ^!Keyboard RIGHT LEFT

        What does your ^!Keyboard do? Unselect? That might be where your
        glitch is coming from. Try ^!Jump Select_Start or ^!Jump Select_End.
        Or I think ^!Select 0 (zero) will do it, it's been awhile. <g>

        >Again, I use NoteTab Pro 4.95 and Windows 2000 (Norwegian version).
        >
        >Regards,
        >Magnus
        >
        > -----Opprinnelig melding-----
        > Fra: Sheri [mailto:silvermoonwoman@...]
        > Sendt: 23. desember 2003 15:17
        > Til: ntb-clips@yahoogroups.com
        > Emne: Re: [Clip] A problem with SetDocIndex
        >
        >
        > Which NoteTab variant and version are you using? And which OS and
        > language?


        Happy Clip'n!
        Jody

        www.clean-funnies.com, http://www.fookes.us/maillist.htm

        Subscribe: mailto:ntb-Clips-Subscribe@yahoogroups.com
        UnSubscribe: mailto:ntb-Clips-UnSubscribe@yahoogroups.com
        Options: http://groups.yahoo.com/group/ntb-clips


        Yahoo! Groups Sponsor
        ADVERTISEMENT





        ----------------------------------------------------------------------------
        --
        Yahoo! Groups Links

        a.. To visit your group on the web, go to:
        http://groups.yahoo.com/group/ntb-clips/

        b.. To unsubscribe from this group, send an email to:
        ntb-clips-unsubscribe@yahoogroups.com

        c.. Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.



        [Non-text portions of this message have been removed]
      • Sheri
        ... Whoa! Hold on there It does not work here. The problem you have with ^!SetDocIndex is on line 13 of your clip: ^!Set %newindex%=^$GetDocIndex$ There is
        Message 3 of 23 , Jan 5, 2004
        • 0 Attachment
          At 01:40 PM 1/5/2004 +0100, you wrote:
          >Well then, I guess the problem is in my computer. I will work around the
          >problem by replacing ^%newindex% with the proper number.

          Whoa! Hold on there <g>

          It does not work here.

          The problem you have with ^!SetDocIndex is on line 13 of your clip:

          ^!Set %newindex%=^$GetDocIndex$

          There is a space after ^$GetDocIndex$

          Regards,
          Sheri
        • Magnus H. Sorby
          Thanks Sheri. I m really sorry to have bothered you all with this! The importance of removing leading and trailing spaces was pointed out by Larry the day
          Message 4 of 23 , Jan 5, 2004
          • 0 Attachment
            Thanks Sheri.

            I'm really sorry to have bothered you all with this! The importance of
            removing leading and trailing spaces was pointed out by Larry the day after
            I first posted my problem. I was absolutely sure that I had checked it and
            also used "Trim Blanks". I obviously hadn't.

            Regards,
            Magnus
            -----Opprinnelig melding-----
            Fra: Sheri [mailto:silvermoonwoman@...]
            Sendt: 5. januar 2004 14:12
            Til: ntb-clips@yahoogroups.com
            Emne: Re: SV: [Clip] A problem with SetDocIndex


            At 01:40 PM 1/5/2004 +0100, you wrote:
            >Well then, I guess the problem is in my computer. I will work around the
            >problem by replacing ^%newindex% with the proper number.

            Whoa! Hold on there <g>

            It does not work here.

            The problem you have with ^!SetDocIndex is on line 13 of your clip:

            ^!Set %newindex%=^$GetDocIndex$

            There is a space after ^$GetDocIndex$

            Regards,
            Sheri



            Yahoo! Groups Sponsor
            ADVERTISEMENT





            ----------------------------------------------------------------------------
            --
            Yahoo! Groups Links

            a.. To visit your group on the web, go to:
            http://groups.yahoo.com/group/ntb-clips/

            b.. To unsubscribe from this group, send an email to:
            ntb-clips-unsubscribe@yahoogroups.com

            c.. Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.



            [Non-text portions of this message have been removed]
          • Jody
            Hi Sheri and Magnus, ... Good find Sheri, (even though you sent my eMail to your trash box awhile back.) Definitely agreed; I just said it worked fine
            Message 5 of 23 , Jan 5, 2004
            • 0 Attachment
              Hi Sheri and Magnus,

              >> Well then, I guess the problem is in my computer. I will work
              >> around the problem by replacing ^%newindex% with the proper
              >> number.
              >
              >Whoa! Hold on there <g>

              Good find Sheri, (even though you sent my eMail to your trash box
              awhile back.) <g>

              Definitely agreed; I just said it worked fine here. <g> Magnus,
              You must have missed one of the first few posts mentioning for
              you to check for spaces at the end of the lines. The reason why a
              lot of us miss that in actual testing is because we have the
              setting in Options | Documents | Trim White Spaces checked. It
              does the following:

              Trim White Spaces: Spaces at the end of paragraphs are removed
              when the document is saved.

              So, when we get Clips or make them, every time they are saved,
              the trailing white spaces (just a regular <space>) at the end of
              the lines are removed. The only time that will cause you a
              problem with Clips is if you really want a space at the end. All
              you need to remember then is if you want the space (or more)
              there you add the preset variable ^%Space%, one for every space
              you want. (The setting also effects regular document line endings.)

              FWIW, you could have just posted your Clip on the list. :)
              Somebody might have spotted it sooner like that probably saving
              you a lot of headaches. The data wasn't really necessary to start
              with, that is, to just take a quick look at the Clip. Later
              somebody might have requested you send a few lines of the data
              file to the list. Anyway, your Clip will run a lot faster if you
              add the couple lines to the top like I mentioned. Good luck!

              >It does not work here.
              >
              >The problem you have with ^!SetDocIndex is on line 13 of your clip:
              >
              >^!Set %newindex%=^$GetDocIndex$
              >
              >There is a space after ^$GetDocIndex$


              Happy Clip'n!
              Jody

              www.clean-funnies.com, http://www.fookes.us/maillist.htm

              Subscribe: mailto:ntb-Clips-Subscribe@yahoogroups.com
              UnSubscribe: mailto:ntb-Clips-UnSubscribe@yahoogroups.com
              Options: http://groups.yahoo.com/group/ntb-clips
            • Sheri
              ... Hi Mangus, We ve all been there, so don t let it trouble you. One of the advantages of NoteTab Pro over the other variants is the ability to turn on
              Message 6 of 23 , Jan 5, 2004
              • 0 Attachment
                At 02:49 PM 1/5/2004 +0100, you wrote:
                >Thanks Sheri.
                >
                >I'm really sorry to have bothered you all with this! The importance of
                >removing leading and trailing spaces was pointed out by Larry the day after
                >I first posted my problem. I was absolutely sure that I had checked it and
                >also used "Trim Blanks". I obviously hadn't.
                >
                >Regards,
                >Magnus


                Hi Mangus,

                We've all been there, so don't let it trouble you. One of the advantages of NoteTab Pro over the other variants is the ability to turn "on" non-printing spaces, which in most cases makes things like that stand out. You can enable it on the View tab in Options (Show Nonprinting Text).

                I will make a couple of suggestions about your clip. Since the only reason you are bouncing back and forth between documents is to add text from variables, I think it would be faster and more efficient to use ^!AppendtoFile. Whatever file name you choose, you could Close that file and delete it (if it exists) at the beginning of your clip, and Open it for viewing at the end of your clip. Also, you will find that there are clip instructions that will allow you to move the cursor anywhere you want it in your document without using ^!Keyboard commands. Although the ^!Keyboard commands may seem convenient, they are subject to focus and timing issues that can sometimes cause unexpected results.

                Have fun,
                Sheri
              • Sheri
                Hi Jody, ... I m innocent, my computer did it all by itself. ... I have just recently installed NTP on XP, and had not changed the default setting so
                Message 7 of 23 , Jan 5, 2004
                • 0 Attachment
                  Hi Jody,

                  At 08:01 AM 1/5/2004 -0600, you wrote:

                  >Good find Sheri, (even though you sent my eMail to your trash box
                  >awhile back.) <g>

                  I'm innocent, my computer did it all by itself. <BG>


                  >So, when we get Clips or make them, every time they are saved,
                  >the trailing white spaces (just a regular <space>) at the end of
                  >the lines are removed. The only time that will cause you a
                  >problem with Clips is if you really want a space at the end. All
                  >you need to remember then is if you want the space (or more)
                  >there you add the preset variable ^%Space%, one for every space
                  >you want. (The setting also effects regular document line endings.)

                  I have just recently installed NTP on XP, and had not changed the default setting so trailing blanks were not being trimmed.

                  However, having now enabled it (in NTP 4.95), and after deleting and reloading Mangus's clip library a few times, I think trimming blanks must apply only to documents and not to clip libraries (unless you happen to open the clip library as if it were a document, re-save it and reload it). I made another change to his library (in Clip Edit), saved the clip, closed and reopened NTP, and the space was still there.

                  Regards,
                  Sheri
                • Jody
                  Hi Sheri, ... Yeah, I ve heard that one before... ... It appears to be broke in the Clip Editor... Maybe it has been like that for a long time. I downloaded
                  Message 8 of 23 , Jan 5, 2004
                  • 0 Attachment
                    Hi Sheri,

                    >>Good find Sheri, (even though you sent my eMail to your trash box
                    >>awhile back.) <g>
                    >
                    >I'm innocent, my computer did it all by itself. <BG>

                    Yeah, I've heard that one before...

                    >I have just recently installed NTP on XP, and had not changed the
                    >default setting so trailing blanks were not being trimmed.
                    >
                    >However, having now enabled it (in NTP 4.95), and after deleting
                    >and reloading Mangus's clip library a few times, I think trimming
                    >blanks must apply only to documents and not to clip libraries
                    >(unless you happen to open the clip library as if it were a
                    >document, re-save it and reload it). I made another change to his
                    >library (in Clip Edit), saved the clip, closed and reopened NTP,
                    >and the space was still there.

                    It appears to be broke in the Clip Editor... Maybe it has been
                    like that for a long time. I downloaded the zip, double clicked
                    on in zip prog since clb is associated with NoteTab, saved to
                    Library, :), and did a List Update to get it on my Libraries bar.
                    Obviously, it was when I had it open as a document and saved it
                    that the space was removed. I do know for sure though (at least I
                    think I do;) that they use to be trimmed in the Clip Editor - not
                    visible at the time though. Switch in/out of the Library and it
                    will trim it, at least it just did here.

                    See ya in the funnies,
                    Jody Adair, Prov. 15:15

                    Blessed are they who can laugh at themselves
                    for they shall never cease to be amused.
                    http://www.clean-funnies.com
                  • Sheri
                    Hi Jody, ... Any idea how you did it? I m assuming you mean you did it without loading and saving it as if it was a document first (as happened when you
                    Message 9 of 23 , Jan 5, 2004
                    • 0 Attachment
                      Hi Jody,

                      At 09:33 AM 1/5/2004 -0600, you wrote:
                      >Switch in/out of the Library and it
                      >will trim it, at least it just did here.

                      Any idea how you did it? I'm assuming you mean you did it without loading and saving it as if it was a document first (as happened when you initially loaded the clb file from the zip and re-saved it).

                      I tried, but wasn't able to make that happen here. After making a change to his library, I switched libraries and was prompted "Save Changes to Clipbook Library SetDocIndex?"

                      Clicked Yes. Switched back to his library and the space was still there. Just to make sure it wasn't because the library was resident, I then closed and reopened NTP. It was still there.

                      Regards,
                      Sheri
                    • Jody
                      Hi Sheri, Are you double sure you have Document | Trim White Spaces checked? Here s another way. Open Clip Editor. Add a space to the end of a line. Save,
                      Message 10 of 23 , Jan 5, 2004
                      • 0 Attachment
                        Hi Sheri,

                        Are you double sure you have Document | Trim White Spaces checked?

                        Here's another way. Open Clip Editor. Add a space to the end of a
                        line. Save, click on another Clip and then back on the original.
                        Space removed with Clip Editor still open.

                        >> Switch in/out of the Library and it will trim it, at least it
                        >> just did here.
                        >
                        >Any idea how you did it? I'm assuming you mean you did it without
                        >loading and saving it as if it was a document first (as happened
                        >when you initially loaded the clb file from the zip and re-saved
                        >it).


                        Happy Clip'n!
                        Jody

                        www.clean-funnies.com, http://www.fookes.us/maillist.htm

                        Subscribe: mailto:ntb-Clips-Subscribe@yahoogroups.com
                        UnSubscribe: mailto:ntb-Clips-UnSubscribe@yahoogroups.com
                        Options: http://groups.yahoo.com/group/ntb-clips
                      • Sheri
                        Hi Jody, Apparently its not enough to set Trim White Spaces in View|Options|Documents. With the [Clips] document open, I needed to use Document|Properties,
                        Message 11 of 23 , Jan 5, 2004
                        • 0 Attachment
                          Hi Jody,

                          Apparently its not enough to set Trim White Spaces in View|Options|Documents. With the [Clips] document open, I needed to use Document|Properties, i.e., to select Use Default Settings!

                          Regards,
                          Sheri
                        • Jody
                          Hi Sheri,, ... Shouldn t have to. The Document settings are dealt with in two ways. This is what I have in PasteBack for one of my FAQ support questions. I
                          Message 12 of 23 , Jan 5, 2004
                          • 0 Attachment
                            Hi Sheri,,

                            >Apparently its not enough to set Trim White Spaces in
                            >View|Options|Documents. With the [Clips] document open, I needed
                            >to use Document|Properties, i.e., to select Use Default Settings!

                            Shouldn't have to. The Document settings are dealt with in two ways.
                            This is what I have in PasteBack for one of my FAQ support questions.
                            I type in doc abd copy.cut it below starting in the next paragraph.
                            The "doc" will not be there anymore of course. :)

                            There are two settings for documents:

                            One is in View | Options | Documents... It controls the features
                            used for all new documents like when you click on the New
                            Document icon on the Toolbar (Ctrl+N).

                            The second is off the main menu under Document | Properties... It
                            controls each document's settings, that is, the one you have
                            focused in NoteTab. So, for an existing file you want to change
                            the properties for that document in Document | Properties off the
                            main menu. The properties for the focused file override the
                            settings made in Options for all new documents. The settings are
                            stored in NoteTab's main folder in NoteTab.fpr (NotePro.fpr for
                            Pro) and remembered between NoteTab sessions.

                            ----

                            Me again. ;) If you go back to Document | Properties, you should
                            be able to set Trim White Spaces then for the Clip Editor, hmmm,
                            which is actually the .clb file. Soooo, perhaps for all new
                            Libraries the Options settings will be used, but for existing
                            Libraries that were made when you may have had Trim White Spaces
                            unchecked when you made it would not work like we/I, well,
                            finally, after all these years of fumbling around with that
                            feature and on the list I think we stumbled across the "problem"
                            with me talking us through it. Bet ya that is how it works. :)
                            I'm too tired to test... been up all night again...

                            Oh, what happened when you checked Use Default Settings - it uses
                            what your current Options settings are at - not NoteTab's install
                            default. Wanna bet? :) I'm just taking an educated guess??? Later

                            Happy Clip'n!
                            Jody

                            www.clean-funnies.com, http://www.fookes.us/maillist.htm

                            Subscribe: mailto:ntb-Clips-Subscribe@yahoogroups.com
                            UnSubscribe: mailto:ntb-Clips-UnSubscribe@yahoogroups.com
                            Options: http://groups.yahoo.com/group/ntb-clips
                          • Sheri
                            Hi Jody, I guess something I had done in clip-edit (i.e., while editing the [Clips] document) was causing it not to use default properties, so my changing the
                            Message 13 of 23 , Jan 5, 2004
                            • 0 Attachment
                              Hi Jody,

                              I guess something I had done in clip-edit (i.e., while editing the [Clips] document) was causing it not to use default properties, so my changing the options default to Trim White Spaces had no effect. Maybe that had happened to Mangus too. I've discovered that even clicking Wordwrap on the toolbar disables default properties for the current document. There is only one set of properties that applies to the [Clips] document; it doesn't matter which library is active. New clippers should be warned to set Trim White Spaces in Document|Properties for [Clips] as well as in Options.

                              IMO it would be helpful if the post-install default for Trim White Spaces was "on" instead of "off". Then unless the user changed that particular default option prior to ever using clip-edit he'd be all set. Just a thought for future versions :)

                              Regards,
                              Sheri
                            • Jody
                              Hi Sheri, (I ll let Eric know about this so that he can file this in his NoteTab - things to do/check folder.) ... That should be a bug then IMO. If you click
                              Message 14 of 23 , Jan 6, 2004
                              • 0 Attachment
                                Hi Sheri,

                                (I'll let Eric know about this so that he can file this in his
                                NoteTab - things to do/check folder.)

                                >I guess something I had done in clip-edit (i.e., while editing
                                >the [Clips] document) was causing it not to use default
                                >properties, so my changing the options default to Trim White
                                >Spaces had no effect.

                                That should be a bug then IMO. If you click on Document | Trim
                                White Spaces (TWS) in Properties (not Options), it should set it for
                                the whole clb file since NoteTab deals with the whole file.
                                (Sometimes we overlook that thinking the Clip Editor is a
                                separate entity.) (I don't write like this (saying things you
                                probably know) making it sound like you do not know what you are
                                doing, but for the benefit of others and a reminder for us all. :)

                                My argument is if you open a regular document and set TWS in the
                                document's Properties, it will/should be set overriding the
                                Default (our personal Options | Documents) settings. Therefore,
                                it should act the same with the Clipbook Library. I have not
                                checked to set it with the clb opened as a document, and not just
                                the Clip Editor. Perhaps that is where the glitch is.

                                >Maybe that had happened to Mangus too. I've discovered that even
                                >clicking Wordwrap on the toolbar disables default properties for
                                >the current document.

                                Yes, you will notice if you toggle the word wrap state and then
                                go to Document | Properties that it should be toggled there as
                                well. I've seen it like that. Never paid attention to see if it
                                does it "hot" or if NoteTab has to be restarted for it to show
                                though. Note that the Toolbar icons work hand in hand (tied
                                together) with the dialog check boxes. If you check the Word Wrap
                                box, then the Word Wrap icon will get depressed on the Toolbar
                                for instance.

                                >There is only one set of properties that applies to the [Clips]
                                >document; it doesn't matter which library is active. New clippers
                                >should be warned to set Trim White Spaces in Document|Properties
                                >for [Clips] as well as in Options.

                                I will have to investigate this further. I'm not agreeing or
                                disagreeing although in theory, it should not work like that at
                                least when compared to how other documents work with these
                                features. I think that would be the better setting though.
                                Although the Clipbook Library is its own think, NoteTab still
                                treats it as a file/document, at least for the most part.
                                Thinking about the Show Headers feature though - that works for
                                all Libraries. You cannot set it to show for one Library, but not
                                another. However, that is not a document property.

                                >IMO it would be helpful if the post-install default for Trim
                                >White Spaces was "on" instead of "off". Then unless the user
                                >changed that particular default option prior to ever using clip-
                                >edit he'd be all set. Just a thought for future versions :)

                                I agree if... you know more scripting and programming languages
                                than me, so maybe you know the answer. What if a programmer has
                                real white spaces at the end of an existing 30k line file with
                                460 lines ending in them. Ouch! We know he would have plenty of
                                backups, but nevertheless... :) Perhaps Eric could have a one
                                time warning whenever a document had a white space at the end of
                                the line and it was about to get removing stating what the
                                circumstances would be and the benefit of having it done.

                                Thanks for your feedback! Off to town now...

                                Happy Clip'n!
                                Jody

                                www.clean-funnies.com, http://www.fookes.us/maillist.htm

                                Subscribe: mailto:ntb-Clips-Subscribe@yahoogroups.com
                                UnSubscribe: mailto:ntb-Clips-UnSubscribe@yahoogroups.com
                                Options: http://groups.yahoo.com/group/ntb-clips
                              Your message has been successfully submitted and would be delivered to recipients shortly.