Loading ...
Sorry, an error occurred while loading the content.

Combobox Bug?

Expand Messages
  • CB2
    cc d to: NoteTab Next Release List Hello all: I m using NoteTab Pro v4.95. I ve found what appears to be a bug in combobox
    Message 1 of 1 , Jul 27, 2003
    • 0 Attachment
      cc'd to: NoteTab Next Release List <ntb-nextrelease@yahoogroups.com>

      Hello all:

      I'm using NoteTab Pro v4.95.

      I've found what appears to be a bug in combobox wizard fields that force
      the user to select a predefined listvalue. My apologies if this has been
      covered/addressed before. I seem to dimly recall something like this coming
      up somewhere before, but I couldn't find anything in the Yahoo! archives,
      so maybe I'm just imagining things. Anyway, here goes:

      H="Combobox Bug?"
      ^!ClearVariables
      ^!SET %test%="^?{(T=C)Items==foobar|nyet|yada}"
      ^!IF "^%test%" = "" ^!SET %test%="gumby"
      ^!Prompt "^%test%"

      Here's what I do to produce the problem:

      1. Run the "Combobox Bug?" clip.

      2. Type in "neener" (without the quotes).

      3. Don't use the OK button on the wizard.
      Instead, press the Enter key on the keyboard.
      An error prompt will appear:

      Error, "neener" is not in the list. Please choose an existing item.

      4. Press the OK button on the error prompt.

      5. The prompt defined in the clip appears, showing %test% as nyet.
      No opportunity to 'choose an existing item' is given.

      6. Repeat steps 1-5, but enter "blah" (no quotes) instead of neener.
      The same thing happens, except the clip prompt shows %test% as gumby.

      Everything works fine if I use the OK button on the wizard (rather than the
      Enter key on the keyboard).
      --
      Charles Beasley II
    Your message has been successfully submitted and would be delivered to recipients shortly.