Loading ...
Sorry, an error occurred while loading the content.

A question about Trim Blanks Was: [Clip] Clip bar

Expand Messages
  • Larry Thomas
    Hi Bob, Jody, and Eric I previously wrote: =================== I am really not sure what is wrong here unless it is with the RegExp engine in NoteTab. I have
    Message 1 of 5 , May 31, 2003
    • 0 Attachment
      Hi Bob, Jody, and Eric

      I previously wrote:
      ===================

      I am really not sure what is wrong here unless it is with the RegExp engine
      in NoteTab. I have deleted this clip from my library without testing it on
      the clipbar. Because I realized that there was a better way from one of
      the other posters. I have run this clip on the clipbar and it really does
      work for me each and every time I run it whether from the clipbar or from
      the open clipbook panel.

      H="Remove Trailing Spaces"
      ;Larry Thomas <larryt@...>
      ;05/31/2003, 11:25:12 AM
      ^!Select All
      ^!Menu Modify/Lines/Trim Blanks
      ^!Jump1
      ===================

      Now I see the above clip does not work at all. Then I add a space between
      Jump and 1 so the last line is changed to ^!Jump 1 and it works.

      In the help file it says:

      Trim Blanks
      This command removes trailing blank and tab characters from the end of the
      current line or selected lines.


      When I run this clip on itself, it removes the space between ^!Jump and 1
      which turns it into ^!Jump1 and causes the clip to fail. Is this a bug or
      what?

      Here is the corrected clip and I have changed ^!Jump 1 to ^!Jump Text_Start
      to romove this problem.

      H="Remove Trailing Spaces"
      ;Larry Thomas <larryt@...>
      ;05/31/2003, 11:25:12 AM
      ^!Select All
      ^!Menu Modify/Lines/Trim Blanks
      ^!Jump Text_Start

      Regards,

      Larry
      larryt@...
    • Mark B.
      Larry, This is an oddity I ve noticed in Trim Blanks : when the last line selected ends with a one-letter word and no trailing space, Trim Blanks joins the
      Message 2 of 5 , May 31, 2003
      • 0 Attachment
        Larry,

        This is an oddity I've noticed in "Trim Blanks": when the last line
        selected ends with a one-letter word and no trailing space, Trim
        Blanks joins the last two words. For example, select one or more of
        these "before" lines; run Modify | Lines | Trim Blanks; then look at
        the bottom-most selected line.

        BEFORE:
        Who? It is I
        350 K
        11 7 5 3 2

        AFTER:
        Who? It isI
        350K
        11 7 5 32

        ---
        Mark B
        NoteTab Std 4.95, XP Home

        --- In ntb-clips@yahoogroups.com, Larry Thomas <larryt@c...> wrote:
        >
        >
        > When I run this clip on itself, it removes the space between ^!Jump
        and 1 which turns it into ^!Jump1 and causes the clip to fail. Is
        this a bug or what?
        >
      • hugo_paulissen
        For example, select one or more of ... at ... Mark, Indeed! Seems like a bug. You could use this instead... ^!Replace s+$ RWAS Hugo
        Message 3 of 5 , May 31, 2003
        • 0 Attachment
          For example, select one or more of
          > these "before" lines; run Modify | Lines | Trim Blanks; then look
          at
          > the bottom-most selected line.
          >
          > BEFORE:
          > Who? It is I
          > 350 K
          > 11 7 5 3 2
          >
          > AFTER:
          > Who? It isI
          > 350K
          > 11 7 5 32
          >


          Mark,

          Indeed! Seems like a bug.

          You could use this instead...

          ^!Replace "\s+$" >> "" RWAS

          Hugo
        • Ray Tomes
          ... Larry and Mark I ran Larry s clip on itself and on Mark s data and it worked fine and without bugs. I have NoteTab Lite 4.92 so the bug is not in that
          Message 4 of 5 , May 31, 2003
          • 0 Attachment
            Mark B. wrote:

            > This is an oddity I've noticed in "Trim Blanks": when the last line
            > selected ends with a one-letter word and no trailing space, Trim
            > Blanks joins the last two words. For example, select one or more of
            > these "before" lines; run Modify | Lines | Trim Blanks; then look at
            > the bottom-most selected line.
            >
            > BEFORE:
            > Who? It is I
            > 350 K
            > 11 7 5 3 2
            >
            > AFTER:
            > Who? It isI
            > 350K
            > 11 7 5 32


            Larry and Mark

            I ran Larry's clip on itself and on Mark's data and it worked fine and
            without bugs.

            I have NoteTab Lite 4.92 so the bug is not in that version.
            Do you need an upgrade?

            Ray
          • Sheri
            ... Yes, that does the same thing for me. I use auto trimming feature and it works fine (you do have to save and reload before trimmed result appears, but at
            Message 5 of 5 , May 31, 2003
            • 0 Attachment
              At 11:29 PM 5/31/03 +0000, you wrote:
              >For example, select one or more of
              >> these "before" lines; run Modify | Lines | Trim Blanks; then look
              >at
              >> the bottom-most selected line.
              >>
              >> BEFORE:
              >> Who? It is I
              >> 350 K
              >> 11 7 5 3 2
              >>
              >> AFTER:
              >> Who? It isI
              >> 350K
              >> 11 7 5 32
              >>
              >
              >
              >Mark,
              >
              >Indeed! Seems like a bug.
              >
              >You could use this instead...
              >
              >^!Replace "\s+$" >> "" RWAS
              >
              >Hugo

              Yes, that does the same thing for me.

              I use auto trimming feature and it works fine (you do have to save and reload before trimmed result appears, but at least you don't have to remember to trim blanks).

              View|Options|Documents|Trim White Spaces

              Regards,
              Sheri
            Your message has been successfully submitted and would be delivered to recipients shortly.