Loading ...
Sorry, an error occurred while loading the content.

Can't Install Microsoft Security Essentials (error "0x8004ff01")

Expand Messages
  • Ray Shapp
    To All, I keep getting error 0x8004ff01 when I attempt to install Microsoft Security Essentials. I am also unable to install the one Critical Update
    Message 1 of 1 , Nov 3, 2009
    • 0 Attachment
      To All,

      I keep getting error "0x8004ff01" when I attempt to install Microsoft Security
      Essentials. I am also unable to install the one "Critical Update" offered when
      I run Windows Update. That Critical Update is called, "Microsoft .NET
      Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET
      versions 2.0 through 3.5 (KB951847) x86".

      I posted this question on a WinXP help discussion group, and I have a long
      thread of ineffective suggestions. I can repeat the details of everything I
      tried, but for brevity, I'll just provide the following:

      Running WinXP Home with SP 3. This is a Dell Dimension 4550 purchased new from
      Dell. All Microsoft software passes validation.

      I use Firefox for other tasks, but all these update attempts were done using
      Internet Explorer v6.0.

      I am running with Administrative privilege on a stand-alone PC.

      I deleted all antivirus software.

      I ran the online antivirus Version: 7.1 (Beta) scan from HouseCall at>>>
      No threats were detected.

      I have no firewall except the firewall that comes with WinXP Home.

      I had downloaded the file


      from http://www.microsoft.com/Security_Essentials/

      That file seemed to execute ok. It validated my OS. Then it said it was
      installing MSE components, but after about three minutes, it gave me the
      "0x8004ff01". error and suggested I try installing again. After various
      "fixes", I've repeated this step with the same results about 6 or 8 times now.

      Maybe the Windows Installer is corrupt, therefore, I downloaded and executed
      WindowsXP-KB942288-v3-x86.exe from the following site:

      WindowsXP-KB942288-v3-x86 executed without error.

      I successfully installed Microsoft Baseline Security Analyzer 2.1. When I
      tried to execute MBSA, it failed with this error: "Windows Installer Service
      could not be accessed".

      Something is preventing me from installing the Windows Installer update. That
      may be the key to this whole problem, but I would be interested in your
      suggestions for other troubleshooting avenues as well.

      Thank you for your help.

      Ray Shapp
    Your message has been successfully submitted and would be delivered to recipients shortly.