Loading ...
Sorry, an error occurred while loading the content.
 

Re: [NTO] Double-Click Opens But Doesn't Play File

Expand Messages
  • Ray Shapp
    Hi Axel, With your help, I may (or may not) have located the problem.
    Message 1 of 19 , Jul 9, 2008
      Hi Axel,

      With your help, I may (or may not) have located the problem.

      <<It's all in the very first part HKCR (i.e. HKEY_CLASSES_ROOT)>>

      Here below my signature is a segment of the Registry of the new PC which I
      have exported. It shows that the Open command for WMV files is the Windows
      Media Player yet, when I look at file associations in
      Explorer-Tools-Option-File types, it shows Zoom Player as the associated
      application. I compared this part of the Registry with the same area of the
      Registry on the older (Dell 4550) PC. See both exported Registry branches
      below my signature. These branches of the Registries from the two PCs look
      identical.

      Please confirm that this is a real discrepancy. If it is, What would be the
      remedy? Alec has suggested uninstalling and re-installing Zoom Player using
      Revo Uninstaller. I haven't tried that, but I will unless you see a better
      fix.

      Thanks for your continuing help!

      Ray Shapp

      ***segment of Registry from Asus Quad 2.4MHz PC***

      Windows Registry Editor Version 5.00

      [HKEY_CLASSES_ROOT\WMVFile\shell\open]
      @="&Open"
      "LegacyDisable"=""

      [HKEY_CLASSES_ROOT\WMVFile\shell\open\command]
      @="\"C:\\Program Files\\Windows Media Player\\wmplayer.exe\" /prefetch:7 /Open
      \"%L\""

      [HKEY_CLASSES_ROOT\WMVFile\shell\open\DropTarget]
      "CLSID"="{CE3FB1D1-02AE-4a5f-A6E9-D9F1B4073E6C}"




      ***Segment of Registry from Older (Dell4550) PC***

      Windows Registry Editor Version 5.00

      [HKEY_CLASSES_ROOT\WMVFile\shell\open]
      @="&Open"
      "LegacyDisable"=""

      [HKEY_CLASSES_ROOT\WMVFile\shell\open\command]
      @="\"C:\\Program Files\\Windows Media Player\\wmplayer.exe\" /prefetch:7 /Open
      \"%L\""

      [HKEY_CLASSES_ROOT\WMVFile\shell\open\DropTarget]
      "CLSID"="{CE3FB1D1-02AE-4a5f-A6E9-D9F1B4073E6C}"
    • Axel Berger
      ... Not as such. As in both cases the WMPlayer is not opened but your Zoom player is, those two branches must be irrelevant. Please go and check what the
      Message 2 of 19 , Jul 9, 2008
        Ray Shapp wrote:
        > Please confirm that this is a real discrepancy.

        Not as such. As in both cases the WMPlayer is not opened but your
        Zoom player is, those two branches must be irrelevant. Please go and
        check what the <.WMV> entry above really points at. It can't be
        <WMFfile> but will probably be something like <WMV_auto_file>. What
        ever it is, this is the key you need to check.

        Axel
      • Alec Burgess
        ... Ray: I encourage you to attempt to continue to investigate a registry tweak to resolve your problem since more knowledge/experimentation is always a
        Message 3 of 19 , Jul 9, 2008
          Ray Shapp (ras45@...) wrote (in part) (on 7/9/2008 at 5:07 AM):
          > Please confirm that this is a real discrepancy. If it is, What would
          > be the
          > remedy? Alec has suggested uninstalling and re-installing Zoom Player
          > using
          > Revo Uninstaller. I haven't tried that, but I will unless you see a
          > better
          > fix.
          Ray: I encourage you to attempt to continue to investigate a registry
          "tweak" to resolve your problem since more knowledge/experimentation is
          always a "good thing (tm)" however IMO - uninstall/reinstall of a
          program is almost always a zero-risk, minimal time attempt and likely
          (though not guaranteed) way to correct mysterious problems.

          That said you can combine the two approaches by the following method:
          Get InstallRite (google for it) and Revo Uninstaller (you may have
          already got this?)

          InstallRite allows you to take a File-system and Registry snapshot, do
          "something" then redo the snapshot and compare the results in a
          tree-view. so .... assuming you elect to go this route ...

          1. in InstallRite - take the initial snapshot
          2. use Revo Uninstaller (with deep clean) to do the "normal
          uninstall" and then remove all traces it can find.
          3. reinstall ZoomPlayer
          4. if necessary - go into Zoom Player and set file-associations
          through there interface (options or something done while running
          the installer itself
          1. see if it works :-)
          5. in InstallRite - click Analyze
          1. review changes to your system as a result of (2) and (3)
          (4) above.


          Note: if you see while doing the snapshot that InstallRite is spending a
          lot of time checking file-system areas that you are not interested in
          (eg Tiff-cache) in Configure you can tell it to skip certain
          folders/disks/file-patterns etc.

          IF in 4.1 you find that now ZoomPlayer will open and play AVIs etc you
          s/b able to see exactly what the change was that made the difference.
          Note that by doing the snapshot BEFORE the initial uninstall and AFTER
          the reinstall and first execution you should be able to isolate just the
          changes.

          --
          Regards ... Alec (buralex@gmail)



          [Non-text portions of this message have been removed]
        • Ray Shapp
          Hi Alec and Axel, Thanks for the great ideas. Playing with InstallRite and Revo Uninstaller and ERUNT (in case I make a mess of things) should be an
          Message 4 of 19 , Jul 9, 2008
            Hi Alec and Axel,

            Thanks for the great ideas. Playing with InstallRite and Revo Uninstaller and
            ERUNT (in case I make a mess of things) should be an interesting adventure.
            Unfortunately I have to drop this problem for a few days because my wife is in
            hospital (for relatively minor surgery). I will be Mr. Mom maybe until
            Saturday.

            I'll be back with results of the InstallRite comparison soon. Meanwhile, can
            you explain why HKEY_CLASSES_ROOT\WMVFile\shell\open\command on both PCs (see
            below) refers to Windows Media Player when the file association for WMV files
            is Zoom Player?

            Thanks again,

            Ray Shapp

            [HKEY_CLASSES_ROOT\WMVFile\shell\open\command]
            @="\"C:\\Program Files\\Windows Media Player\\wmplayer.exe\" /prefetch:7 /Open
            \"%L\""
          • Axel Berger
            ... I thought I already did. That subtree pertains to a hypothetical file class which probably never gets called. Your key defines that
            Message 5 of 19 , Jul 10, 2008
              Ray Shapp wrote:
              > Meanwhile, can you explain why
              > HKEY_CLASSES_ROOT\WMVFile\shell\open\command on both PCs (see
              > below) refers to Windows Media Player when the file association
              > for WMV files is Zoom Player?

              I thought I already did. That subtree pertains to a hypothetical
              file class <WMVfile> which probably never gets called. Your key
              <.WMV> defines that extension to be something else, probably
              <WMV_auto_file>, so that is where Windows looks what to do with
              *.wmv.

              Axel
            • Ray Shapp
              To All, I started this thread back in July of 2008. Axel tried to help me, but I never did resolve the issue. (I only partially understood his advice.)
              Message 6 of 19 , Mar 9, 2010
                To All,

                I started this thread back in July of 2008. Axel tried to help me, but I never
                did resolve the issue. (I only partially understood his advice.)

                Restating the problem:

                When I double click a multi-media file such as AVI, WMV, MP4 etc, or when I
                right click on such a file and then click OPEN, Zoom Player launches but the
                audio or video file does not play. If I click the PLAY icon in Zoom Player, I
                get the "No media loaded" message. If I drag the AV file onto the Zoom Player
                application window, the music or video plays normally. IOW, no further action
                is required after dropping the file onto the Zoom Player application window.

                I only recently discovered another symptom that might give you a clue as to
                how to fix my problem. If I right-click the AV file then select SEND TO... and
                click Zoom Player, the application launches and the file plays normally.

                I doubt the problem is with missing or corrupt codecs, and file associations
                point all AV file types to Zoom Player. I have the same version of Zoom Player
                and the same codecs installed on two different PCs. The older PC (Dell 4550)
                launches and plays all media files normally. The newer PC (home brew) has the
                problem as described above.

                Both PCs run WinXP Pro SP3.

                Any advice or trouble-shooting ideas?

                Thank you.

                Ray Shapp
              • Dave
                Hi to behave the way you want it has to be set as the default player for that media ,it sounds as though the is another media player set as default, have you
                Message 7 of 19 , Mar 10, 2010
                  Hi
                  to behave the way you want it has to be set as the default player for that
                  media ,it sounds as though the is another media player set as default, have
                  you installed another media player at all ??
                  THANKYOU DAVE M

                  ----- Original Message -----
                  From: "Ray Shapp" <ras45@...>
                  To: <ntb-OffTopic@yahoogroups.com>
                  Sent: Wednesday, March 10, 2010 5:28 PM
                  Subject: Re: [NTO] Double-Click Opens But Doesn't Play File


                  > To All,
                  >
                  > I started this thread back in July of 2008. Axel tried to help me, but I
                  > never
                  > did resolve the issue. (I only partially understood his advice.)
                  >
                  > Restating the problem:
                  >
                  > When I double click a multi-media file such as AVI, WMV, MP4 etc, or when
                  > I
                  > right click on such a file and then click OPEN, Zoom Player launches but
                  > the
                  > audio or video file does not play. If I click the PLAY icon in Zoom
                  > Player, I
                  > get the "No media loaded" message. If I drag the AV file onto the Zoom
                  > Player
                  > application window, the music or video plays normally. IOW, no further
                  > action
                  > is required after dropping the file onto the Zoom Player application
                  > window.
                  >
                  > I only recently discovered another symptom that might give you a clue as
                  > to
                  > how to fix my problem. If I right-click the AV file then select SEND TO...
                  > and
                  > click Zoom Player, the application launches and the file plays normally.
                  >
                  > I doubt the problem is with missing or corrupt codecs, and file
                  > associations
                  > point all AV file types to Zoom Player. I have the same version of Zoom
                  > Player
                  > and the same codecs installed on two different PCs. The older PC (Dell
                  > 4550)
                  > launches and plays all media files normally. The newer PC (home brew) has
                  > the
                  > problem as described above.
                  >
                  > Both PCs run WinXP Pro SP3.
                  >
                  > Any advice or trouble-shooting ideas?
                  >
                  > Thank you.
                  >
                  > Ray Shapp
                  >
                  >
                  >
                  >
                  > ------------------------------------
                  >
                  > Yahoo! Groups Links
                  >
                  >
                  >
                  >
                • Ray Shapp
                  To All, I just noticed that in Zoom Player Options File Associations, the Play checkbox was unmarked. After I inserted a checkmark, media files now play
                  Message 8 of 19 , Mar 10, 2010
                    To All,

                    I just noticed that in Zoom Player Options > File Associations, the "Play"
                    checkbox was unmarked. After I inserted a checkmark, media files now play
                    immediately when Zoom Player launches.

                    Problem solved!

                    Ray Shapp
                  • Ray Shapp
                    Hi Dave, Thanks for the reply. Zoom Player is the default player in the
                    Message 9 of 19 , Mar 11, 2010
                      Hi Dave,


                      Thanks for the reply.


                      <<to behave the way you want it has to be set as the default player for that
                      media>>

                      Zoom Player is the "default" player in the sense that it is associated with
                      the file multimedia types such as AVI, MP4. WMV etc. That's why Zoom Player
                      always launches when I double click one of those types of file. After
                      launching the application, I was baffled as to why the video or audio clip
                      would not autostart.

                      Our emails must have crossed. As I said earlier, the solution was to mark the
                      "Play" checkbox within Zoom Player.

                      Regards,

                      Ray Shapp
                    Your message has been successfully submitted and would be delivered to recipients shortly.