Loading ...
Sorry, an error occurred while loading the content.

Re: [NTO] Double-Click Opens But Doesn't Play File

Expand Messages
  • Alec Burgess
    Axel Berger (Axel-Berger@nexgo.de) wrote (in part) (on 7/8/2008 at 1:56 ... Good point Axel - If that is the problem I think using
    Message 1 of 19 , Jul 7, 2008
    • 0 Attachment
      Axel Berger (Axel-Berger@...) wrote (in part) (on 7/8/2008 at 1:56
      AM):
      > Ray Shapp wrote:
      > > I have exactly duplicated all the ZP options on both PCs
      >
      > Look into the registry and compare the entries for those two file
      > types. My guess are quotes around the "%1" -- media file names
      > typically contain spaces.
      Good point Axel - If that is the problem I "think" using
      Explorer-Tools-Option-File types should correct that. I've used
      ZoomPlayer in the past (not currently installed) and don't recall any
      problems suggestive of the installer / options settings for ZoomPlayer
      having a problem with them - you'd think it would have been corrected
      long ago - n'est ce pas?

      --
      Regards ... Alec (buralex@gmail)
    • Axel Berger
      ... I seem to remember that while most installers do it right, associating a file type through the open with dialog tends to omit those quotes. ... I m not
      Message 2 of 19 , Jul 8, 2008
      • 0 Attachment
        Alec Burgess wrote:
        > you'd think it would have been corrected long ago - n'est ce pas?

        I seem to remember that while most installers do it right, associating a
        file type through the "open with" dialog tends to omit those quotes.

        > Explorer-Tools-Option-File types

        I'm not the GUI type myself, which is why I prefer NoteTab to, say,
        Frontpage, so I suggest the easiest way is editing the registry directly
        through regedit.
        And if you do as I say and always back up the registry beforehand it is
        quite safe too. If on the other hand, you do as I do, you may be in for
        the interesting afternoon every once in a while.

        Axel
      • Axel Berger
        ... No. As Ray said, clicking the file does open the right program but that fails to find the file. So the assciation as such is correct. In same cases it is
        Message 3 of 19 , Jul 8, 2008
        • 0 Attachment
          Alec Burgess wrote:
          > Is it possible that you have inadvertently set some option in Media
          > Player that is silently blocking attempts to change file associations
          > - or have some third party spyware guard that is doing this w/o your
          > knowledge? (This one is pretty unlikely IMO).

          No. As Ray said, clicking the file does open the right program but that
          fails to find the file. So the assciation as such is correct. In same
          cases it is not the command line for open at fault but the entry under
          ddeexec. But as there is one computer doing it correctly and one not, it
          is simply a case of looking into the registries and comparing.

          Axel
        • Ray Shapp
          HI Axel and Alec, Thank you both for your great help. My responses to your suggestions are interspersed below.
          Message 4 of 19 , Jul 8, 2008
          • 0 Attachment
            HI Axel and Alec,

            Thank you both for your great help.

            My responses to your suggestions are interspersed below.


            <<You don't say explicitly say that you have uninstaller and re-installed
            ZoomPlayer but I assume you have?>>

            Yes. I used the ZP uninstaller then ran CCleaner then got a fresh copy of ZP
            from http://www.inmatrix.com/zplayer/ (Note: I am running the same version of
            ZP on both machines.) I also scanned with Spyware Blaster, Spybot Search and
            Destroy, Ad Aware, AVG, and did several reboots. BTW, All scans show that I
            have a clean PC (no malware removals or repairs were necessary).


            <<checking your OP I see that YES it does work when opening within the
            ZPlayer. Okay, this sounds pretty simple - its "just" a matter of
            verifying the file association.>>

            I usually associate a new file type using Open With, but in this case, I took
            the extra steps to examine the associations by using
            Explorer-Tools-Option-File and in two cases, I changed AVI and WMV to Media
            Player Classic and then went back through Explorer-Tools-Option-File types to
            re-associate the two media types with ZP. No joy.


            <<But as there is one computer doing it correctly and one not, it is simply a
            case of looking into the registries and comparing.>>

            This may be the best advice, but I don't mess with the Registry very often. I
            do use ERUNT for Registry backup, so I will get into the Registries as a last
            resort. I know there is a way to export parts of the Registry. Please tell me
            where in the Registry I should look for the parts you suggest I should
            compare. I'll examine the two dumps side-by-side in NTP.


            << Install VLC (just google) - its another alternate video player 1a) Does VLC
            work? - interesting to know whether is ALL non-MediaPlayer
            or something special about>>

            I would like to try VLC again. I have used VLC v0.5.3 on the older PC, but I
            didn't like the interface. I just DLed VLC v0.8.6. The same test video and
            audio files that launch Zone Player but don't render do play immediately when
            I "Open With" VLC. There is nothing special about these media files. I've been
            playing some of them for years (Moonlight Sonata, Fur Elise, etc). (Note: I
            don't know how to insert u-umlaut into a plain text email.)


            <<Get Revo Uninstaller <snip>its just possible "something" is screwing up file
            associations or what have you for Zoom Player. Full disclosure - I don't
            really understand codecs but know they are important!>>

            I'd like to have a nice utility like this in any case, but I need some sleep
            before I go any farther. I doubt my problem is with file associations because
            double-clicking any of my media files does open ZP. I'll report whether Revo
            Uninstaller does any good later today. I may even get into the Registry later
            too.

            I agree that codecs are important, but that's an unlikely issue in this case
            because all the files render correctly if I use Send To to get them into ZP or
            if I use the Open File menu item within ZP. They just don't start
            automatically after they launch ZP via double-click.

            I didn't say explicitly, but I did try many combinations of options in ZP. The
            default options should be sufficient to get double-clicked media files into
            the Play List, but I also checked and unchecked all Play List options with no
            joy. I also exported the config file from the older (correctly working PC) and
            installed it on the new PC, but again no joy.

            Many thanks for your help.

            Ray Shapp
          • Dave
            Hi Ray when you deleted the extensions for the other players did they actually take I would close explorer down and start again ,the other thing did the icons
            Message 5 of 19 , Jul 8, 2008
            • 0 Attachment
              Hi Ray
              when you deleted the extensions for the other players did they actually take
              I would close explorer down and start again ,the other thing did the icons
              for the files change when you changed players ?
              THANKYOU DAVE M

              ----- Original Message -----
              From: "Ray Shapp" <ras45@...>
              To: <ntb-OffTopic@yahoogroups.com>
              Sent: Tuesday, July 08, 2008 10:16 PM
              Subject: Re: [NTO] Double-Click Opens But Doesn't Play File


              > HI Axel and Alec,
              >
              > Thank you both for your great help.
              >
              > My responses to your suggestions are interspersed below.
              >
              >
              > <<You don't say explicitly say that you have uninstaller and re-installed
              > ZoomPlayer but I assume you have?>>
              >
              > Yes. I used the ZP uninstaller then ran CCleaner then got a fresh copy of
              > ZP
              > from http://www.inmatrix.com/zplayer/ (Note: I am running the same
              > version of
              > ZP on both machines.) I also scanned with Spyware Blaster, Spybot Search
              > and
              > Destroy, Ad Aware, AVG, and did several reboots. BTW, All scans show that
              > I
              > have a clean PC (no malware removals or repairs were necessary).
              >
              >
              > <<checking your OP I see that YES it does work when opening within the
              > ZPlayer. Okay, this sounds pretty simple - its "just" a matter of
              > verifying the file association.>>
              >
              > I usually associate a new file type using Open With, but in this case, I
              > took
              > the extra steps to examine the associations by using
              > Explorer-Tools-Option-File and in two cases, I changed AVI and WMV to
              > Media
              > Player Classic and then went back through Explorer-Tools-Option-File types
              > to
              > re-associate the two media types with ZP. No joy.
              >
              >
              > <<But as there is one computer doing it correctly and one not, it is
              > simply a
              > case of looking into the registries and comparing.>>
              >
              > This may be the best advice, but I don't mess with the Registry very
              > often. I
              > do use ERUNT for Registry backup, so I will get into the Registries as a
              > last
              > resort. I know there is a way to export parts of the Registry. Please tell
              > me
              > where in the Registry I should look for the parts you suggest I should
              > compare. I'll examine the two dumps side-by-side in NTP.
              >
              >
              > << Install VLC (just google) - its another alternate video player 1a) Does
              > VLC
              > work? - interesting to know whether is ALL non-MediaPlayer
              > or something special about>>
              >
              > I would like to try VLC again. I have used VLC v0.5.3 on the older PC, but
              > I
              > didn't like the interface. I just DLed VLC v0.8.6. The same test video and
              > audio files that launch Zone Player but don't render do play immediately
              > when
              > I "Open With" VLC. There is nothing special about these media files. I've
              > been
              > playing some of them for years (Moonlight Sonata, Fur Elise, etc). (Note:
              > I
              > don't know how to insert u-umlaut into a plain text email.)
              >
              >
              > <<Get Revo Uninstaller <snip>its just possible "something" is screwing up
              > file
              > associations or what have you for Zoom Player. Full disclosure - I don't
              > really understand codecs but know they are important!>>
              >
              > I'd like to have a nice utility like this in any case, but I need some
              > sleep
              > before I go any farther. I doubt my problem is with file associations
              > because
              > double-clicking any of my media files does open ZP. I'll report whether
              > Revo
              > Uninstaller does any good later today. I may even get into the Registry
              > later
              > too.
              >
              > I agree that codecs are important, but that's an unlikely issue in this
              > case
              > because all the files render correctly if I use Send To to get them into
              > ZP or
              > if I use the Open File menu item within ZP. They just don't start
              > automatically after they launch ZP via double-click.
              >
              > I didn't say explicitly, but I did try many combinations of options in ZP.
              > The
              > default options should be sufficient to get double-clicked media files
              > into
              > the Play List, but I also checked and unchecked all Play List options with
              > no
              > joy. I also exported the config file from the older (correctly working PC)
              > and
              > installed it on the new PC, but again no joy.
              >
              > Many thanks for your help.
              >
              > Ray Shapp
              >
              >
              >
              > ------------------------------------
              >
              > Yahoo! Groups Links
              >
              >
              >
            • Ray Shapp
              Hi Dave,
              Message 6 of 19 , Jul 8, 2008
              • 0 Attachment
                Hi Dave,

                <<when you deleted the extensions for the other players did they actually take
                >>

                When I changed the file associations, double-clicking did launch the correct
                application. In the case of Zoom Player, the files did not get added to the
                Play List, therefore, they did not play. When the file association was with
                VLC, the files not only launched VLC but they began to play immediately.


                <<I would close explorer down and start again>>

                I not only closed Windows Explorer, I actually rebooted between changing the
                file associations.


                <<did the icons for the files change when you changed players>>

                I didn't notice.

                Ray Shapp
              • Axel Berger
                ... It s all in the very first part HKCR (i.e. HKEY_CLASSES_ROOT). First look at the entry beginning with a dot as in . All this usually does is define
                Message 7 of 19 , Jul 8, 2008
                • 0 Attachment
                  Ray Shapp wrote:
                  > Please tell me where in the Registry I should look for the parts
                  > you suggest I should compare. I'll examine the two dumps
                  > side-by-side in NTP.

                  It's all in the very first part HKCR (i.e. HKEY_CLASSES_ROOT). First
                  look at the entry beginning with a dot as in <.WMV>. All this usually
                  does is define the (internal, not display) name of the file type. In my
                  case this is <WMVFile>. Theb go further down to look at the entry for
                  <WMVFile> -> shell -> open -> command. The content is a DOS commandline,
                  in my case <"E:\W98-Prog\Windows Media Player\mplayer2.exe" "%1">.

                  Sometimes <open> contains a <ddeexec> besides the <command>. I don't
                  know what it's for exactly, but if present it seems to be important.

                  Axel
                • Ray Shapp
                  Hi Axel, With your help, I may (or may not) have located the problem.
                  Message 8 of 19 , Jul 9, 2008
                  • 0 Attachment
                    Hi Axel,

                    With your help, I may (or may not) have located the problem.

                    <<It's all in the very first part HKCR (i.e. HKEY_CLASSES_ROOT)>>

                    Here below my signature is a segment of the Registry of the new PC which I
                    have exported. It shows that the Open command for WMV files is the Windows
                    Media Player yet, when I look at file associations in
                    Explorer-Tools-Option-File types, it shows Zoom Player as the associated
                    application. I compared this part of the Registry with the same area of the
                    Registry on the older (Dell 4550) PC. See both exported Registry branches
                    below my signature. These branches of the Registries from the two PCs look
                    identical.

                    Please confirm that this is a real discrepancy. If it is, What would be the
                    remedy? Alec has suggested uninstalling and re-installing Zoom Player using
                    Revo Uninstaller. I haven't tried that, but I will unless you see a better
                    fix.

                    Thanks for your continuing help!

                    Ray Shapp

                    ***segment of Registry from Asus Quad 2.4MHz PC***

                    Windows Registry Editor Version 5.00

                    [HKEY_CLASSES_ROOT\WMVFile\shell\open]
                    @="&Open"
                    "LegacyDisable"=""

                    [HKEY_CLASSES_ROOT\WMVFile\shell\open\command]
                    @="\"C:\\Program Files\\Windows Media Player\\wmplayer.exe\" /prefetch:7 /Open
                    \"%L\""

                    [HKEY_CLASSES_ROOT\WMVFile\shell\open\DropTarget]
                    "CLSID"="{CE3FB1D1-02AE-4a5f-A6E9-D9F1B4073E6C}"




                    ***Segment of Registry from Older (Dell4550) PC***

                    Windows Registry Editor Version 5.00

                    [HKEY_CLASSES_ROOT\WMVFile\shell\open]
                    @="&Open"
                    "LegacyDisable"=""

                    [HKEY_CLASSES_ROOT\WMVFile\shell\open\command]
                    @="\"C:\\Program Files\\Windows Media Player\\wmplayer.exe\" /prefetch:7 /Open
                    \"%L\""

                    [HKEY_CLASSES_ROOT\WMVFile\shell\open\DropTarget]
                    "CLSID"="{CE3FB1D1-02AE-4a5f-A6E9-D9F1B4073E6C}"
                  • Axel Berger
                    ... Not as such. As in both cases the WMPlayer is not opened but your Zoom player is, those two branches must be irrelevant. Please go and check what the
                    Message 9 of 19 , Jul 9, 2008
                    • 0 Attachment
                      Ray Shapp wrote:
                      > Please confirm that this is a real discrepancy.

                      Not as such. As in both cases the WMPlayer is not opened but your
                      Zoom player is, those two branches must be irrelevant. Please go and
                      check what the <.WMV> entry above really points at. It can't be
                      <WMFfile> but will probably be something like <WMV_auto_file>. What
                      ever it is, this is the key you need to check.

                      Axel
                    • Alec Burgess
                      ... Ray: I encourage you to attempt to continue to investigate a registry tweak to resolve your problem since more knowledge/experimentation is always a
                      Message 10 of 19 , Jul 9, 2008
                      • 0 Attachment
                        Ray Shapp (ras45@...) wrote (in part) (on 7/9/2008 at 5:07 AM):
                        > Please confirm that this is a real discrepancy. If it is, What would
                        > be the
                        > remedy? Alec has suggested uninstalling and re-installing Zoom Player
                        > using
                        > Revo Uninstaller. I haven't tried that, but I will unless you see a
                        > better
                        > fix.
                        Ray: I encourage you to attempt to continue to investigate a registry
                        "tweak" to resolve your problem since more knowledge/experimentation is
                        always a "good thing (tm)" however IMO - uninstall/reinstall of a
                        program is almost always a zero-risk, minimal time attempt and likely
                        (though not guaranteed) way to correct mysterious problems.

                        That said you can combine the two approaches by the following method:
                        Get InstallRite (google for it) and Revo Uninstaller (you may have
                        already got this?)

                        InstallRite allows you to take a File-system and Registry snapshot, do
                        "something" then redo the snapshot and compare the results in a
                        tree-view. so .... assuming you elect to go this route ...

                        1. in InstallRite - take the initial snapshot
                        2. use Revo Uninstaller (with deep clean) to do the "normal
                        uninstall" and then remove all traces it can find.
                        3. reinstall ZoomPlayer
                        4. if necessary - go into Zoom Player and set file-associations
                        through there interface (options or something done while running
                        the installer itself
                        1. see if it works :-)
                        5. in InstallRite - click Analyze
                        1. review changes to your system as a result of (2) and (3)
                        (4) above.


                        Note: if you see while doing the snapshot that InstallRite is spending a
                        lot of time checking file-system areas that you are not interested in
                        (eg Tiff-cache) in Configure you can tell it to skip certain
                        folders/disks/file-patterns etc.

                        IF in 4.1 you find that now ZoomPlayer will open and play AVIs etc you
                        s/b able to see exactly what the change was that made the difference.
                        Note that by doing the snapshot BEFORE the initial uninstall and AFTER
                        the reinstall and first execution you should be able to isolate just the
                        changes.

                        --
                        Regards ... Alec (buralex@gmail)



                        [Non-text portions of this message have been removed]
                      • Ray Shapp
                        Hi Alec and Axel, Thanks for the great ideas. Playing with InstallRite and Revo Uninstaller and ERUNT (in case I make a mess of things) should be an
                        Message 11 of 19 , Jul 9, 2008
                        • 0 Attachment
                          Hi Alec and Axel,

                          Thanks for the great ideas. Playing with InstallRite and Revo Uninstaller and
                          ERUNT (in case I make a mess of things) should be an interesting adventure.
                          Unfortunately I have to drop this problem for a few days because my wife is in
                          hospital (for relatively minor surgery). I will be Mr. Mom maybe until
                          Saturday.

                          I'll be back with results of the InstallRite comparison soon. Meanwhile, can
                          you explain why HKEY_CLASSES_ROOT\WMVFile\shell\open\command on both PCs (see
                          below) refers to Windows Media Player when the file association for WMV files
                          is Zoom Player?

                          Thanks again,

                          Ray Shapp

                          [HKEY_CLASSES_ROOT\WMVFile\shell\open\command]
                          @="\"C:\\Program Files\\Windows Media Player\\wmplayer.exe\" /prefetch:7 /Open
                          \"%L\""
                        • Axel Berger
                          ... I thought I already did. That subtree pertains to a hypothetical file class which probably never gets called. Your key defines that
                          Message 12 of 19 , Jul 10, 2008
                          • 0 Attachment
                            Ray Shapp wrote:
                            > Meanwhile, can you explain why
                            > HKEY_CLASSES_ROOT\WMVFile\shell\open\command on both PCs (see
                            > below) refers to Windows Media Player when the file association
                            > for WMV files is Zoom Player?

                            I thought I already did. That subtree pertains to a hypothetical
                            file class <WMVfile> which probably never gets called. Your key
                            <.WMV> defines that extension to be something else, probably
                            <WMV_auto_file>, so that is where Windows looks what to do with
                            *.wmv.

                            Axel
                          • Ray Shapp
                            To All, I started this thread back in July of 2008. Axel tried to help me, but I never did resolve the issue. (I only partially understood his advice.)
                            Message 13 of 19 , Mar 9 10:28 PM
                            • 0 Attachment
                              To All,

                              I started this thread back in July of 2008. Axel tried to help me, but I never
                              did resolve the issue. (I only partially understood his advice.)

                              Restating the problem:

                              When I double click a multi-media file such as AVI, WMV, MP4 etc, or when I
                              right click on such a file and then click OPEN, Zoom Player launches but the
                              audio or video file does not play. If I click the PLAY icon in Zoom Player, I
                              get the "No media loaded" message. If I drag the AV file onto the Zoom Player
                              application window, the music or video plays normally. IOW, no further action
                              is required after dropping the file onto the Zoom Player application window.

                              I only recently discovered another symptom that might give you a clue as to
                              how to fix my problem. If I right-click the AV file then select SEND TO... and
                              click Zoom Player, the application launches and the file plays normally.

                              I doubt the problem is with missing or corrupt codecs, and file associations
                              point all AV file types to Zoom Player. I have the same version of Zoom Player
                              and the same codecs installed on two different PCs. The older PC (Dell 4550)
                              launches and plays all media files normally. The newer PC (home brew) has the
                              problem as described above.

                              Both PCs run WinXP Pro SP3.

                              Any advice or trouble-shooting ideas?

                              Thank you.

                              Ray Shapp
                            • Dave
                              Hi to behave the way you want it has to be set as the default player for that media ,it sounds as though the is another media player set as default, have you
                              Message 14 of 19 , Mar 10 4:39 AM
                              • 0 Attachment
                                Hi
                                to behave the way you want it has to be set as the default player for that
                                media ,it sounds as though the is another media player set as default, have
                                you installed another media player at all ??
                                THANKYOU DAVE M

                                ----- Original Message -----
                                From: "Ray Shapp" <ras45@...>
                                To: <ntb-OffTopic@yahoogroups.com>
                                Sent: Wednesday, March 10, 2010 5:28 PM
                                Subject: Re: [NTO] Double-Click Opens But Doesn't Play File


                                > To All,
                                >
                                > I started this thread back in July of 2008. Axel tried to help me, but I
                                > never
                                > did resolve the issue. (I only partially understood his advice.)
                                >
                                > Restating the problem:
                                >
                                > When I double click a multi-media file such as AVI, WMV, MP4 etc, or when
                                > I
                                > right click on such a file and then click OPEN, Zoom Player launches but
                                > the
                                > audio or video file does not play. If I click the PLAY icon in Zoom
                                > Player, I
                                > get the "No media loaded" message. If I drag the AV file onto the Zoom
                                > Player
                                > application window, the music or video plays normally. IOW, no further
                                > action
                                > is required after dropping the file onto the Zoom Player application
                                > window.
                                >
                                > I only recently discovered another symptom that might give you a clue as
                                > to
                                > how to fix my problem. If I right-click the AV file then select SEND TO...
                                > and
                                > click Zoom Player, the application launches and the file plays normally.
                                >
                                > I doubt the problem is with missing or corrupt codecs, and file
                                > associations
                                > point all AV file types to Zoom Player. I have the same version of Zoom
                                > Player
                                > and the same codecs installed on two different PCs. The older PC (Dell
                                > 4550)
                                > launches and plays all media files normally. The newer PC (home brew) has
                                > the
                                > problem as described above.
                                >
                                > Both PCs run WinXP Pro SP3.
                                >
                                > Any advice or trouble-shooting ideas?
                                >
                                > Thank you.
                                >
                                > Ray Shapp
                                >
                                >
                                >
                                >
                                > ------------------------------------
                                >
                                > Yahoo! Groups Links
                                >
                                >
                                >
                                >
                              • Ray Shapp
                                To All, I just noticed that in Zoom Player Options File Associations, the Play checkbox was unmarked. After I inserted a checkmark, media files now play
                                Message 15 of 19 , Mar 10 5:38 AM
                                • 0 Attachment
                                  To All,

                                  I just noticed that in Zoom Player Options > File Associations, the "Play"
                                  checkbox was unmarked. After I inserted a checkmark, media files now play
                                  immediately when Zoom Player launches.

                                  Problem solved!

                                  Ray Shapp
                                • Ray Shapp
                                  Hi Dave, Thanks for the reply. Zoom Player is the default player in the
                                  Message 16 of 19 , Mar 11 3:37 PM
                                  • 0 Attachment
                                    Hi Dave,


                                    Thanks for the reply.


                                    <<to behave the way you want it has to be set as the default player for that
                                    media>>

                                    Zoom Player is the "default" player in the sense that it is associated with
                                    the file multimedia types such as AVI, MP4. WMV etc. That's why Zoom Player
                                    always launches when I double click one of those types of file. After
                                    launching the application, I was baffled as to why the video or audio clip
                                    would not autostart.

                                    Our emails must have crossed. As I said earlier, the solution was to mark the
                                    "Play" checkbox within Zoom Player.

                                    Regards,

                                    Ray Shapp
                                  Your message has been successfully submitted and would be delivered to recipients shortly.