Loading ...
Sorry, an error occurred while loading the content.

Regular Expressions

Expand Messages
  • h.paulissen@facburfdcw.unimaas.nl
    Alec, I brought this OT... ... I guess so... Although Alan C. stated that there is a different meaning for d and [ d] I can t see the reason for that. d *to
    Message 1 of 2 , Sep 4, 2002
      Alec, I brought this OT...

      > Same thing on my Win98 ...NtbPro 4.91:
      > "/d" - works, "[\d]" finds "d" Looks like \d isn't special inside
      > a character class, hence get interpret as \+<any char> = <any
      > char>

      I guess so... Although Alan C. stated that there is a different
      meaning for \d and [\d] I can't see the reason for that. \d *to me*
      means 'any digit', where [\d] stands for '[any digit]'. Especially
      if you're looking for more complex patterns, the meaning of \d (and
      so forth) should not be altered when used in a character class.

      (NoteTab _does_ find a space with this pattern: [\s]. Help has even
      a better example:
      "\b any blank (white) space including space, tab, form-feed, etc.
      Equivalent to [\s\t\f\n\r]"
      But, if you try to run the latter you will find that it finds an f

      > the > TCL kit Alec proposed << (Visual regexp) finds the digits
      > and only the digits with either "\d" or [\d]".

      Same goes for the tool that you couldn't install. And
      ^[\d|\s|\.]+. finds "0 0 0. h" at the beginning of a line...

      > I think I ran into something similar some time ago.
      > I've adopted the habit of using [0123456780] or [0-9] instead of
      > \d and [a-zA-Z] etc when I need or want to use group character
      > classes. Though usually I make the mistake, guess what the
      > problem is and only then enumerate the class ;-)

      In NoteTab [0-9] inside a character class does not work either;
      been through that...

      > I guess this close to v5 the answer is:
      > It does what ever it does, if its not what it SHOULD be - sorry
      > about your luck ;-)

      <G> Right!

      About Padgett's Regular Expression Manager...
      > > See for yourself at:
      > > http://www.vbcity.com/pubs/article.asp?alias=regexp
      > I d/l'd, installed and tried to run this.
      > <offtopic now ....
      > When I tried to run this I got a warning box saying:
      > Run-time error '429':
      > ActiveX component can't create object.
      > The write-up for the program says its still in "beta". Last
      > comments were about six months ago. I signed up to the bulletin
      > board but have to wait for the confirmation e-mail before I can
      > attempt to ask the author what's likely to be wrong. By your
      > comments, I assume this did not occur to you ?

      No, I can run the app without problems and it does a fairly decent
      job. I don't know what prevents you from running the install
      program. Saying something about missing drivers or components would
      be a very wild guess from my side, possibly leading you further away
      from a solution <g>.

    Your message has been successfully submitted and would be delivered to recipients shortly.