Loading ...
Sorry, an error occurred while loading the content.

File Associations

Expand Messages
  • Jody
    Hi Ray, (This is brought over from the Basic list. The thread was Re: [NTB] icon question. The original is below the couple of paragraph s I replied to.)
    Message 1 of 2 , Mar 11 5:32 PM
    • 0 Attachment
      Hi Ray,

      (This is brought over from the Basic list. The thread was "Re:
      [NTB] icon question." The original is below the couple of
      paragraph's I replied to.)

      In case you did not get the problem fixed yet Ray, read on...

      >I wondered whether the problem is caused by multiple associations
      >for TXT and LOG, therefore, I tried to associate TXT with yet
      >another file type, but the Add New File Type screen wouldn't
      >permit it. Instead, I got an error screen that said ".txt" is
      >already in use by file type "NoHands.Document.1". What does THAT
      >mean????

      Beats me, but it appears that some program is trying to associate
      itself, perhaps every time you open it. The file types are in
      the registry. Type in txt and you should hop right to it.

      Something else you might want to try is go into File Types and
      delete the "NoHands.Document.1" entry. You might want to set the
      PasteBoard in NTB and copy the settings before deleting it.
      After that, click on a txt file and go through the motions that
      Windows wants.

      >Is there any way to see a listing of all extensions that have
      >associations?

      Open RegEdit.exe and click on the HotKey_Classes_Root - have fun
      scrolling. ;)

      original:
      On my computer, the NoteTab icon has recently also been hijacked
      by the NotePad icon, therefore I have been following this thread
      closely. This is new behavior. For years, the Swiss flag has
      been associated with all my new TXT and LOG files.

      In Win98 Explorer, View | Folder Options | File Types, TXT and
      LOG extensions are listed as associated with NTPro. The icon,
      however, is the Windows Start flag on a white background. I can
      click the Change Icon button and restore the Swiss flag icon and
      it DOES appear to have been changed while I am viewing the
      Registered File Types in the File Types screen. If I close the
      File Types screen and re-open it, the same windows flag on a
      white background will reappear for the NTPro icon.

      I tried rebooting after making the icon change, but it was no
      help. All the new files I create using NTPro have the NotePad
      icon. Older files that were created by NTPro are still showing
      the Swiss flag icon.

      Another strange condition is that the NotePad icon that keeps
      associating with my TXT and LOG files does NOT appear among the
      icons shown in the File Types screen. IOW, the offending icon is
      not associated with any registered type. Also, there is no entry
      on the File Types screen for NotePad.

      Following Jody's advice, in NTPro View | Options I removed and
      then re-added TXT and LOG in the Associated File Extensions on
      the Associations tab. And I rebooted. Still no help.

      I wondered whether the problem is caused by multiple associations
      for TXT and LOG, therefore, I tried to associate TXT with yet
      another file type, but the Add New File Type screen wouldn't
      permit it. Instead, I got an error screen that said ".txt" is
      already in use by file type "NoHands.Document.1". What does THAT
      mean????

      Is there any way to see a listing of all extensions that have
      associations? The File Types screen shows extensions for each
      registered file type, but it does so one type at a time.

      Sorry for such a long message, but this is maddening!

      Ray Shapp
      Watchung, NJ

      Happy Topics,
      Jody

      The NoteTab Off-Topic List
      mailto:ntb-OffTopic-Subscribe@yahoogroups.com
      mailto:ntb-OffTopic-UnSubscribe@yahoogroups.com
    • Jody
      Hi Ray and Others, I posted a message over here under this thread the other day. Some of you may have followed it through the Basic list also. Anyway, Ray said
      Message 2 of 2 , Mar 13 10:51 PM
      • 0 Attachment
        Hi Ray and Others,

        I posted a message over here under this thread the other day.
        Some of you may have followed it through the Basic list also.
        Anyway, Ray said to post his reply on this list if I thought it
        may be of use to somebody. I think it may be, at least sooner or
        later. ;) Thanks, Ray!

        Thanks for the personal email. I also saw the copy on the OT Group.

        >>Open RegEdit.exe and click on the HotKey_Classes_Root - have fun
        scrolling. ;)<<<<<

        Based on your suggestions, I gingerly edited my registry. This
        is the very first time I have ever made any manual changes to the
        registry. I'm amazed to see that it is 12 megabytes!

        I am using Norton's SystemWorks 2000. It includes a registry
        utility that permits multiple backups of the registry, and it
        also permits easy searching for text in the registry. I used it
        to find and delete all references to NoHands*.*

        I also discovered that I had more than one association for TXT
        files. In Explorer File Types, I removed all associations for
        TXT and LOG. I then used that same screen to add new
        associations for LOG and TXT that all point to NTP using the NTP
        icon.

        The result is that newly created TXT files and LOG files show a
        proper Swiss flag icon. Problem solved. Reboot wasn't even
        necessary!

        I never would have edited the registry if you hadn't encouraged
        me to do so. Thank you for that.

        If you think others would benefit from this exercise, please
        forward this to the OT Group.

        Thank you again *big time*.

        Ray Shapp
        Watchung, NJ

        Happy Topics,
        Jody

        The NoteTab Off-Topic List
        mailto:ntb-OffTopic-Subscribe@yahoogroups.com
        mailto:ntb-OffTopic-UnSubscribe@yahoogroups.com
      Your message has been successfully submitted and would be delivered to recipients shortly.