Loading ...
Sorry, an error occurred while loading the content.

SetDefaultValue does not work

Expand Messages
  • Axel Berger
    SetDefaultValue does not work. To be honest, I did not expect it to with list entries containing ^= . In my case in question the value list is read from a
    Message 1 of 1 , Nov 29, 2013
    View Source
    • 0 Attachment
      SetDefaultValue does not work. To be honest, I did not expect it to with
      list entries containing "^=". In my case in question the value list is
      read from a file and the typical entries look like

      Liber Annuus^=LA;2;3
      LithTec^=LithTec;2;3
      LoBUFA^=LoBUFA;0;1
      Man, New Series^=Man;2;3

      (Grown slowly from primitive beginnings. In some cases the visible entry
      is edited, in most it's just the abbreviation after the ^=.)
      The relevant lines in the clip are

      ^!Set %fNAM%=^$GetFileText(G:\PDF-neu\00c-Abbr.txt)$
      ^!Set %fNAM%=^$StrReplace("^P";"|";"^%fNAM%";FALSE;FALSE)$
      ^!Set %vNAM%=^?{(T=L,H=5)Zeitschrift=^%fNAM%}
      ^!IfCancel loop
      ^!Set %fNAM%=^$SetDefaultValue(^%fNAM%;^%vNAM%)$
      ^!SetArray %aNAM%=^%vNAM%

      The whole clip works fine without the SetDefaultValue line but with 419
      journals in the list and typically entering several articles from the
      same journal in a row it would help considerably.

      Axel

      --
      Dipl.-Ing. F. Axel Berger Tel: +49/ 2174/ 7439 07
      Johann-H├Ąck-Str. 14 Fax: +49/ 2174/ 7439 68
      D-51519 Odenthal-Heide eMail: Axel-Berger@...
      Deutschland (Germany) http://berger-odenthal.de
    Your message has been successfully submitted and would be delivered to recipients shortly.