Loading ...
Sorry, an error occurred while loading the content.

Running Php scripts on the SLUG

Expand Messages
  • chandersawh
    I have php 5.0.4-1 installed on my slug @ /opt/bin/php which is in my path. I am trying to cinfigure the web based portion of mp3 streaming program called
    Message 1 of 4 , Oct 2, 2005
    • 0 Attachment
      I have php 5.0.4-1 installed on my slug @ /opt/bin/php which is in my
      path. I am trying to cinfigure the web based portion of mp3 streaming
      program called 'jinzora2' via a web browser.

      I have the jinzora directory in my /home/user/www/jinzora2/*, however,
      when I point my browser to http://mysite.com/jinzora2/index.php I see
      the php script (source code) displayed instead on actual php web
      configuration page.

      I even set index.php to perrmission 0777 same output.

      How do I execute this php script and get the web config page?

      Thanks
    • Tim Bishop
      I got Jinzora running without any problems. It sounds like a web server configuration problem. Which webserver are you running? I installed the Apache and
      Message 2 of 4 , Oct 2, 2005
      • 0 Attachment
        I got Jinzora running without any problems. It sounds like a web server
        configuration problem. Which webserver are you running?

        I installed the Apache and php-apache packages, then went into the
        httpd.conf page and added .php to the list of files types to process.

        If you haven't already, I recommend creating simple php page <?php
        phpinfo(); ?> and getting that working before you try to get apps working.

        Thanks,
        Tim


        chandersawh wrote:
        > I have php 5.0.4-1 installed on my slug @ /opt/bin/php which is in my
        > path. I am trying to cinfigure the web based portion of mp3 streaming
        > program called 'jinzora2' via a web browser.
        >
        > I have the jinzora directory in my /home/user/www/jinzora2/*, however,
        > when I point my browser to http://mysite.com/jinzora2/index.php I see
        > the php script (source code) displayed instead on actual php web
        > configuration page.
        >
        > I even set index.php to perrmission 0777 same output.
        >
        > How do I execute this php script and get the web config page?
        >
        > Thanks
        >
        >
        >
        >
        >
        >
        > Yahoo! Groups Links
        >
        >
        >
        >
        >
        >
      • chandersawh
        I am running a second instance thttpd called mythttpd. Is this web server not compatable with php scripts? Thanks. PS: I will try running a simple php script
        Message 3 of 4 , Oct 3, 2005
        • 0 Attachment
          I am running a second instance 'thttpd' called mythttpd. Is this web
          server not compatable with php scripts?

          Thanks.

          PS: I will try running a simple php script as recommended.


          --- In nslu2-linux@yahoogroups.com, Tim Bishop <geodog@c...> wrote:
          > I got Jinzora running without any problems. It sounds like a web server
          > configuration problem. Which webserver are you running?
          >
          > I installed the Apache and php-apache packages, then went into the
          > httpd.conf page and added .php to the list of files types to process.
          >
          > If you haven't already, I recommend creating simple php page <?php
          > phpinfo(); ?> and getting that working before you try to get apps
          working.
          >
          > Thanks,
          > Tim
          >
          >
          > chandersawh wrote:
          > > I have php 5.0.4-1 installed on my slug @ /opt/bin/php which is in my
          > > path. I am trying to cinfigure the web based portion of mp3 streaming
          > > program called 'jinzora2' via a web browser.
          > >
          > > I have the jinzora directory in my /home/user/www/jinzora2/*, however,
          > > when I point my browser to http://mysite.com/jinzora2/index.php I see
          > > the php script (source code) displayed instead on actual php web
          > > configuration page.
          > >
          > > I even set index.php to perrmission 0777 same output.
          > >
          > > How do I execute this php script and get the web config page?
          > >
          > > Thanks
          > >
          > >
          > >
          > >
          > >
          > >
          > > Yahoo! Groups Links
          > >
          > >
          > >
          > >
          > >
          > >
        • Tim Bishop
          I believe you have to install a special version of thttpd, the package named php-thttpd to get php support, but I don t know if jinzora will work with it or
          Message 4 of 4 , Oct 3, 2005
          • 0 Attachment
            I believe you have to install a special version of thttpd, the package
            named php-thttpd to get php support, but I don't know if jinzora will
            work with it or not.

            Since Jinzora is tested with Apache, and I am used to Apache, I went
            with that.

            packages installed:
            apache
            php-apache
            mysql


            Good luck,
            Tim


            chandersawh wrote:
            > I am running a second instance 'thttpd' called mythttpd. Is this web
            > server not compatable with php scripts?
            >
            > Thanks.
            >
            > PS: I will try running a simple php script as recommended.
            >
            >
            > --- In nslu2-linux@yahoogroups.com, Tim Bishop <geodog@c...> wrote:
            >
            >>I got Jinzora running without any problems. It sounds like a web server
            >>configuration problem. Which webserver are you running?
            >>
            >>I installed the Apache and php-apache packages, then went into the
            >>httpd.conf page and added .php to the list of files types to process.
            >>
            >>If you haven't already, I recommend creating simple php page <?php
            >>phpinfo(); ?> and getting that working before you try to get apps
            >
            > working.
            >
            >>Thanks,
            >>Tim
            >>
            >>
            >>chandersawh wrote:
            >>
            >>>I have php 5.0.4-1 installed on my slug @ /opt/bin/php which is in my
            >>>path. I am trying to cinfigure the web based portion of mp3 streaming
            >>>program called 'jinzora2' via a web browser.
            >>>
            >>>I have the jinzora directory in my /home/user/www/jinzora2/*, however,
            >>>when I point my browser to http://mysite.com/jinzora2/index.php I see
            >>>the php script (source code) displayed instead on actual php web
            >>>configuration page.
            >>>
            >>>I even set index.php to perrmission 0777 same output.
            >>>
            >>>How do I execute this php script and get the web config page?
            >>>
            >>>Thanks
            >>>
            >>>
            >>>
            >>>
            >>>
            >>>
            >>>Yahoo! Groups Links
            >>>
            >>>
            >>>
            >>>
            >>>
            >>>
            >
            >
            >
            >
            >
            >
            >
            > Yahoo! Groups Links
            >
            >
            >
            >
            >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.