Loading ...
Sorry, an error occurred while loading the content.

Help - Any bash experts in the house?

Expand Messages
  • wibbleman11
    I have added scripts /opt/etc/bashrc and /root/.bashrc as per Unslug:Bash document or nslu2-lnux, and this seems to have messed up my logon somehow. I am
    Message 1 of 4 , Sep 2, 2005
    • 0 Attachment
      I have added scripts /opt/etc/bashrc and /root/.bashrc as
      per "Unslug:Bash" document or nslu2-lnux, and this seems to have
      messed up my logon somehow.

      I am using Dropbear and puTTY. When I log on it has changed the logon
      From "Enter password for root"
      to "Enter password for root@102.123.1.1"

      I have NOT changed the password, just added the two scripts above.

      Heres the snag, there were a few other problems i hadnt yet
      investigated/fixed;
      - for some reason telnet does accept connections
      - proftpd does not start up automatically yet
      - i get write permission errors if i try to change data in the
      privtae area using Linksys SMB via Ethernet.

      Any suggestions?

      (Apache/PHP etc is still running, all the passwords are known,
      surely
      theres a way in with some php script - but how to get the php script
      in?)


      Wibble
    • wibbleman11
      (Sorry, msg was corrupted on yahoo display) I enter root as normal, it then prompts me Enter password for root @ 123. 123. 123. 123 It looks like the bash
      Message 2 of 4 , Sep 2, 2005
      • 0 Attachment
        (Sorry, msg was corrupted on yahoo display)

        I enter "root" as normal, it then prompts me
        Enter password for "root @ 123. 123. 123. 123"

        It looks like the bash scripts have somehow changed to append the IP
        address and thus change the lookup?

        Wibble

        --- In nslu2-linux@yahoogroups.com, "wibbleman11" <wibbleman11@y...>
        wrote:
        > I have added scripts /opt/etc/bashrc and /root/.bashrc as
        > per "Unslug:Bash" document or nslu2-lnux, and this seems to have
        > messed up my logon somehow.
        >
        > I am using Dropbear and puTTY. When I log on it has changed the
        logon
        > From "Enter password for root"
        > to "Enter password for root@1..."
        >
        > I have NOT changed the password, just added the two scripts above.
        >
        > Heres the snag, there were a few other problems i hadnt yet
        > investigated/fixed;
        > - for some reason telnet does accept connections
        > - proftpd does not start up automatically yet
        > - i get write permission errors if i try to change data in the
        > privtae area using Linksys SMB via Ethernet.
        >
        > Any suggestions?
        >
        > (Apache/PHP etc is still running, all the passwords are known,
        > surely
        > theres a way in with some php script - but how to get the php
        script
        > in?)
        >
        >
        > Wibble
      • wibbleman11
        Another piece of detail, dont know if its relevant, but the script i copied into /root/.bashrc was the one in the example for user rather than for root ?
        Message 3 of 4 , Sep 2, 2005
        • 0 Attachment
          Another piece of detail, dont know if its relevant, but the script i
          copied into /root/.bashrc was the one in the example for "user"
          rather than for "root"?

          Wibble

          --- In nslu2-linux@yahoogroups.com, "wibbleman11" <wibbleman11@y...>
          wrote:
          > (Sorry, msg was corrupted on yahoo display)
          >
          > I enter "root" as normal, it then prompts me
          > Enter password for "root @ 123. 123. 123. 123"
          >
          > It looks like the bash scripts have somehow changed to append the
          IP
          > address and thus change the lookup?
          >
          > Wibble
          >
          > --- In nslu2-linux@yahoogroups.com, "wibbleman11"
          <wibbleman11@y...>
          > wrote:
          > > I have added scripts /opt/etc/bashrc and /root/.bashrc as
          > > per "Unslug:Bash" document or nslu2-lnux, and this seems to have
          > > messed up my logon somehow.
          > >
          > > I am using Dropbear and puTTY. When I log on it has changed the
          > logon
          > > From "Enter password for root"
          > > to "Enter password for root@1..."
          > >
          > > I have NOT changed the password, just added the two scripts
          above.
          > >
          > > Heres the snag, there were a few other problems i hadnt yet
          > > investigated/fixed;
          > > - for some reason telnet does accept connections
          > > - proftpd does not start up automatically yet
          > > - i get write permission errors if i try to change data in the
          > > privtae area using Linksys SMB via Ethernet.
          > >
          > > Any suggestions?
          > >
          > > (Apache/PHP etc is still running, all the passwords are known,
          > > surely
          > > theres a way in with some php script - but how to get the php
          > script
          > > in?)
          > >
          > >
          > > Wibble
        • Kai Steinbach
          Hi Wibble ... Do you have a diversion script in place that starts telnet on the slug during reboot? Or have you enabled it from the web interface? ... FAQ:
          Message 4 of 4 , Sep 4, 2005
          • 0 Attachment
            Hi Wibble

            On 02/09/05, wibbleman11 wrote:
            > - for some reason telnet does accept connections

            Do you have a diversion script in place that starts telnet on the slug
            during reboot?
            Or have you enabled it from the web interface?

            > [snip] ... and this seems to have
            > messed up my logon somehow.

            FAQ: Recovery from this kind of things on Unslung 5.x is usually to
            boot without disk, enable telnet on the web (admin/admin), telnet in
            (root/uNSLUng), hotplug the disk and clean up the mess. Then reboot
            with disk again to get back to normal ...

            Can I ask you to add this to the FAQ troubleshooting section, please?

            > - i get write permission errors if i try to change data in the
            > privtae area using Linksys SMB via Ethernet.

            Quota check still running? (search FAQ for "readonly")
            Or drive needs a fsck? http://www.nslu2-linux.org/wiki/FAQ/RepairingDiskErrors

            HTH - Kai
          Your message has been successfully submitted and would be delivered to recipients shortly.