Loading ...
Sorry, an error occurred while loading the content.

SWAT

Expand Messages
  • joshspotts
    Trying to get SWAT running and so far I ve been unsuccessful. Checked the logs (log.swat in particular) and I see this: [2005/07/31 12:16:32, 0]
    Message 1 of 1 , Jul 31, 2005
    • 0 Attachment
      Trying to get SWAT running and so far I've been unsuccessful.
      Checked the logs (log.swat in particular) and I see this:

      [2005/07/31 12:16:32, 0] source/param/loadparm.c:map_parameter(2462)
      Unknown parameter encountered: "client code page"
      [2005/07/31 12:16:32, 0] source/param/loadparm.c:lp_do_parameter
      (3144)
      Ignoring unknown parameter "client code page"

      My system is running unslung-5.5-beta with the Linksys V2.3R29
      firmware. I have bash, bind, cron, nano, ncurses, openldap-libs,
      openssh, openssl, samba (3.0.14a-6), xget, xinetd, zlib. And
      various other support packages and so on. All packages are up to
      date as of this posting.

      I have the redirection script for enabling swat, as mentioned in
      wiki, installed in my /unslung directory. And I have even tried
      starting swat by putting the service file "swat" in my xinetd.d
      directory with this configuration;

      default: off
      # description: SWAT is the Samba Web Admin Tool. Use swat \
      # to configure your Samba server. To use SWAT, \
      # connect to port 901 with your favorite web browser.
      service swat
      {
      port = 901
      socket_type = stream
      wait = no
      user = root
      server = /opt/sbin/swat
      log_on_failure += USERID
      disable = no
      }

      I also have 901/tcp in the services file in /etc (really though it
      was already in there when I checked).

      When I go to http://192.169.1.77:901/ I just get the "This page
      cannot be displayed" error.

      I should also note that only when I go to /opt/sbin and run swat (by
      entering "swat" and hitting return) does the error above in the
      log.swat file get generated (the process appears to start and I am
      not returned to shell prompt). I've checked to see and it does
      appear that a process is started when I run swat from the command
      line (checked by starting another ssh session). But still no
      response when I attempt to web access. The error doesn't appear to
      be generated at reboot.

      Any suggestions would be greatly appreciated, Thanks.
    Your message has been successfully submitted and would be delivered to recipients shortly.