Loading ...
Sorry, an error occurred while loading the content.
 

Re: Problem with openvpn start script

Expand Messages
  • mbanditt
    ... BROKEN_PACKAGES. ... get ... Thanks for your help, Øyvind. I m sorry, feeling very dumb. As I said before, I don t know anything about monotone, bitbake
    Message 1 of 29 , Jul 1, 2005
      > atftp seems to be broken at the moment. I moved it to
      BROKEN_PACKAGES.
      > If you do a monotone pull (in the openembedded directory) you should
      get
      > the change.
      >
      > Øyvind

      Thanks for your help, Øyvind. I'm sorry, feeling very dumb. As I
      said
      before, I don't know anything about monotone, bitbake and bitkeeper.

      Tried, what you said:

      # cd openembedded
      # monotone pull
      monotone: warning: doing anonymous pull
      monotone: connecting to monotone.nslu2-linux.org
      monotone: rebuilding merkle trees for collection org
      monotone: including branch org.openembedded.dev
      monotone: including branch org.openembedded.nslu2-linux
      monotone: including branch org.nslu2-linux.dev
      monotone: [certs: 114] [keys: 7]
      monotone: [bytes in: 6453] [bytes out: 1393] [certs in: 9] [revs in:
      3]
      monotone: verifying new revisions (this may take a while)
      monotone: successful exchange with monotone.nslu2-linux.org
      monotone: [bytes in: 6453] [bytes out: 1407] [certs in: 9] [revs in:
      3]

      Then started the build again:
      # cd ..
      # make openslug-build
      ( cd openslug ; make )
      make[1]: Entering directory `/opt/test/nslu2/openslug'
      ( source setup-env ; bitbake openslug-packages )
      Environment set up for OpenSlug development.
      NOTE: Using cache in '/opt/test/nslu2/openslug/tmp/cache'
      NOTE: Parsing finished. 538 cached, 0 parsed, 25 skipped, 0 masked.
      NOTE: build 200507011251: started

      OE Build Configuration:
      TARGET_ARCH = "armeb"
      TARGET_OS = "linux"
      MACHINE = "nslu2"
      DISTRO = "openslug"
      TARGET_FPU = "soft"

      NOTE: package openslug-image-1.0: started
      NOTE: package openslug-image-1.0-r13: task do_fetch: started
      NOTE: package openslug-image-1.0-r13: task do_fetch: completed
      NOTE: package openslug-image-1.0-r13: task do_rootfs: started
      NOTE: package openslug-image-1.0-r13: task do_rootfs: completed
      NOTE: package openslug-image-1.0-r13: task do_build: started
      NOTE: package openslug-image-1.0-r13: task do_build: completed
      NOTE: package openslug-image-1.0: completed
      NOTE: package atftp-0.7: started
      NOTE: package atftp-0.7-r1: task do_fetch: started
      NOTE: package atftp-0.7-r1: task do_fetch: completed
      NOTE: package atftp-0.7-r1: task do_compile: started
      ERROR: function do_compile failed
      ERROR: see log in
      /opt/test/nslu2/openslug/tmp/work/atftp-0.7-r1/tem
      p/log.do_compile.25097
      NOTE: Task failed:
      /opt/test/nslu2/openslug/tmp/work/atftp-0.7-r1/tem
      p/log.do_compile.25097
      NOTE: package atftp-0.7-r1: task do_compile: failed
      ERROR: TaskFailed event exception, aborting
      NOTE: package atftp-0.7: failed
      ERROR: Build of openslug-packages failed
      make[1]: *** [openslug-firmware] Fehler 1
      make[1]: Leaving directory `/opt/test/nslu2/openslug'
      make: *** [openslug-build] Fehler 2

      Do I need to delete some files in the cache, perhaps? Or should I
      remove the whole cache and start the build all over again?

      Michael
    • Øyvind Repvik
      ... My bad. Enter the openslug directory, then source setup-env and bitbake -cclean atftp to clean out the atftp build dir and stamps. Then you can try
      Message 2 of 29 , Jul 1, 2005
        mbanditt wrote:
        >
        > Do I need to delete some files in the cache, perhaps? Or should I
        > remove the whole cache and start the build all over again?

        My bad. Enter the openslug directory, then "source setup-env" and
        "bitbake -cclean atftp" to clean out the atftp build dir and stamps.
        Then you can try again.

        Øyvind :)
      • Rod Whitby
        ... make update make openslug-build -- Rod
        Message 3 of 29 , Jul 1, 2005
          On 7/1/05, mbanditt <auslands-kv@...> wrote:
          > Thanks for your help, Øyvind. I'm sorry, feeling very dumb. As I
          > said before, I don't know anything about monotone, bitbake and bitkeeper.

          make update
          make openslug-build

          -- Rod
        • mbanditt
          ... Thanks, that one worked. It took another 3 hours to build but now my slug is running on openslug. :-) Next steps are: - Reduce read/write access to the
          Message 4 of 29 , Jul 1, 2005
            >
            > make update
            > make openslug-build
            >
            > -- Rod

            Thanks, that one worked. It took another 3 hours to build but now my
            slug is running on openslug. :-)

            Next steps are:
            - Reduce read/write access to the disk (in order to allow spin down)
            by mounting /var/log and /var/run on ramfs.
            - Exchange dropbear with openssh (as I can't seem to get dropbear to
            reject password-authentication)
            - Install nfs, xinetd, openvpn, crond and some webserver.
            - Experiment with cups and sane (with my HP Officejet)
            - Experiment with home automation :-)

            Btw. many packages that were build in the process are not in the
            oe-feed. Is there another feed or do I have to compile all packages
            myself again when there is an update to some of them?

            Thanks for all your help

            Michael
          • Rod Whitby
            ... The packages built by openslug-packages.bb end up in the openslug/oe feed. -- Rod
            Message 5 of 29 , Jul 1, 2005
              On 7/2/05, mbanditt <auslands-kv@...> wrote:
              > Btw. many packages that were build in the process are not in the
              > oe-feed. Is there another feed or do I have to compile all packages
              > myself again when there is an update to some of them?

              The packages built by openslug-packages.bb end up in the openslug/oe feed.

              -- Rod
            • mbanditt
              ... feed. ... Not sure that I understand you correctly. After my build had finished I found lots of packages in tmp/deploy/ipk that are not in the openslug/oe
              Message 6 of 29 , Jul 3, 2005
                > The packages built by openslug-packages.bb end up in the openslug/oe
                feed.
                >
                > -- Rod

                Not sure that I understand you correctly. After my build had finished
                I found lots of packages in tmp/deploy/ipk that are not in the
                openslug/oe feed. Just to name a few: binutils, crond, openvpn. Can
                they only be installed from self-build packages?

                Cheers,

                Michael

                P.S.: Now on Turboslug :)
              • John Bowler
                From: mbanditt ... That s correct. Look in openembedded/conf/distro.openslug.conf and examine the comments around the FEED_URIS lines - add a new FEED_URIs in
                Message 7 of 29 , Jul 3, 2005
                  From: mbanditt
                  >> The packages built by openslug-packages.bb end up in the openslug/oe
                  >>feed.
                  >>
                  >> -- Rod
                  >
                  >Not sure that I understand you correctly. After my build had finished
                  >I found lots of packages in tmp/deploy/ipk that are not in the
                  >openslug/oe feed. Just to name a few: binutils, crond, openvpn. Can
                  >they only be installed from self-build packages?

                  That's correct.

                  Look in openembedded/conf/distro.openslug.conf and examine the comments
                  around the FEED_URIS lines - add a new FEED_URIs in your local.conf file
                  which points to an FTP server for your tmp/deploy/ipk directory. Then you
                  will be able to ipkg install anything that can be built. Please update one
                  of the OpenSlug source pages explaining how to do this -
                  http://www.nslu2-linux.org/wiki/OpenSlug/CustomisingTheBuild is probably a
                  good place.

                  So far as the standard feed is concerned it is currently not being updated.
                  The development team believes everyone would be very sorry if we started
                  updating it, because the latest builds from monotone use a *new* glibc.

                  In essence what we have is a stable feed locked to OpenSlug 2.0 and what we
                  do *not* have is an 'unstable' feed locked to the latest monotone tree.
                  Øyvind has made some good suggestions on the channel (#nslu2-linux) about
                  what is required - the requirements are greater than for unslung because
                  unslung does not change the base libc library.

                  John Bowler <jbowler@...>
                • mbanditt
                  ... openslug openvpn is broken as well (get the same test-crypto error as with unslung openvpn) :( Michael
                  Message 8 of 29 , Jul 4, 2005
                    >
                    > unslung openvpn is broken. openslug openvpn works, for the time being.

                    openslug openvpn is broken as well (get the same test-crypto error as
                    with unslung openvpn) :(

                    Michael
                  • Øyvind Repvik
                    ... It s fixed in unstable (ie, the monotone repo). To fix openvpn, edit openembedded/packages/openvpn/openvpn-2.0.bb and add this line before inherit
                    Message 9 of 29 , Jul 4, 2005
                      mbanditt wrote:
                      >>unslung openvpn is broken. openslug openvpn works, for the time being.
                      >
                      >
                      > openslug openvpn is broken as well (get the same test-crypto error as
                      > with unslung openvpn) :(

                      It's fixed in unstable (ie, the monotone repo). To fix openvpn, edit
                      openembedded/packages/openvpn/openvpn-2.0.bb and add this line before
                      "inherit autotools":

                      CFLAGS += "-fno-inline"

                      then clean out and rebuild.
                      This will make the bug go away ;-)

                      Øyvind
                    • Mathieu Monney
                      Hi everybody ! I would like to know if someone has put his slug in his case when it is overclocked ! Because I am afraid of the heating of this CPU... I am
                      Message 10 of 29 , Jul 4, 2005
                        Hi everybody !
                        I would like to know if someone has put his slug in his case when it is
                        overclocked ! Because I am afraid of the heating of this CPU... I am
                        asking me if it is reasonable to put the slug in his case when it is
                        overclocked...?
                        Sorry or my approximativ english ;-) !

                        Mathieu
                      • Øyvind Repvik
                        ... Yes, I have been running it inside the case for a couple of days now. The difference from the original is hardly noticeable. Øyvind
                        Message 11 of 29 , Jul 4, 2005
                          Mathieu Monney wrote:
                          > Hi everybody !
                          > I would like to know if someone has put his slug in his case when it is
                          > overclocked ! Because I am afraid of the heating of this CPU... I am
                          > asking me if it is reasonable to put the slug in his case when it is
                          > overclocked...?
                          > Sorry or my approximativ english ;-) !
                          >
                          > Mathieu
                          Yes, I have been running it inside the case for a couple of days now.
                          The difference from the original is hardly noticeable.

                          Øyvind
                        • mbanditt
                          ... edit ... before ... Thanks! I am learning, slowly but steadily. I have been looking for a possibility to somehow add this option (as it was mentioned in
                          Message 12 of 29 , Jul 4, 2005
                            > It's fixed in unstable (ie, the monotone repo). To fix openvpn,
                            edit
                            > openembedded/packages/openvpn/openvpn-2.0.bb and add this line
                            before
                            > "inherit autotools":
                            >
                            > CFLAGS += "-fno-inline"
                            >
                            > then clean out and rebuild.
                            > This will make the bug go away ;-)
                            >
                            > Øyvind

                            Thanks! I am learning, slowly but steadily. I have been looking for a
                            possibility to somehow add this option (as it was mentioned in
                            slugbug), but didn't know the exact command (CFLAGS).

                            Is there somewhere a kind of tutorial to bitbake? I've been
                            unsuccessfully searching for it quite a while now :(

                            And I also would like to port some apps from unslung to openslug. Some
                            seem to be simple to port (e.g. nano or imagemagick, the latter I need
                            for some automated webcam downloads and converts). I guess in several
                            cases it's mostly changing the install path. However, I have no idea
                            where to download e.g. the bitbake imagemagick.bb, libjpeg.bb,
                            libpng.bb etc. files and include them in the bitbake tree. Would this
                            be the right way?

                            Thanks again

                            Michael
                          • yahpn
                            I also have been running at 233 MHz inside the case with the case in the vertical position. The case never felt too hot so I doubt the following is necessary,
                            Message 13 of 29 , Jul 4, 2005
                              I also have been running at 233 MHz inside the case with the case in
                              the vertical position. The case never felt too hot so I doubt the
                              following is necessary, but I thought it might be hotter than it needs
                              to be since there were no holes on top. So, I drilled some, and while
                              I was at it, I made the pin holes on the component side of the side
                              case wider.

                              I made some holes wide enough to allow me to insert the thermocouple
                              from my multimeter. The measurements show no temperature problems at
                              all. Ambient temperatures in a couple of places inside the case and
                              even the IXP420 case temperature (harder to measure) itself are in the
                              40 - 49 C range. According to the datasheet ambient is allowed to be
                              as high as 70 C.

                              --- In nslu2-linux@yahoogroups.com, Øyvind Repvik <oyvind@r...> wrote:
                              > Mathieu Monney wrote:
                              > > Hi everybody !
                              > > I would like to know if someone has put his slug in his case when
                              it is
                              > > overclocked ! Because I am afraid of the heating of this CPU... I am
                              > > asking me if it is reasonable to put the slug in his case when it is
                              > > overclocked...?
                              > > Sorry or my approximativ english ;-) !
                              > >
                              > > Mathieu
                              > Yes, I have been running it inside the case for a couple of days now.
                              > The difference from the original is hardly noticeable.
                              >
                              > Øyvind
                            Your message has been successfully submitted and would be delivered to recipients shortly.