Loading ...
Sorry, an error occurred while loading the content.
 

Re: [nslu2-linux] ipkg upgrade apache problem

Expand Messages
  • Josh Parsons
    ... Can you be more specific? -- Josh Parsons Philosophy Department 1238 Social Sciences and Humanities Bldg. University of California Davis, CA 95616-8673 USA
    Message 1 of 16 , Jun 3, 2005
      On Fri, 2005-06-03 at 15:33 +0000, etherkidd wrote:
      > I used ipkg upgrade recently and i believe it upgraded my apache and
      > php. Now it doesn't work...

      Can you be more specific?

      --
      Josh Parsons
      Philosophy Department
      1238 Social Sciences and Humanities Bldg.
      University of California
      Davis, CA 95616-8673
      USA

      Please avoid sending me Word or PowerPoint attachments.
      See http://www.gnu.org/philosophy/no-word-attachments.html
    • Josh Parsons
      ... What happens if you run thttpd in the foreground, like this: /opt/sbin/thttpd -C /opt/etc/thttpd.conf -D -l - (as root)? -- Josh Parsons Philosophy
      Message 2 of 16 , Jun 3, 2005
        On Fri, 2005-06-03 at 19:31 +0100, Robert Hammond wrote:

        > I see the same problem but with php-thttpd.
        > Running the startup script 'S80thttpd start' does suggest that it has
        > started but it is definitely not running. ps shows no instance.

        What happens if you run thttpd in the foreground, like this:

        /opt/sbin/thttpd -C /opt/etc/thttpd.conf -D -l -

        (as root)?

        --
        Josh Parsons
        Philosophy Department
        1238 Social Sciences and Humanities Bldg.
        University of California
        Davis, CA 95616-8673
        USA

        Please avoid sending me Word or PowerPoint attachments.
        See http://www.gnu.org/philosophy/no-word-attachments.html
      • Robert Hammond
        In message , Josh Parsons writes ... Command seems to complete but thttpd is not
        Message 3 of 16 , Jun 3, 2005
          In message <1117827273.3719.8.camel@...>, Josh Parsons
          <jbparsons@...> writes
          >On Fri, 2005-06-03 at 19:31 +0100, Robert Hammond wrote:
          >
          >> I see the same problem but with php-thttpd.
          >> Running the startup script 'S80thttpd start' does suggest that it has
          >> started but it is definitely not running. ps shows no instance.
          >
          >What happens if you run thttpd in the foreground, like this:
          >
          >/opt/sbin/thttpd -C /opt/etc/thttpd.conf -D -l -
          >
          Command seems to complete but thttpd is not running.

          >(as root)?
          >
          I changed the default user some time back to run as an instance of root.
          My conf is:-

          dir=/opt/share/www
          # port=8080
          port=888
          user=nobody
          nochroot
          nosymlink
          novhost
          logfile=/opt/var/log/thttpd.log
          # <snipped for news posting>
          pidfile=/opt/var/run/thttpd.pid


          --
          Robert Hammond
          PGP:0x154144DA
        • etherkidd
          ... it seems to give this error httpd not running, trying to start (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80 no listening
          Message 4 of 16 , Jun 3, 2005
            --- In nslu2-linux@yahoogroups.com, Josh Parsons <jbparsons@u...> wrote:
            > On Fri, 2005-06-03 at 15:33 +0000, etherkidd wrote:
            > > I used ipkg upgrade recently and i believe it upgraded my apache and
            > > php. Now it doesn't work...
            >
            > Can you be more specific?
            >
            > --
            > Josh Parsons
            > Philosophy Department
            > 1238 Social Sciences and Humanities Bldg.
            > University of California
            > Davis, CA 95616-8673
            > USA
            >
            > Please avoid sending me Word or PowerPoint attachments.
            > See http://www.gnu.org/philosophy/no-word-attachments.html

            it seems to give this error

            httpd not running, trying to start
            (98)Address already in use: make_sock: could not bind to address
            0.0.0.0:80
            no listening sockets available, shutting down
            Unable to open logs

            i've seen this error before and used netstat -a and found nothing
            running at port 80. Changed the port in http.conf to something else
            and same error. Can't figure why I'm getting this error...

            Choose default N to not overwite files while doing the upgrade. Not
            sure what else to include...

            says "httpd not running, trying to start" when running the script and
            under ps command the 2 entries

            1328 root 13192 R /opt/sbin/httpd -k restart
            1329 nobody 11576 S /opt/sbin/httpd -k restart
          • Josh Parsons
            ... This is a problem with apache, not php-apache (that is just the php module for apache, not the webserver itself). Check your apache configuration - it
            Message 5 of 16 , Jun 3, 2005
              On Fri, 2005-06-03 at 20:04 +0000, etherkidd wrote:

              > httpd not running, trying to start
              > (98)Address already in use: make_sock: could not bind to address
              > 0.0.0.0:80

              This is a problem with apache, not php-apache (that is just the php
              module for apache, not the webserver itself). Check your apache
              configuration - it should not be trying to bind to port 80, and is not
              configured to do so by default.

              My guess is you've somehow broken your apache config and not noticed
              until upgrading php forced you to restart it.

              --
              Josh Parsons
              Philosophy Department
              1238 Social Sciences and Humanities Bldg.
              University of California
              Davis, CA 95616-8673
              USA

              Please avoid sending me Word or PowerPoint attachments.
              See http://www.gnu.org/philosophy/no-word-attachments.html
            • Josh Parsons
              ... Interesting. I have two suggestions: 1) can you see if php-thttpd will work for you with the original configuration? If so, it would be helpful to know
              Message 6 of 16 , Jun 3, 2005
                On Fri, 2005-06-03 at 20:51 +0100, Robert Hammond wrote:

                > >/opt/sbin/thttpd -C /opt/etc/thttpd.conf -D -l -
                > >
                > Command seems to complete but thttpd is not running.

                Interesting. I have two suggestions:

                1) can you see if php-thttpd will work for you with the original
                configuration? If so, it would be helpful to know exactly what about
                your configuration causes it to die. You can figure that out by
                experiment.

                2) If that doesn't work, I'd like you to try running the command line I
                gave you above under strace, like this:

                strace /opt/sbin/thttpd -C /opt/etc/thttpd.conf -D -l - 2>thttpd.stlog

                You may need to install strace first with ipkg.

                The -D flag to thttpd should cause it to run forever in the foreground
                until interrupted; hopefully an strace log will reveal to us why it is
                exiting.

                The log which will appear in thttpd.stlog will be probably quite
                lengthy, so please don't post it to the list. I suggest you look at it
                yourself and if you can't make head or tail of it, email it to me off
                list.

                --
                Josh Parsons
                Philosophy Department
                1238 Social Sciences and Humanities Bldg.
                University of California
                Davis, CA 95616-8673
                USA

                Please avoid sending me Word or PowerPoint attachments.
                See http://www.gnu.org/philosophy/no-word-attachments.html
              • Robert Hammond
                In message , Josh Parsons writes ... Have changed back to standard configuration
                Message 7 of 16 , Jun 3, 2005
                  In message <1117863039.4906.16.camel@...>, Josh
                  Parsons <jbparsons@...> writes
                  >On Fri, 2005-06-03 at 20:51 +0100, Robert Hammond wrote:
                  >
                  >> >/opt/sbin/thttpd -C /opt/etc/thttpd.conf -D -l -
                  >> >
                  >> Command seems to complete but thttpd is not running.
                  >
                  >Interesting. I have two suggestions:
                  >
                  >1) can you see if php-thttpd will work for you with the original
                  >configuration? If so, it would be helpful to know exactly what about
                  >your configuration causes it to die. You can figure that out by
                  >experiment.
                  >
                  Have changed back to standard configuration without success. Will
                  check out a few more things later.

                  >2) If that doesn't work, I'd like you to try running the command line I
                  >gave you above under strace, like this:
                  >
                  >strace /opt/sbin/thttpd -C /opt/etc/thttpd.conf -D -l - 2>thttpd.stlog
                  >
                  >You may need to install strace first with ipkg.
                  >
                  >The -D flag to thttpd should cause it to run forever in the foreground
                  >until interrupted; hopefully an strace log will reveal to us why it is
                  >exiting.
                  >
                  >The log which will appear in thttpd.stlog will be probably quite
                  >lengthy, so please don't post it to the list. I suggest you look at it
                  >yourself and if you can't make head or tail of it, email it to me off
                  >list.
                  >
                  Log file sent by email. It terminated on it's own with an exit logged.
                  One observation from a quick scan of the log, it may indicate that some
                  library files are missing.
                  --
                  Robert Hammond
                  PGP:0x154144DA
                • Robert Hammond
                  In message , Robert Hammond writes ... Also I have discovered an interesting log message in
                  Message 8 of 16 , Jun 3, 2005
                    In message <2KTL9$ARmUoCFw0G@...>, Robert Hammond
                    <rob.hammond@...> writes
                    >In message <1117863039.4906.16.camel@...>, Josh
                    >Parsons <jbparsons@...> writes
                    >>On Fri, 2005-06-03 at 20:51 +0100, Robert Hammond wrote:
                    >>
                    >>> >/opt/sbin/thttpd -C /opt/etc/thttpd.conf -D -l -
                    >>> >
                    >>> Command seems to complete but thttpd is not running.
                    >>
                    >>Interesting. I have two suggestions:
                    >>
                    >>1) can you see if php-thttpd will work for you with the original
                    >>configuration? If so, it would be helpful to know exactly what about
                    >>your configuration causes it to die. You can figure that out by
                    >>experiment.
                    >>
                    >Have changed back to standard configuration without success. Will
                    >check out a few more things later.
                    >
                    >>2) If that doesn't work, I'd like you to try running the command line I
                    >>gave you above under strace, like this:
                    >>
                    >>strace /opt/sbin/thttpd -C /opt/etc/thttpd.conf -D -l - 2>thttpd.stlog
                    >>
                    >>You may need to install strace first with ipkg.
                    >>
                    >>The -D flag to thttpd should cause it to run forever in the foreground
                    >>until interrupted; hopefully an strace log will reveal to us why it is
                    >>exiting.
                    >>
                    >>The log which will appear in thttpd.stlog will be probably quite
                    >>lengthy, so please don't post it to the list. I suggest you look at it
                    >>yourself and if you can't make head or tail of it, email it to me off
                    >>list.
                    >>
                    >Log file sent by email. It terminated on it's own with an exit logged.
                    >One observation from a quick scan of the log, it may indicate that some
                    >library files are missing.
                    Also I have discovered an interesting log message in /var/log/messages
                    <26>Jun 4 07:14:07 thttpd[858]: socket :: - Address family not
                    supported by protocol
                    --
                    Robert Hammond
                    PGP:0x154144DA
                  • etherkidd
                    ... No. like I said. I choose to keep the existing config files and not to overwrite the files so it should bind to port 80! Anyway I found out what was the
                    Message 9 of 16 , Jun 4, 2005
                      --- In nslu2-linux@yahoogroups.com, Josh Parsons <jbparsons@u...> wrote:
                      > On Fri, 2005-06-03 at 20:04 +0000, etherkidd wrote:
                      >
                      > > httpd not running, trying to start
                      > > (98)Address already in use: make_sock: could not bind to address
                      > > 0.0.0.0:80
                      >
                      > This is a problem with apache, not php-apache (that is just the php
                      > module for apache, not the webserver itself). Check your apache
                      > configuration - it should not be trying to bind to port 80, and is not
                      > configured to do so by default.

                      No. like I said. I choose to keep the existing config files and not
                      to overwrite the files so it should bind to port 80!

                      Anyway I found out what was the problem because I became impatient but
                      neglected to post about it. I ipkg removed and reinstalled php-apache
                      and when it still didn't work I checked the apache logs. The culprit
                      was eaccelerator.

                      I removed eaccelerator and everything was back up again. I hope
                      someone can create a new build of it as soon as possible.
                    • Robert Hammond
                      In message , etherkidd writes ... Thanks for this tip, I have also now removed eaccelerator and my php-thttpd
                      Message 10 of 16 , Jun 4, 2005
                        In message <d7rnea+3t8p@...>, etherkidd <etherkidd@...>
                        writes
                        >--- In nslu2-linux@yahoogroups.com, Josh Parsons <jbparsons@u...> wrote:
                        >> On Fri, 2005-06-03 at 20:04 +0000, etherkidd wrote:
                        >>
                        >> > httpd not running, trying to start
                        >> > (98)Address already in use: make_sock: could not bind to address
                        >> > 0.0.0.0:80
                        >>
                        >> This is a problem with apache, not php-apache (that is just the php
                        >> module for apache, not the webserver itself). Check your apache
                        >> configuration - it should not be trying to bind to port 80, and is not
                        >> configured to do so by default.
                        >
                        >No. like I said. I choose to keep the existing config files and not
                        >to overwrite the files so it should bind to port 80!
                        >
                        >Anyway I found out what was the problem because I became impatient but
                        >neglected to post about it. I ipkg removed and reinstalled php-apache
                        >and when it still didn't work I checked the apache logs. The culprit
                        >was eaccelerator.
                        >
                        >I removed eaccelerator and everything was back up again. I hope
                        >someone can create a new build of it as soon as possible.
                        >
                        Thanks for this tip, I have also now removed eaccelerator and my
                        php-thttpd now also functions.
                        --
                        Robert Hammond
                        PGP:0x154144DA
                      • Josh Parsons
                        Etherkidd, Rob Hammond, The problem seems to have been that I did not rebuild the eaccelerator ipk after updating php to 5.0.4. The feed now contains an
                        Message 11 of 16 , Jun 4, 2005
                          Etherkidd, Rob Hammond,

                          The problem seems to have been that I did not rebuild the eaccelerator
                          ipk after updating php to 5.0.4. The feed now contains an updated
                          eaccelerator - upgrading to that should solve your problems.

                          --
                          Josh Parsons
                          Philosophy Department
                          1238 Social Sciences and Humanities Bldg.
                          University of California
                          Davis, CA 95616-8673
                          USA

                          Please avoid sending me Word or PowerPoint attachments.
                          See http://www.gnu.org/philosophy/no-word-attachments.html
                        • Josh Parsons
                          ... I don t understand. If you are saying that you have never modified or upgraded the apache config files since you first installed apache, then apache will
                          Message 12 of 16 , Jun 4, 2005
                            On Sat, 2005-06-04 at 08:06 +0000, etherkidd wrote:

                            > > configuration - it should not be trying to bind to port 80, and is not
                            > > configured to do so by default.
                            >
                            > No. like I said. I choose to keep the existing config files and not
                            > to overwrite the files so it should bind to port 80!

                            I don't understand. If you are saying that you have never modified or
                            upgraded the apache config files since you first installed apache, then
                            apache will be binding to port 8000, as every apache ipk ever
                            distributed does that.

                            If you are saying that you have modified your apache configuration to
                            bind to port 80, and not upgraded it since, then you should be worried
                            about the error message you quoted in your previous email. Probably the
                            trouble is that the built-in thttpd server is also using port 80.

                            --
                            Josh Parsons
                            Philosophy Department
                            1238 Social Sciences and Humanities Bldg.
                            University of California
                            Davis, CA 95616-8673
                            USA

                            Please avoid sending me Word or PowerPoint attachments.
                            See http://www.gnu.org/philosophy/no-word-attachments.html
                          • etherkidd
                            ... I installed apache and it was binding to port 8000. Among the first things I did was to change the port to 80. I than used ipkg upgrade. There was a
                            Message 13 of 16 , Jun 4, 2005
                              > I don't understand. If you are saying that you have never modified or
                              > upgraded the apache config files since you first installed apache, then
                              > apache will be binding to port 8000, as every apache ipk ever
                              > distributed does that.
                              >
                              > If you are saying that you have modified your apache configuration to
                              > bind to port 80, and not upgraded it since, then you should be worried
                              > about the error message you quoted in your previous email. Probably the
                              > trouble is that the built-in thttpd server is also using port 80.

                              I installed apache and it was binding to port 8000. Among the first
                              things I did was to change the port to 80.

                              I than used ipkg upgrade. There was a prompt during that process that
                              asks to overwrite the config files. The default is N. Therefore when
                              it's finished upgraded... it should still bind to 80 because it did
                              not overwite the config files that I set to overwrite 80.

                              I might be mistaken... but I hope that clears the confusion. The
                              process process upgraded quite a bit of stuff but I wasn't paying much
                              attention... Thank you for your assistance and the new compile of
                              eaccelerator... Need that for gallery as it's so slow without it.
                            • etherkidd
                              ... I knew this wasn t a problem because I ve changed the nslu2 thttpd port before configuring the apache port to 80.
                              Message 14 of 16 , Jun 4, 2005
                                >> trouble is that the built-in thttpd server is also using port 80.

                                I knew this wasn't a problem because I've changed the nslu2 thttpd
                                port before configuring the apache port to 80.
                              Your message has been successfully submitted and would be delivered to recipients shortly.