Loading ...
Sorry, an error occurred while loading the content.
 

Tab - autocomplete

Expand Messages
  • DreamCarrier
    I m a complete *nix n00b. When I fist installed the Slug I dind t have autocomplete on [tab] Then I did some upgrades and suddenly I did have it.. Great
    Message 1 of 4 , Feb 21, 2005
      I'm a complete *nix n00b.
      When I fist installed the Slug I dind't have autocomplete on [tab]
      Then I did some upgrades and suddenly I did have it.. Great stuff..
      After som more updates autocomplete disappeared again.
      I was wondering. Is it the terminal app (Putty) or is it the telnet
      server in the slug or is it just me being an ignorant? (please don't
      answer the last question)
      Anyone know how to fix this so I can get autocomplete back?
    • Inge Bjørnvall Arnesen
      The terminal program is usually irrelevant (tab=0x09). Which shell are you using? AFAIK, by default auto complete works on bash and busybox 1.0 shell, but not
      Message 2 of 4 , Feb 21, 2005
        The terminal program is usually irrelevant (tab=0x09). Which shell are you
        using?

        AFAIK, by default auto complete works on bash and busybox 1.0 shell, but not
        on 0.6 Linksys busybox (it might be something one can enable, but when bash
        is around I don't really care).

        /opt/bin/sh - Yes
        /bin/sh - No
        /opt/bin/bash - Yes

        -- Inge


        ----Original Message----
        From: DreamCarrier [mailto:korea@...]
        Sent: 21. februar 2005 11:06
        To: nslu2-linux@yahoogroups.com
        Subject: [nslu2-linux] Tab - autocomplete

        > I'm a complete *nix n00b.
        > When I fist installed the Slug I dind't have autocomplete
        > on [tab] Then I did some upgrades and suddenly I did have
        > it.. Great stuff.. After som more updates autocomplete
        > disappeared again. I was wondering. Is it the terminal
        > app (Putty) or is it the telnet server in the slug or is
        > it just me being an ignorant? (please don't
        > answer the last question)
        > Anyone know how to fix this so I can get autocomplete
        > back?
        >
        >
        >
        >
        >
        > [ Moderator Note: All static information is slowly moving
        > to the Wiki at http://www.nslu2-linux.org ]
        > Yahoo! Groups Links
        >
        >
        >
      • DreamCarrier
        Busybox 1.0 I changed the shell path is passwd to /opt/bin/sh and now it works. Thanks a lot! ... are you ... shell, but not ... when bash
        Message 3 of 4 , Feb 21, 2005
          Busybox 1.0
          I changed the shell path is passwd to /opt/bin/sh and now it works.
          Thanks a lot!

          --- In nslu2-linux@yahoogroups.com, Inge Bjørnvall Arnesen
          <i.b.arnesen@f...> wrote:
          > The terminal program is usually irrelevant (tab=0x09). Which shell
          are you
          > using?
          >
          > AFAIK, by default auto complete works on bash and busybox 1.0
          shell, but not
          > on 0.6 Linksys busybox (it might be something one can enable, but
          when bash
          > is around I don't really care).
          >
          > /opt/bin/sh - Yes
          > /bin/sh - No
          > /opt/bin/bash - Yes
          >
          > -- Inge
          >
          >
          > ----Original Message----
          > From: DreamCarrier [mailto:korea@d...]
          > Sent: 21. februar 2005 11:06
          > To: nslu2-linux@yahoogroups.com
          > Subject: [nslu2-linux] Tab - autocomplete
          >
          > > I'm a complete *nix n00b.
          > > When I fist installed the Slug I dind't have autocomplete
          > > on [tab] Then I did some upgrades and suddenly I did have
          > > it.. Great stuff.. After som more updates autocomplete
          > > disappeared again. I was wondering. Is it the terminal
          > > app (Putty) or is it the telnet server in the slug or is
          > > it just me being an ignorant? (please don't
          > > answer the last question)
          > > Anyone know how to fix this so I can get autocomplete
          > > back?
          > >
          > >
          > >
          > >
          > >
          > > [ Moderator Note: All static information is slowly moving
          > > to the Wiki at http://www.nslu2-linux.org ]
          > > Yahoo! Groups Links
          > >
          > >
          > >
        • Spöttel Otmar
          Hello DreamCarrier, that is not a good choice to change the shell for the root user. Because if the shell is not available, you can t login! I use the
          Message 4 of 4 , Feb 21, 2005
            Hello DreamCarrier,

            that is not a good choice to change the shell for the root user. Because if
            the shell is not available, you can't login!
            I use the following .profile script:
            echo ---------------------------------------------------------------------
            echo "Hello $USER, nice to see you :)"
            echo ---------------------------------------------------------------------
            echo
            . ~/.alias

            # set the prompt
            export PS1="\[\033[1;33m\]\u@\h\[\033[0;37m\]:\w > "

            # execute everything from everywhere :-)
            export PATH=$PATH:.:~/bin:

            # environment for midnight Commander
            export TERMINFO=/opt/lib/terminfo
            export TERM=xterm-pcolor

            # test for the bash, if exists run the bash
            test -f /opt/bin/bash && exec /opt/bin/bash

            create the file .profile in the root home directory (~)
            and insert the things above.
            Also you can create a .alias file with them you can create "shortcuts" i.e.
            alias "d=ls -la"

            Otmar

            ----- Original Message -----
            From: "DreamCarrier" <korea@...>
            To: <nslu2-linux@yahoogroups.com>
            Sent: Monday, February 21, 2005 11:36 AM
            Subject: [nslu2-linux] Re: Tab - autocomplete



            Busybox 1.0
            I changed the shell path is passwd to /opt/bin/sh and now it works.
            Thanks a lot!

            --- In nslu2-linux@yahoogroups.com, Inge Bjørnvall Arnesen
            <i.b.arnesen@f...> wrote:
            > The terminal program is usually irrelevant (tab=0x09). Which shell
            are you
            > using?
            >
            > AFAIK, by default auto complete works on bash and busybox 1.0
            shell, but not
            > on 0.6 Linksys busybox (it might be something one can enable, but
            when bash
            > is around I don't really care).
            >
            > /opt/bin/sh - Yes
            > /bin/sh - No
            > /opt/bin/bash - Yes
            >
            > -- Inge
            >
            >
            > ----Original Message----
            > From: DreamCarrier [mailto:korea@d...]
            > Sent: 21. februar 2005 11:06
            > To: nslu2-linux@yahoogroups.com
            > Subject: [nslu2-linux] Tab - autocomplete
            >
            > > I'm a complete *nix n00b.
            > > When I fist installed the Slug I dind't have autocomplete
            > > on [tab] Then I did some upgrades and suddenly I did have
            > > it.. Great stuff.. After som more updates autocomplete
            > > disappeared again. I was wondering. Is it the terminal
            > > app (Putty) or is it the telnet server in the slug or is
            > > it just me being an ignorant? (please don't
            > > answer the last question)
            > > Anyone know how to fix this so I can get autocomplete
            > > back?
            > >
            > >
            > >
            > >
            > >
            > > [ Moderator Note: All static information is slowly moving
            > > to the Wiki at http://www.nslu2-linux.org ]
            > > Yahoo! Groups Links
            > >
            > >
            > >





            [ Moderator Note: All static information is slowly moving to the Wiki at
            http://www.nslu2-linux.org ]


            Yahoo! Groups Sponsor

            Get unlimited calls to

            U.S./Canada




            --------------------------------------------------------------------------------
            Yahoo! Groups Links

            a.. To visit your group on the web, go to:
            http://groups.yahoo.com/group/nslu2-linux/

            b.. To unsubscribe from this group, send an email to:
            nslu2-linux-unsubscribe@yahoogroups.com

            c.. Your use of Yahoo! Groups is subject to the Yahoo! Terms of Service.
          Your message has been successfully submitted and would be delivered to recipients shortly.