Loading ...
Sorry, an error occurred while loading the content.
 

thttpd vs permissions on /dev/sdb1 flash drive

Expand Messages
  • teg00
    Hi, I ve been happily experimenting with the RamHackU2 firmware (because, like George, I don t like listening to disk drives). Problem: I m trying to run the
    Message 1 of 5 , Dec 25, 2004
      Hi,
      I've been happily experimenting with the RamHackU2 firmware
      (because, like George, I don't like listening to disk drives).

      Problem: I'm trying to run the thttpd from the yahoo files section
      and it isn't working for me. All URLs fail with a "not world
      readable" error... And thttpd really does want all files to be
      world-readable (according to the acme man page.) But it looks like
      when /dev/sdb1 is originally mounted, it is given a umask of 007
      instead of 000, since world permissions appear to be missing.

      Mount with the remount option evidentally cannot overide the original
      umask, and my attempts to umount /dev/sdb1 and try a new mount always
      fail with a device busy error.

      (When I try running the built-in thttpd, I get a different error,
      URL not found.)

      Ideas?

      Thanks,

      -teg
    • Lars
      thats a common issue with thttpd and vfat. The build in thttpd is fixed somway, so it can show files from vfat but it mixes them with graphics from the web
      Message 2 of 5 , Dec 25, 2004
        thats a common issue with thttpd and vfat. The build in thttpd is
        fixed somway, so it can show files from vfat but it mixes them with
        graphics from the web interface. But if you have our site on a ext2
        partion you can read data from a vfat with php, perl or wathever.
        Sez ilafe


        --- In nslu2-linux@yahoogroups.com, "teg00" <gray@w...> wrote:
        >
        > Hi,
        > I've been happily experimenting with the RamHackU2 firmware
        > (because, like George, I don't like listening to disk drives).
        >
        > Problem: I'm trying to run the thttpd from the yahoo files section
        > and it isn't working for me. All URLs fail with a "not world
        > readable" error... And thttpd really does want all files to be
        > world-readable (according to the acme man page.) But it looks like
        > when /dev/sdb1 is originally mounted, it is given a umask of 007
        > instead of 000, since world permissions appear to be missing.
        >
        > Mount with the remount option evidentally cannot overide the original
        > umask, and my attempts to umount /dev/sdb1 and try a new mount always
        > fail with a device busy error.
        >
        > (When I try running the built-in thttpd, I get a different error,
        > URL not found.)
        >
        > Ideas?
        >
        > Thanks,
        >
        > -teg
      • Inge Bjørnvall Arnesen
        Dear List, I was looking though /usr/sbin/WatchDog which seems to be a stock NSLU2 script. It uses awk to check the length of /var/log/messages, but awk is not
        Message 3 of 5 , Dec 25, 2004
          Dear List,

          I was looking though /usr/sbin/WatchDog which seems to be a stock NSLU2
          script. It uses awk to check the length of /var/log/messages, but awk is not
          installed on my system. What has happened here? Is it like this from the
          factory or is it an oversight in the unslung distro?

          best,

          -- Inge
        • mrthreeplates
          ... It is hard for me to answer the questions as I am now using the unslung f/w, but I ll give it a try. As I recall, the vfat (Windows) filesytem does not
          Message 4 of 5 , Jan 2, 2005
            --- In nslu2-linux@yahoogroups.com, "teg00" <gray@w...> wrote:
            >
            > Hi,
            > I've been happily experimenting with the RamHackU2 firmware
            > (because, like George, I don't like listening to disk drives).
            >
            > Problem: I'm trying to run the thttpd from the yahoo files section
            > and it isn't working for me. All URLs fail with a "not world
            > readable" error... And thttpd really does want all files to be
            > world-readable (according to the acme man page.) But it looks like
            > when /dev/sdb1 is originally mounted, it is given a umask of 007
            > instead of 000, since world permissions appear to be missing.
            >

            It is hard for me to answer the questions as I am now
            using the unslung f/w, but I'll give it a try.

            As I recall, the vfat (Windows) filesytem does not support
            anything close to the file modes/owners of unix. From my
            tests, it looks like when
            a vfat f/s is mounted, it "sets" the file mode and owner to
            be the same and you cannot change them. I think it is user=nobody,
            group=???, perm=770, but I could be mistaken.

            I suspect that you probably *could* change them on a global basis
            if you tweaked the vfat fs module.

            In any case, I was able to get it to work without having to resort
            to that.

            I believe that I set the UID in the thttpd.conf file so that it was
            the same as the UID given to all of the vfat files. That way it
            could always read the files.

            Of course, you can't do anything fancy with per-file security, but
            that is probably fine for most people.

            Hope that helps.

            George

            > Mount with the remount option evidentally cannot overide the original
            > umask, and my attempts to umount /dev/sdb1 and try a new mount always
            > fail with a device busy error.
            >
            > (When I try running the built-in thttpd, I get a different error,
            > URL not found.)
            >
            > Ideas?
            >
            > Thanks,
            >
            > -teg
          • Terry Gray
            Thanks George. Your note encouraged me to try again, and this time I succeeded. My problem was in trying to use the newer thttpd I found in the Yahoo group s
            Message 5 of 5 , Jan 2, 2005
              Thanks George. Your note encouraged me to try again, and this time I
              succeeded. My problem was in trying to use the newer thttpd I found in
              the Yahoo group's files section, which strictly adheres the the rule
              that the files must be world readable. So it is necessary to use the
              builtin thttpd with the Flash's FAT filesystem because it is not so
              strict on permissions and will export the FAT files even if they were
              not mounted as world-readable.

              I had previousy tried the builtin thttpd but apparently had an error
              in the conf file.

              Thanks again.

              -teg

              On Sun, 2 Jan 2005, mrthreeplates wrote:

              > --- In nslu2-linux@yahoogroups.com, "teg00" <gray@w...> wrote:
              >
              > > I've been happily experimenting with the RamHackU2 firmware
              > > (because, like George, I don't like listening to disk drives).
              > >
              > > Problem: I'm trying to run the thttpd from the yahoo files section
              > > and it isn't working for me. All URLs fail with a "not world
              > > readable" error... And thttpd really does want all files to be
              > > world-readable (according to the acme man page.) But it looks like
              > > when /dev/sdb1 is originally mounted, it is given a umask of 007
              > > instead of 000, since world permissions appear to be missing.
              >
              > I believe that I set the UID in the thttpd.conf file so that it was
              > the same as the UID given to all of the vfat files. That way it
              > could always read the files.
              >
              > Of course, you can't do anything fancy with per-file security, but
              > that is probably fine for most people.
              >
              > Hope that helps.
              >
              > George
            Your message has been successfully submitted and would be delivered to recipients shortly.