Loading ...
Sorry, an error occurred while loading the content.

php fcgi in6addr_any errors

Expand Messages
  • Wesley Turner-Harris
    Hello Everyone, I m hoping someone can help me debug my problems with a mbwe-bluering 1st ed. I recently changed opt feeds from gumstix1151 to mbwe-bluering
    Message 1 of 1 , Aug 19, 2012
    • 0 Attachment
      Hello Everyone,

      I'm hoping someone can help me debug my problems with a mbwe-bluering 1st ed. I recently changed opt feeds from gumstix1151 to mbwe-bluering hoping it would have better packages. It then broke php for me using lighttpd. Anyway, when starting the server, I get...

      /opt/bin/php-fcgi: can't resolve symbol '__in6addr_any'
      2012-08-19 02:56:21: (mod_fastcgi.c.920) child exited: 1 
      2012-08-19 02:56:21: (mod_fastcgi.c.923) if you try do run PHP as FastCGI backend make sure you use the FastCGI enabled version.
      You can find out if it is the right one by executing 'php -v' and it should display '(cgi-fcgi)' in the output, NOT (cgi) NOR (cli)
      2012-08-19 02:56:21: (mod_fastcgi.c.1200) [ERROR]: spawning fcgi failed. 
      2012-08-19 02:56:21: (server.c.673) Configuration of plugins failed. Going down. 

      Now if I revert to the gumstix feed and re-install php + php-fcgi, restart lighttpd, it works again, no problems. Of course the easy way would be to do that. I'm pulling hair out trying to figure out why old version succeeds while the newer fails. The gumstix php versions are 5.2.12-1 while the mbwe-bluering versions are 5.2.17-2. Any insights?

      I should also mention that php -v produces the CLI version whilst on the bluering version and it produces php-fcgi on the gumstix.

      Best,

      Wesley Turner-Harris
      Web Developer @ Barrel
    Your message has been successfully submitted and would be delivered to recipients shortly.