Loading ...
Sorry, an error occurred while loading the content.

Re: MySQL 4.1.22 build fails

Expand Messages
  • tals1975
    Fajar, Thanks for your prompt reply. I think the problem is somewhere else, because g++ exists in the toolchain:
    Message 1 of 4 , May 16, 2012
    • 0 Attachment
      Fajar,

      Thanks for your prompt reply. I think the problem is somewhere else, because g++ exists in the toolchain:

      cs05q1armel/toolchain/arm-none-linux-gnueabi/gcc-2005q1-glibc-2.3.4/bin/arm-none-linux-gnueabi-g++

      Please see this page:
      http://bugs.mysql.com/bug.php?id=25576

      I'm just trying to re-compile the package (needed for perl-dbd-mysql).
      Someone has already compiled it successfully
      (the package is available in the repository: http://ipkg.nslu2-linux.org/feeds/optware/cs05q1armel/cross/unstable/mysql_4.1.22-3_arm.ipk

      The question is why I can not?

      --
      Sergey

      --- In nslu2-linux@yahoogroups.com, "Fajar A. Nugraha" <fajar@...> wrote:
      >
      > On Wed, May 16, 2012 at 5:19 PM, tals1975 <tals1975@...> wrote:
      > >
      > >
      > >
      > > Hi All,
      > >
      > > MySQL 4.1.22 build fails. Can someone have a look at this please?
      > > Original mysql.mk was not modified.
      > >
      > > Thank you in advance,
      > > Sergey
      > >
      > > source='my_new.cc' object='my_new.o' libtool=no \
      > > DEPDIR=.deps depmode=none /bin/sh ../depcomp \
      > > g++ -DDEFAULT_BASEDIR=\"/opt\" -DDATADIR="\"/opt/var\""
      > > -DDEFAULT_CHARSET_HOME="\"/opt\"" -DSHAREDIR="\"/opt/share/mysql\""
      > > -DHAVE_CONFIG_H -I. -I. -I.. -I../zlib -I../include -I../include -I. -O
      > > -DDBUG_OFF -c -o my_new.o my_new.cc
      > > ../depcomp: line 512: exec: g++: not found
      >
      > Isn't that last line obvious?
      >
      > You should be able to work around that by installing whatever package
      > that provides g++.
      >
      > --
      > Fajar
      >
    • tals1975
      Fajar, You were right... Installation of gcc-c++ resolved the issue. -- Regards, Sergey
      Message 2 of 4 , May 16, 2012
      • 0 Attachment
        Fajar,

        You were right...
        Installation of gcc-c++ resolved the issue.

        --
        Regards,
        Sergey

        --- In nslu2-linux@yahoogroups.com, "tals1975" <tals1975@...> wrote:
        >
        > Fajar,
        >
        > Thanks for your prompt reply. I think the problem is somewhere else, because g++ exists in the toolchain:
        >
        > cs05q1armel/toolchain/arm-none-linux-gnueabi/gcc-2005q1-glibc-2.3.4/bin/arm-none-linux-gnueabi-g++
        >
        > Please see this page:
        > http://bugs.mysql.com/bug.php?id=25576
        >
        > I'm just trying to re-compile the package (needed for perl-dbd-mysql).
        > Someone has already compiled it successfully
        > (the package is available in the repository: http://ipkg.nslu2-linux.org/feeds/optware/cs05q1armel/cross/unstable/mysql_4.1.22-3_arm.ipk
        >
        > The question is why I can not?
        >
        > --
        > Sergey
        >
        > --- In nslu2-linux@yahoogroups.com, "Fajar A. Nugraha" <fajar@> wrote:
        > >
        > > On Wed, May 16, 2012 at 5:19 PM, tals1975 <tals1975@> wrote:
        > > >
        > > >
        > > >
        > > > Hi All,
        > > >
        > > > MySQL 4.1.22 build fails. Can someone have a look at this please?
        > > > Original mysql.mk was not modified.
        > > >
        > > > Thank you in advance,
        > > > Sergey
        > > >
        > > > source='my_new.cc' object='my_new.o' libtool=no \
        > > > DEPDIR=.deps depmode=none /bin/sh ../depcomp \
        > > > g++ -DDEFAULT_BASEDIR=\"/opt\" -DDATADIR="\"/opt/var\""
        > > > -DDEFAULT_CHARSET_HOME="\"/opt\"" -DSHAREDIR="\"/opt/share/mysql\""
        > > > -DHAVE_CONFIG_H -I. -I. -I.. -I../zlib -I../include -I../include -I. -O
        > > > -DDBUG_OFF -c -o my_new.o my_new.cc
        > > > ../depcomp: line 512: exec: g++: not found
        > >
        > > Isn't that last line obvious?
        > >
        > > You should be able to work around that by installing whatever package
        > > that provides g++.
        > >
        > > --
        > > Fajar
        > >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.