Loading ...
Sorry, an error occurred while loading the content.

cuetools 1.3.1 doesn't work for me

Expand Messages
  • tals1975
    Hi All, I ve faced a strange behavior of cuetools 1.3.1 on my NAS. All utilities of cuetools package show me always the same message: run `{CUETOOLS_UTILS}
    Message 1 of 3 , Feb 27, 2012
    • 0 Attachment
      Hi All,

      I've faced a strange behavior of cuetools 1.3.1 on my NAS.
      All utilities of cuetools package show me always the same message:
      run `{CUETOOLS_UTILS} --help' for usage

      All other installed optware packages work fine.


      Please can anyone give me a piece of advise where the issue could be in?

      Thank you in advance!
      Sergey

      ENV#: / Output
      1)
      uname -a
      Linux WD 2.6.24.4 #1 Thu Apr 1 16:43:58 CST 2010 armv5tejl unknown

      2)
      strace cueprint test.cue
      execve("/opt/bin/cueprint", ["cueprint", "test.cue"], [/* 13 vars */]) = 0
      uname({sys="Linux", node="WD", ...}) = 0
      brk(0) = 0x1e000
      access("/etc/ld.so.preload", R_OK) = -1 ENOENT (No such file or directory)
      open("/opt/lib/v5l/fast-mult/half/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
      stat64("/opt/lib/v5l/fast-mult/half", 0xbe9d0260) = -1 ENOENT (No such file or directory)
      open("/opt/lib/v5l/fast-mult/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
      stat64("/opt/lib/v5l/fast-mult", 0xbe9d0260) = -1 ENOENT (No such file or directory)
      open("/opt/lib/v5l/half/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
      stat64("/opt/lib/v5l/half", 0xbe9d0260) = -1 ENOENT (No such file or directory)
      open("/opt/lib/v5l/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
      stat64("/opt/lib/v5l", 0xbe9d0260) = -1 ENOENT (No such file or directory)
      open("/opt/lib/fast-mult/half/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
      stat64("/opt/lib/fast-mult/half", 0xbe9d0260) = -1 ENOENT (No such file or directory)
      open("/opt/lib/fast-mult/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
      stat64("/opt/lib/fast-mult", 0xbe9d0260) = -1 ENOENT (No such file or directory)
      open("/opt/lib/half/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
      stat64("/opt/lib/half", 0xbe9d0260) = -1 ENOENT (No such file or directory)
      open("/opt/lib/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
      stat64("/opt/lib", {st_mode=S_IFDIR|0755, st_size=17592186044416, ...}) = 0
      open("/etc/ld.so.cache", O_RDONLY) = 3
      fstat64(3, {st_mode=S_IFREG|0644, st_size=17592186044416, ...}) = 0
      mmap2(NULL, 5759, PROT_READ, MAP_PRIVATE, 3, 0) = 0x40015000
      close(3) = 0
      open("/lib/libc.so.6", O_RDONLY) = 3
      read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0(\0\1\0\0\0d:\1\0004\0\0\0"..., 512) = 512
      fstat64(3, {st_mode=S_IFREG|0755, st_size=17592186044416, ...}) = 0
      mmap2(NULL, 1071092, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x4001e000
      mmap2(0x4011e000, 16384, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x100) = 0x4011e000
      mmap2(0x40122000, 6132, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x40122000
      close(3) = 0
      mprotect(0x4011e000, 8192, PROT_READ) = 0
      mprotect(0x4001c000, 4096, PROT_READ) = 0
      munmap(0x40015000, 5759) = 0
      write(2, "run `cueprint --help' for usage\n", 32run `cueprint --help' for usage
      ) = 32
      exit_group(1) = ?
    • tals1975
      Hi All, This seems to be a know issue... http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=439776 So
      Message 2 of 3 , Mar 2, 2012
      • 0 Attachment
        Hi All,

        This seems to be a know issue...
        http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=439776 

        So cueprint command line argument parsing is also broken for ARM926EJ-S rev 5 (v5l) processors. Looking for a patch...



        --- In nslu2-linux@yahoogroups.com, "tals1975" <tals1975@...> wrote:
        >
        > Hi All,
        >
        > I've faced a strange behavior of cuetools 1.3.1 on my NAS.
        > All utilities of cuetools package show me always the same message:
        > run `{CUETOOLS_UTILS} --help' for usage
        >
        > All other installed optware packages work fine.
        >
        >
        > Please can anyone give me a piece of advise where the issue could be in?
        >
        > Thank you in advance!
        > Sergey
        >
        > ENV#: / Output
        > 1)
        > uname -a
        > Linux WD 2.6.24.4 #1 Thu Apr 1 16:43:58 CST 2010 armv5tejl unknown
        >
        > 2)
        > strace cueprint test.cue
        > execve("/opt/bin/cueprint", ["cueprint", "test.cue"], [/* 13 vars */]) = 0
        > uname({sys="Linux", node="WD", ...}) = 0
        > brk(0) = 0x1e000
        > access("/etc/ld.so.preload", R_OK) = -1 ENOENT (No such file or directory)
        > open("/opt/lib/v5l/fast-mult/half/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
        > stat64("/opt/lib/v5l/fast-mult/half", 0xbe9d0260) = -1 ENOENT (No such file or directory)
        > open("/opt/lib/v5l/fast-mult/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
        > stat64("/opt/lib/v5l/fast-mult", 0xbe9d0260) = -1 ENOENT (No such file or directory)
        > open("/opt/lib/v5l/half/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
        > stat64("/opt/lib/v5l/half", 0xbe9d0260) = -1 ENOENT (No such file or directory)
        > open("/opt/lib/v5l/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
        > stat64("/opt/lib/v5l", 0xbe9d0260) = -1 ENOENT (No such file or directory)
        > open("/opt/lib/fast-mult/half/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
        > stat64("/opt/lib/fast-mult/half", 0xbe9d0260) = -1 ENOENT (No such file or directory)
        > open("/opt/lib/fast-mult/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
        > stat64("/opt/lib/fast-mult", 0xbe9d0260) = -1 ENOENT (No such file or directory)
        > open("/opt/lib/half/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
        > stat64("/opt/lib/half", 0xbe9d0260) = -1 ENOENT (No such file or directory)
        > open("/opt/lib/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
        > stat64("/opt/lib", {st_mode=S_IFDIR|0755, st_size=17592186044416, ...}) = 0
        > open("/etc/ld.so.cache", O_RDONLY) = 3
        > fstat64(3, {st_mode=S_IFREG|0644, st_size=17592186044416, ...}) = 0
        > mmap2(NULL, 5759, PROT_READ, MAP_PRIVATE, 3, 0) = 0x40015000
        > close(3) = 0
        > open("/lib/libc.so.6", O_RDONLY) = 3
        > read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0(\0\1\0\0\0d:\1\0004\0\0\0"..., 512) = 512
        > fstat64(3, {st_mode=S_IFREG|0755, st_size=17592186044416, ...}) = 0
        > mmap2(NULL, 1071092, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x4001e000
        > mmap2(0x4011e000, 16384, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x100) = 0x4011e000
        > mmap2(0x40122000, 6132, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x40122000
        > close(3) = 0
        > mprotect(0x4011e000, 8192, PROT_READ) = 0
        > mprotect(0x4001c000, 4096, PROT_READ) = 0
        > munmap(0x40015000, 5759) = 0
        > write(2, "run `cueprint --help' for usage\n", 32run `cueprint --help' for usage
        > ) = 32
        > exit_group(1) = ?
        >
      • tals1975
        Hi All, The following patch fixes the issue: http://patch-tracker.debian.org/patch/series/view/cuetools/1.3.1-12/04-source-fixes.diff
        Message 3 of 3 , Mar 12, 2012
        • 0 Attachment
          Hi All,

          The following patch fixes the issue:
          http://patch-tracker.debian.org/patch/series/view/cuetools/1.3.1-12/04-source-fixes.diff


          --- In nslu2-linux@yahoogroups.com, "tals1975" <tals1975@...> wrote:
          >
          > Hi All,
          >
          > This seems to be a know issue...
          > http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=439776
          > <http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=439776>
          >
          > So cueprint command line argument parsing is also broken for ARM926EJ-S
          > rev 5 (v5l) processors. Looking for a patch...
          >
          >
          >
          > --- In nslu2-linux@yahoogroups.com, "tals1975" <tals1975@> wrote:
          > >
          > > Hi All,
          > >
          > > I've faced a strange behavior of cuetools 1.3.1 on my NAS.
          > > All utilities of cuetools package show me always the same message:
          > > run `{CUETOOLS_UTILS} --help' for usage
          > >
          > > All other installed optware packages work fine.
          > >
          > >
          > > Please can anyone give me a piece of advise where the issue could be
          > in?
          > >
          > > Thank you in advance!
          > > Sergey
          > >
          > > ENV#: / Output
          > > 1)
          > > uname -a
          > > Linux WD 2.6.24.4 #1 Thu Apr 1 16:43:58 CST 2010 armv5tejl unknown
          > >
          > > 2)
          > > strace cueprint test.cue
          > > execve("/opt/bin/cueprint", ["cueprint", "test.cue"], [/* 13 vars */])
          > = 0
          > > uname({sys="Linux", node="WD", ...}) = 0
          > > brk(0) = 0x1e000
          > > access("/etc/ld.so.preload", R_OK) = -1 ENOENT (No such file or
          > directory)
          > > open("/opt/lib/v5l/fast-mult/half/libc.so.6", O_RDONLY) = -1 ENOENT
          > (No such file or directory)
          > > stat64("/opt/lib/v5l/fast-mult/half", 0xbe9d0260) = -1 ENOENT (No such
          > file or directory)
          > > open("/opt/lib/v5l/fast-mult/libc.so.6", O_RDONLY) = -1 ENOENT (No
          > such file or directory)
          > > stat64("/opt/lib/v5l/fast-mult", 0xbe9d0260) = -1 ENOENT (No such file
          > or directory)
          > > open("/opt/lib/v5l/half/libc.so.6", O_RDONLY) = -1 ENOENT (No such
          > file or directory)
          > > stat64("/opt/lib/v5l/half", 0xbe9d0260) = -1 ENOENT (No such file or
          > directory)
          > > open("/opt/lib/v5l/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or
          > directory)
          > > stat64("/opt/lib/v5l", 0xbe9d0260) = -1 ENOENT (No such file or
          > directory)
          > > open("/opt/lib/fast-mult/half/libc.so.6", O_RDONLY) = -1 ENOENT (No
          > such file or directory)
          > > stat64("/opt/lib/fast-mult/half", 0xbe9d0260) = -1 ENOENT (No such
          > file or directory)
          > > open("/opt/lib/fast-mult/libc.so.6", O_RDONLY) = -1 ENOENT (No such
          > file or directory)
          > > stat64("/opt/lib/fast-mult", 0xbe9d0260) = -1 ENOENT (No such file or
          > directory)
          > > open("/opt/lib/half/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or
          > directory)
          > > stat64("/opt/lib/half", 0xbe9d0260) = -1 ENOENT (No such file or
          > directory)
          > > open("/opt/lib/libc.so.6", O_RDONLY) = -1 ENOENT (No such file or
          > directory)
          > > stat64("/opt/lib", {st_mode=S_IFDIR|0755, st_size=17592186044416,
          > ...}) = 0
          > > open("/etc/ld.so.cache", O_RDONLY) = 3
          > > fstat64(3, {st_mode=S_IFREG|0644, st_size=17592186044416, ...}) = 0
          > > mmap2(NULL, 5759, PROT_READ, MAP_PRIVATE, 3, 0) = 0x40015000
          > > close(3) = 0
          > > open("/lib/libc.so.6", O_RDONLY) = 3
          > > read(3,
          > "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0(\0\1\0\0\0d:\1\0004\0\0\0"..., 512)
          > = 512
          > > fstat64(3, {st_mode=S_IFREG|0755, st_size=17592186044416, ...}) = 0
          > > mmap2(NULL, 1071092, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE,
          > 3, 0) = 0x4001e000
          > > mmap2(0x4011e000, 16384, PROT_READ|PROT_WRITE,
          > MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x100) = 0x4011e000
          > > mmap2(0x40122000, 6132, PROT_READ|PROT_WRITE,
          > MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x40122000
          > > close(3) = 0
          > > mprotect(0x4011e000, 8192, PROT_READ) = 0
          > > mprotect(0x4001c000, 4096, PROT_READ) = 0
          > > munmap(0x40015000, 5759) = 0
          > > write(2, "run `cueprint --help' for usage\n", 32run `cueprint --help'
          > for usage
          > > ) = 32
          > > exit_group(1) = ?
          > >
          >
        Your message has been successfully submitted and would be delivered to recipients shortly.