Loading ...
Sorry, an error occurred while loading the content.

[Bug 33] Changed - NativeToolchain lacks needed packages

Expand Messages
  • unslung@gmail.com
    ============================================================================ THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY INSTEAD
    Message 1 of 6 , Dec 1, 2004
    • 0 Attachment
      ============================================================================
      THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY

      INSTEAD FOLLOW BUG'S URL BELOW IN ORDER TO DETAIL BUG:
      ============================================================================
      Bug #: 33 (http://slugbug.nslu2-linux.org/bug.php?op=show&bugid=33)
      Reported By: jeremy@...
      ----------------------------------------------------------------------------
      Summary: NativeToolchain lacks needed packages
      ! URL: http://www.nslu2-linux.org/wiki/Info/NativeNSLU2Toolchain
      ! Product: Other Unsupported Items
      ! Version: unknown
      To be Closed in Version: None
      Closed in Version: None
      ! Component: other
      Site(s): All
      Status: Assigned
      Resolution: None
      Severity: Significant
      ! OS/Version: N/A
      Database: None
      Priority: 3 - Medium
      Assigned To: nslu2-linux@yahoogroups.com
      ============================================================================
      COMMENTS

      ----- Posted by jeremyeglen at 3:20 PM on 2004-12-01 -----
      I am using Unslung 2

      As detailed in this thread:
      http://groups.yahoo.com/group/nslu2-linux/message/2464 the
      NativeNSLU2Toolchain build linked from the wiki page lacks the necessary
      packages.

      I followed the wiki instructions for NativeNSLU2Toolchain
      and BuildMake without error (and to my belief, following directions
      precisely). However, during the MakeGawk process, the ./configure
      process dies with the error:
      checking how to run the C preprocessor...
      /lib/cpp
      configure: error: C preprocessor "/lib/cpp" fails
      sanity check
      See `config.log' for more details.

      config.log reports
      (in pertinent part):
      configure:3040: gcc -E conftest.c
      In file
      included from conftest.c:12:
      /share/hdd/data/compile/src/gcc-3.3.4-glibc-2.2.5/lib/gcc-lib/armv5b-softfloat-linux/3.3.4/include/limits.h:11:23:
      syslimits.h: No such file or directory
      configure:3046: $? = 1
      configure: failed program was:
      | /* confdefs.h. */
      |
      | #define
      PACKAGE_NAME "GNU Awk"
      | #define PACKAGE_TARNAME
      "gawk"
      | #define PACKAGE_VERSION "3.1.4"
      | #define
      PACKAGE_STRING "GNU Awk 3.1.4"
      | #define PACKAGE_BUGREPORT
      "bug-gawk@..."
      | #define PACKAGE "gawk"
      |
      #define VERSION "3.1.4"
      | /* end confdefs.h. */
      | #ifdef
      __STDC__
      | # include <limits.h>
      | #else
      | # include
      <assert.h>
      | #endif
      | Syntax error
      configure:3040: gcc -E conftest.c
      In file included from conftest.c:12:

      /share/hdd/data/compile/src/gcc-3.3.4-glibc-2.2.5/lib/gcc-lib/armv5b-softfloat-linux/3.3.4/include/limits.h:11:23:
      syslimits.h: No such file or directory
      configure:3046: $? = 1
      configure: failed program was:
      | /* confdefs.h. */
      |
      | #define
      PACKAGE_NAME "GNU Awk"
      | #define PACKAGE_TARNAME
      "gawk"
      | #define PACKAGE_VERSION "3.1.4"
      | #define
      PACKAGE_STRING "GNU Awk 3.1.4"
      | #define PACKAGE_BUGREPORT
      "bug-gawk@..."
      | #define PACKAGE "gawk"
      |
      #define VERSION "3.1.4"
      | /* end confdefs.h. */
      | #ifdef
      __STDC__
      | # include <limits.h>
      | #else
      | # include
      <assert.h>
      | #endif
      | Syntax error
      configure:3040: gcc -E -traditional-cpp conftest.c
      In file included
      from
      /share/hdd/data/compile/src/gcc-3.3.4-glibc-2.2.5/armv5b-softfloat-linux/sys-include/features.h:283,

      from
      /share/hdd/data/compile/src/gcc-3.3.4-glibc-2.2.5/armv5b-softfloat-linux/sys-include/assert.h:36,

      from conftest.c:14:
      /share/hdd/data/compile/src/gcc-3.3.4-glibc-2.2.5/armv5b-softfloat-linux/sys-include/sys/cdefs.h:31:
      #error "You need a ISO C conforming compiler to use the glibc
      headers"
      configure:3046: $? = 1
      configure: failed program was:
      | /* confdefs.h. */
      |
      | #define PACKAGE_NAME "GNU Awk"
      |
      #define PACKAGE_TARNAME "gawk"
      | #define PACKAGE_VERSION
      "3.1.4"
      | #define PACKAGE_STRING "GNU Awk 3.1.4"
      |
      #define PACKAGE_BUGREPORT "bug-gawk@..."
      | #define
      PACKAGE "gawk"
      | #define VERSION "3.1.4"
      | /* end
      confdefs.h. */
      | #ifdef __STDC__
      | # include <limits.h>
      |
      #else
      | # include <assert.h>
      | #endif
      |
      Syntax error
      configure:3040: gcc -E -traditional-cpp conftest.c
      In
      file included from
      /share/hdd/data/compile/src/gcc-3.3.4-glibc-2.2.5/armv5b-softfloat-linux/sys-include/features.h:283,

      from
      /share/hdd/data/compile/src/gcc-3.3.4-glibc-2.2.5/armv5b-softfloat-linux/sys-include/assert.h:36,

      from conftest.c:14:
      /share/hdd/data/compile/src/gcc-3.3.4-glibc-2.2.5/armv5b-softfloat-linux/sys-include/sys/cdefs.h:31:
      #error "You need a ISO C conforming compiler to use the glibc
      headers"
      configure:3046: $? = 1
      configure: failed program was:
      | /* confdefs.h. */
      |
      | #define PACKAGE_NAME "GNU Awk"
      |
      #define PACKAGE_TARNAME "gawk"
      | #define PACKAGE_VERSION
      "3.1.4"
      | #define PACKAGE_STRING "GNU Awk 3.1.4"
      |
      #define PACKAGE_BUGREPORT "bug-gawk@..."
      | #define
      PACKAGE "gawk"
      | #define VERSION "3.1.4"
      | /* end
      confdefs.h. */
      | #ifdef __STDC__
      | # include <limits.h>
      |
      #else
      | # include <assert.h>
      | #endif
      |
      Syntax error
      configure:3040: /lib/cpp conftest.c
      In file included
      from conftest.c:12:
      /share/hdd/data/compile/src/gcc-3.3.4-glibc-2.2.5/lib/gcc-lib/armv5b-softfloat-linux/3.3.4/include/limits.h:11:23:
      syslimits.h: No such file or directory
      configure:3046: $? = 1
      configure: failed program was:
      | /* confdefs.h. */
      |
      | #define
      PACKAGE_NAME "GNU Awk"
      | #define PACKAGE_TARNAME
      "gawk"
      | #define PACKAGE_VERSION "3.1.4"
      | #define
      PACKAGE_STRING "GNU Awk 3.1.4"
      | #define PACKAGE_BUGREPORT
      "bug-gawk@..."
      | #define PACKAGE "gawk"
      |
      #define VERSION "3.1.4"
      | /* end confdefs.h. */
      | #ifdef
      __STDC__
      | # include <limits.h>
      | #else
      | # include
      <assert.h>
      | #endif
      | Syntax error
      configure:3040: /lib/cpp conftest.c
      In file included from
      conftest.c:12:
      /share/hdd/data/compile/src/gcc-3.3.4-glibc-2.2.5/lib/gcc-lib/armv5b-softfloat-linux/3.3.4/include/limits.h:11:23:
      syslimits.h: No such file or directory
      configure:3046: $? = 1
      configure: failed program was:
      | /* confdefs.h. */
      |
      | #define
      PACKAGE_NAME "GNU Awk"
      | #define PACKAGE_TARNAME
      "gawk"
      | #define PACKAGE_VERSION "3.1.4"
      | #define
      PACKAGE_STRING "GNU Awk 3.1.4"
      | #define PACKAGE_BUGREPORT
      "bug-gawk@..."
      | #define PACKAGE "gawk"
      |
      #define VERSION "3.1.4"
      | /* end confdefs.h. */
      | #ifdef
      __STDC__
      | # include <limits.h>
      | #else
      | # include
      <assert.h>
      | #endif
      | Syntax error
      configure:3123: result: /lib/cpp
      configure:3147: /lib/cpp conftest.c
      In file included from conftest.c:12:
      /share/hdd/data/compile/src/gcc-3.3.4-glibc-2.2.5/lib/gcc-lib/armv5b-softfloat-linux/3.3.4/include/limits.h:11:23:
      syslimits.h: No such file or directory
      configure:3153: $? = 1
      configure: failed program was:
      | /* confdefs.h. */
      |
      | #define
      PACKAGE_NAME "GNU Awk"
      | #define PACKAGE_TARNAME
      "gawk"
      | #define PACKAGE_VERSION "3.1.4"
      | #define
      PACKAGE_STRING "GNU Awk 3.1.4"
      | #define PACKAGE_BUGREPORT
      "bug-gawk@..."
      | #define PACKAGE "gawk"
      |
      #define VERSION "3.1.4"
      | /* end confdefs.h. */
      | #ifdef
      __STDC__
      | # include <limits.h>
      | #else
      | # include
      <assert.h>
      | #endif
      | Syntax error
      configure:3147: /lib/cpp conftest.c
      In file included from
      conftest.c:12:
      /share/hdd/data/compile/src/gcc-3.3.4-glibc-2.2.5/lib/gcc-lib/armv5b-softfloat-linux/3.3.4/include/limits.h:11:23:
      syslimits.h: No such file or directory
      configure:3153: $? = 1
      configure: failed program was:
      | /* confdefs.h. */
      |
      | #define
      PACKAGE_NAME "GNU Awk"
      | #define PACKAGE_TARNAME
      "gawk"
      | #define PACKAGE_VERSION "3.1.4"
      | #define
      PACKAGE_STRING "GNU Awk 3.1.4"
      | #define PACKAGE_BUGREPORT
      "bug-gawk@..."
      | #define PACKAGE "gawk"
      |
      #define VERSION "3.1.4"
      | /* end confdefs.h. */
      | #ifdef
      __STDC__
      | # include <limits.h>
      | #else
      | # include
      <assert.h>
      | #endif
      | Syntax error

      This
      error will prevent anyone from following the NSLU2Toolkit directions
      from being able to compile native packages on the NSLU2. It seems,
      therefore, to be a significant block on new development for the system.

      ----- Posted by rwhitby at 3:42 PM on 2004-12-01 -----
      + Just a note to let you know that the Native NSLU2 Toolchain is a
      + contributed item, so it will require the original author of that
      + contributed item to get it fixed (none of the core Unslung or OpenSlug
      + development team uses that native compilation package as far as I know).
      +

      Note that all of the Unslung packages are built using a
      + cross-compiler.

      The lack of a native compiler is not a significant
      + block on new development for the system (as most things can be
      + cross-compiled) - however, it is a convenient (albeit slow) way to get
      + things compiled for the slug. Hopefully the original author of the
      + native toolchain will fix it and release a new version.
    • unslung@gmail.com
      ============================================================================ THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY INSTEAD
      Message 2 of 6 , Dec 3, 2004
      • 0 Attachment
        ============================================================================
        THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY

        INSTEAD FOLLOW BUG'S URL BELOW IN ORDER TO DETAIL BUG:
        ============================================================================
        Bug #: 33 (http://slugbug.nslu2-linux.org/bug.php?op=show&bugid=33)
        Reported By: jeremy@...
        ----------------------------------------------------------------------------
        Summary: NativeToolchain lacks needed packages
        URL: http://www.nslu2-linux.org/wiki/Info/NativeNSLU2Toolchain
        Product: Other Unsupported Items
        Version: unknown
        To be Closed in Version: None
        Closed in Version: None
        Component: other
        Site(s): All
        ! Status: Resolved
        ! Resolution: Fixed
        Severity: Significant
        OS/Version: N/A
        Database: None
        Priority: 3 - Medium
        Assigned To: nslu2-linux@yahoogroups.com
        ============================================================================
        COMMENTS

        ----- Posted by rwhitby at 3:42 PM on 2004-12-01 -----
        Just a note to let you know that the Native NSLU2 Toolchain is a
        contributed item, so it will require the original author of that
        contributed item to get it fixed (none of the core Unslung or OpenSlug
        development team uses that native compilation package as far as I know).


        Note that all of the Unslung packages are built using a
        cross-compiler.

        The lack of a native compiler is not a significant
        block on new development for the system (as most things can be
        cross-compiled) - however, it is a convenient (albeit slow) way to get
        things compiled for the slug. Hopefully the original author of the
        native toolchain will fix it and release a new version.

        ----- Posted by jeremyeglen at 6:26 AM on 2004-12-03 -----
        + The problem is fixed by ensuring to export C_INCLUDE_PATH; I will
        + update the wiki.
      • unslung@gmail.com
        ============================================================================ THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY INSTEAD
        Message 3 of 6 , Dec 11, 2004
        • 0 Attachment
          ============================================================================
          THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY

          INSTEAD FOLLOW BUG'S URL BELOW IN ORDER TO DETAIL BUG:
          ============================================================================
          Bug #: 33 (http://slugbug.nslu2-linux.org/bug.php?op=show&bugid=33)
          Reported By: jeremy@...
          ----------------------------------------------------------------------------
          Summary: NativeToolchain lacks needed packages
          URL: http://www.nslu2-linux.org/wiki/Info/NativeNSLU2Toolchain
          Product: Other Unsupported Items
          Version: unknown
          To be Closed in Version: None
          Closed in Version: None
          Component: other
          Site(s): All
          ! Status: Closed
          Resolution: Fixed
          Severity: Significant
          OS/Version: N/A
          Database: None
          Priority: 3 - Medium
          Assigned To: nslu2-linux@yahoogroups.com
          ============================================================================
        • Mark Glines
          I d really like to build a native compiler suite that can be installed with ipkg. Unfortunately, I don t understand OpenEmbedded well enough to do this.
          Message 4 of 6 , Dec 11, 2004
          • 0 Attachment
            I'd really like to build a native compiler suite that can be installed
            with ipkg. Unfortunately, I don't understand OpenEmbedded well enough
            to do this. Openembedded.org's wiki is still down. Does anyone have
            a copy of their PackageAuthorsGuide document, so I can RTFM and try to
            figure out how to do this?

            Mark


            unslung@... wrote:
            > ============================================================================
            > THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY
            >
            > INSTEAD FOLLOW BUG'S URL BELOW IN ORDER TO DETAIL BUG:
            > ============================================================================
            > Bug #: 33 (http://slugbug.nslu2-linux.org/bug.php?op=show&bugid=33)
            > Reported By: jeremy@...
            > ----------------------------------------------------------------------------
            > Summary: NativeToolchain lacks needed packages
            > URL: http://www.nslu2-linux.org/wiki/Info/NativeNSLU2Toolchain
            > Product: Other Unsupported Items
            > Version: unknown
            > To be Closed in Version: None
            > Closed in Version: None
            > Component: other
            > Site(s): All
            > ! Status: Closed
            > Resolution: Fixed
            > Severity: Significant
            > OS/Version: N/A
            > Database: None
            > Priority: 3 - Medium
            > Assigned To: nslu2-linux@yahoogroups.com
            > ============================================================================
            >
            >
            >
            > [ Moderator Note: All static information is slowly moving to the Wiki at http://www.nslu2-linux.org ]
          • unslung@gmail.com
            ============================================================================ THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY INSTEAD
            Message 5 of 6 , Apr 9, 2005
            • 0 Attachment
              ============================================================================
              THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY

              INSTEAD FOLLOW BUG'S URL BELOW IN ORDER TO DETAIL BUG:
              ============================================================================
              Bug #: 33 (http://slugbug.nslu2-linux.org/bug.php?op=show&bugid=33)
              Reported By: jeremy@...
              ----------------------------------------------------------------------------
              Summary: NativeToolchain lacks needed packages
              URL: http://www.nslu2-linux.org/wiki/Info/NativeNSLU2Toolchain
              Product: Other Unsupported Items
              Version: unknown
              To be Closed in Version: None
              Closed in Version: None
              Component: other
              Site(s): All
              ! Status: Resolved
              Resolution: Fixed
              Severity: Significant
              OS/Version: N/A
              Database: None
              Priority: 3 - Medium
              Assigned To: nslu2-linux@yahoogroups.com
              ============================================================================
            • unslung@gmail.com
              ============================================================================ THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY INSTEAD
              Message 6 of 6 , Apr 9, 2005
              • 0 Attachment
                ============================================================================
                THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY

                INSTEAD FOLLOW BUG'S URL BELOW IN ORDER TO DETAIL BUG:
                ============================================================================
                Bug #: 33 (http://slugbug.nslu2-linux.org/bug.php?op=show&bugid=33)
                Reported By: jeremy@...
                ----------------------------------------------------------------------------
                Summary: NativeToolchain lacks needed packages
                URL: http://www.nslu2-linux.org/wiki/Info/NativeNSLU2Toolchain
                Product: Other Unsupported Items
                Version: unknown
                To be Closed in Version: None
                Closed in Version: None
                Component: other
                Site(s): All
                ! Status: Closed
                Resolution: Fixed
                Severity: Significant
                OS/Version: N/A
                Database: None
                Priority: 3 - Medium
                Assigned To: nslu2-linux@yahoogroups.com
                ============================================================================
              Your message has been successfully submitted and would be delivered to recipients shortly.