Loading ...
Sorry, an error occurred while loading the content.

Re: Unable to build cross-compile toolchain

Expand Messages
  • Brian
    See http://sourceware.org/ml/crossgcc/2007-09/msg00005.html and the patch at http://www.svalli.com/armccnotes.html This might have something to do with the
    Message 1 of 3 , Feb 24, 2012
    • 0 Attachment
      See
      http://sourceware.org/ml/crossgcc/2007-09/msg00005.html
      and the patch at http://www.svalli.com/armccnotes.html

      This might have something to do with the version of echo being used. In the case of shell builtin echo, wher /bin/sh links to.

      Hope this helps,

      -Brian

      --- In nslu2-linux@yahoogroups.com, Brent Gordon <nslu2@...> wrote:
      >
      > I am trying to build the cross-compile toolchain for the NSLU2 without
      > success. I am following the instructions at
      > http://www.nslu2-linux.org/wiki/Optware/AddAPackageToOptware and the
      > process breaks at the "make toolchain" step with the following errors:
      >
      > <snip 57,000+ lines of output>
      > In file included from version.c:32:
      > /home/slug/optware/nslu2/toolchain/crosstool/build/armv5b-softfloat-linux/gcc-3.3.5-glibc-2.2.5/build-glibc/csu/version-info.h:1:1:
      > missing terminating " character
      > /home/slug/optware/nslu2/toolchain/crosstool/build/armv5b-softfloat-linux/gcc-3.3.5-glibc-2.2.5/build-glibc/csu/version-info.h:2:1:
      > missing terminating " character
      > /home/slug/optware/nslu2/toolchain/crosstool/build/armv5b-softfloat-linux/gcc-3.3.5-glibc-2.2.5/build-glibc/csu/version-info.h:3:1:
      > missing terminating " character
      > /home/slug/optware/nslu2/toolchain/crosstool/build/armv5b-softfloat-linux/gcc-3.3.5-glibc-2.2.5/build-glibc/csu/version-info.h:4:1:
      > missing terminating " character
      > make[3]: ***
      > [/home/slug/optware/nslu2/toolchain/crosstool/build/armv5b-softfloat-linux/gcc-3.3.5-glibc-2.2.5/build-glibc/csu/version.o]
      > Error 1
      > make[3]: Leaving directory
      > `/home/slug/optware/nslu2/toolchain/crosstool/build/armv5b-softfloat-linux/gcc-3.3.5-glibc-2.2.5/glibc-2.2.5/csu'
      > make[2]: *** [csu/subdir_lib] Error 2
      > make[2]: Leaving directory
      > `/home/slug/optware/nslu2/toolchain/crosstool/build/armv5b-softfloat-linux/gcc-3.3.5-glibc-2.2.5/glibc-2.2.5'
      > make[1]: *** [all] Error 2
      > make[1]: Leaving directory
      > `/home/slug/optware/nslu2/toolchain/crosstool/build/armv5b-softfloat-linux/gcc-3.3.5-glibc-2.2.5/build-glibc'
      > make: *** [/home/slug/optware/nslu2/toolchain/crosstool/.built] Error 2
      >
      > $ cat version-info.h
      >
      > "Compiled on a Linux >>2.6.24-30-generic<< system on 2012-02-24.
      > "
      > "Available extensions:
      > "
      > " GNU libio by Per Bothner\n"
      > " crypt add-on version 2.1 by Michael Glad and others\n"
      > " linuxthreads-0.9 by Xavier Leroy\n"
      > " BIND-8.2.3-T5B\n"
      > " libthread_db work sponsored by Alpha Processor Inc\n"
      > " NIS(YP)/NIS+ NSS modules 0.19 by Thorsten Kukuk\n"
      >
      >
      > Notice that the closing quotes for lines 1 and 3 appear on lines 2 and
      > 4, respectively.
      >
      > Here are the details on my system:
      > $ uname -a
      > Linux ubuntu-vm 2.6.24-30-generic #1 SMP Mon Jan 2 19:48:58 UTC 2012
      > i686 GNU/Linux
      >
      > $ gcc -v
      > Reading specs from /usr/lib/gcc-lib/i486-linux-gnu/3.3.6/specs
      > Configured with: ../src/configure -v --enable-languages=c,c++
      > --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info
      > --with-gxx-include-dir=/usr/include/c++/3.3 --enable-shared
      > --enable-__cxa_atexit --with-system-zlib --enable-nls
      > --without-included-gettext --enable-clocale=gnu --enable-debug
      > i486-linux-gnu
      > Thread model: posix
      > gcc version 3.3.6 (Ubuntu 1:3.3.6-15ubuntu6)
      >
      > $ svnversion
      > 12706
      >
      > How do I fix this? When it comes to Linux programming I am neither a
      > noob nor a guru. I've tried editing the version-info.h file, but make
      > deletes the directory when starting.
      > Brent
      >
    • Brent Gordon
      I thought I had changed the link for /bin/sh to bash, but it was still set to dash. Once I fixed that everything worked. Thanks, Brent On 2/24/2012 2:38 PM,
      Message 2 of 3 , Feb 29, 2012
      • 0 Attachment
        I thought I had changed the link for /bin/sh to bash, but it was still set to dash.  Once I fixed that everything worked.

        Thanks,
        Brent

        On 2/24/2012 2:38 PM, Brian wrote:
         

        See
        http://sourceware.org/ml/crossgcc/2007-09/msg00005.html
        and the patch at http://www.svalli.com/armccnotes.html

        This might have something to do with the version of echo being used. In the case of shell builtin echo, wher /bin/sh links to.

        Hope this helps,

        -Brian~-|**|PrettyHtmlEnd|**|-~end group email -->

      Your message has been successfully submitted and would be delivered to recipients shortly.